Learn how to capture a handwritten signature with Adobe Capture CC and turn it into an animation in After Effects.

Capture a shape in Adobe Capture

Open Adobe Capture CC. Select Shapes and click the plus sign (+). Use your camera on your mobile device to capture a handwritten signature.    

Adjust the slider to select a look you want and click the round button to finalize your selection.    


Save a shape in Adobe Capture 

If you like the captured signature, click Next, then in the Preview screen press Next again. Finally, name your shape and choose a Library you would like to save to and press Save Shape.

If you want to clean up the rough edges of the signature, you can open Illustrator, get the signature from your CC Libraries, and edit the signature.    


Import the signature from your Creative Cloud Libraries    

Open After Effects and create a new composition.

Choose Layer > New > Solid... to create a solid layer. In the Solid Settings dialog box, enter a name for the layer in the Name field and under Color choose the color you want. Then click OK.

If the Libraries panel is not already open, choose Window > Libraries to open it.

Drag the signature from the Libraries panel to the Composition panel.    


Make the mask in After Effects    

In the After Effects tool bar, select the Pen tool. Zoom in the signature text. Trace along the center of each letter in the order that you would actually write the letters by hand.


Generate the stroke    

In After Effects, choose Effect > Generate > Stroke.

In the Stroke effect panel, make sure that All Masks and Stroke Sequentially are both selected.

Then increase your brush size until the strokes completely cover the signature.

From the Paint Style pull-down menu, choose Reveal Original Image.    


Define the length of animation    

In the Stroke effect panel, make sure that Start is set to 0%. Click the stopwatch icon next to End and set it to 0%. 

Move the playhead forward to a location where you want the animation to end.    


Preview the animation    

Return to the Stroke effect panel and set the setting for End to 100%.

In the Preview panel, click the First Frame button and then the Play button to see a preview of the animation of the signature.    


Contributor: Matty Newton

Was this page helpful?