Learn techniques for creating several popular visual effects.

Place type into video footage

Use the 3D Camera Tracker effect to place type into a scene.

 

What you learned: Place text into a scene 

The 3D Camera Tracker effect analyzes video footage to recreate the camera movement originally used to create a shot. After the analysis, you can place text that looks like it's part of the original scene.

  1. Select the video layer in the timeline.
  2. Select Animation > Track Camera.
    As the footage is analyzed in the background, you can see a status update of the progress in the Effect Controls panel.
  3. After the analysis is complete, make sure the effect is selected in the timeline or Effect Controls panel so you can see the rainbow-colored tracking markers.
  4. Select track points to specify the placement of text and line up the target along the ground plane.
  5. Hover the mouse over the middle of the target to reposition it, if needed, and then right-click the target and choose Set Ground Plane and Origin.
  6. Right-click the target again and choose Create Text and Camera.
  7. Adjust the orientation parameters to fine-tune the text placement.

 

Blur out unwanted elements
 

Add a blur over a specific area in the video footage.

 

What you learned: Add a blur over a moving section of video footage

Any mask can follow movement with the Track Mask function. You can apply an effect to the mask to blur a section: 

  1. Select the video layer in the Timeline.
  2. Select the Pen tool and draw a mask around the area to blur in the Composition panel. Click back on the first mask point when you finish to close the mask.
  3. Right-click the words Mask 1 in the Timeline and choose Track Mask. Notice the Tracker Panel opens in the lower right corner of the interface. 
  4. In the Tracker Panel, click the Method drop-down and choose Postion, Scale & Rotation.
  5. Click the inner right-facing arrow to track all frames to the right of the CTI in the Timeline.
  6. In the main menu, select Effect > Blur > Fast Box Blur and set the blur value.
  7. Open the options for the Fast Blur Effect in the Timeline, scroll to the bottom and click the plus (+) button to the right of the Compositing Options to apply the mask to the Fast Box Blur instead of the entire image.
  8. Press the spacebar on your keyboard to view the results.
     

Isolate elements with greenscreen
 

Isolate elements by pulling a greenscreen key.

 

What you learned: Create transparency in greenscreen video using the Keylight effect

Keying uses a specific color or luminance value to determine transparency. The process of removing that specific color or luminance value from an image is known as keying or “pulling a key.”

  • To pull the initial greenscreen key using the Keylight effect:
    1. Select the video layer in the composition and select Effect > Keying > Keylight (1.2) from the main menu.
    2. Notice that the effect appears in the Effect Controls panel. Leave the View drop-down menu set to Final Result.
    3. Select the eyedropper in the Screen Color section and click the greenscreen background in the Composition panel to choose the color you want to remove. Pick an area where the green is well lit and nicely saturated.
    4. To see the quality of the key, change the View drop-down menu from Final Result to Screen Matte. White pixels are opaque, black pixels are transparent, and anything gray is semi-transparent.
    5. Adjust the Screen Balance setting to heighten the effect of the key (these changes are subtle).
    6. Increase the Screen Gain value if the background has too many gray pixels. (Generally, it’s a good idea to keep this value at 110 or less.) This setting increases or decreases the amount of variance in the green used to pull the key.
  • To refine the key using Screen Matte:
    1. Open the options for Screen Matte.
    2. Adjust Screen Matte parameters, such as Clip Black, Clip White, Clip Rollback, Screen Shrink/Grow, Screen Despot Black.
    3. Set the View menu back to Final Result.
    4. Set the Replace Method menu to Source to mix the original footage pixels back into the keyed footage and remove noise.
       

Clean up keyed footage with a garbage matte
 

Clean up keyed footage using a garbage matte.

 

What you learned: Clean up keyed footage

Greenscreen footage can sometimes display extra noise around the edge of the image that is hard to remove using the Keylight effect alone.

  • To quickly remove noise from the edges of keyed footage, apply a mask to the video layer. This kind of mask is called a garbage matte:
    1. Select the video layer and use the Rectangle tool to draw a rectangle around the subject of the key.
    2. Press MM to reveal the mask feather settings and set the feather value.
    3. Press the spacebar to preview the scene and make sure the subject stays inside the mask.
  • Some areas are difficult to fix with one Keylight setting. You can create a duplicate layer to fix the problem:
    1. Mask out the area in question from the original keyed footage then duplicate the layer.
    2. Change mask settings of the duplicate layer to reveal only the problematic section of the key.
    3. Adjust the Keylight settings of the duplicate layer to fix the problematic area.
       

Retime video to add impact

Retime video to create visual impact.

 

What you learned: Retime video to create visual impact

When you slow down video, the higher the frame rate, the more you can slow down the action and keep the action smooth.

  • To change the frame rate for how After Effects interprets footage:
    1. Right-click the video in the Project panel and choose Interpret Footage > Main
    2. Enable Conform to new frame rate and enter a new frame rate.
  • To retime a video layer to a specific duration:
    1. Right-click the video layer and go to Time > Time Stretch
    2. Type the new desired duration into the New Duration setting and click OK.
  • To retime any video layer using Time Remapping:
    1. Rght-click the layer and choose Time > Enable Time Remapping.
    2. Add keyframes where the retiming is to take place by clicking once on the diamond button between the two arrows and to the left of the words Time Remap in the Timeline.
      Time Remapping keyfames record a specific point in time. 
    3. Slide added Time Remapping keyframes left or right in the timeline to increase or decrease playback speed of the footage.
  • To adjust speed changes over time between retiming keyframes with the Graph Editor:
    1. Make sure the words Time Remap are selected in the Timeline and enable the option Edit Value Graph under the Graph Type and Options button on the bottom left of the Graph Editor.
    2. Drag keyframes vertically up or down to change playback speed
      The angles between keyframes determine playback speed:
      • Steeper = Faster
      • Flat = still frame
      • Downward = Playing in Reverse
05/18/2018


Presenter: Ian Robinson

Was this page helpful?