Adobe® ColdFusion® Builder™ is built on top of Eclipse™, an open-source IDE (Integrated Development Environment). An IDE contains most of the tools that developers need within a single application. ColdFusion Builder provides tools for editing and validating code, managing files and projects, and debugging. The plug-in architecture of ColdFusion Builder lets you extend the functionality for your own needs.

ColdFusion Builder runs on Microsoft® Windows® and Apple® Macintosh platforms. The installation configuration options let you install ColdFusion Builder as a standalone installation or as a set of plug-ins within an existing Eclipse workbench installation. For more information, see Installing Adobe ColdFusion Builder.

ColdFusion Builder configurations

The ColdFusion Builder installer provides the following two configuration options:

  • Standalone ColdFusion Builder IDE Installation: Installs ColdFusion Builder as a standalone IDE (Integrated Development Environment) built on Eclipse™ 4.6.
  • ColdFusion Builder plug-ins within Eclipse IDE: Installs ColdFusion Builder as a plug-in with an existing Eclipse IDE. This configuration is for users who already use the Eclipse workbench and want to add ColdFusion Builder plug-ins to their toolkit of Eclipse plug-ins.

If you are not sure which configuration to use, follow these guidelines:

  • If you already use and have Eclipse 4.6 or higher installed, select the plug-in configuration.
  • If you do not have Eclipse 4.6 or higher installed, select the standalone configuration. This configuration also allows you to install other Eclipse plug-ins, so you can expand the scope of your development work in the future.

The two configurations provide the same functionality. However, some menu names and the ways to access the menu commands sometimes differ slightly in the plug-in configuration.

Activating ColdFusion Builder

When you start ColdFusion Builder, you are prompted to enter the product serial number. When you enter a valid product serial number, activation happens in the background the first time the software detects an Internet connection. For more information, visit the Adobe Product Activation Center at www.adobe.com/go/activation.

If you do not enter the product serial number when you start ColdFusion Builder, you can use the trial version of the full-featured ColdFusion Builder (2016 release) for 60 days. After the trial expires, you need to purchase a license to continue using all the features. If not, ColdFusion Builder switches to a feature-limited Express Edition.

ColdFusion Builder Express Edition

The Express Edition lets you use ColdFusion Builder with the basic features such as editor, code assist, and syntax highlighting.But the following key features are not available in the Express Edition:

  • Code assist for extensions
  • Code insight
  • Extension callback
  • Connection to remote server
  • Quick fix
  • Debugging remote projects
  • Refactoring
  • ColdFusion search
  • Code formatting
  • Log viewer
  • Local file browser
  • Code hyperlinks
  • Hover help
  • Mobile development, inspection, debugging, and packaging 

You can convert the Express Edition to a full-featured version by purchasing the license and specifying the product serial number.

Managing ColdFusion Builder licenses

If you are a single-license user you can use ColdFusion Builder on up to two computers. To use your ColdFusion Builder license on a different computer than your original two computers, deactivate the ColdFusion Builder license on one of the two computers. After which, you can use it on another computer.

Updating ColdFusion Builder

Updates to ColdFusion Builder can include changes to security or new product functionality. Adobe recommends that you periodically check and install the updates, when available.

  1. In Adobe ColdFusion Builder, select Help > Check for Updates. If any new updates are available, ColdFusion Builder downloads and installs the updates.

  2. For the updates to take effect, restart ColdFusion Builder (standalone configuration) or restart Eclipse (plug-in configuration).

Installing third-party Eclipse plug-ins

ColdFusion Builder provides integration with third-party Eclipse plug-ins that let you extend or customize your development environment. You can install the third-party Eclipse plug-ins on Windows and Mac OS X platforms.

  1. In Adobe ColdFusion Builder, select Help > Install New Software.

  2. Click Add.

  3. Enter the name and URL of the plug-in to install.

  4. Select the plug-ins to Install.

  5. Click Next and follow the instructions in the Install wizard.

  6. Click Finish.

Getting started experience

ColdFusion Builder presents a dynamic getting started experience. Any time you start ColdFusion Builder, the Start Page screen invites access to:

  • Getting started tutorials
  • Workflows
  • Movie tutorials
  • Notifications such as What is new in a release and details of ColdFusion and ColdFusion Builder releases and hot fixes
  • Tips and tricks
  • Useful resources
  • Most used options such as Recently Open Files, Links to Open Project Wizard, Add server, Recommended extensions, and Install Extensions

You can choose to hide the Start Page, and then later display it again.

ColdFusion Builder Help System

While you work in ColdFusion Builder, you can display context-sensitive Help for specific user interface elements of the workbench (views and dialog boxes) and language-reference help for code elements.

Eclipse Help System

The Eclipse Help system displays CFML reference Help for code elements. The Eclipse Help system also displays Help for any third-party plug-ins that you install or that come packaged with ColdFusion Builder.

 The help content for the dialogs and wizards will be shown in a built-in browser just like how the help content for the CFML tags are rendered.

To open and view the Eclipse Help system, select Help > Help Contents.

Display CFML Reference Help

The CFML Reference is integrated into ColdFusion Builder, letting you quickly review the reference Help for a CFML tag or function.

To open the Help topic for a CFML tag or function, do the following:

  1. In the CFML editor, select a CFML tag element or function by highlighting or placing the pointer on the built-in tag or function name.

  2. Press F1 (Windows) or the equivalent keyboard shortcut for Mac OS. A link to the Help page for the selected tag is displayed in the docked Help window.

    Note:

    In Mac OS, when you press Command+Shift+/ to view Help for a CFML tag or function, generic editor Help appears in the docked Help window. To see the tag or function-specific Help, click the selected tag or function name in the CFML Editor again.

  3. Click the Help page link. The Help page for the selected tag or function is displayed.

Set Help Preferences

You can set Help preferences to control how Help is displayed in the Eclipse Help system.

  1. In ColdFusion Builder, select Window > Preferences.

  2. In the Preferences dialog box, you see a tree-view structure on the left side. Select Help.

  3. Set the following options, as required.

  • Open help search Determines whether to display the help search in the Dynamic Help view window or in a browser. By default, in the Dynamic Help is selected.
  • Open help view documents Determines where to display documents that are opened from links in Dynamic Help. By default, In-place is selected, and Help documents open in the Dynamic Help view window. To open Help documents in the ColdFusion Builder IDE editing area, select In the editor area.
  • Open help contents Lets you display help in a web browser of your choice. By default, the embedded browser of the IDE displays Help. Select In an external browser and then select the Web Browser link to select your web browser.
  • Open window context help Determines how to display context-sensitive Help links for an open window. By default, context-sensitive Help links are displayed in the Dynamic Help view which, when opened, is docked into the current perspective like all other views. To display context-sensitive Help links in an infopop (similar to a tooltip), select In An Infopop.
  • Open dialog context help Determines how to display context-sensitive Help links for an open dialog box. By default, Help is displayed in the dialog box. To display context-sensitive Help links in an infopop (similar to a tooltip), select In An Infopop.

Use dynamic Help

Dynamic Help is docked to the current perspective and displays topics for the associated views and dialog boxes.

  1. Select Help > Dynamic Help.

To change the default keyboard shortcut binding, select Window > Preferences > General > Keys, and change the associated binding for the Dynamic Help command. For more information on changing keyboard shortcuts, see CFML Editor keyboard shortcuts.

Getting started with ColdFusion Builder

Using ColdFusion Builder, you can develop ColdFusion applications in a full-featured IDE that lets you complete the following tasks:

Note:

Before getting started with the tasks, ensure that you are familiar with the ColdFusion Builder workbench and its capabilities and features. For more information, see ColdFusion Builder Workbench Basics.

  • Create ColdFusion projects: Using the Project wizard, you can create a project and configure a local or remote server with it. For more information, see Creating a ColdFusion project.
  • Add and manage servers: ColdFusion Builder includes integrated server management that allows you to manage your ColdFusion servers, the ColdFusion Administrator, and Server Monitor within ColdFusion Builder.You can configure both JRun and non-JRun servers. To manage your applications efficiently, ColdFusion Builder provides features such as virtual hosts, virtual directories, and URL prefixes. For more information on using these features and managing your servers, see Managing Servers.
  • Create ColdFusion pages, components, and interfaces: ColdFusion Builder provides wizards that let you create resources such as, ColdFusion pages, ColdFusion components (CFCs), and interfaces. You can associate these resources to a project. For more information, see Add ColdFusion pages, interfaces, and components.
  • Write and edit your ColdFusion application source code using the CFML editor: ColdFusion Builder provides code editors to edit CFML, HTML, JavaScript, and CSS code. Based on the type of code that you are editing, the appropriate editor is opened. For more information, see ColdFusion Builder editors.The editors provide many features, including code colorization, code assist, and Outline view, which help you navigate through your code. The CFML editor provides features such as code completion, code refactoring, and streamlined code navigation. ColdFusion Builder lets you use different colors and fonts to display your code in the editor. For more information on the complete feature-functionality of the CFML Editor, see Code Editing in ColdFusion Builder.
  • Write and edit SQL statements using the SQL Editor: The CFML editor has an integrated SQL editor that lets you edit and write SQL statements. You can also set code colorization preferences for supported SQL statements. For more information on the SQL Editor, see SQL Editor.
  • Use and create CFML dictionaries: ColdFusion Builder provides built-in CFML dictionaries that assist you with CFML code completion. CFML dictionaries are supported for ColdFusion versions 7, 8 and 9. You can also create your own custom CFML dictionary. For more information about using and creating dictionaries, see CFML Dictionaries.
  • Use ColdFusion Builder development views: ColdFusion Builder provides many views that let you develop your applications easily.The RDS FileView lets you access and explore file systems on local and remote servers. The RDS DataView lets you access and explore local or remote data sources. For more information, see RDS FileView and RDS DataView.You can also query data on a local or remote data servers using the RDS Query Viewer. For more information, see RDS Query viewer.The Services Browser view lets you browse through CFCs and their methods within the server web root. You can access both local and remote CFCs and web services. For more information, see Services Browser view.The Snippets view and Outline view let you reuse and streamline your code. For more information, see Snippets view and Outline view.For more information about all the development views, see ColdFusion Builder Development perspective.
  • Use the ColdFusion debugger to debug applications: ColdFusion Builder provides an integrated debugger with debugging views, like the Debug view and the Breakpoints view, which let you debug your applications. You can add breakpoints to your code, step into or over functions, and examine and evaluate expressions. You can debug files on both local and remote servers. For more information, see Debugging Applications.The Problems view, TailView view, and Console view detect syntax, server, and compilation errors and display them.
  • Use and develop ColdFusion Builder extensions: Use the Extensions view to manage ColdFusion Builder extensions. You can develop extensions to generate code, design user interfaces, and perform basic CRUD (Create, Read, Update, and Delete) operations on the database. You can also develop extensions to perform custom actions such as opening files in the CFML Editor or inserting text in an open file. For more information about creating extensions, see ColdFusion Builder Extensions. ColdFusion Builder provides the ColdFusion Builder Extension Creator to guide you through the process of creating and packaging extensions.
    The following extensions come packaged with ColdFusion Builder.
    • Adobe CFC Generator
    • ActionScript Class Generator
      For more information on installing and using these extensions, see Using Extensions.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy