Discover how to access, edit, and explore previous versions of Illustrator cloud documents in Illustrator, anywhere.
Colorful postcard imagery in an Illustrator document

What you'll need

This sample file contains assets provided by Adobe Stock for your tutorial practice purposes only. Check out the ReadMe file in the folder for the terms of use for this file. Adobe Stock has millions of royalty-free images and videos for your commercial use.  You can get 10 images with a free month trial.

Illustrator gives you seamless access to your Illustrator documents anywhere, using the power of cloud documents. A cloud document is an Illustrator document stored in the Adobe cloud that can be accessed anywhere you sign in to Illustrator. As you work on a cloud document, changes are automatically saved to the Adobe cloud, so the document is always available and up to date. You also have access to document history, which lets you browse previously saved versions of a document, bookmark and name specific versions, and open a version in a new window to see changes.

Open a local document

Sign in to Illustrator on your computer. On the Home screen, click the Open button. If a Cloud documents window opens, click the On Your Computer button in that window to switch to your local file system; then navigate to an .AI file on your computer and click Open. Otherwise, navigate directly to an Illustrator document (.AI) on your computer and click Open.

Clicking the On Your Computer button in the Cloud document window to save an Illustrator document locally

Save as a cloud document

Choose File > Save As. If you see a window with options to choose to save to cloud documents or save to computer, click the Save To Cloud Documents button. In the Cloud documents window that appears, you can change the name and click the Save button.

Note: If a file system window opens when saving, click the Save Adobe Cloud Document button in that window to follow the instructions for this step.

Clicking Save to Cloud documents button to save the Illustrator document as a cloud document in the Cloud documents window

The document automatically uploads to the Adobe cloud and becomes a cloud document that you can access anywhere you log in to Illustrator with the same Adobe ID. If you are offline after you save to cloud documents, the document will automatically upload to the Adobe cloud when you are connected. You can tell which open documents are saved to Adobe cloud by the cloud icon in the document tab above the Document window.

Cloud icon on the document tab indicating an open cloud document

Note: Currently, if you are offline, you cannot open a cloud doc.

A major benefit of a cloud document in Illustrator is that it automatically and regularly saves to the Adobe cloud as you work on it — often faster than saving locally (depending on your connection speed). The default auto-save interval is five minutes in Illustrator on your computer.  

Tip: You can change that cloud saving interval in Illustrator > Preferences > File Handling & Clipboard (macOS) or Edit > Preferences > File Handling & Clipboard (Windows).

Edit the document

Let’s make a change to the document. One way to quickly change the look of a document is to alter artwork color. In the sample file, select the Direct Selection tool and click to select one of the black shapes. To change the color, click the Fill color in the Properties panel. With the swatches showing in the panel, double-click the black swatch.

Edit the applied color to a selected shape in the Fill color panel

We changed the color to orange. Select Preview to see the color change throughout the document. The color you’re adjusting is a global color, which means it will update everywhere it’s used in the document, regardless of whether the artwork is selected or not. Click OK.

Change the color swatch values in the Swatch Options dialog box to edit a color globally

Close the document by choosing Choose File > Close. The document is saved automatically. 

Open a cloud document

If you still have a document open, click the Home tab above the document window to return to the Home screen. With the Home screen showing, with no document open, click Cloud documents on the left. The Cloud Documents Organizer is useful for viewing and managing all your cloud documents. You can organize your cloud documents into folders and rename, delete, move, organize, and open cloud documents. 

Accessing the home screen via the Home icon. In the Home screen, clicking Cloud Documents to show cloud documents

By clicking the ellipses (three dots) for a cloud document or selecting a series of cloud documents, you can rename, delete, and move them to a folder. 

Open the same cloud document by clicking its thumbnail. 

With cloud documents showing in the Home screen, renaming, deleting, and organizing cloud documents

Note: Another way to open a cloud document in Illustrator is to choose File > Open, or with the Home screen showing, click Open. If a file system window opens, click the Open Adobe Cloud Document button in that window to switch to the Cloud documents window; then click a cloud document thumbnail to open it.

Explore cloud document versioning

By saving a document as a Cloud document, you can also view and manage document versioning in Illustrator and on the web (assets.adobe.com/files). In Illustrator, with a cloud document open, open the Version History panel by choosing File > Version History or Window > Version History. 

The Version History panel lets you open previous versions of a document so you can copy elements to the current document or save an earlier version and pick up your work from there. If you select a version in the Version History panel list, you can preview it at the top of the panel. By clicking the three dots icon for that version, you have a few options. By selecting Name This Version, you can give a name to the chosen version, maybe to keep track of important milestones throughout a design project. You can also choose Revert To This Version to roll back the open cloud document to that saved history state.

Revealing options for versions in the Version History pane

You can also bookmark specific versions to retain those milestones indefinitely by clicking the Mark Version icon for a history state. Those marked versions appear in the Marked Versions section of the Version History panel. 

Marking a version of a cloud document in the Version History panel
09/02/2020

Adobe Stock contributor: Diana Hlevnjak

Was this page helpful?