Use this topic to learn how to add or edit scripts

Note:

Adobe will stop the Adobe Story CC service on January 22, 2019. Adobe Story CC, Adobe Story CC (Classic), and Adobe Story CC desktop application will be discontinued. See End of service FAQ for more information.

Create, import, duplicate, and copy a script

Add or edit scripts
Add or edit scripts

  • To create a script in the Projects view, select the project and click Create Script. Enter a title for the script, select the type of script (TV or Film) that you want to create, select the template to be used for the script and click Create.
  • To import a script in the Projects view, click Import > Select Script. When you edit a copy of a script outside Adobe Story, such as with MS® Word, you can import the document as the latest version of the script. This obviates the need to manually incorporate the changes. After the import, the state of the document before the import becomes the previous version of the document.
  • To duplicate a script within a project, in the Projects view, select the script. A menu appears at the top of the screen, select Copy > To Current Project.
  • To copy a script to another project, select the script in the Projects view. Select Copy > To Different Project from the menu at the top. A dialog box comes up where you can select the destination project.

You can only copy scripts to a project for which you are the owner, co-author, or writer.

Note:

If you import a script, Adobe Story formats it and creates a scene outline.

Scene elements

Scene element Description
Scene Heading A script usually opens with the Scene Heading of the first scene in the format INT/EXT. - .
Action An introduction to the scene, or the action being described in the scene.
Character The name of the character(s) involved in the action, or speaking the dialogue. A character element can have multiple characters separated by “ / “. For example, a simultaneous dialog may be spoken by multiple characters at the same time.
Speaking Extra An extra who may have a couple of speaking lines. Speaking extras are listed as extras in reports. Speaking Extra is indicated in blue and an * in the Character of the scene list.
Parenthetical The tone in which the actor narrates the dialogue, for example frowning and nonchalantly.
Dialog The dialogue for the character.
Transition Indicates how a scene transitions to another scene, for example FADE OUT.
General Use the General element if the text you enter cannot be classified under the standard elements.

You can change the element in a scene using the Element menu or keyboard shortcuts. You can also right-click the Scene element, and choose from the menu. The character, parenthetical, and the first line of the dialogue are always kept together. When there is insufficient space to accommodate the three elements at the end of a page, they are automatically moved to the next page with contd. mentioned.

Write scripts

  1. Single-click a script in the Projects view. The script opens in the Authoring view.
  2. Adobe Story assigns the Scene Heading element to the first paragraph. Enter the Scene Heading, and press Enter. The Action element is automatically inserted. If your script doesn’t begin with a Scene Heading, select a desired option from the Elements menu.
  3. Press Enter after the Character element. The focus shifts to the Dialog element. 
  4. When you press Enter after the character element or the parenthetical element, the focus shifts to the dialog element.
  5. Press Enter after the dialog element. The focus shifts to the character element. 
  6. Continue typing the scene using the required screen elements. Adobe Story assigns the standard formatting for the elements.
  7. Use the transition element to indicate end of a scene. Press Enter to move to the next scene.

Note:

The Action element is automatically converted to Scene Heading when you enter INT, EXT, I/E, or E/I in the beginning. However, auto-conversion doesn’t happen when you copy content to the Action element.

Writing aids

Adobe Story provides you with many options that help making the script writing process simpler and more efficient.

Auto-Complete

When you enable Auto-Complete, a list of options is displayed when you type the first few letters of a word that Adobe Story recognizes. Instead of typing the entire word, you can select an option from the menu.

For scene elements, a list of options is displayed when you insert the scene element. For example, if you are typing a scene heading with a location mentioned earlier, Adobe Story prompts with a list of locations matching the text. Click the location in the menu that appears. The location is added at the cursor location.

Select View > Auto-Complete to enable or disable Auto-Complete.

Following are the auto-complete options for inserting scene elements:

Key

Context

Effect

Enter

Scene Heading element

Inserts the Action element

Enter

Empty Scene Heading element

Displays the list of relevant elements

Enter

Parenthetical element

Inserts the Dialog element

Enter

Dialog element

Inserts the Character element

Formatting toolbar

The formatting toolbar provides you with options to format text in a document.

The toolbar is displayed only if you have enabled the option.

UI toolbar
Formatting toolbar

  • Select View > Formatting toolbar. You can do the following using the formatting toolbar:
    • Change the style of the selected text.
    • Change text color.
    • Change the way text is indented.
    • Highlight text within the script.
    • Change the Element type.

Paragraph flow

If a dialog does not fit on a page, the whole dialog flows to the next page. This prevents a dialog from breaking across pages.

When the following sequence of elements does not fit in a page, the whole sequence is wrapped to the next page:

  • Character followed by Dialog
  • Character followed by Dialog and then by Parenthetical
  • Character followed by Parenthetical and then by Dialog

This ensures that the relevant Character and Parenthetical elements stay with the dialog in a page.

Insert sticky notes

You can use sticky notes to add text annotations to your scripts. To insert sticky notes, select Insert > Sticky Notes. You can modify sticky notes in the following ways:

  • Drag the notes to change their position in a script.
  • Resize the note as per the text.
  • Box the note to create a box around your note.
  • Delete the note.
Sticky note
Sticky Note

Additional info

Use the following steps to add additional info in your documents:

  1. To add additional info to your document, select Insert > Additional Info. You can also use Cmd+Shift+Y.

  2. Add additional info
    Add additional info

    In the Additional Information dialog, add your instructions in the text field and click OK. Check the Boxed option if you want to box your additional info.

Show and hide overlays

Show and hide overlays in View menu
Show and hide overlays in View menu

Overlays are anything you draw on your script pad, which is not text. For example, scene numbers, camera shots, and sound elements. You can hide or show the overlays in your document. To show the overlays, open the View menu and select the overlay type. Visible overlays display a tick mark next to them.

If you want to remove an overlay, open the View menu and unselect the particular overlay type. When you print the document, the hidden overlays are not visible.

Export scripts

You can save a script to disk as a file with a .stdoc extension. 

Print scripts

  1. Select File > Print.

  2. In the Print dialog, select the following:

    • Paper size in which you want to print the script.
    • Number of pages to print. You can choose to print all pages, or specify a range of pages in the script to print.
    • Select Print Only Changed Pages if you want to print only the pages that have changed since the Track Changes feature was turned on.

    For example, if the page range selected for printing is 5-9 and pages 6-7 have changed since tracking was turned on, only pages 6-7 are printed. You can now print multiple non-contiguous scenes from a script. For example, you can select and print scenes 5, 8, 23, and 28.

  3. Click OK.

Scene Properties panel

When you work with scripts, you can use Scene Properties panel to view a summary of your scene. To display the panel, in the authoring view, select View > Scene Properties panel.

Following are the elements of the panel:

Element Description
Navigation By clicking the arrows next to the scene number, you can move between scenes.
Scene number Scene Properties panel displays the scene number at the top of the panel. The scene number is fetched from the source script.
Scene heading Scene Properties panel displays the scene heading. The scene heading is fetched from the source script.
Time and location of the scene Scene Properties panel displays time and location details of the scene. Details include Running Time, Time of Day, Story Day, and Studio/Location.
Characters Scene Properties panel displays a list of speaking and non-speaking characters in the scene.
Extras Scene Properties panel displays a list of speaking and non-speaking extras.
Synopsis Scene Properties panel displays the scene synopsis. Synopsis is the summary of a scene, which is added manually at the beginning of the scene.

Add and detect non-speaking characters

Scene Properties panel detects speaking and non-speaking characters and displays them in the panel. All characters with dialogues in a scene are categorized as SPEAKING CHARACTERS. Characters with no dialogue in a scene are categorized as NON-SPEAKING CHARACTERS.

The panel reads the character list created for the document. Character list includes names of all the characters in a script. If you click Detect, Scene Properties panel attempts to detect if the characters in the list are included in the scene. Any character which is part of the list but not included in the scene is categorized as a non-speaking character.

You can also edit the non-speaking character list. To modify the list, click Edit, EDIT NON-SPEAKING CHARACTERS dialog is displayed. You can perform the following tasks in the dialog:

  • Add a non-speaking character
  • Edit an existing non-speaking character
  • Delete an exiting non-speaking character

 

Add and edit non-speaking extras

You can also add non-speaking extras to your scene. To add non-speaking extras, click Edit and the EDIT NON-SPEAKING EXTRAS dialog is displayed. Add your extras and click OK.

Note:

 For more information on how to log in to the Flex version, see Scene properties panel.

History panel

You can work with versions of a document in the History panel. To view the panel, click View > History. You can also access the panel through Scene Properties panel. When you open the Scene Properties panel, there is a History tab next to panel. Click the tab to open the History panel.

Information about various versions of the script is displayed in the History panel. Information includes version number, author, and the time stamp. The content that you entered in the Description section when versioning a document is displayed when you move your mouse over the Comment icon. By default, the current version is selected and is editable. Older versions of your documents can only be viewed.

Create version numbers

Versioning a document helps create a history for the document, and monitor changes to a document over time. Versions are created in two ways:

  • Auto-versioning: When you edit your current document, Adobe Story automatically assigns version to your document. These versions are auto-saved.
  • Manual versioning: When you edit your document, select File > Save As and save your document as a version. You can add a version description in the Save As - Adobe Story dialog.

Compare versions

You can compare two versions of a document in History panel. To compare two versions, select a version and hover your mouse over the other version. A tooltip is displayed, which contains the following information:

  • Scenes: Number of new scenes, number of deleted scenes, and number of changed scenes in comparison to the selected version.
  • Words: Count of words changed in comparison to the selected version.

Restore and delete document versions

You can restore and delete different versions of your documents. In History panel, click the three dots icon next to the version you want to delete or restore. You get a list of actions you can perform. Select one of the following options:

  • Delete: Select Delete to delete the version. Only doc owner can delete a version.
  • Restore: Select Restore if you want to convert an older version into the current version. Restore option retains the older version and creates a copy of it, which is then converted to the current version. Doc owner, co-author, and writer can restore a version.
Restore and delete document versions
Restore and delete document versions

Compare two versions

You can compare two versions of a document with the Compare option. In History panel, click the three dots icon next to the version you want to compare and select Compare from the list. You can:

  • Compare the current version with an older version.
  • Compare two older versions.

You can keep two versions of your document next to each other and compare them. The top of the document shows the version number, name, and the date the document was last saved. You can edit the document as you compare and the changes are synced.

Changes in Outline view when comparing versions

Outline view
Outline view

When you compare two versions next to each other, the Outline view displays the differences in the two versions. The deleted elements are marked in red, new elements are marked in green, and any modification in scenes display a star next to them.

Customize templates

You can customize templates for different purposes within Adobe Story. For more information, see Customizing templates for scripts.

Import custom templates

You can import following film and TV templates to your new script documents:

  • Customized templates saved on your disk.
  • Templates created in Adobe Story classic (Flex).

Use the following steps to import templates in to new script documents:

  1. Go to document list view and click + SCRIPT icon.

  2. In the Create New Document dialog, click Template. A drop-down list is displayed, which includes the default and customized templates.

    Import film template
    Import film template

  3. Choose a suitable template and click Import.

Change template

For TV and film scripts, you can switch to any template from the currently applied template available under that particular script format. To switch, use the following steps:

  1.  Open a script document and select Edit > Change Template.

  2. In the Change Template dialog, click TEMPLATE and choose from the drop-down list.

    Change template
    Change template

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy