Issue

When you choose File > Open or File > Save As in Adobe Photoshop CS3 or other CS3 application, the dialog box flashes and then disappears. Or, the application appears to freeze.

Solutions

Do one or more of the following solutions.

Note: Some of these procedures require you to locate hidden files, hidden folders, or files by their full filenames, which include extensions (for example, settings.xml). By default, Windows Explorer doesn't show hidden files, hidden folders, and filename extensions that it recognizes. For information on showing hidden files and folders in Windows, see Show hidden files, hidden folders, and filename extensions | Windows XP | Vista | Windows 7 (kb404324).

Solution 1: Press the Esc key, and then choose File > Open or File > Save As.

If the Open or Save As dialog's position is not reset, then continue with the following solutions.

Solution 2: Use the keyboard to move the dialog back into view.

  1. Choose File > Open or File > Save As. (Choose whichever dialog fails to appear on your screen.)
  2. Remove your hand from your mouse or other pointing device.
  3. Press and release the Alt key on your keyboard.
  4. Press and release the spacebar.
  5. Press and release the M key.
  6. Use the Left or Right Arrow key to move the dialog box back into view on your monitor. Hold down the Left arrow key for several seconds. If the Save As or Open dialog box does not appear, then hold down the Right arrow key until the dialog appears.



    Note: If you have other displays configured above or below your current display, use the Up or Down arrow keys instead or the Left or Right arrow keys.

     
  7. Choose a filename and other options in the dialog, and then click Save or Open. The application remembers the current window placement, and you can resume using your mouse or other pointing device.

Solution 3: Switch to the Adobe Dialog.

If the lower-left portion of the Open or Save As dialog is visible, then click Use Adobe Dialog.



If the lower-left portion of the Open or Save As dialog is not visible, and if another Version Cue-enabled application (Illustrator CS3 or InDesign CS3) is installed, then open the other application Choose File > Open, and click Use Adobe Dialog. Then return to your other. CS3 application.

Solution 4: Set your other monitor to be the primary monitor.

For instructions on changing the primary monitor in Windows XP, see "Change the primary monitor" in Windows Help and Support.

For instructions on changing the primary monitor in Windows Vista, see "Change display settings on multiple monitors" in Windows Help and Support.

Solution 5: If you use the Adobe Dialog because you use Adobe Version Cue, then reset the Version Cue Client settings file.

  1. Close all Adobe applications.
  2. Exit from the Version Cue Server.
  3. Do one of the following:



    • Windows XP: Rename or delete the settings.xml file (for example, to settings.old) in the \Documents and Settings\[your user name]\Application Data\Adobe\Workflow folder.
    • Windows Vista: Rename or delete the settings.xml file (for example, to settings.old) in the \Users\[your user name]\AppData\Roaming\Adobe\Workflow folder.

Solution 6: Install the latest drivers for your video display adapter.

If you already have the latest drivers, reinstall them to repair the installation.

Solution 7: Re-create the CS3 application preferences file.

Photoshop is used as an example. For other applications, the process is the same, but the preference location is slightly different, based on the name of the application.

  1. Close Photoshop CS3.
  2. Do one of the following:



    • Windows XP: Rename the Adobe Photoshop CS3 Prefs.psp file (for example, to Adobe Photoshop CS3 Prefs.old) in the \Documents and Settings\[your user name]\Application Data\Adobe\Adobe Photoshop CS3\Adobe Photoshop CS3 Settings folder.
    • Windows Vista: Rename the Adobe Photoshop CS3 Prefs.psp file (for example, to Adobe Photoshop CS3 Prefs.old) in the \Users\[your user name]\AppData\Roaming\Adobe Photoshop CS3\Adobe Photoshop CS3 Settings folder.
  3. Open Photoshop CS3. Photoshop creates a preferences file.

If the problem continues, the preferences file isn't the cause. To restore custom settings, delete the new preferences file and restore the original name of the previous preferences file.

Solution 8: Update the user privileges on the preferences folder.

Damaged or incorrect user permissions can prevent CS3 applications from saving the location of the Open and Save As dialogs in its preference file.

To update the permissions on the Adobe-specific folders that store your preferences, use the Command Prompt method below. Or, use one of the three alternate methods that follow.

Command Prompt method:

You can use this method on either Windows XP or Windows Vista.

  1. Quit all applications.
  2. Choose Start > All Programs > Accessories > Command Prompt.
  3. Type the following command in the Command Prompt window exactly as it appears below, including the quotation marks, and then press Enter:



    cacls "%appdata%\adobe" /T /E /C /G "%username%":F



    Important: Be sure to enter a space before and after /T, /E, /C, and /G.

  4. Close the Command Prompt window.

Alternate method for Windows XP Professional:

  1. Close your CS3 applications.
  2. Choose Start > My Computer.
  3. Choose Tools > Folder Options.
  4. Click the View tab.
  5. At the bottom of the Advanced Settings section, uncheck Use Simple File Sharing.
  6. Click OK.
  7. Choose Start > Run.
  8. Type the following command and then click OK or press Enter on your keyboard:



    %appdata%

     
  9. Right-click the Adobe folder and select Properties.
  10. Select the Security tab.
  11. Make sure that Administrators and SYSTEM are listed and that security permissions are set to Full Control.
  12. Click Advanced.
  13. Check Replace Permission Entries On All Child Objects With Entries Shown Here That Apply To Child Objects.
  14. Click the Owner tab.
  15. Select Administrators.
  16. Check Replace Owner On Subcontainers And Objects.
  17. Click OK.
  18. Click OK on the warning that displays.
  19. Open your CS3 application(s).

Alternate method for Windows XP Home:

  1. Restart Windows into Safe Mode.

    1. Quit all applications.
    2. Choose Start > Run, type msconfig in the Open text box, and then click OK.
    3. Click the BOOT.INI tab.
    4. In the Boot Options section, select /SAFEBOOT.
    5. Click OK, and then restart your computer.



      Note: Upon restart, you are sometimes notified that the System Configuration Utility has made changes to the way that Windows starts. If so, click OK, and then click Cancel when the System Configuration utility appears.
  2. Choose Start > My Computer.
  3. Choose Tools > Folder Options.
  4. Click the View tab.
  5. At the bottom of the Advanced Settings section, uncheck Use Simple File Sharing.
  6. Click OK.
  7. Choose Start > Run.
  8. Type the following command and then click OK:



    %appdata%

     
  9. Right-click the Adobe folder and select Properties.
  10. Select the Security tab.
  11. Make certain that Administrators and SYSTEM are listed and security permissions are set to full control.
  12. Click Advanced.
  13. Click Replace Permission Entries On All Child Objects With Entries Shown Here That Apply To Child Objects.
  14. Click the Owner tab.
  15. Select Administrators.
  16. Check on Replace Owner On Subcontainers And Objects.
  17. Click OK.
  18. Click OK on the warning that displays.
  19. Choose Start > Run, type msconfig in the Open box, and then click OK.
  20. Click the BOOT.INI tab.
  21. In the Boot Options section, deselect /SAFEBOOT.
  22. Click OK, and then restart your computer.
  23. Open your CS3 applications.

Alternate method for Windows Vista:

  1. Close your CS3 applications.
  2. Click Start.
  3. In the Start Search box, type the following command and then press Enter:



    %appdata%

     
  4. Right-click on the Adobe folder and select Properties.
  5. Select the Security tab.
  6. Make certain that Administrators and SYSTEM are listed and security permissions are set to full control.
  7. If Administrators and SYSTEM are not set to Full Control, then do the following:
    1. Click Edit.
    2. Follow the onscreen navigation through the UAC (User Account Control) elevation prompt.
    3. Make the necessary changes.
  8. Click Advanced.
  9. Click Edit, and then confirm the UAC elevation prompt.
  10. Check Replace Permission Entries On All Child Objects With Entries Shown Here That Apply To Child Objects.
  11. Click OK.
  12. Click the Owner tab.
  13. Click Edit and follow the on-screen navigation through the UAC elevation prompt.
  14. Select Administrators.
  15. Check on Replace Owner On Subcontainers And Objects.
  16. Click OK.
  17. Click OK on the warning that displays.
  18. Open your CS3 applications

Solution 9: Run your CS3 applications in a new user account.

Create a user account that has the same permissions as the account that you use when the problem occurs. If the problem doesn't recur, then the original user account can be damaged. For instructions on creating a user account, see "To add a new user to the computer" in Windows Help or contact your system administrator.

Additional Information

This issue can occur when you use OS dialog boxes, you have or had a dual-monitor setup, and the application was displayed on the secondary monitor.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy