Learn how to make your Adobe Illustrator assets ready for Adobe Aero.

You can bring Illustrator assets as an image file or as a Photoshop document (PSD) with layers.

Illustrator files can be exported to PSD with their layers preserved for use in layered AR creations. Layers at the top level of a PSD become layers in Aero. To control which parts of the document become different layers in PSD (and therefore Aero), you need to do one of two things:

  1. Separate your document into separate layers. Illustrator layers become Photoshop layers on export, which become Aero layers when imported.

  2. If your document is a single layer in Illustrator, you can use groups to control which elements become layers in your export. Note: In this case, elements next to each other in the Layers Panel in Illustrator are each collapsed into a single PSD layer.

Note:

In Illustrator, elements on the same layer in the Layers Panel are collapsed into a single PSD layer.

Bringing Illustrator assets as a flat image into Aero

To bring Illustrator assets as an image into Aero, you have to export as SVG from Illustrator. Aero imports as a flat layer now. The vector contents are rasterized upon importing into Aero.

  1. From Adobe Illustrator CC, go to File > Export > Export As...

  2. Choose SVG.

  3. Save the file somewhere you are able to access from your phone, for example, your Creative Cloud Files.

  4. Now, open Aero on your device and import the asset.

Bringing Illustrator assets as multi-layered content into Aero

To bring multi-layered assets from Illustrator into Aero, export as PSD from Illustrator. This helps preserve the layers upon importing in to Aero. 

Note:

If your creation is on a single layer but is separated into groups and elements, you can simply export a PSD and then import assets

  1. From Adobe Illustrator CC, go to File>Export>Export As... 

  2. Choose PSD.

  3. Click Export and press OK.

  4. Save the file that you want to import into Aero, in a place accessible from your mobile device (Creative Cloud or files).

  5. Optionally, edit the exported Photoshop Document.

  6. Now open Aero on your device and import the asset.

  7. To space out the layers of your asset, select it and choose Spacing.

A few things to keep in mind

  • Every layer is rasterized upon import into Aero. Because every layer is rasterized, documents with low number of layers are likely to have better performance in Aero.
  • You can flatten layer groups from the Window>Layers panel in Adobe Illustrator. 
  • To use objects on different layers in Aero, separate the layers in Adobe Illustrator.
  • Layer groups at the top level are flattened into a single layer each.
  • Adjustment layers and blend modes at the top level are ignored.
  • Adjustment layers within layer groups are flattened.
  • Smart objects, text layers, layer effects, and vector layers are rasterized.
  • 3D layers at the top level are not processed. Upon import, the first normal layer is imported instead.
  • Channels applied as masks are a part of the layer composites. Extra channels are ignored.

A little more about using Layers in Illustrator

Layers in Illustrator can also be created, reordered, and deleted via the layers panel in Windows>Layers

If your work is organized into separate groups and you want to convert them to layers, you can use the menu in the layers panel. 

Open Windows > Layers. In the Layers panel menu, click Release to Layers (Sequence) or Release to Layers (Build) option. Layers are created from your groups and elements.

What's next?

In Adobe Aero, follow the steps to import assets from Creative Cloud Files.

You can then place the asset, edit the scene, and add interactivity to your 3D content. 

Have a question or an idea?

If you have a question to ask or an idea to share, come and participate in Adobe Aero Community. We would love to hear from you. Also, share your ideas on User Voice to make Adobe Aero better.

Dont forget to showcase your work on Behance and seek inspiration from others work as well.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy