Remarque :

la fonctionnalité OpenGL dans After Effects CS6 est différente de celles des versions antérieures. Ce document concerne uniquement les versions After Effects CS4 à CS5.5. Pour plus d’informations sur les fonctions du GPU dans After Effects CS6, regardez cette vidéo.

Ce document peut vous aider à résoudre les problèmes liés à OpenGL qui se produisent avec After Effects. Les problèmes OpenGL peuvent se manifester sous différentes formes, notamment les suivantes (mais sans que cette liste soit exhaustive) :

  • Au démarrage, Adobe After Effects se bloque ou se ferme sans erreur.
  • Un blocage se produit lorsque vous purgez le montage ou prévisualisez une composition ou en effectuez le rendu.
  • Un blocage se produit lorsque vous modifiez les paramètres d’un effet alors que les prévisualisations OpenGL sont activées.
  • Un blocage se produit lorsque vous activez les prévisualisations OpenGL.
  • La fenêtre de composition est longue à se réactualiser.
  • Des artefacts ou des blocs de pixels « pollueurs » apparaissent dans la fenêtre de composition.
  • La fenêtre de composition est différente selon que les prévisualisations OpenGL sont activées ou désactivées.
  • Un message d’erreur de l’un des types suivants s’affiche :

    « Alerte After Effects : Un problème s’est produit lors du traitement des commandes OpenGL. »

    « L’instruction à 0x00fe1940 emploie l’adresse mémoire 0x000000000. La mémoire ne peut pas être lue. »

    « AE_OpenGL : Echec de génération du calque d’ombre (5065::0) »

    « Cette composition est trop complexe pour le matériel OpenGL. »

    "Erreur After Effects : AE_OpenGL : Erreur de création de texture. (5065 :: 0) »

Pour obtenir des informations sur la configuration des préférences de prévisualisation dans After Effects pour OpenGL, ainsi qu’une liste des fonctions After Effects prises en charge par OpenGL, voir Rendu avec OpenGL dans l’aide d’After Effects.

Pour tirer le meilleur parti de ce document, effectuez les différentes tâches dans l’ordre dans lequel elles y figurent. Enregistrez les tâches à réaliser et les différents résultats obtenus, notamment les erreurs et autres problèmes. Ces informations peuvent être utiles au support technique d’Adobe si vous êtes amené à le contacter.

Vous devez être connecté en tant qu’administrateur pour effectuer certaines des procédures de ce document.

Sous Windows, certaines de ces procédures nécessitent que vous localisiez les fichiers et dossiers cachés. Certaines procédures nécessitent que vous recherchiez les fichiers selon leur nom de fichier complet, extension comprise (par exemple, exemple_nomfichier.ini). Par défaut, l’Explorateur Windows n’affiche pas les fichiers et dossiers cachés, ni les extensions de fichier connues. Consultez la section Affichage des fichiers et dossiers cachés dans Windows pour plus d’informations.

Pour Windows Vista, les étapes de ce document qui font référence au Panneau de configuration concernent l’affichage classique. Pour plus d’informations sur l’activation de l’affichage classique du Panneau de configuration et sur de nombreuses autres procédures standard du système d’exploitation, reportez-vous à Procédures standard du système d’exploitation.

Ces étapes peuvent vous aider à résoudre les problèmes OpenGL les plus courants. Avant de réaliser l’une de ces tâches, sauvegardez l’ensemble de vos fichiers personnels (par exemple, les fichiers After Effects créés antérieurement). Si une erreur système se produit, redémarrez toujours votre ordinateur afin d’actualiser sa mémoire. Si vous continuez à travailler sans redémarrer l’ordinateur, vous risquez d’aggraver le problème.

1. Mise à jour vers la version la plus récente d’After Effects

Pour trouver les mises à jour disponibles, sélectionnez Aide > Mises à jour dans After Effects.

2. Vérification visant à s’assurer que le système dispose de la configuration requise pour After Effects

La configuration système requise pour After Effects figure à la page : Configuration requise pour Adobe After Effects.

3. Vérification visant à s’assurer que la carte vidéo et les pilotes répondent aux exigences d’OpenGL

L’utilisation d’OpenGL dans After Effects requiert une carte OpenGL prenant en charge OpenGL 2.0.

Pour déterminer la version d’OpenGL que votre carte prend en charge, cliquez sur le bouton Informations sur OpenGL dans les préférences de prévisualisation. Sous Mac OS, choisissez After Effects > Préférences > Prévisualisations. Sous Windows, choisissez Edition > Préférences > Prévisualisations.

Pour plus d’informations sur le matériel OpenGL pris en charge, consultez la section Fonctions GPU (CUDA, OpenGL).

Les pilotes de carte vidéo plus récents peuvent améliorer les fonctionnalités OpenGL de votre carte. Consultez l’article Mise à jour du pilote de la carte vidéo ci-dessous.

4. Désactivation d’OpenGL afin de déterminer s’il est à l’origine du problème

Pour désactiver les prévisualisations OpenGL :

  1. Choisissez After Effects > Préférences > Prévisualisations (Mac OS) ou Edition > Préférences > Prévisualisations (Windows).
  2. Désélectionnez l’option Activer OpenGL.

Remarque : OpenGL ne prend pas en charge certaines fonctions dans After Effects, et l’apparence de votre composition peut changer selon que vous utilisez des prévisualisations OpenGL ou des prévisualisations rendues par logiciel. Pour obtenir la liste des fonctions prises en charge par OpenGL, voir Rendu avec OpenGL dans la rubrique Rendu et exportation de l’aide d’After Effects.

5. Suppression du module externe OpenGL du dossier de modules externes d’After Effects

Pour déterminer si la technologie OpenGL est à l’origine du problème, supprimez le module externe OpenGL et redémarrez After Effects.

Pour supprimer le module externe OpenGL :

  1. Quittez After Effects.
  2. Mac OS : faites glisser le fichier AE_OpenGL.plugin du dossier Applications/Adobe After Effects CS4/Plug-ins/Extensions sur le Bureau.

    Windows : faites glisser le fichier AE_OpenGL.AEX du dossier C:\Program Files\Adobe\Adobe After Effects CS4\Support Files\Plug-ins\Extensions sur le Bureau.
  3. Redémarrez After Effects.

Si le problème persiste, OpenGL n’en est pas la cause. Replacez le module externe OpenGL dans son emplacement d’origine. Si le problème ne se reproduit pas, il est lié à OpenGL. Consultez l’article Mise à jour du pilote de la carte vidéo ci-dessous.

6. Mise à jour du pilote de la carte vidéo

La plupart des problèmes ou conflits OpenGL sont résolus par la mise à jour du pilote de carte vidéo. En général, les fabricants de cartes vidéo mettent fréquemment à jour les pilotes logiciels. Si vous n’avez pas mis à jour récemment le pilote de votre carte vidéo, contactez le fabricant de la carte vidéo afin d’obtenir un pilote mis à jour ou téléchargez-en un depuis le site Web du fabricant.

7. Redémarrage d’After Effects et test du comportement à l’origine du blocage (Windows uniquement)

Après un blocage provoqué par un problème OpenGL sous Windows, After Effects CS4 peut désactiver automatiquement la préférence Empêcher la fragmentation de l’espace d’adressage DLL. Cette préférence permet à After Effects d’accéder à une plus grande quantité de mémoire RAM contiguë, mais peut être incompatible avec certains pilotes OpenGL.

Vous pouvez activer ou désactiver la préférence Empêcher la fragmentation de l’espace d’adressage DLL via Edition > Préférences > Mémoire et cache.

Laissez cette préférence activée, sauf en cas de blocages liés à OpenGL ou à la mémoire. Si vous désactivez la préférence en raison d’un problème OpenGL et que vous mettez ensuite à jour les pilotes de carte vidéo, réactivez la préférence. Vérifiez ensuite à nouveau le problème.

8. Optimisation de la préférence de mémoire Texture

Des blocages ou des erreurs OpenGL peuvent se produire si After Effects tente d’utiliser trop de mémoire de texture vidéo. La mémoire de texture est la quantité de mémoire RAM dont dispose la carte vidéo (VRAM).

Pour définir la valeur Mémoire de textures dans After Effects :

  1. Multipliez la mémoire VRAM installée totale par 80 % pour calculer la valeur Mémoire de textures optimale.
  2. Dans After Effects, choisissez After Effects > Préférences > Prévisualisations (Mac OS) ou Edition > Préférences > Prévisualisations (Windows).
  3. Cliquez sur Informations sur OpenGL.
  4. Entrez la valeur calculée à l’étape 1, puis cliquez sur OK.

La valeur Mémoire de textures équivaut à 80 % de la mémoire VRAM figurant sur votre carte vidéo. (Si vous utilisez plusieurs cartes vidéo, calculez 80 % de la mémoire VRAM de la carte vidéo identifiée dans la boîte de dialogue Informations sur OpenGL.) Si la valeur Mémoire de textures d’After Effects est définie sur plus de 80 % de la mémoire VRAM, la carte vidéo risque de ne pas disposer de mémoire VRAM suffisante pour gérer l’interface utilisateur ou d’autres tâches. (L’écran entier peut devenir blanc, par exemple.) Si la valeur est définie sur moins de 80 %, les prévisualisations OpenGL dans After Effects peuvent nécessiter plus de temps pour traiter les images.

Consultez l’aide de Mac OS ou de Windows pour savoir comment déterminer la quantité de VRAM présente sur une carte graphique.

9. Purge des caches d’image et de la mémoire vidéo

Si After Effects affiche des artefacts ou des blocs de pixels « pollueurs » dans la fenêtre de composition, il est possible que la mémoire vidéo (VRAM) soit saturée, fragmentée ou corrompue. Purgez les caches d’image et la mémoire vidéo pour vider la mémoire VRAM et laissez After Effects reconstruire la prévisualisation de composition.

Pour purger les caches d’image, choisissez Edition > Purger > Caches d’image.

Pour purger la mémoire vidéo, choisissez Edition > Purger > Mémoire vidéo.

Remarque : certains économiseurs d’écran qui utilisent OpenGL (ou Direct3D sous Windows) peuvent corrompre la mémoire vidéo s’ils sont activés alors qu’After Effects est en cours d’exécution. Changez ou désactivez l’économiseur d’écran si vous avez fréquemment des problèmes d’images corrompues dans la fenêtre de composition après la désactivation de l’économiseur d’écran.

10. Redéfinition du paramètre de couleur de la carte sur Le plus élevé (32 bits) (Windows) ou Millions (Mac OS)

Reportez-vous à l’aide Mac OS ou à l’aide Windows pour plus d’informations sur la modification des paramètres de carte vidéo ou d’affichage.

11. Désactivation des fonctions avancées de la carte vidéo (Windows uniquement)

La plupart des pilotes de carte vidéo incluent des utilitaires permettant d’accéder aux fonctions avancées de la carte. En particulier, les fonctions d’anticrénelage et de mode 16 bits peuvent entrer en conflit avec OpenGL et provoquer le blocage d’After Effects. Définissez les fonctions avancées de la carte sur leurs valeurs par défaut, puis désactivez les fonctions d’anticrénelage et de mode 16 bits.

Si vous utilisez plusieurs moniteurs avec une carte Nvidia, définissez le paramètre d’écrans multiples sur « Compatible ».

Reportez-vous à la documentation de la carte vidéo ou au site Web du fabricant pour obtenir des instructions sur la façon d’accéder à ses fonctions avancées.

12. Utilisation d’un seul moniteur

Si vous utilisez plusieurs moniteurs et rencontrez des problèmes avec OpenGL dans After Effects, essayez ce qui suit :

  • Si vous avez placé la fenêtre de l’application After Effects ou le panneau Composition sur un moniteur secondaire, déplacez la fenêtre vers le moniteur principal.
  • Déconnectez tous les moniteurs sauf un.
  • Si vous utilisez plusieurs cartes vidéo, supprimez-les toutes sauf une. Pour obtenir des résultats optimaux avec OpenGL, utilisez une seule carte vidéo à double moniteur.

13. Placement du script Reduce OpenGL Texture Size dans le dossier des scripts de démarrage

Le script Reduce OpenGL Texture Size réduit la quantité de mémoire de texture utilisée par After Effects et peut fournir une meilleure compatibilité avec les cartes vidéo plus anciennes.

Pour placer le script Reduce OpenGL Texture Size dans le dossier des scripts de démarrage :

  1. Accédez au dossier des scripts After Effects.

    Sous Mac OS : Applications/Adobe After Effects CS4/Scripts.

    Sous Windows : C:\Program Files\Adobe\Adobe After Effects CS4\Support Files\Scripts.
  2. Déplacez le fichier Reduce OpenGL Texture Size.jsx du dossier (support) vers le dossier Startup.

Une carte vidéo plus récente peut améliorer les fonctionnalités OpenGL de votre ordinateur et rendre le script inutile. Après avoir installé une nouvelle carte et ses pilotes, replacez le script Reduce OpenGL Texture Size dans le dossier (support). Réinitialisez ensuite les préférences d’After Effects.

14. Réinitialisation des préférences d’After Effects

Recréez le fichier de préférences d’After Effects afin d’éliminer les problèmes susceptibles d’être causés par des préférences OpenGL endommagées.

Pour recréer le fichier de préférences d’After Effects, redémarrez After Effects. Lancez l’application tout en maintenant enfoncées les touches Ctrl+Alt+Maj (Windows) ou Commande+Option+Maj (Mac OS).

15. Contact avec le support technique d’Adobe

Si aucune des étapes ci-dessus n’a permis de résoudre l’erreur ou le blocage que vous rencontrez avec After Effects, contactez le support technique d’Adobe. Vous pouvez trouver les options de support dans le support Adobe.

 

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne