Présentation de l’interface

Découvrez l’interface et l’espace de travail de Substance 3D Designer.

Designer peut sembler impressionnant au début, mais une fois que vous connaissez l’utilité de chaque partie de son interface, il devient beaucoup plus facile à comprendre.

Diagramme présentant une version simplifiée de la disposition de l’interface utilisateur de Designer, avec des libellés pointant vers chaque section.

A. Barre d’outils principale B. Explorateur C. Graphe D. Propriétés E. Vue 2D F. Vue 3D G. Bibliothèque 

Remarque :

Il se peut que vous ne reconnaissiez pas certains des termes de cette page. Si un mot ou un concept ne vous est pas familier, consultez le Glossaire pour en obtenir la définition ou découvrez les Concepts de base de Substance Designer.

Barre d’outils principale

Recherchez les menus principaux et les boutons d’accès rapide utiles.

Dans le menu Fichier, vous pouvez :

  • enregistrer et ouvrir des packages ;
  • créer des packages et des graphes ;
  • charger à nouveau tout le contenu ;
  • quitter l’application.

Le menu Édition vous permet d’annuler et de rétablir des actions. Il vous donne également accès à la fenêtre Préférences dans laquelle vous pouvez régler les paramètres de l’application.

Le menu Outils vous permet d’ajuster les options de Substance Engine. Substance Engine est le processus qui calcule les graphes Substance. Dans le menu Outils, vous pouvez mettre en pause, réinitialiser et régler les paramètres de Substance Engine. Le menu Outils vous donne également accès au Gestionnaire de plugins.

Le menu Fenêtres permet de gérer les fenêtres qui composent l’interface de Designer. Vous pouvez ouvrir de nouvelles fenêtres, activer/désactiver la visibilité d’une fenêtre particulière ou utiliser Fenêtres > Réinitialiser la disposition pour rétablir l’état par défaut de Designer.

Dans le menu Aide, vous pouvez accéder à des ressources telles que la documentation, les tutoriels et les notes de mise à jour de Designer. Vous pouvez également nous envoyer des commentaires et signaler des bogues, ou trouver des informations supplémentaires sur les licences et les versions.

Panneau Explorateur

Permet de gérer les packages et les ressources.

Deux exemples de menu contextuel ouverts dans le panneau Explorateur. La première image illustre le menu contextuel d’un package, tandis que la seconde présente le menu contextuel d’un graphe.
Le menu contextuel change en fonction du type de ressource sur lequel vous cliquez. À gauche, vous pouvez voir le menu contextuel d’un package, tandis qu’à droite, il s’agit de celui d’un graphe.

Le panneau Explorateur est votre principal moyen d’interagir avec des fichiers et des ressources dans Designer. 

Le panneau Explorateur répertorie tous les packages ouverts et en affiche le contenu. Cliquez avec le bouton droit de la souris sur les packages, les graphes ou d’autres ressources pour afficher un menu contextuel. Toutes les ressources disposent d’un ensemble d’options standard :

  • Ouvrir
  • Fermer
  • Renommer
  • Copier et coller

Certaines ressources ont des options uniques qui ne sont disponibles que dans le menu contextuel. Vous pouvez également cliquer avec le bouton droit de la souris sur un espace vide dans le panneau Explorateur pour créer un package vide.

Des boutons situés en haut du panneau Explorateur permettent de gérer vos ressources. Pour activer ces boutons, commencez par sélectionner un package ou un graphe.

Si vous cliquez sur une ressource, le panneau Propriétés est mis à jour et affiche les propriétés de la sélection en cours.

Vous pouvez ouvrir plusieurs panneaux Explorateur. Utilisez Fenêtres > Nouvel explorateur pour ouvrir un autre panneau Explorateur.

Viewport du graphe

Permet de créer des graphes basés sur des nœuds.

Copie d’écran de la fenêtre de graphe de Designer. Cette image présente la barre d’outils Graphe affichée en haut de la fenêtre ainsi que le viewport du graphe au-dessous de cette barre d’outils.
Le viewport du graphe se compose de la barre d’outils Graphe et de l’élément Affichage du graphe. La barre d’outils Nœud fait partie de la barre d’outils Graphe.

Le viewport du graphe est l’emplacement où vous passerez la plupart de votre temps dans Designer. Il affiche les graphes que vous créez ou ouvrez avec Designer. De plus, vous pouvez y ajouter, supprimer et organiser des nœuds.

Il existe deux zones distinctes : la barre d’outils et la zone d’affichage.

Barre d’outils Graphe

Copie d’écran recadrée de la barre d’outils Graphe.

La barre d’outils Graphe contient des outils permettant de gérer votre graphe et la plupart des nœuds les plus utilisés. Pour simplifier les choses, les boutons avec arrière-plans colorés sont des nœuds tandis que les autres boutons sont des outils. 

Les outils suivants sont disponibles sur la barre d’outils principale :

  •  Mise au point : replace votre sélection dans la vue. Si aucun nœud n’est sélectionné, l’outil Mise au point affiche l’intégralité du graphe. L’outil Mise au point vous permet d’accéder rapidement à votre sélection ou de la rechercher. La touche de raccourci F a la même fonction.
  •  Réinitialiser le zoom : rétablit le niveau de zoom 1:1 par défaut. La touche de raccourci Z a la même fonction.
  •  Copie d’écran : permet d’enregistrer une copie d’écran PNG de l’ensemble de votre graphe, avec la transparence. Vous pouvez définir le nom et l’emplacement du fichier dans la boîte de dialogue Fichier qui s’ouvre.
  •  Informations : ouvre une liste déroulante où vous pouvez activer/désactiver les options Noms de connecteur, Badges du nœud, Taille du nœud et Durées du nœud. Lorsqu’elles sont activées, ces options ajoutent des informations aux nœuds dans la zone d’affichage.
  •  Recherche : permet de rechercher des nœuds et des paramètres dans le graphe en filtrant le type et le texte.
  •  Flux des tons clairs : clarifie les nœuds connectés à la sélection en cours. Les nœuds non connectés sont grisés.
  •  Barre d’outils Nœud : active/désactive l’affichage des boutons des nœuds atomiques. 
  •  Barre d’outils Parent : active/désactive l’affichage du contrôle Résolution du parent sur la barre d’outils.
  •  Mode de création de lien : permet de choisir l’un des trois modes à utiliser (Standard, Matériau ou Matériau compact). Les raccourcis clavier 1, 2 et 3 exécutent les mêmes fonctions.
  •  Liens de rectangle : permet de définir si les liens sont des courbes lisses ou des angles rectangulaires.
  •  Contrôle de durée : permet de réinitialiser les affichages de durée. L’option Contrôle de durée n’est appropriée que si le paramètre Durées du nœud est activé dans la liste déroulante Informations.
  •  Outils : permet d’accéder à une liste déroulante comprenant diverses options. 
    • L’option Effacer supprime les nœuds inutilisés du graphe.
    • L’option Exporter les sorties ouvre la boîte de dialogue Exporter qui vous permet d’exporter des fichiers bitmap.
    • L’option Réexporter les sorties réexécute une sortie précédente avec les mêmes options, sans afficher la boîte de dialogue.
    • L’option Exportateur PSD ouvre le panneau Exportateur PSD supplémentaire. Le panneau Exportateur PSD s’affiche à droite de la vue du graphe.
  •  Barre d’outils Vignettes : active/désactive l’affichage des options de vignettes sur la barre d’outils.
  •  Outils d’alignement : active/désactive l’affichage des outils d’alignement sur la barre d’outils. Les outils d’alignement vous permettent d’aligner et d’organiser vos nœuds sur la grille du graphe.

 

Barre d’outils Nœud

Barre d’outils Nœud

Cliquez sur un nœud de la barre d’outils Nœud pour l’ajouter au graphe. La barre d’outils Nœud contient les nœuds atomiques de Designer. Il s’agit des nœuds fondamentaux des graphes Designer. Ce sont les blocs de création que vous pouvez utiliser pour créer des réseaux complexes. Pour plus d’informations sur les nœuds, reportez-vous à la page Présentation des nœuds.

Remarque :

La barre d’outils Nœud n’est qu’une façon d’ajouter des nœuds. De nombreux autres nœuds sont disponibles au-delà de ceux affichés dans la barre d’outils. Pour en savoir plus, consultez l’article Création d’un graphe.

Affichage du graphe

Vue du graphe

La zone d’affichage du graphe contient les nœuds qui composent le graphe. Placez et connectez des nœuds afin de créer un graphe qui génère vos textures. 

Reportez-vous à la page Création d’un graphe pour en savoir plus sur l’utilisation du graphe.

Panneau Propriétés

Permet de modifier les propriétés contextuelles.

Copies d’écran juxtaposées du panneau Propriétés. La première image présente le panneau Propriétés tel qu’il apparaît lorsque le graphe est sélectionné. La seconde image illustre le panneau lorsqu’un nœud de fusion est sélectionné.
Le panneau Propriétés change d’apparence en fonction de la ressource sélectionnée. L’image de gauche montre comment le panneau Propriétés apparaît avec un graphe sélectionné. L’image de droite illustre le panneau Propriétés lorsqu’un nœud de fusion est sélectionné.

Le panneau Propriétés est contextuel et affiche les paramètres qui modifient le comportement de la ressource ou du nœud sélectionnés. Combinés, les panneaux Graphe et Propriétés sont ceux dans lesquels vous passerez le plus de temps dans Designer.

En raison du nombre élevé de contrôles pouvant être affichés simultanément, le panneau Propriétés dispose de catégories permettant de les organiser. Vous trouverez ci-dessous une description des principales catégories :

  • La catégorie Paramètres de base est présente sur les ressources du graphe et sur chaque nœud. Elle vous permet de modifier les paramètres de base liés à la résolution et à la configuration du graphe. Certains paramètres importants sont répertoriés ci-dessous.
    • Taille de sortie : définit la résolution du graphe ou du nœud. 
    • Format de sortie : définit le format ou la précision du graphe ou du nœud. 
    • Mode de répétition : détermine si une image est placée en dehors de ses limites.
    • Graine aléatoire : modifie la graine aléatoire utilisée pour la génération procédurale.

Le comportement des paramètres de base dépend du mode d’héritage (). Relatif signifie que le comportement du nœud est défini ailleurs (soit par le graphe, soit par un nœud précédemment connecté). Absolu signifie qu’il est défini à l’aide des contrôles de paramètre. Si un paramètre de base est grisé, c’est probablement parce que le mode d’héritage est défini sur Relatif.

  • La catégorie Attributs contient les métadonnées associées au graphe ou au nœud. Vous pouvez utiliser des métadonnées pour créer des catégories dans la bibliothèque.
  • La catégorie Paramètres d’entrée n’est visible que pour les graphes. Vous trouverez tous vos paramètres exposés ici.
  • La catégorie Paramètres de l’instance/spécifiques est visible uniquement pour les nœuds. Le nom diffère entre les nœuds atomiques et les nœuds d’instance, mais la fonctionnalité est la même : elle permet d’ajuster les paramètres propres au nœud concerné. Vous pouvez modifier la couleur de la sortie d’un nœud, l’opacité d’une opération de fusion ou l’échelle d’un bruit, par exemple.
  • La catégorie Entrées n’est visible que pour les graphes. Elle répertorie tous les nœuds d’entrée ou paramètres exposés et vous permet d’en définir les noms et les propriétés. 
  • La catégorie Valeurs d’entrée n’est visible que pour les nœuds. Elle permet d’ajouter des valeurs d’entrée à un nœud. Vous n’utilisez les valeurs d’entrée que dans les workflows avancés.
  • La catégorie Sorties n’est visible que pour les graphes. Elle répertorie tous les nœuds de sortie (ou emplacements) et vous permet d’en définir les noms et les propriétés à partir d’un emplacement central.

Viewport 2D

Permet d’obtenir un aperçu d’image contextuel.

Vue 2D

Le viewport 2D affiche le contenu de vos nœuds. Double-cliquez sur un nœud d’image dans le graphe pour afficher la sortie du nœud dans la vue 2D.

Votre interaction avec le viewport 2D se limite au zoom et au déplacement lors d’un zoom avant. Vous pouvez effectuer un zoom avant ou arrière par défilement. Utilisez les boutons situés en bas à droite du viewport 2D pour contrôler le zoom. Vous pouvez également réinitialiser le zoom à l’aide du raccourci Z ou effectuer une mise au point sur la zone de travail à l’aide de la touche F.

Vous trouverez les contrôles suivants en haut du viewport 2D :

  •  Image d’arrière-plan : définit une image d’arrière-plan pour indiquer s’il y a des pixels transparents.
  •  Enregistrer la vue : permet d’enregistrer l’image actuelle du viewport 2D dans un fichier bitmap.
  •  Copier dans le Presse-papiers : copie le contenu du viewport 2D dans le presse-papiers. 
  •  Sélectionner la sortie : permet de basculer entre les différentes sorties du nœud.
  •  Sélectionner l’ensemble UV : permet de sélectionner le canal UV à afficher. Ce bouton est grisé à moins que l’option Afficher les UV dans la vue 2D du menu Scène du viewport 3D ne soit active.

Vous trouverez des boutons avec des fonctions supplémentaires en bas à gauche de la vue 2D :

  •  Affichage du canal : permet d’activer et de désactiver les canaux R, V et B. Idéal en mode Niveaux de gris.
  •  Affichage de la transparence : permet d’afficher les pixels transparents sous forme de texture à damier ou de noir plat.
  •  Basculement entre niveaux de gris/couleur : permet de basculer entre l’affichage du viewport 2D en couleur ou en niveaux de gris.
  •  Répétition : répète l’image dans le viewport 2D. Ainsi, vous pouvez trouver facilement les artefacts de la répétition. Lorsque le curseur de la souris est dans le viewport 2D, la barre d’espace sert de raccourci.
  •  Utiliser la taille physique : active/désactive l’utilisation des informations de la taille physique pour l’affichage de l’aperçu.
  •  Informations sur l’image : ouvre un panneau d’informations sur l’image qui affiche les valeurs exactes des pixels que vous survolez avec le curseur.
  •  Histogramme : ouvre un panneau affichant une analyse Histogramme de l’aperçu en cours.
  •  Activation/Désactivation de sRVB : active/désactive l’affichage dans l’espace colorimétrique sRVB.
  •  Activation/Désactivation de la prémultiplication : active/désactive la prémultiplication des pixels ayant un canal Alpha, avec la couleur d’arrière-plan.

Viewport 3D

Permet d’interagir avec un aperçu 3D de tout votre matériau.

Vue 3D

Le viewport 3D affiche votre matériau. Contrairement au viewport 2D, il utilise par défaut les cartes de sortie de votre graphe pour rendre un matériau complet. Dans le viewport 3D, vous pouvez voir comment vos canaux, comme la couleur de base, la normale et la rugosité, se combinent pour créer un résultat final.

Pour afficher votre matériau dans le viewport 3D, cliquez avec le bouton droit de la souris sur une zone vide de la zone d’affichage du graphe, puis sélectionnez Afficher les sorties dans la vue 3D. Vous pouvez également envoyer des cartes individuelles vers la vue 3D en cliquant avec le bouton droit de la souris sur le nœud et en sélectionnant Afficher dans la vue 3D

Vous pouvez utiliser un clavier et une souris à 3 boutons pour interagir avec le viewport comme suit :

  • Cliquez sur le bouton gauche de la souris et faites-la glisser pour faire tourner la caméra photo autour du maillage.
  • Cliquez sur le bouton central de la souris et faites-la glisser pour que la caméra effectue un panoramique.
  • Cliquez sur le bouton droit de la souris et faites-la glisser ou défiler pour effectuer un zoom avant ou arrière dans le maillage.
  • Le raccourci clavier F permet à la caméra de refaire la mise au point sur le maillage central, au cas où vous le perdriez de vue.
  • Le raccourci Ctrl + Maj + bouton droit de la souris (Cmd + Maj + bouton droit de la souris sur Mac) fait pivoter les éclairages d’environnement.

Les sept menus principaux sont décrits ci-dessous :

  • Le menu Scène permet de modifier le maillage affiché dans le viewport. Vous pouvez également enregistrer et charger l’état du viewport. Pour afficher votre maillage personnalisé dans le viewport 3D, double-cliquez dessus dans le panneau Explorateur.
  • Le menu Matériaux affiche tous les emplacements de matériaux sur votre maillage et vous permet de choisir le shader et les paramètres utilisés. Dans ce menu, vous pouvez configurer des options telles que les tuiles UV, le displacement en hauteur et le rendu non PBR.
  • Le menu Lumières est un menu des premières versions de Designer. Les lumières de ce menu sont désactivées par défaut, et nous vous recommandons de ne pas les utiliser à moins d’ouvrir d’anciens fichiers. Sélectionnez l’option Modifier pour accéder aux paramètres de lumière.
  • Le menu Caméra vous permet de passer d’un angle de vue prédéfini à un autre. Il permet également d’enregistrer les captures rendues à partir du viewport 3D. Sélectionnez l’option Modifier pour changer les paramètres de post-traitement.
  • Le menu Environnement propose des options permettant de régler l’éclairage de la scène basé sur l’image. Pour modifier l’image HDR dans la vue 3D, effectuez un glisser-déposer d’une ressource à partir de la catégorie Vue 3D du panneau Bibliothèque.
  • Le menu Affichage permet de modifier divers paramètres du viewport, par exemple la structure filaire et l’affichage de la résolution.
  • Système de rendu est un menu important qui vous permet de passer du rendu OpenGL en temps réel au tracé de rayon Iray à accélération GPU. Lorsque la technologie Iray est choisie comme système de rendu, d’autres options Iray sont alors disponibles.

Panneau Bibliothèque

Permet de trouver des ressources pour vos graphes.

Vue de bibliothèque

Dans le panneau Bibliothèque, vous avez accès à tout le contenu par défaut de Designer. Pour mieux comprendre les différents types de nœuds de la bibliothèque, consultez la page Présentation des nœuds.

Vous pouvez ajouter du contenu de la Bibliothèque à votre graphe en le faisant simplement glisser dans la zone d’affichage du graphe. Vous pouvez également utiliser les raccourcis clavier barre d’espace ou tabulation tout en passant le curseur sur la zone d’affichage du graphe pour ouvrir un menu permettant de rechercher rapidement des nœuds.

Les grandes vignettes du panneau Bibliothèque peuvent vous aider lors de la recherche de contenu. Ajustez leur taille à l’aide du menu déroulant situé dans le coin supérieur droit ().

Et ensuite ?

L’interface ayant été couverte, vous êtes prêt à passer aux Concepts de base de Designer. 

Une question ou une idée ?

Si vous avez une question ou une idée à partager, rejoignez d’autres utilisateurs de la communauté Substance 3D Designer. Obtenez de l’aide, faites des suggestions qui pourraient être incorporées dans Designer ou montrez votre travail et vos techniques.

Si vous avez de nouvelles idées pour les nœuds ou les fonctionnalités de Designer, partagez-les avec nous ici !

Logo Adobe

Accéder à votre compte