Отстраняване на проблеми с шрифтовете в приложения на Adobe на Mac OS X

Този документ може да ви помогне при решаването на проблеми, които възникват, когато инсталирате шрифтове или когато използвате шрифтове с приложения на Adobe на Mac OS X. Проблемите с шрифтовете могат да се проявят по много различни начини, включително (но не ограничено до) следните:

  • В менюто с шрифтове на вашите приложения не се появяват шрифтове.
  • Шрифтовете не се отпечатват правилно.
  • Шрифтовете в менютата и диалоговите прозорци съдържат неправилни букви или знаци.
  • Шрифтовете не излизат правилно на екрана.
  • След инсталиране на шрифтовете се появяват грешки и сривове.
  • Шрифтовете са достъпни само за някои потребители.

За да се възползвате максимално от този документ, изпълнете следващите задачи в този ред.

1. Проверете дали форматът на шрифта се поддържа.

Ако използвате неподдържан формат на шрифта, системата не може да показва или отпечатва шрифта в приложенията.

Mac OS X поддържа следните формати на шрифтове:

  • .dfont
  • Multiple Master (само за Mac OS X 10.2 и по-късни версии)
  • OpenType (.otf)
  • TrueType (.ttf)
  • TrueType Collection (.ttc)
  • Тип 1 (PostScript)

2. Уверете се, че шрифтът е инсталиран в правилната папка.

Mac OS X включва пет папки с шрифтове, които ви позволяват да използвате шрифтовете по различни начини. Можете да инсталирате колкото са необходими папки, тъй като Mac OS X разрешава дублирани копия на шрифт в системата. Ако има шрифтове с дублирани имена, Mac OS X използва шрифтове, независимо от формата на шрифта, от следващите местоположения в описания ред:

  1. Users/[потребителско име]/Library/Fonts
  2. Library/Fonts
  3. Network/Library/Fonts
  4. System/Library/Fonts (Избягвайте да променяте тази папка. Тя съдържа шрифтове с формат .dfont, които са необходими на Mac OS X за системна употреба и показване. За още информация вижте Mac OS X: Местоположения на шрифтовете и техните цели.)
  5. System Folder/Fonts

Забележка: Шрифтовете, инсталирани в System Folder/Fonts са налични за всички приложения Classic, Carbon и Cocoa.

За да инсталирате шрифт в Mac OS X, направете следното:

  1. Излезте от всички приложения (за да използвате шрифта в тези приложения).
  2. Влезте:
    • Ако инсталирате шрифтове в папката Users/[потребителско име]/Library/Font, влезте с потребителското си име.
    • Ако инсталирате шрифтове в папката Library/Fonts, влезте като администратор.
    • Ако инсталирате шрифтове в папката Network/Library/Fonts на мрежов сървър, се обърнете към вашия мрежов администратор.
  3. Плъзнете файловете с шрифтове от оригиналния носител (например компактдиск) до една или повече от следващите папки на твърдия диск:

    Забележка: Когато инсталирате шрифтове PostScript, плъзнете файла с векторни шрифтове и куфарчето с растерни шрифтове към подходящата папка. (В Mac OS X, куфарчетата с шрифтове изглеждат и се държат като другите файлове с шрифтове. Вие не можете да ги отворите с двукратно щракване върху файла, както можете в Mac OS 9.)

    • System Folder/Fonts за достъп до шрифта в приложения, изпълнявани в Mac OS X, и приложения, изпълнявани в режим Classic (Mac OS 9)
    • Library/Fonts за достъп до шрифта във всички приложения от всички потребители в Mac OS X. (Шрифтовете не са достъпни в приложения, изпълнявани в режим Classic.)
    • Users/[потребителско име]/Library/Fonts – използвани от конкретен потребител в Mac OS X. (Шрифтът е достъпен във всички приложения в Mac OS X, само когато влезете като конкретния потребител.)
    • Network/Library/Fonts – достъпни за отдалечени потребители на мрежов файлов сървър, изпълняващ Mac OS X в локална мрежа (LAN)

3. Проверете дали файлове за екран и печат са инсталирани. (PostScript шрифтове)

За да използвате PostScript шрифтове в Mac OS X, инсталирайте растерните (екран) или куфарчето, съдържащо растерните шрифтове, и векторните (принтер) шрифтове в същата папка. (Файловете с растерни шрифтове на Adobe използват името на шрифта. Векторните файлове използват съкратена, PostScript версия на името на шрифта (например „Isabe“ за шрифта Isabella.) Ако даден файл с векторни шрифтове не е инсталиран, шрифтът може да се отпечатва неправилно. Ако файлът с растерни шрифтове не е инсталиран, шрифтът не е наличен в менюто с шрифтове.

4. Използвайте програмата за управление на шрифтове Adobe Type Manager (ATM) с приложения Classic.

ATM не позволява шрифтовете да се появяват на екрана назъбени и следователно помага на PostScript шрифтовете да се отпечатват по-плавно на принтери, които не са PostScript, когато изпълняват приложения в режим Classic. Можете да изтеглите безплатна версия на ATM Light 4.6 от уеб сайта на Adobe.

5. Отстраняване на неизправности в софтуер за управление на шрифтове на трета страна.

Деактивирайте всички помощни програми за управление на шрифтове, като Extensis Suitcase Fusion, Insider FontAgent Pro или Linotype FontExplorer X. Опитайте да изпълните действието, което е генерирало проблема преди това (стартиране на приложението, достъп до менюто с шрифтове и т.н.). След това направете едно от следните:

  • Ако проблемът се появи отново, преминете към следващия раздел по-долу.
  • Ако проблемът не се появи отново, активирайте отново помощната програма за управление на шрифтове. Използвайте я, за да извършите двоична изолация на шрифтовете, като забраните 50% от шрифтовете и сравните резултатите с двете половини. След това продължете този процес за половината, която възпроизвежда проблема.

6. Премахнете файловете с шрифтове.

Преместете файловете с шрифтове от папките Fonts (Шрифтове) в папките Users (Потребители), Library (Библиотека) и Network (Мрежа) към работния плот или друго местоположение и рестартирайте компютъра. Ако проблемът не се повтори, един или повече от файловете с шрифтове, който преместихте, причинява проблема. Връщайте файловете с шрифтове по няколко наведнъж, за да определите кой шрифт причинява проблема. (Например върнете файловете с шрифтове, които започват с А-Е в папката System/Library/Fonts и след това рестартирайте компютъра. Ако проблемът не се повтори, добавете друга малка група от файловете с шрифтове. Ако проблемът се повтори, един от файловете с шрифтове, който току-що добавихте, може да е причината. Премахнете файловете с шрифтове и ги добавяйте един по един. Рестартирайте компютъра всеки път, докато намерите конкретният файл с шрифтове, който причинява проблема.) Когато откриете файла с шрифтове, който причинява проблема, преинсталирайте шрифта от оригиналния носител.

7.Използвайте текуща версия на шрифта.

Уверете се, че използвате най-новата версия на шрифта.

За да проверите шрифт от Adobe Type Library, изберете файла с шрифта и изберете File > Get Info > General (Файл > Получаване на информация > Общи), за да проверите датата на създаване. (Ако използвате PostScript шрифтове, проверете датата на създаване на всеки векторен файл и файл от куфарчето.) Ако датата на създаване на шрифта е преди 1992 г., може да е налична нова версия на шрифта. За информация за надстройки се свържете с отдела за клиентска поддръжка на Adobe на телефон 1-800-833-6687.

8. Изчистете системния кеш на шрифтове.

Клиентите може да се насочат да използват безплатната помощна програма Font Cache Cleaner. Помощната програма и инструкциите за употребата й са на следния адрес: http://homepage.mac.com/mdouma46/fcache/fcache.html. Повредени кеш файлове на шрифтове водят до показване на шрифтовете като повредени, дори ако не са. Често срещан симптом е объркан текст на екрана. След като кешът бъде изчистен, повреден кеш на шрифтове може да се отстрани като възможен източник на проблема.

Отхвърляне на отговорност: Adobe не поддържа директно употребата на Font Cache Cleaner. 

9. Отстраняване на проблеми с повредени шрифтове.

Може да възникне системна грешка, ако приложението има достъп до повреден шрифт. 

  1. Плъзнете съдържанието на папката Library/ Fonts в нова папка на работния плот. (Ако сте добавили ръчно шрифтове към папката Library/ Application Support/ Adobe/ Fonts, плъзнете и тези шрифтове към новата папка.)
  2. Във Finder изберете File > Find (Файл > Намери).
  3. Напишете AdobeFnt.lst, изберете системния диск и след това натиснете Return.
  4. Изтрийте намерените файлове AdobeFnt.lst (например AdobeFnt10.lst).
  5. Рестартирайте компютъра.
  6. Рестартирайте InDesign. InDesign създава нови файлове AdobeFnt.lst.
  7. Опитайте да пресъздадете проблема. След това направете едно от следващите:
    • Ако проблемът не се повтаря, върнете един шрифт към папката Library/Fonts и след това повтаряйте стъпки 5-6, докато идентифицирате проблемния шрифт.
    • Ако имате помощна програма за управление на шрифтове, рестартирайте я и активирайте шрифтове в малки групи или отделно, за да идентифицирате проблемния шрифт.
    • Ако проблемът се появи отново, преместете съдържанието на новата папка обратно на работния плот в папката Library/Fonts

Забележка: Ако при търсенето не намерите файл adobefnt.lst, уверете се, че критериите за търсене са зададени на „всякакви“ в диалоговия прозорец Find (Намери).

За отстраняване на проблеми с шрифтове, ако използвате Font Book, направете следното:

Важно: Не изпразвайте кошчето преди последната стъпка в този процес.

  1. Излезте от Font Book и всички други отворени приложения.
  2. Отидете до Home/Library/Preferences и премахнете следните файлове:
    • com.apple.fontbook.plist
    • com.apple.ATS.plist

    Забележка: Първият файл е файла с предпочитания за Font Book. Вторият файл посочва шрифтовете, които забранихте във Font Book. След като изтриете com.apple.ATS.plist, всички забранени по-рано шрифтове се зареждат, когато влезте следващия път. Ако сте инсталирали стотици или хиляди шрифтове, бързодействието на системата ви може да е забавено, когато всички забранени по-рано шрифтове се заредят.

  3. Изтрийте кеша на шрифтовете. За да изтриете кеша на шрифтовете, направете следното:
    1. Отворете папката Library/Caches/ATS.
    2. Намерете и изтрийте папката с кеша на шрифтовете. Например, ако сте първият потребител, дефиниран на вашия Мас, папката е наречена 501. Ако сте вторият потребител, папката е наречена 502.

      Забележка: Ако използвате Fast User Switching (Бързо превключване на потребители), в папката ви ATS може да има папки 501.xxx, 502.xxx. Преместете ги в кошчето.

  4. Ако се иска да се удостоверява изхвърлянето на коя да е от тези папки, дайте своята парола на администратор.
  5. Рестартирайте компютъра.
  6. Влезте в акаунта си и изпразнете кошчето.

 

Този материал е лицензиран под лиценз Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  Публикациите в Twitter™ и Facebook не попадат под клаузите на Creative Commons.

Правни бележки   |   Правила за онлайн поверителност