Guia do Usuário Cancelar

Exportar gráficos e vídeos com o Animate

  1. Guia do Usuário do Adobe Animate
  2. Introdução ao Animate
    1. Novidades no Animate
    2. Glossário visual
    3. Requisitos de sistema do Animate
    4. Atalhos de teclado do Animate
    5. Trabalhar com vários tipos de arquivo no Animate
  3. Animação
    1. Noções básicas de animação no Animate
    2. Como usar quadros e quadros-chave no Animate
    3. Animação quadro a quadro no Animate
    4. Como trabalhar com animação de interpolação clássica no Animate
    5. Ferramenta Pincel
    6. Guia de movimento
    7. Interpolação de movimento e ActionScript 3.0
    8. Sobre a animação com interpolação de movimento
    9. Animações de interpolação de movimento
    10. Criação de uma animação de interpolação de movimento
    11. Utilização dos quadros-chave de propriedade
    12. Animação de posição com uma interpolação
    13. Editar interpolações de movimento usando o Motion Editor
    14. Edição do caminho de movimento de uma animação de interpolação
    15. Manipulação de interpolações de movimento
    16. Adição de atenuações personalizadas
    17. Criação e aplicação das predefinições de movimento
    18. Configuração de extensões de interpolação de animação
    19. Trabalhar com interpolações de movimento salvas como arquivos XML
    20. Interpolações de movimento e interpolações clássicas
    21. Interpolação de formas
    22. Uso da animação da ferramenta Bone no Animate
    23. Trabalhar com manipulação de caracteres no Animate
    24. Como usar camadas de máscara no Adobe Animate
    25. Como trabalhar com cenas no Animate
  4. Interatividade
    1. Como criar botões com o Animate
    2. Converter projetos do Animate em outros formatos de tipo de documento
    3. Criação e publicação de documentos HTML5 Canvas no Animate
    4. Adicionar interatividade com snippets de código no Animate
    5. Criar componentes HTML5 personalizados
    6. Uso de componentes do HTML5 Canvas
    7. Criação de componentes personalizados: exemplos
    8. Snippets de código para componentes personalizados
    9. Práticas recomendadas - Publicidade com o Animate
    10. Criação e publicação de Realidade virtual
  5. Fluxo de trabalho e espaço de trabalho
    1. Criação e gerenciamento de pincéis
    2. Uso de Google Fonts em documentos HTML5 Canvas
    3. Uso das Bibliotecas da Creative Cloud e do Adobe Animate
    4. Uso dos painéis Palco e Ferramentas do Animate
    5. Fluxo e espaço de trabalho do Animate
    6. Uso de fontes da Web em documentos HTML5 Canvas
    7. Linhas de tempo e ActionScript
    8. Trabalhar com múltiplas linhas de tempo
    9. Definir preferências
    10. Uso de painéis de criação do Animate
    11. Criar camadas na linha do tempo com o Animate
    12. Exportar animações para aplicativos móveis e mecanismos de jogo
    13. Mover e copiar objetos
    14. Modelos
    15. Localização e substituição no Animate
    16. Desfazer, refazer e o painel de Histórico
    17. Atalhos de teclado
    18. Como usar a linha do tempo no Animate
    19. Criação de extensões HTML
    20. Opções de otimização para imagens e GIFs animados
    21. Configurações de exportação para imagens e GIFs
    22. Painel Ativos no Animate
  6. Multimídia e vídeo
    1. Transformação e combinação de objetos gráficos no Animate
    2. Criar e trabalhar com instâncias do símbolo no Animate
    3. Traçado de imagem
    4. Como usar som no Adobe Animate
    5. Exportação de arquivos SVG
    6. Criação de arquivos de vídeo para uso no Animate
    7. Como adicionar vídeos no Animate
    8. Trabalhar com pontos de sinalização de vídeo
    9. Desenhar e criar objetos com o Animate
    10. Remodelação de linhas e formas
    11. Traçados, preenchimentos e gradientes com o Animate CC
    12. Trabalhar com o Adobe Premiere Pro e o After Effects
    13. Painéis de cor no Animate CC
    14. Abrir arquivos do Flash CS6 com o Animate
    15. Trabalho com texto clássico no Animate
    16. Aplicação de ilustração final no Animate
    17. Bitmaps importados no Animate
    18. Gráficos em 3D
    19. Trabalhar com símbolos no Animate
    20. Desenhar linhas e formas com o Adobe Animate
    21. Trabalho com bibliotecas no Animate
    22. Exportação de sons
    23. Seleção de objetos no Animate CC
    24. Trabalho com arquivos AI do Illustrator no Animate
    25. Aplicação de padrões com a ferramenta Pincel de borrifar
    26. Aplicação de modos de mesclagem
    27. Organização de objetos
    28. Automação de tarefas com o menu Comandos
    29. Texto multilíngue
    30. Uso de câmera no Animate
    31. Uso do Animate com o Adobe Scout
    32. Trabalhar com arquivos Fireworks
    33. Filtros gráficos
    34. Som e ActionScript
    35. Preferências de desenho
    36. Desenho com a ferramenta Caneta
  7. Plataformas
    1. Converter projetos do Animate em outros formatos de tipo de documento
    2. Suporte da plataforma personalizada
    3. Criação e publicação de documentos HTML5 Canvas no Animate
    4. Criação e publicação de um documento WebGL
    5. Compactação de aplicativos no AIR para iOS
    6. Publicação de AIR em aplicativos Android
    7. Publicação no Adobe AIR para desktop
    8. Configurações de publicação do ActionScript
    9. Práticas recomendadas - Organização do ActionScript em um aplicativo
    10. Como usar ActionScript com o Animate
    11. Práticas recomendadas - Diretrizes de acessibilidade
    12. Acessibilidade no espaço de trabalho do Animate
    13. Programação e gerenciamento de scripts
    14. Ativação do suporte para plataformas personalizadas
    15. Visão geral do suporte da plataforma personalizada
    16. Criação de conteúdo acessível
    17. Trabalhar com plug-ins personalizados de suporte da plataforma
    18. Depuração do ActionScript 3.0
    19. Ativação do suporte para plataformas personalizadas
  8. Publicação e exportação
    1. Exportação de arquivos do Animate CC
    2. Publicação OAM
    3. Exportação de arquivos SVG
    4. Exportar gráficos e vídeos com o Animate
    5. Publicação de documentos AS3
    6. Exportar animações para aplicativos móveis e mecanismos de jogo
    7. Exportação de sons
    8. Exportação de arquivos de vídeo QuickTime
    9. Controle de reprodução de vídeo externo com o ActionScript
    10. Práticas recomendadas - Dicas para a criação de conteúdo em dispositivos móveis
    11. Práticas recomendadas - Convenções de vídeo
    12. Práticas recomendadas - Diretrizes de criação de aplicativos SWF
    13. Práticas recomendadas - Estruturação de arquivos FLA
    14. Práticas recomendadas para otimizar arquivos FLA para o Animate
    15. Configurações de publicação do ActionScript
    16. Especificar configurações de publicação para o Animate
    17. Exportação de arquivos projetores
    18. Exportar imagens e GIFs animados
    19. Modelos de publicação HTML
    20. Trabalhar com o Adobe Premiere Pro e o After Effects
    21. Compartilhar e publicar animações rapidamente

Exportar preferências do aplicativo

Você pode alternar entre preferências para especialistas e para novatos.  Também é possível exportar suas próprias configurações do aplicativo, incluindo configuração da barra de ferramentas, atalhos do teclado e outras configurações do aplicativo, como um único arquivo.  Transferir suas preferências do aplicativo entre dispositivos é tão simples quanto exportar e importar um arquivo.

Exportar preferências do aplicativo

Exportar preferência
Exportar preferência - exporte todas as configurações ou as configurações salvas selecionadas para levá-las para outras máquinas ou com outros

Exportação de imagens e gráficos

Sequência de PNG

Você pode exportar uma série de arquivos de imagem de um clipe de filme, botão ou símbolo gráfico na Biblioteca ou no Palco. Durante a exportação, o Animate (antigo Flash Professional) cria um arquivo de imagem separado para cada quadro no símbolo. Se você exportar do Palco, todas as transformações (por exemplo, a escala) que você aplicou à ocorrência do símbolo são preservadas na saída da imagem.

Para exportar uma sequência de PNG:

  1. Selecione um único clipe de filme, botão ou símbolo gráfico na Biblioteca ou no Palco.

  2. Clique com o botão direito do mouse e selecione Exportar sequência de PNG.

  3. Na caixa de diálogo Salvar como, selecione um local de saída e clique em OK.

     

  4. Na caixa de diálogo Exportar sequência de PNG, defina as opções que desejar. 

    Largura - determina a largura da saída de imagem. Você pode dimensionar a saída mudando este valor. O padrão é a largura do conteúdo do símbolo.

    Altura - determina a altura da saída de imagem. Você pode dimensionar a saída mudando este valor. O padrão é a altura do conteúdo do símbolo.

    Resolução - determina a resolução da saída de imagem. O padrão é 72 dpi.

    Cores - especifica a profundidade de bits da saída de imagem. Você pode selecionar 8, 24 ou 32 bits. O padrão é 32 bits, que suporta transparência. Se você selecionar 24 bits ou 8 bits, que não suportam transparência, a configuração de Plano de fundo será alterada para Palco. Veja abaixo.

    Plano de fundo - a cor a ser usada como cor de plano de fundo na saída de imagem. Essa opção ficará disponível somente quando a opção Cores estiver definida como 8 ou 24 bits. Quando a opção Cores estiver definida como 32 bits, a imagem de plano de fundo ficará sempre transparente. Quando a opção Cores estiver definida como 8 bits ou 24 bits, o padrão da opção Plano de fundo será a cor do Palco. Com imagens de 8 bits ou 24 bits, é possível alterar a configuração para Opaco e, em seguida, selecionar uma cor de plano de fundo do seletor de cores. Como alternativa, selecione um valor alfa para o plano de fundo para criar transparência.

    Suavização - Alterna entre suavizar ou não as bordas da saída de imagem. Desative essa opção se não estiver usando um plano de fundo transparente e as imagens puderem ser colocadas em uma cor de plano de fundo diferente da cor atual do Palco.

  5. Clique em Exportar para exportar a sequência de PNG.

Exportar GIF animado

É possível exportar arquivos GIF animados no Animate com as seguintes etapas: 

  1. Acesse Arquivo > Exportar > Exportar GIF animado

    Uma caixa de diálogo é exibida. 

  2. Escolha as opções desejadas na caixa de diálogo e clique em Concluído para exportar a animação como um arquivo GIF animado. 

    Além disso, é possível exportar o arquivo de imagem GIF estático selecionando Arquivo > Exportar > Exportar imagem.

Exportar imagens e gráficos para a Biblioteca da CC

Para exportar suas imagens ou gráficos para a Biblioteca da CC, selecione Janela > Biblioteca da CC

A janela das Bibliotecas da CC é exibida. 

Clique no ícone + no canto inferior esquerdo da janela Bibliotecas da CC, selecione as imagens ou arquivos gráficos e clique em Adicionar.

Formato de intercâmbio gráfico FXG (descontinuado após o Animate)

Sobre arquivos FXG

O FXG é um formato de arquivo de intercâmbio para plataforma Animate/Flash. O FXG é baseado em um subconjunto do MXML, linguagem de programação baseada em XML usada pela estrutura do Flex. O formato FXG ajuda designers e desenvolvedores a colaborarem de maneira mais eficiente, possibilitando que eles troquem conteúdos gráficos com alta fidelidade. Os designers podem criar gráficos usando ferramentas de design da Adobe e exportá-los para um formato FXG. Você pode usar o arquivo FXG em ferramentas como o Adobe Flash Builder e o Adobe Flash Catalyst para desenvolver ricas experiências de Internet e aplicativos.

Ao criar um arquivo FXG, gráficos vetoriais são salvos diretamente com o arquivo. Elementos para quais não há tag disponível no FXG são exportados como gráficos bitmap, que são referenciados no arquivo FXG. Isso inclui bitmaps, alguns filtros, alguns modos de mesclagem, degradês, máscaras e 3D. Alguns desses efeitos podem ser exportados como FXG, mas talvez não seja possível importá-los pelo aplicativo que abre o arquivo FXG.

Ao exportar um arquivo contendo um vetor e imagens em bitmap utilizando exportar FXG, uma pasta separada é criada junto com o arquivo FXG. A pasta tem um nome <filename.assets> e contém as imagens em bitmaps associadas ao arquivo FXG.

Para obter mais informações sobre o formato FXG, consulte a Especificação do FXG 2.0 .

Restrições à exportação de FXG

O Animate permite a seleção de um ou mais objetos no palco para exportação para FXG. Os nomes do objeto e da camada são preservados na exportação para o formato FXG.

Os itens a seguir são restringidos quando salvos em um arquivo FXG:

  • Grades de escala-9: exportados, mas legíveis somente pelo Adobe Illustrator.

  • Som e vídeo: não exportados.

  • Componentes: não exportados.

  • Interpolações e animação com vários quadros: não exportadas, mas um quadro selecionado será exportado como objeto estático.

  • Fontes incorporadas: não exportadas.

  • Símbolos de botão: o Animate exporta somente o estado Para cima dos botões.

  • Propriedades 3D: não exportadas.

  • Propriedades de Cinemática inversa (IK): não exportadas.

  • Atributos de texto: alguns atributos podem não ser exportados.

Exportar conteúdo do Animate no formato FXG

No Animate, é possível exportar conteúdo no formato FXG de duas maneiras:

  • Para exportar objetos no Palco como FXG, selecione os objetos e selecione Exportar > Exportar seleção. Em seguida, selecione o formato FXG no menu Tipo de arquivo.

  • Para salvar todo o Palco como FXG, selecione Exportar > Exportar imagem e selecione FXG da Adobe no menu Tipo de arquivo.

Sequência JPEG e imagem JPEG

Essas opções correspondem às opções de Configurações de publicação em JPEG. No entanto, a Tela de correspondência corresponde ao item exportado para o tamanho do conteúdo do Animate como aparece em sua tela. A opção Corresponder filme iguala a imagem JPEG ao conteúdo do Animate e mantém as proporções da imagem original.

Sequência PNG e imagem PNG

As opções de configuração de exportação de PNG são semelhantes às opções de Configurações de publicação de PNG (que também podem ser aplicadas), com as seguintes exceções:

Dimensões

Define o tamanho da imagem bitmap exportada ao número de pixels que você especifica nos campos Largura e Altura.

Resolução

Insira uma resolução em dpi. Para usar a resolução de tela e manter as proporções da imagem original, selecione Corresponder tela.

Cores

Igual à opção Profundidade de bits da guia Configurações de publicação em PNG. Define o número de bits por pixel a ser usado na criação da imagem. Para obter uma imagem de 256 cores, selecione 8 bits; para milhares de cores, selecione 24 bpc; para milhares de cores com transparência (32 bpc), selecione 24 bpc com Alfa. Quanto maior a profundidade de bits, maior o arquivo.

Incluir

Selecione a opção de exportação da área mínima da imagem ou especifique o documento inteiro.

Observação:

As dimensões do GIF exportado limitam-se a um valor menor que 4000 pixels. Essa limitação em dimensão aplica-se a versões do anteriores à CS6.

Observação:

A opção Pontilhar cores sólidas não funciona se a opção 256 cores estiver selecionada. Isto quer dizer que a imagem GIF não é pontilhada se o esquema de cor selecionado para o GIF for 256 cores.

(Descontinuado após o Animate) Imagem bitmap (BMP)

Crie imagens bitmap a serem usadas em outros aplicativos. A caixa de diálogo Exportar bitmap tem as seguintes opções:

Dimensões

Define o tamanho da imagem bitmap exportada em pixels. O tamanho que você especifica sempre tem as mesmas proporções da imagem original.

Resolução

Define a resolução da imagem bitmap exportada em pontos por polegada (dpi) e calcula automaticamente a largura e a altura com base no tamanho do desenho. Para definir uma resolução compatível com o seu monitor, selecione Corresponder tela.

Profundidade de cores

Especifica a profundidade de bits da imagem. Alguns aplicativos do Windows não são compatíveis com a mais recente profundidade de 32 bits por canal (bpc) para imagens bitmap. Se você tiver problemas com o formato de 32 bpc, use o formato de 24 bpc.

Suavidade

Aplica suavização de borda ao bitmap exportado. A suavização de borda gera imagens bitmap de alta qualidade, mas pode criar um halo de pixels em cinza ao redor de uma imagem colocada em um plano de fundo colorido. Desmarque a seleção se aparecer um halo.

Documento do Animate (SWF)

Para posicionar o conteúdo do Animate em outro aplicativo, como o Dreamweaver, exporte o documento inteiro como um arquivo SWF. O Animate exporta o arquivo SWF usando as configurações atuais das Configurações de publicação do arquivo FLA.

Exportação de vídeos HD com o Adobe Media Encoder

O Animate permite exportar interpolações, símbolos e gráficos para vídeos de alta definição de diversos formatos. O recurso de exportação de vídeo foi aprimorado para ter uma integração fácil e completa com o Adobe Media Encoder.

No Animate, você pode escolher qualquer formato de vídeo e suas predefinições compatíveis com o AME e, se você selecionar a opção apropriada, o Animate garantirá que o vídeo seja colocado na fila e até processado automaticamente no AME. Você será notificado assim que o processamento for concluído com sucesso.

Além disso, é possível exportar todas as cenas ou uma cena desejada para repetir, e para uma cena específica, você pode exportar todos os quadros ou um intervalo de quadros.

Os vídeos HD exportados com o Animate podem ser usados com aplicativos de comunicações ativadas para conferência, fluxo e compartilhamento de vídeo.

Por padrão, o Animate consegue exportar somente arquivos (.MOV) para filme QuickTime. Para exportar a função, é necessário instalar a versão mais recente do QuickTime Player, visto que o Animate otimiza as bibliotecas do QuickTime ao exportar arquivos MOV.

O fluxo de trabalho da exportação de vídeo HD foi remodelada, de modo que o Animate está agora integrado ao Adobe Media Encoder. Isso possibilita a você converter arquivos MOV para vários outros formatos. No final, o Adobe Media Encoder foi otimizado para apresentar somente formatos de exportação pertinentes para o conteúdo do Animate. Para obter mais informações sobre Codificação e Exportação de vídeos por meio do Adobe Media Encoder, consulte Codificar e exportar vídeo e áudio.

Observação:

O Adobe Media Encoder é automaticamente instalado quando você instala o Animate com o aplicativo de desktop da Creative Cloud.

Diferença entre fluxos de trabalho de exportação de vídeo anteriores e mais recentes

O novo fluxo de trabalho está diferente do fluxo de trabalho de exportação de vídeo do CS6 e versões anteriores.

Os principais pontos de diferença são

  • Integração com o Adobe Media Encoder: o Animate foi integrado ao Adobe Media Encoder 7.0, e as versões iniciais não dependiam do AME.
  • Formatos de exportação: o Animate consegue exportar somente filmes QuickTime.
  • Vídeos HD: o Animate permite a exportação de vídeos HD.

Além disso, o fluxo de trabalho do CS6 apresentava os seguintes problemas:

  • O fluxo de exportação de MOV utilizando o QuickTime era sujeito a erros e consumia memória.
  • A exportação de AVI não suportava clipes de vídeo.

Com o Animate, os problemas mencionados acima foram consertados, incluindo a questão de perda de quadros. Com o fluxo de trabalho do Adobe Media Encoder, é possível exportar para arquivos MOV sem problemas no Animate. Com o novo fluxo de trabalho AME, você pode exportar conteúdo do Animate para arquivos MOV e utilizar posteriormente o AME para converter arquivos MOV para qualquer saída desejada.

Início da exportação no quadro nº2

De acordo com a estrutura da linha do tempo, o vídeo exportado pode ser o resultado de um dos seguintes cenários:

  1. Se houver mais de um quadro na linha do tempo raiz, a exportação começará do quadro nº2.
  2. Se houver apenas um quadro na linha do tempo raiz, a exportação incluirá o quadro nº1.
  3. Se houver mais de um quadro na linha do tempo raiz e o ActionScript ou som for adicionado ao quadro número 1, ele será chamado.

Exportação de vídeo HD

Antes de começar a exportar, execute os procedimentos a seguir:

  • Instale o QuickTime
  • Defina a taxa de quadros em um valor igual ou inferior a 60 fps. Para obter mais informações, consulte Noções básicas de animação.
  1. Crie ou abra um FLA existente.

  2. Vá para Arquivo > Exportar > Exportar vídeo.

    Exportação de vídeo
    Caixa de diálogo Exportar vídeo

  3. Na caixa de diálogo Exportar vídeo, a Largura de renderização e a Altura de renderização assumem os valores de largura e altura definidos para o tamanho do Palco.

  4. Na caixa de diálogo Exportar vídeo, defina as opções desejadas:

    • Tamanho da renderização A e L: configure o tamanho da renderização de acordo com a resolução na qual você deseja exportar, que pode ser em vídeo HD ou vídeo normal. Defina os valores iguais à Largura e à Altura do Palco, respectivamente. Se desejar alterar os valores de Largura de renderização e Altura de renderização, modifique o tamanho do Palco de forma correspondente. O Animate mantém a proporção do aspecto de acordo com as dimensões do palco.
    • Ignorar cor do palco (gerar canal alfa): Gerar um canal alfa por meio da cor do palco. O canal alfa é codificado como uma faixa transparente. Ele permite que você sobreponha o filme do QuickTime exportado em cima de outros conteúdos para alterar a cor de fundo ou cena.
    • Converta o vídeo no Adobe Media Encoder: Selecione essa opção se desejar converter o arquivo MOV exportado em um formato diferente usando o AME. Se selecionado, o AME é iniciado depois que o Animate conclui a exportação do vídeo.
    • Caminho do vídeo exportado: digite ou navegue para o caminho ao qual deseja exportar o vídeo.
    • Parar exportação: especifique quando o Animate deverá finalizar a exportação.
      • Quando o último quadro for atingido: selecione essa opção se desejar finalizar no último quadro.
    Parar exportação quando o último quadro for atingido
    Parar exportação quando o último quadro for atingido

    • Parar exportação: especifique quando o Animate deverá finalizar a exportação.
      • Depois de um tempo decorrido: selecione essa opção e especifique a extensão de tempo após a qual deseja finalizar a exportação. A opção permite que você exporte seções do vídeo, separadamente.
    Parar exportação após 1 minuto e 15 segundos
    Parar exportação após 1 minuto e 15 segundos

    Parar exportação após 3 segundos
    Parar exportação após 3 segundos

  5. Clique em Exportar. Caso tenha selecionado a opção Converter vídeo no Adobe Media Encoder, o AME é iniciado e o arquivo MOV exportado fica disponível em uma nova fila. Para saber mais sobre como codificar e converter vídeos usando o AME, consulte Codificar e exportar vídeo e áudio.

Exportação da sequência SVG

Com a nova atualização para a configuração Exportar, os usuários podem exportar a linha de tempo atual como sequência SVG. Clique em Arquivo> Exportar> Exportar filme… e selecione Salvar como tipo como Sequência SVG.

Exportar sequência SCG
Exportar sequência SVG

Exportar ativos animados para vídeos, GIFs animados e muito mais

O Animate tem um processo de publicação eficiente ao exportar seus ativos animados para GIFs animados, vídeos e muito mais. Deseja saber como exportar a animação? Assista ao tutorial no fim deste exemplo e siga estas etapas.

  1. Clique em Arquivo> Exportar> Exportar vídeo.

  2. Na caixa de diálogo Exportar vídeo, escolha as seguintes opções:

    • Tamanho de renderização: defina os valores iguais à Largura e à Altura do Palco, respectivamente.
    • Ignorar cor do palco (gerar canal alfa): criar um canal alfa usando a cor do palco.
    • Converter vídeo no Adobe Media Encoder: converte o arquivo MOV exportado em um formato diferente.
    • Parar exportação: escolha a opção necessária para finalizar a exportação.
    • Navegar: insira o caminho em que deseja exportar o vídeo.
  3. Clique em Exportar.

Como exportar os ativos animados para vídeo, GIF animado e outros formatos.

Assista ao vídeo para saber como exportar vídeos para GIFs animados e outros formatos.
Logotipo da Adobe

Fazer logon em sua conta