Use these settings to optimize the file size for Adobe Captivate documents that you save as the native Captivate (.cptx) files or publish (.swf, .f4v, .exe, & .app) from Captivate.

Full Motion recording preference

Video Color Mode: Set the preference to 16-bit color. Selecting 16-bit results in a smaller file size when recording. However, as your OS is likely displaying in 32-bit color, the range of colors recorded isn't as large.

To adjust this preferences, with a project open:

  1. Select Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac OS).
  2. In the Category panel, select FMR from the Recording menu.
  3. Select the Video Color Mode under the SWF conversion section.

Optimizing slide properties

From the Properties Panel, you can adjust the quality level for each slide. Selecting the Optimized, JPEG, or High Quality format sometimes increases the file size. Only use a format other than Low (8-bit) when appropriate.

Non-interactive objects and media - Adjust JPEG quality

By default, Adobe Captivate automatically sets the quality of JPEG images in projects. However, you can adjust this setting depending upon the images used in your project. Using higher percentage values allows for high-quality images, but it also increases overall file size.

To adjust this preferences, with a project open:

  1. Select Edit > Preferences (Windows) or Adobe Captivate > Preferences (Mac OS).
  2. In the Category panel, select SWF Size And Quality from the Project menu.
  3. Enter your preferred value in the JPEG Image Quality text box.

Non-interactive objects and media - Adjust Video quality

Adobe Captivate provides four levels of video quality, even only the Low option is suggested for most uses.

To adjust this preference, choose Windows > Properites with a project open to open the Property inspector. Ensure that Low is selected.  Low is the most efficient choice for most screenshots because it uses 256 optimized colors.  

Selecting the JPEG, High Quality, or Optimized format sometimes increases the file size. Use a format other than Standard only when necessary and appropriate.

Audio adjustments to reduce file size

Audio files present the common challenge of balancing quality against size. The higher the sound quality, the larger the file size. The more you compress a sound and the lower the sampling rate, the smaller the size, and lower the quality. Adobe Captivate lets you control the way sound is recorded and compressed based upon your input and output requirements.

Creating audio in Adobe Captivate is essentially a two-part process. You record audio in WAV format, and then Adobe Captivate converts the WAV file into an mp3 file. When files are in WAV format, they have a degree of flexibility. You can edit and adjust them “downward,” compressing them into mp3 files uniquely tailored to their playback scenario.

When working with audio, keep your users in mind. If a user is likely to access the Adobe Captivate project by using a dial-up modem, use a higher compression/lower sampling rate, such as 56 Kbps. However, if you are distributing the project on a CD-ROM, you can use a lower compression/higher sampling rate, such as 144 Kbps. In the best development case, experiment to find the optimal balance between sound quality and file size for your users.

Final adjustments before publishing

After you have finished your Adobe Captivate project, you can make some adjustments before publishing or distributing the file that can reduce the file size.

With your project open, select Edit > Preferences > Project > SWF Size And Quality (Windows) or Adobe Captivate > Preferences > Project > SWF Size And Quality (Mac OS). Then, specify the following properties:

Compress Full Motion Recording SWF File - Compresses the full motion recording SWF file to a smaller size. Choosing this option can increase the time taken to preview or publish the project.

Settings - Indicates the quality of the published SWF file. You can select the quality of the SWF file by moving the slider bar to the corresponding option: High, Medium, Low, or Custom. When you choose High, Medium, or Low, Adobe Captivate uses its internal settings to set the quality of the file. Files of a higher quality are compressed to a lesser extent, and therefore are sometimes a greater file size. You can customize the options for quality when you move the slider to the Custom level.

Retain Slide Quality Settings - Retains the slide quality settings defined in the Property inspector of the slide. See Optimizing Slide Properties

BMP - Determines the image quality of bitmaps (screenshots) generated during recording. Reducing the image quality reduces the file size but can affect the quality of the color in the images. Any bitmap files that you have inserted in the project are also affected.

JPEG - Determines the quality of JPEG files that you have inserted in the project. Reducing the image quality reduces the file size but can affect the quality of the color in the images. JPEG images are detailed and contain many colors, so greatly lowering their quality is not advised. See Non-interactive Objects and Media - Adjust JPEG Quality

Audio - Determines the quality of audio files used in the project. Audio files are converted to mp3 format before they are published. A file with higher quality does not affect the file size drastically but significantly improves the audio quality.

Advanced Project Compression - Enables Adobe Captivate to take into account only the difference between two slides instead of publishing both the slides. The compression reduces the size of the published project. Choosing this option can increase the time taken to preview or publish the project. Compressed projects sometimes do not play as intended in Flash Player.

Compress SWF File - Compresses the published SWF file. Compressed SWF files can be played only with Flash Player 9 or later. Choosing this option can increase the time taken to preview or publish the project.

Delete Unused Library Objects - After your project is complete, delete any unused library objects to reduce your final output file size. From the Library Panel, click the 'Select Unused Items' button in the Panel toolbar. Then you can delete all unused items by clicking the Delete button in the Panel toolbar.

PowerPoint Import - Reduce the file size of projects with embedded slides

You can import a presentation into an Adobe Captivate project without linking (embedded mode). The entire presentation is embedded into the Adobe Captivate project. Slides that are not selected during import are also imported into the Adobe Captivate project, but they are not visible in the project. When you choose to reduce the file size, Adobe Captivate deletes such slides permanently from the project. This process is irreversible.

  1. Open the Adobe Captivate project and navigate to a slide that was imported from the PowerPoint presentation.
  2. Right-click (Windows) or Control-click (Mac OS) the slide generated from Microsoft PowerPoint, and then select Edit with Microsoft PowerPoint > Find Presentation in the Library.
When you select this option, the PowerPoint presentation containing the slide is highlighted in the library.
  3. In the Library panel, right-click (Windows) or Control-click (Mac OS) the presentation in the Presentation folder.
  4. Select Compact.

Note: The Compact option is disabled for linked presentations.


Other best practices for reducing file size

  • One important factor is the kilobytes per second ratio. Check the bandwidth analysis to find this factor. Don't despair if your project is large; it is possible for a large project to stream well over the Internet. For example, a while a 400 KB file seems large, if it plays for 5 minutes, it streams easily over a 28.8-Kbps modem. The first slide in a project always has a longer kilobytes-per-second ratio, because it loads first and additional project information loads with it.
  • Consider your color settings and the images included in your project. Two quick tips for reducing file size are to avoid color gradients and to avoid photo images.
  • If you are not going to upload your SWF files to Adobe® Connect™ Enterprise, turn off the Include Adobe Connect Metadata option in the project preferences. This option is on by default, and it adds data to your project that allows for better integration with Adobe Connect. If you do not use Adobe Connect, turn this option off to reduce project size.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy