Adobe Acrobat PDFMaker (pulsante Converti in Adobe PDF nella scheda/barra degli strumenti PDFMaker) è un componente aggiuntivo che crea file PDF nelle applicazioni Microsoft Office. Questa funzionalità viene installata con Acrobat Professional e Standard.

  • In MS Office 2003 e versioni precedenti, PDFMaker utilizza la stampante Adobe PDF per creare un file PostScript. Quindi, la stampante Adobe PDF si interfaccia con l'applicazione Adobe Acrobat Distiller per creare un file PDF.
  • In MS Office 2007, 2010, 2016 e 365, PDFMaker utilizza la libreria di AdobePDF per convertire un documento Microsoft Office in PDF.
  • Acrobat Distiller o la stampante Adobe PDF possono inoltre essere utilizzati in maniera indipendente per creare file PDF.

Questo documento può aiutare a risolvere i problemi che si verificano quando si tenta di creare file PDF nelle applicazioni Office tramite Acrobat PDFMaker. Benché questo documento sia specifico per Microsoft Word, la maggior parte delle procedure di risoluzione dei problemi si applica a Microsoft PowerPoint e Microsoft Excel.

 

La barra multifunzione di Acrobat non è disponibile nelle applicazioni Office 2016 e Office 365 in Windows

Si applica alle versioni Office 2016 e Office 365 di Word, Excel e PowerPoint

Prova i seguenti passaggi per risolvere il problema:  

  1. Fai clic con il pulsante destro del mouse sull’icona di Word e scegli Esegui come amministratore.

    Se viene visualizzata la finestra di controllo account utente, fai clic su .

  2. Apri un documento vuoto: scegli il modello Documento vuoto. In alternativa, è possibile aprire un documento Word esistente.

  3. Nel menu File, fai clic su Opzioni. Viene visualizzata la finestra di dialogo Opzioni di Word.

  4. Scegli Componenti aggiuntivi nell’elenco delle opzioni. Nel menu a discesa Gestisci, seleziona Componenti aggiuntivi COM, quindi fai clic su VAI.

    Componenti aggiuntivi di Word
  5. Nella finestra di dialogo Componenti aggiuntivi COM, seleziona la casella di controllo Componente aggiuntivo COM Acrobat PDFMaker Office se non è selezionato, quindi fai clic su OK.

    Componente aggiuntivo COM Acrobat PDFMaker Office

PDFMaker si chiude in modo inatteso con Office 2016 e Office 365 su Windows

Acrobat PDFMaker si chiude in modo inatteso con Office 2016 e Office 365 su Windows dopo l'aggiornamento di febbraio 2016 di Office.

Adobe sta analizzando il problema e sta collaborando con Microsoft per risolvere la soluzione il prima possibile. Nel mentre, per creare PDF, consultate qui la soluzione alternativa.

Verifica della compatibilità di Acrobat con Microsoft Office

Prima di iniziare la risoluzione dei problemi, assicuratevi che la versione di Acrobat in esecuzione sia compatibile con la versione di Office in esecuzione. Per ulteriori dettagli, consultate Browser Web che supportano PDF di Acrobat e applicazioni compatibili con PDFMaker | Acrobat, Reader.

Risoluzione dei problemi di Acrobat Distiller e della stampante Adobe PDF (applicabile solo a PDFMaker per MS Office 2003 e versioni precedenti)

Acrobat PDFMaker (per MS Office 2003 e versioni precedenti) utilizza la stampante Adobe PDF, la quale a sua volta si serve dell'applicazione Acrobat Distiller, per convertire documenti Word. Di conseguenza, il primo passo nella risoluzione dei problemi consiste nel determinare se Acrobat Distiller funziona correttamente:

Tentativo di creazione di un file PDF da Word con la stampante Adobe PDF 

  1. Aprite un documento in Word e scegliete File > Stampa.
  2. Scegliete Adobe PDF nel menu del nome della stampante e fate clic su OK.

Tentativo di creazione di un PDF con l'applicazione Acrobat Distiller

Nota: questo metodo non supporta funzionalità PDFMaker avanzate, come ad esempio il mantenimento di collegamenti e struttura del documento.

  1. Aprite un documento Word e selezionate File > Stampa.
  2. Nella finestra di dialogo Stampa selezionate una stampante PostScript (ad esempio, la stampante Adobe PDF), scegliete Stampa su file, quindi fate clic su OK.

    Viene creato un file PostScript (.ps o .prn).

    Nota: se non si dispone di una stampante PostScript, potete scaricare un driver della stampante PostScript dal sito Web di Adobe. Dopo aver installato il driver, completate il passaggio 2. Se selezionate la stampante Adobe PDF, deselezionate "Non inviare font ad Adobe PDF" per creare un file PostScript.

  3. In Acrobat, scegliete Avanzate > Acrobat Distiller.
  4. Scegliete un'impostazione nell'elenco delle impostazioni predefinite o mantenete quella predefinita.
  5. Scegliete File > Apri, Tutti i file dal menu a comparsa Tipo file, selezionate il file PS o PRN creato, quindi fate clic su Apri.
  6. Specificate un nome e una posizione per il file PDF, quindi fate clic su Salva.
  7. Aprite il file messages.log nella cartella seguente per Windows (NT, 2000, XP, Vista, 7): %AppData%\Adobe\Acrobat\Distiller [numero versione]

  8. Verificate il file messages.log per le informazioni di risoluzione dei problemi:

    • Se il file indica perché è impossibile creare il file PDF in Acrobat Distiller, utilizzate la casella di testo di ricerca in centro di supporto di Acrobat per cercare i documenti correlati. Ad esempio, se il file elenca un errore di PostScript, risolvete l'errore in base ai consigli in Risoluzione degli errori di PostScript.
    • Se il file non indica perché è impossibile creare il file PDF in Acrobat Distiller, create un documento Word che contenga solo alcune parole. Quindi, provate a creare un file PDF da tale documento tramite la stampante Adobe PDF e l'applicazione Acrobat Distiller:
    • Se potete creare un file PDF dal nuovo documento, il problema potrebbe essere generato da PDFMaker. Consultate Risoluzione dei problemi di Acrobat PDFMaker.
    • Se non potete creare un file PDF dal nuovo documento, utilizzate un file da un'altra applicazione. Quindi, provate a creare un file PDF con Acrobat Distiller. Se il problema si verifica con il file da un'altra applicazione, reinstallate Acrobat Distiller. Se il problema non si verifica con il file da un'altra applicazione, risolvete i problemi del comportamento specifico tramite i documenti elencati in Contenuto correlato. Oppure, cercate all'interno della guida di Acrobat. Per ulteriore assistenza, contattate il supporto tecnico di Acrobat.

Risoluzione dei problemi di Acrobat PDFMaker

Se è possibile creare un file PDF con la stampante Adobe PDF o Acrobat Distiller, ma non con Acrobat PDFMaker, il problema potrebbe essere generato da una funzionalità di Acrobat PDFMaker. Per determinare se una qualsiasi di queste funzioni è la causa del problema, disattivarle. Quindi, riprovare a creare un file PDF:

  1. In Word, scegliete Adobe PDF > Modifica impostazioni conversione.
  2. Scegliete la dimensione del file più piccola nel menu di modifica delle impostazioni di conversione.
  3. Fate clic sulla scheda Word e deselezionate tutte le opzioni.
  4. Fate clic sulla scheda Segnalibri e deselezionate tutte le opzioni dei segnalibri.
  5. Fate clic sulla scheda Protezione e deselezionate tutte le opzioni di protezione.
  6. Fate clic su OK.
  7. Provate a creare un file PDF:
  • Se non è possibile creare un file PDF, consultate Risoluzione dei problemi specifici per il documento.
  • Se siete in grado di creare un file PDF, determinate quali funzionalità provocano il problema: attivate una funzionalità e provate a creare un file PDF. Ripetete questa procedura fino a quando viene riscontrato il problema. Quindi, create un documento Word che contenga solo alcune parole. Provate a creare un file PDF da tale documento tramite le stesse impostazioni Acrobat PDFMaker:
  • Se siete in grado di creare un file PDF dal nuovo documento, il problema è specifico del documento. Consultate Risoluzione dei problemi specifici per il documento.
  • Se non è possibile creare un file PDF dal nuovo documento, la funzionalità di più recente attivazione continua a provocare problemi. Reinstallate Acrobat PDFMaker. Se il problema persiste, contattate il supporto di Acrobat

Risoluzione dei problemi specifici per il documento

Se determinate che il problema è specifico del documento, eseguite la risoluzione dei problemi come segue.

Attivazione delle sole funzionalità di Acrobat PDFMaker utilizzate dal documento

Ad esempio, se il documento contiene solo gli stili di intestazione Intestazione 1 e Intestazione 2, disattivate gli altri stili di intestazione nella finestra di dialogo Acrobat PDFMaker.

Passate alla vista normale del documento in Word, quindi create il file PDF tramite Acrobat PDFMaker

Ricreazione del documento Word per eliminare tutti i danni

Procedete in uno dei modi indicati di seguito:

  • Copiate e incollate il contenuto del documento Word in un nuovo documento, quindi create il file PDF.
  • Selezionate tutto il testo nel documento, modificatene il font e salvate il documento con un nuovo nome. Word riscrive il documento, eliminando elementi che potrebbero entrare in conflitto con Acrobat PDFMaker. Dopo aver salvato il documento, potete riformattarlo con il font desiderato.
  • Se il documento è stato creato con una versione di Word diversa da quella utilizzata per creare il file PDF, apportate una piccola modifica al documento. Quindi salvatelo con un nuovo nome. Questa procedura forza Word a riscrivere il documento, probabilmente eliminando qualsiasi elemento che possa entrare in conflitto con Acrobat PDFMaker.

Ricreazione di qualsiasi stile di intestazione nel documento, quindi creazione del file PDF

Identificazione degli elementi in conflitto nel documento

  1. Create un documento Word.
  2. Copiate metà del documento Word originale nel nuovo documento Word.
  3. Convertite il nuovo documento Word in PDF tramite Acrobat PDFMaker
  • Se il problema persiste, è presente un elemento di conflitto nel nuovo documento Word. Per isolare ulteriormente l'elemento di conflitto, ripetete i passaggi 1-3 e copiate metà del secondo documento Word in un altro documento Word nuovo.
  • Se il problema non viene più riscontrato, è presente un elemento di conflitto nel documento Word originale. Per isolare ulteriormente il problema, ripetete i passaggi 1-3 e copiate l'altra metà del documento Word originale in un altro documento Word nuovo. Se entrambe le metà del documento vengono convertite correttamente, chiudete altri programmi in esecuzione, compresa l'applicazione Office. Eliminate i file .tmp (spesso disponibili nella cartella Windows/Temp).

Reinstallazione di programmi

Rimuovete Acrobat e Office o l'applicazione Office specifica (Word, PowerPoint o Excel). Reinstallate Office o l'applicazione Office specifica, quindi reinstallate Acrobat.

Per rimuovere Acrobat, utilizzate Installazione applicazioni di Pannello di controllo. Per istruzioni su come rimuovere Office, consultate la documentazione relativa o contattate Microsoft.

Rimozione della protezione se il documento Word è protetto

Per istruzioni su come rimuovere la protezione, consultate la documentazione di Word o contattate Microsoft. 

Risoluzione dei problemi con altre macro in Microsoft Word

PDFMaker può entrare in conflitto con altre macro, come ad esempio software fax o antivirus. Se altre attività di risoluzione dei problemi non hanno successo o se PDFMaker presenta problemi dopo l'installazione di una macro di terzi, risolvete i problemi con altre macro. Le macro note per provocare incompatibilità includono Duden Korrektor Plus 2.0, ViaVoice 10 e versioni successive, Personal Translator 2002 Office Plus, OfficeReady Stuffit, Leuchter Informatic AG WordPlus e GoldMine Link per Word.

Per determinare se PDFMaker è in conflitto con un'altra macro, eliminate o disattivate le altre macro una alla volta (fate riferimento al collegamento applicabile di seguito). Quindi, riprovate a convertire un documento in un PDF tramite PDFMaker. Se il problema non si ripresenta, contattate il produttore di tale macro.

Risoluzione dei problemi in Microsoft Word

Le procedure riportate di seguito sono basate sugli articoli della knowledge base di Microsoft:

Per ulteriori informazioni sulla risoluzione dei problemi di Microsoft Word, visitate il sito Web di Microsoft e cercate un articolo pertinente.

Avvio di Word tramite l'opzione /a e aggiunta di PDFMaker manuale

L'opzione /a consente di avviare Word e impedisce ai componenti aggiuntivi e ai modelli globali (compreso il modello normale) di essere caricati automaticamente. L'opzione /a blocca inoltre i file delle impostazioni; ovvero, i file delle impostazioni non possono essere letti o modificati se utilizzate questa opzione.

Nota: le modifiche a preferenze, personalizzazioni o macro durante una sessione dell'opzione /a di Word vengono perse quando si esce da Word.

Per avviare Word tramite l'opzione /a:

  1. Chiudete tutti i programmi.
  2. Scegliete Start > Esegui.
  3. Nella finestra di dialogo Esegui, digitate winword.exe /a.
  4. Fate clic su OK. La finestra di dialogo Esegui viene chiusa e si avvia Word.

Per caricare PDFMaker manualmente (solo Acrobat 6.x):

  1. Chiudete tutti i programmi.
  2. Selezionate Strumenti > Modelli e componenti aggiuntivi.
  3. Selezionate PDFMaker.dot (non PDFMakerA.dot) e fate clic su OK.

    Vengono visualizzate le icone PDFMaker.

Per Acrobat 7.x, 8.x, 9.x, X (come applicabile) 

Per caricare manualmente PDFMaker (MS Word 2003 o versioni precedenti):

  1. Chiudete tutti i programmi.
  2. Selezionate Strumenti > Personalizza e fate clic sulla scheda Comandi.
  3. Fate clic su Strumenti nel pannello delle categorie.
  4. Trascinate i componenti aggiuntivi COM dal pannello dei comandi al menu degli strumenti tenendo premuto il pulsante del mouse. Quando nel menu Strumenti vengono visualizzati i comandi del menu, trascinate i componenti aggiuntivi COM appena sotto l'opzione Personalizza, quindi rilasciate il pulsante del mouse.
  5. Fate clic su Chiudi.
  6. Fate clic sui componenti aggiuntivi COM nel menu Strumenti.
  7. Fate clic su Aggiungi, individuate il componente aggiuntivo (il componente aggiuntivo PDFMaker si trova in [percorso di installazione Acrobat]\PDFMaker\Office\PDFMOfficeAddIn.dll) e fate clic su OK.

  8. Premete Alt+F11 per avviare Visual Basic Editor.
  9. Premete Ctrl+G per avviare la finestra immediata di Visual Basic Editor.
  10. Per avviare PDFMaker in Word, digitate Application.COMAddIns("PDFMaker.OfficeAddin").Connect = True. Chiudete Visual Basic Editor.
  11. Verificate che il menu Adobe PDF venga ora visualizzato a destra della guida nella barra del menu di Microsoft Word.

Caricate manualmente PDFMaker (MS Word 2007 e 2010):

  1. Chiudete tutti i programmi.
  2. Fate clic sul pulsante di Microsoft Office e sulle opzioni di Word.

  3. Fare clic sui componenti aggiuntivi.

  4. Nell'elenco di gestione, fate clic sui componenti aggiuntivi COM, quindi su Vai.

  5. Se il componente aggiuntivo Acrobat PDFMaker COM è elencato e selezionato nella finestra di dialogo dei componenti aggiuntivi COM, effettuate quanto segue. In caso contrario, procedete al passaggio 6.

  6. Fate clic per deselezionare la casella di controllo del componente aggiuntivo Acrobat PDFMaker COM.

  7. Fate clic su OK per chiudere la finestra di dialogo dei componenti aggiuntivi COM.

  8. Ripetete i passaggi da 1 a 3 e quindi fate clic per selezionare la casella di controllo del componente aggiuntivo di Acrobat PDFMaker COM, nella finestra di dialogo dei componenti aggiuntivi COM.

  9. Verificate che la scheda di Acrobat venga visualizzata nella barra multifunzione di MS Word.

  10. Se il componente aggiuntivo Acrobat PDFMaker COM NON è elencato nella finestra di dialogo dei componenti aggiuntivi COM, seguite i passaggi da 7 a 10 nella sezione Per caricare manualmente PDFMaker (MS Word 2003 o versioni precedenti)

Create un documento Word di prova e avviate PDFMaker: 

  1. Digitate del testo nel documento Word.
  2. Scegliete File > Salva e salvate il documento di prova sul desktop.
  3. Fate clic su Converti in Adobe PDF.

Se il problema viene risolto quando utilizzate l'opzione /a per avviare Word, rimuovete tutti i componenti che vengono caricati durante l'avvio di Word. Rimuovete questi componenti uno alla volta nell'ordine in cui sono visualizzati in Word. I seguenti componenti vengono caricati durante l'avvio di Word:

  • Macro automatiche di Word
  • modello globale (Normal.dot)
  • Componenti aggiuntivi (WLLs)
  • Modelli nella cartella di avvio di Word e nelle cartelle di avvio di Office
  • Componenti aggiuntivi COM
  • Chiave dei dati di Word nel registro di Windows
  • Chiave delle opzioni di Word nel registro di Windows
  • Macro automatiche di Word

Nota: fate riferimento ai seguenti servizi di supporto per il prodotto Microsoft per ulteriori procedure di risoluzione dei problemi di Word:

Rinominate il file del modello Normal.dot

Per istruzioni su come rinominare il file del modello globale, consultate la sezione "Modello globale (Normal.dotm o Normal.dot)" nell'articolo di assistenza di Microsoft, Come ripristinare le opzioni utente e le impostazioni di registro in Word. Scorrete nella pagina per visualizzare l'articolo.

Importante: non utilizzate l'opzione /a per riavviare Word dopo aver completato i passaggi.

Se la ridenominazione del modello globale risolve i problemi, significa che il modello Normal.dot è danneggiato. A volte è necessario modificare diverse impostazioni per ripristinare le opzioni. Se il file Normal.dot rinominato contiene personalizzazioni come stili, macro o voci AutoText che non è possibile ricreare facilmente, provate a utilizzare l'Organizzatore per copiare tali personalizzazioni dal file Normal.dot precedente al nuovo Normal.dot.

Per ulteriori informazioni su come utilizzare l'Organizzatore, seguite questi passaggi:

  1. Avviate Word.
  2. Scegliete Guida > Guida di Microsoft Word.
  3. Nell'Assistente di Office o nella Ricerca libera, digitate Organizzatore.

  4. Fate clic su Cerca per visualizzare gli argomenti restituiti.

Se il problema non viene risolto, provate a utilizzare il precedente modello globale (Normal.dot) invece del nuovo modello globale. Per utilizzare il precedente modello Normal.dot, rinominate il nuovo modello Normal.dot in Normal.dot. Se continuate a risolvere i problemi con PDFMaker dopo aver utilizzato questo documento, contattate il supporto Acrobat.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online