Animate CC(以前名为 Flash Professional CC)提供了一种新的画笔工具,可以在 Animate 中使用我们在 Adobe Illustrator 中所熟知的艺术画笔和图案画笔。与现有的画笔工具不同,这种画笔工具是基于笔触的。

使用画笔工具可以通过沿绘制路径应用所选艺术画笔的图案,绘制出风格化的画笔笔触。您可以将画笔笔触应用于现有的路径,使用画笔工具在绘制路径的同时应用画笔笔触,还可以自定义图像的平滑输出效果。

艺术画笔

使用艺术画笔可沿路径绘制一个矢量图案,然后将其拉伸至整个长度。系统默认提供一组艺术画笔预设,可将它们直接用在您的 Animate 项目中。在“工具”面板中选定画笔工具后,即可在“属性”面板的“画笔库”中访问这些预设。

将这些艺术画笔添加到文档后,便可以使用画笔、钢笔、线条、矩形、椭圆形等工具(铅笔工具除外,它只列出基本的笔触样式)访问它们了。

 

PaintBrushStyles1
画笔工具

图案画笔

图案画笔可沿同一路径重复绘制图案。画笔库中默认提供一组图案画笔预设。

使用图案画笔

查看和选择图案画笔的操作步骤:

  1. 选择“窗口”>“画笔库”,或选择“画笔工具”,然后转至“属性面板”>“样式”>“画笔库”图标。

  2. 双击画笔库中的任一图案画笔,将其添加到文档中。添加到文档后,它会列在“属性”面板的“笔触样式”下拉列表中。

pattern brushes

编辑图案画笔

  1. “属性面板”>“笔触样式”设置中,单击“编辑笔触样式”选项以显示“画笔”屏幕。

    Pattern Brush PI_PR3
    画笔工具中的画笔

  2. 画笔选项中,将画笔类型选为“艺术画笔”或“画笔图案”。

    working with paint brush - editing an art brush
    艺术画笔和图案画笔

  3. 如果将画笔类型选为“艺术画笔”,请设置以下选项:

    • 名称:指定所选画笔的名称。
    • 按比例缩放:将艺术画笔按笔触长度的一定比例缩放。
    • 拉伸以适合笔触长度:拉伸艺术画笔以适合笔触长度。
    • 辅助线之间拉伸:只拉伸位于辅助线之间的艺术画笔区域。艺术画笔的头尾部分适用于所有笔触,不会被拉伸。
    working with paint brush - pattern brush optiosn
    图案画笔选项

  4. 如果将画笔类型选为“图案画笔”,请设置以下选项:

    • 名称:指定所选画笔的名称。
    • “拉伸以适合”、“添加间距以适合”和“近似路径”:这些选项指定如何沿笔触应用图案拼块。
    • 翻转图稿:翻转所选图案:水平或垂直。
    • 间距:在不同片段的图案之间设置间距。默认值为 0。
    • 角部:根据所选设置自动生成角部拼块:中间、侧面、切片和重叠。默认选项是“侧面”
    • 应用至现有笔触并更新画笔:允许您使用指定设置创建一个新的画笔(更改将只适用于以后绘制的新笔触),或将这些设置应用于以前绘制的所有笔触。
    more_pattern_brush
    画笔库中的图案画笔

stretchtofit
拉伸以适合

addspacetofit
添加间距以适合


approxpath
近似路径



从 Adobe Capture CC 导入画笔

您可以使用适用于 Android 和 iOS 的 Adobe Capture CC 移动应用程序创建并向您的 CC 库中添加新的画笔。有关详细信息,请参阅 Adobe Capture CC

要创建或导入自定义矢量画笔:

  1. 使用 Adobe Capture 应用程序捕获一张图片。

  2. 将图片转换为画笔并将其保存到 CC 库中。

  3. 在 Animate 中打开 CC 库,然后单击新添加的画笔。此画笔即被添加到画笔库和当前文档中。

向文档中添加艺术画笔或图案画笔

从画笔库

您可以将画笔库中可用的新艺术画笔导入自己的文档中。

  1. 在“工具”面板中,单击 图标。“属性”面板中将显示画笔选项。
  2. 单击 图标。将显示“画笔库”面板。
PatternBrush LibraryView
画笔库

  1. 单击艺术画笔的类别、子类别,导航到要使用的画笔,或通过在搜索框中键入字符串的方式搜索库中的画笔。 
  2. 双击一个画笔,以将它添加到文档中。选定画笔会作为当前选定笔触样式显示在“属性”面板“画笔”工具的“样式”下拉框中。 

从 Creative Cloud (CC) 库

除默认提供的艺术画笔预设外,您还可以使用 CC 库将新的艺术画笔导入您的 Animate 文档中。

要添加新的艺术画笔,可打开 CC 库面板,然后单击所支持的任何一种画笔即可。(Animate 当前仅支持从 CC 库导入矢量画笔)。

  1. 在“工具”面板中,单击 图标。从“属性”面板选择“画笔”或“图案画笔”。
  2. 单击“窗口”>“CC 库”。将显示“CC 库”面板。
ImportingBrush
从 CC 库导入画笔

  1. 在“画笔”中,可以浏览在 CC 库中创建和保存的画笔。 
  2. 双击一个画笔,以将它添加到文档中。选定画笔会作为当前选定笔触样式显示在“属性”面板“画笔”工具的“样式”下拉框中。 

使用艺术画笔

通过沿绘制路径应用所选艺术画笔的图案,您可以使用基于笔触的画笔工具来绘制画笔笔触。您可以将画笔笔触应用于现有的路径,也可以使用“画笔”工具,在绘制路径的同时应用画笔笔触。 

对象绘制和合并绘制模式

使用艺术画笔时,默认将启用绘制对象模式,以便可以单独绘制每个画笔笔触,而不会与现有笔触合并,导致不良的笔触交叉。与合并绘制模式相比,您会看到对象绘制模式的性能更高,这是因为画笔笔触通常包含大量的矢量数据和合并形状,从而可能导致 Animate 执行得更慢。

要将已绘制好的形状转换为一个绘制对象,可在舞台上选择图形,然后单击“修改”>“合并对象”>“联合”

将艺术画笔笔触转换为填充

Animate 中绘制的艺术画笔与笔触一样,可通过使用“将线条转换为填充”选项将其改为填充。

要进行转换,首先选择舞台上绘制的画笔笔触,然后单击“修改”>“形状”>“将线条转换为填充”

转换为填充后,它将丢失其路径编辑能力而像普通填充的作用一样。

绘制为填充色

利用画笔工具中的“绘制为填充色”选项,可将画笔生成的形状设置为笔触或填充区域。

draw-as-fill
“绘制为填充色”选项

对舞台上的图形应用艺术画笔样式

您可以将新的艺术画笔样式应用至已绘制好的形状或现有的 Animate 文档中。

选择舞台上的一种形状,然后通过在“属性”面板中选择一种艺术画笔笔触样式来修改其笔触样式。 

stroke-style1

画笔中的压力和斜度

Animate CC 对使用画笔工具绘制的笔触提供了压力和斜度支持。取决于对铁笔应用的压力或斜度,您可以绘制不同宽度的艺术和图案笔触。要想做进一步调整,可使用“宽度”工具来调整宽度点。

Animate 中的倾斜选项在 Surface Pro 设备中可用,而不需要 WinTab 驱动程序。 

注意:

工具栏中的压力和斜度图标仅在为计算机连接了 Wacom 压敏平板电脑时才显示。

使用压力和斜度修饰符

  1. 选择画笔工具,然后选择工具栏中的 图标启用压力敏感度,或选择 图标启用斜度敏感度。默认百分比值为 1% 和 100%,分别对应于最小压力/斜度值和最大压力/斜度值。

    working with paint brush - pressure and tilt options
  2. 使用画笔工具根据应用于钢笔的压力或斜度创建可变宽度笔触。

    Pressure_p
    具有/没有压力敏感度

自定义压力和斜度敏感度

  1. 选择画笔工具。在“属性面板”中,选择“笔触样式”设置,然后单击“编辑笔触样式”选项以显示“画笔选项”。

  2. 设置最小压力/斜度和最大压力/斜度百分比值,二者分别对应于最小笔触宽度和最大笔触宽度。可接受的值为 1到 100 之间的整数。

    Tilt_sensitivity
    压力和斜度值

  3. 单击“添加”,添加具有选定压力和斜度敏感度设置的新画笔。

使用画笔工具绘制

使用画笔工具可以通过沿绘制路径应用所选艺术画笔的图案,绘制出风格化的画笔笔触。您可以将画笔笔触应用于现有的路径,也可以使用“画笔”工具,在绘制路径的同时应用画笔笔触。

  1. 在“工具”面板中,单击 图标。

  2. 在“工具”面板的选项中选择画笔工具的一种绘制模式:

    Brush_tool_options
    画笔工具选项

    • 若要绘制直线,并将接近三角形、椭圆、圆形、矩形和正方形的形状转换为这些常见的几何形状,请选择“伸直”
    • 若要绘制平滑曲线,请选择“平滑”
    • 若要绘制墨水模式输出效果而不修改图形,请选择“墨水”
    dr_03pencil_mode
    以伸直、平滑和墨水模式绘制的线条

编辑画笔

您可以使用“编辑画笔”选项来编辑艺术画笔的属性。单击“编辑画笔”图标,可针对选定画笔启动“画笔编辑”对话框。如果选择某个“艺术画笔”进行编辑,则会显示“艺术画笔选项”对话框:您可以修改属性(例如画笔方向、缩放首选项和重叠首选项)并将这些更改应用到现有笔触。选择一个普通画笔,然后单击“编辑画笔”,将针对该画笔类型启动编辑对话框。 

编辑艺术画笔

  1. 选择一种艺术画笔样式,然后单击“样式”下拉框旁边的“编辑”按钮。
  2. 在“编辑艺术画笔选项”框中,您可以编辑以下内容:
    • 按比例缩放:按比例缩放画笔大小而不拉伸画笔。
    • 拉伸以适合笔触长度:根据正在绘制的笔触的长度拉伸画笔。
    • 在辅助线之间拉伸:在辅助线之间拉伸画笔。 
    • 重叠:指定是否调整边角和折痕以防止重叠。
    • 翻转图稿:翻转画笔形状。
    • 画笔方向:更改画笔方向。
create_PB_2
编辑艺术画笔

  1. 要对使用画笔绘制的现有笔触应用更改并对画笔应用更改,请选择“应用至现有笔触并更新画笔”。 
  2. 单击“添加”保存更改。 

编辑实心和基本笔触样式

  1. 选择一种画笔/笔触样式,然后单击“样式”下拉框旁边的“编辑”按钮。
  2. 在“笔触样式”框中,可以编辑以下内容:
    • 类型
    • 4 倍缩放
    • 粗细
    • 锐化角部
Edit-Stroke-Style
编辑笔触样式

常用选项的 PI 快捷键

在“属性”面板中,您可以使用以下快捷键按钮以更方便访问:

  • 扩展以填充:将选定笔触转换为填充,然后将它们合并在一起
  • 创建对象:将合并模式中选定的形状转换为绘制对象(与联合操作相同)
  • 分离:将选定绘制对象拆分为原始形状
PI-options

有关如何使用画笔工具的教程

有关如何使用画笔工具的教程

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略