了解 Animate CC 最新版本的新增功能 。
an_appicon_128

2018 年 12 月版(版本 19.1)和 2018 年 10 月版(版本 19.0)Animate CC 向角色动画制作人员、游戏设计人员、广告开发人员、动画制作人员及教育内容编创人员推出了激动人心的新功能。阅读本文可快速了解这些功能的简要介绍以及更多相关信息的资源链接。


Animate 19.1 中的新增功能

“橡皮擦”工具中的“压力”和“斜度”支持

“橡皮擦”工具中添加“压力”和“斜度”选项,增强了绘图选项。您现在可以使用橡皮擦工具,根据应用到橡皮擦的压力或斜度创建宽度可变的笔触。

使用橡皮擦工具的示例说明
使用橡皮擦工具的示例说明

有关更多信息,请参阅“改变线条和形状”中的“拖动修改”部分。

油漆桶工具增强功能

您现在可以使用油漆桶工具来单击并拖动对象的轮廓,以用所选颜色填充它们。可以在轮廓上的任意方向单击并拖动该工具。油漆桶工具在跨轮廓捕获点时填充颜色。

“拖动填充”选项
“拖动填充”选项

有关更多信息,请参阅“使用油漆桶工具修改涂色区域”

SVG 导出增强功能

您现在可以从 Animate 导出 SVG 文件,而不会随之产生任何不需要的定义和 ID。增强了 SVG 合成功能。此导出选项卡增强了导入到 Character Animator 中的 SVG 文件的质量。

有关导出 SVG 工作流程的更多信息,请参阅“导出 SVG 文件”

Animate 19.0 新增功能

自动嘴形同步

角色动画师使用 Animate CC 时,对口型始终是一个费时费力的工作。现在,使用 Adobe Sensei 支持的 Animate,您可以让口型与声音语调自动同步。 

自动嘴形同步功能可基于所选择的语音图层,在时间轴上更轻松、快捷地放置适当的口型。您可以利用现有口型列表(在图形元件中绘制)并给它们标记相应的视位来实现。在图形元件上应用自动嘴形同步功能后,软件将对指定语音图层进行分析,然后将在不同位置自动创建关键帧,以匹配语音的发音嘴型。如果需要,可以使用常规工作流程和帧选择器进行进一步的调整。

自动嘴形同步
自动嘴形同步

有关详细信息,请参阅在 Animate CC 中创建元件实例

VR 创作和发布(测试版)

2D 游戏开发人员、教育者或 Web 开发人员可以使用 Animate 中的 2D 技能集,导出全景或 360 度虚拟现实动画。   

Animate 现在引入了 VR 360 和 VR Panorama 文档类型,使您能够轻松创作这种具有吸引力的内容。此外,您还可以使用虚拟现实文档类型将 3D 模型内容(.glb 文件)导入到 Animate 项目中并与 VR 输出交互。 

可以在“预览”面板中单击并移动 MovieClip 实例。当您单击并移动对象时,Animate 可自动检测它们。 根据所选文档类型,对象沿着柱面或球面路径移动。  

Animate 还允许您使用 API 在运行时管理虚拟现实动画。 例如,您可以在用户单击按钮时在 360 度虚拟现实环境中引入一些对象。  

VR 正在发布输出样例
VR 正在发布输出样例

有关详细信息,请参阅虚拟现实创作和发布

用于矢量和栅格内容的雕刻资源

现在,您可以使用资源变形工具对复杂的矢量形状和位图轻松变形。创建动画而不必在每个帧上重新绘制资源。

使用对象上显示的弯曲手柄,可以调整特定对象区域或扭曲特定对象区域,同时使其他区域保持不变。 用户可以使用选择工具选择多个对象,然后选择资源扭曲工具,在其上创建弯曲手柄。 您可以使用变形对象上显示的变形手柄改变特定对象的形状。此资源变形工具使您能够在复杂的形状或位图图像上创建逐帧动画和补间动画。

资源弯曲图例
资源弯曲图例

有关详细信息,请参阅变换和组合图形对象

用于已提升性能的纹理发布

作为动画师,您现在可以继续以矢量格式创作内容,并以矢量或栅格格式导出以用于 HTML5 平台。 

单击“文件”>“发布设置”。如果已启用“基本”选项卡中的“将动画导出为纹理”,则可以查看 “图像设置”选项卡中的纹理发布选项。默认情况下,在纹理发布中包含所有元件。要选择性地为纹理选择元件,请单击“更改”

纹理发布设置
纹理发布设置

有关更多信息,请参阅导出移动应用程序和游戏引擎的动画中的“纹理发布”

建立图层父子关系和图层效果

建立图层父子关系

Animate 允许您将一个图层设置为另一个图层的父项。建立图层父子关系的一种简单方法是允许您动画的一个图层/对象控制另一个图层/对象。作为动画设计人员或游戏设计人员,您可以更轻松地控制人物不同部位的移动,从而加快您的动画时间。 

现在,通过在父子图层中组织资源,可以轻松地在姿势之间进行动画处理。当父图层上的对象移动时,子图层自动随它一起移动。  

图层分类
图层分类

有关详细信息,请参阅使用 Animate CC 创建时间轴图层

图层效果

为图层添加着色和滤镜、淡入淡出播放以及景深等等。您可以在不更改舞台上的对象的情况下进行所有这些更改。 

可将多个帧级别滤镜同时应用到帧中的所有对象。可以将滤镜直接应用到时间轴(帧)上,无需将资源或动画置于影片剪辑内。可以将滤镜应用到所有类型的资源上,包括图形元件和形状,因此提高了灵活性。

使用图层效果

使用图层效果
观看本视频,了解如何使用图层深度和图层效果来增强动画效果。

有关详细信息,请参阅使用 Animate CC 创建时间轴图层

导出为 GL 传输格式 (glTF)

现在,动画制作者可以导出用于在网站上运行的新 glTF 标准动画。新的 WebGL-glTF 标准(测试版)和 WebGL-glTF 扩展(测试版)文档类型已添加到 Animate 中的现有文档类型列表中。

您可以使用标准文档类型,以便与标准 glTF 播放包集成。扩展文档类型使您能够创建具有交互性的高级动画,这些动画可在 Animate 新 glTF 运行时上运行。

WebGL-glTF 导出(标准和扩展)

WebGL-glTF 导出(标准和扩展)
观看本视频,了解如何在 Animate CC 中使用标准和扩展 WebGL-glTF 文档类型。

有关详细信息,请参阅创建和发布 WebGL 文档

改进了与 After Effects 的集成

作为动画制作人员,您经常需要在 Animate 中创建动画并将其导入 After Effects 以进行后期处理任务。现在,Animate 通过为 After Effects 提供一个插件来优化此工作流。  

您可以将 Animate FLA 文件导入 After Effects,以将它们合成视频或将其作为视频进行渲染,从而取得更有创造性的效果。Animate 的图层层次结构在 After Effects 中可继续保持。After Effects 可以使用该插件与 Animate 交互。  

Animate 和 After Effects 工作流程
Animate 和 After Effects 工作流程

有关详细信息,请参阅使用 Premiere Pro 和 After Effects

新的主屏幕

现在,可以通过新的主屏幕快速开始使用 Animate。使用任意方法选择动画目标时,Animate 都能提供预设格式。 从屏幕顶部的选项卡(如“角色动画”、“社交”、“游戏”、“教育”、“广告”、“Web”和“高级”)中选择目标。可以在“高级”选项卡中选择所需文件类型,如 HTML5 Canvas、ActionScript 3.0、VR 360(测试版)等。 

为每个目标选择相应的预设,然后单击“创建”即可开始创建动画。可以在左窗格中查看最近使用的文件。示例资源在启动屏幕的底部提供。  

单击左侧窗格中的“学习”可访问各种教程,以帮助您快速学习和理解相关概念、工作流程、提示和技巧。您还可以查阅相关教程,以获取 Animate CC 19.0 版中的大部分最新功能。

处理动画时,如需新建文档,可使用“文件”>“新建”。或者,可以使用以下快捷键:

Windows OS:CTRL + N。

macOS:CMD + N。

新的主屏幕
新的主屏幕

其他更改

颜料桶工具您现在可以使用“颜料桶工具”来单击并拖动对象的轮廓,以用所选颜色填充它们。可以在轮廓上的任意方向单击并拖动该工具。颜料桶工具在跨轮廓捕获点时填充颜色。

快速补间创建您现在可以通过选择对象快速从舞台中创建补间。选择舞台上的对象,右键单击并选择一个补间动画以快速创建补间。 如果所选对象属于多个图层,则会在所有图层中创建一个一秒钟动画。

对 MS Office 触控笔的支持现在,Microsoft Surface 用户可以获得最佳性能和线条质量,因为触控笔本身受支持。

更好的界面Animate 用户界面已使用 Spectrum 框架进行了更新,使其与其他 Creative Cloud 产品一样清晰直观。

退出图形元件的帧同步您可以在编辑元件时将图形元件与父时间轴同步。输入并离开图形元件后,将同步图形元件并保留帧位置。

重新设计的时间轴 时间轴控件经过重新设计,方便使用。某些控件移动到时间轴的顶部。以前,控件放置在时间轴的底部。

画笔和橡皮擦工具增强功能使用预览画笔和最终画笔描边改进了绘图体验。画笔工具中添加了“压力”和“倾斜”选项以及最小画笔大小选项。画笔工具中提供了简化的平滑控件。橡皮擦工具中提供了更多控件,画笔工具中的所有功能现在均适用于橡皮擦工具。

有关橡皮擦工具增强功能的更多信息,请参阅改变线条和形状

合并图层

可以先将一组图层分组,然后再将其合并为单个图层。在时间轴中,选择图层,然后右键单击选定的图层。从弹出菜单中选择“合并图层”,如下方屏幕截图所示。

在“时间轴”中合并图层
在“时间轴”中合并图层

新建主题

现在,可以从 Animate 的四个颜色主题中任意选择。要更改主题,请选择“编辑”>“首选参数”。在“常规”选项卡中,单击“用户界面”旁边的下拉列表菜单,然后选择相应的主题。

用户界面主题
用户界面主题

样本面板改进

您可以展开样本面板,而不影响其颜色对齐顺序。拖动面板时,它会增加样本的大小,如第二个屏幕抓图所示。如果您进一步拖动它,样本面板将分布在多个列中,如下面第三个屏幕抓图所示。

多列中的样本
多列中的样本

可以导出、导入或重复使用已保存的样本。标记的样本可以在 Animate 中的所有文档类型中重复使用。 

H264 视频导入增强功能

在 Animate 中导入 H264 格式的视频时,将会默认导入整个视频,且不会改变视频的帧数。如果想要匹配文档 FPS,则可以在“视频”对话框中选择相应的选项,如下方屏幕截图所示。

  • 如果已选择“匹配文档 FPS”,则 Animate 将会出现一定程度的掉帧,因为视频 fps 与文档 fps 不同。
  • 如果未选择“匹配文档 FPS”,则不会掉帧。

默认情况下,“匹配文档 FPS”选项处于未选中状态。

 

匹配文档 FPS
匹配文档 FPS

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略