应用基线偏移

使用“基线偏移”可以相对于周围文本的基线上下移动选定字符。手动设置分数字或调整随文图形的位置时,该选项特别有用。

op_09
Baseline shift values applied to text

  1. 选择文本。
  2. 在“字符”面板或“控制”面板中,为“基线偏移” 键入一个数值。输入正值会将字符的基线移到文字行基线的上方;输入负值则会将基线移到文字基线的下方。

注意:

要增大或减小该值,请在“基线偏移”框中单击,然后按向上或向下箭头键。在按下向上或向下箭头键的同时按住 Shift,可以按更大的增量更改值。

要更改基线偏移的默认增量,请在“首选项”对话框的“单位和增量”部分中为“基线偏移”指定一个值。

使字符上标或下标采用非 OpenType 字体

  1. 选择文本。
  2. 在“字符”面板菜单或“控制”面板中选择“上标”或“下标”。

选择“上标”或“下标”后,预定义的基线偏移值和文字大小就会应用于选定文本。

所应用的值为当前字体大小和行距的百分比,并且基于“文字首选项”对话框中的设置。选择文本时,这些值不会显示在“字符”面板的“基线偏移”和“大小”框中。

注意:

您可以使用“高级文字”首选项更改上标和下标的默认大小和位置。

应用下划线或删除线

下划线和删除线的默认粗细取决于文字的大小。

Jeff Witchel 在下面的链接中提供了一份有关下划线的视频教程:在 InDesign 中自定下划线

应用下划线或删除线

  1. 选择文本。
  2. 在“字符”面板菜单或“控制”面板中,选择“下划线”或“删除线”。

更改下划线或删除线选项

如果想在大小不同的字符下创建平整的下划线,或是创建特殊效果(如背景高光),创建自定下划线就显得特别有用。

op_18
Before and after adjusting underlines

  1. 在“字符”面板菜单或“控制”面板菜单中,选择“下划线选项”或“删除线选项”。
  2. 执行下列任一操作,然后单击“确定”:
    • 选择“启用下划线”或“启用删除线”,以在当前文本中启用下划线或删除线。

    • 在“粗细”中选择一种粗细或键入一个值,以确定下划线或删除线的线条粗细。

    • 在“类型”中,选择其中一个下划线或删除线选项。

    • 在“位移”中,确定线条的垂直位置。位移从基线算起。正值将使下划线移到基线的上方,使删除线移到基线的下方。

    • 如果要确保在印刷时描边不会使下层油墨挖空,请选择“叠印描边”。

    • 选择颜色和色调。如果指定了实线以外的线条类型,请选择间隙颜色或间隙色调,以更改虚线、点或线之间区域的外观。

    • 如果要在另一种颜色上打印下划线或删除线,且希望避免出现打印套不准错误,请选择“叠印描边”或“叠印间隙”。

注意:

要更改段落或字符样式中的下划线或删除线选项,请使用在创建或编辑该样式时所显示的对话框中的“下划线选项”或“删除线选项”部分。

将连笔字应用于字母对

当给定字体中提供了连笔字时,InDesign 会自动插入连笔字。连笔字是用于在排版时替换某些字母对(如“fi”和“fl”)的字符。选中“连笔字”选项后,InDesign 所使用的字符会显示并打印为连笔字,但这些字符是完全可编辑的,并且不会导致拼写检查程序产生单词标记错误。

op_11
Individual characters (top) and ligature combinations (bottom)

使用 OpenType 字体时,如果在“字符”面板菜单、“控制”面板菜单或上下文菜单中选择“连笔字”,则 InCopy 将生成该字体中定义的任何标准连笔字,具体情况取决于字体设计程序。不过,某些字体包含更多花饰和可选连笔字(选择“自由连笔字”命令后即可生成)。

  1. 选择文本。
  2. 从弹出框中选择“连笔字”。或者,您可以使用“字符”面板菜单或“控制”面板菜单选择“连笔字”。

更改文本的颜色、渐变或描边

可以将颜色、渐变和描边应用到字符,然后继续编辑文本。使用“色板”面板和“描边”面板将颜色、渐变和描边应用到文本,或是在创建或编辑样式时更改“字符颜色”设置。

op_34
Swatches

A. Swatch affects fill or stroke B. Swatch affects container or text C. Tint percentage 
  1. 执行以下操作之一:
    • 要对某一框架内的部分文本应用颜色更改,请使用“文字”工具 选择文本。

    • 要对某一框架内的全部文本应用颜色更改,请使用“选择”工具 选择该框架。在对文本(而非容器)应用颜色时,请确保选择了“工具”面板或“色板”面板中的“格式针对文本”图标

  2. 在“工具”面板或“色板”面板中,选择是对填色还是对描边应用颜色更改。如果选择“描边”,则颜色更改只影响字符的轮廓。
  3. 执行以下操作之一:
    • 在“色板”面板中,单击一种颜色或渐变色板。

    • 在“描边”面板中,指定粗细或其他描边选项。

通过使用渐变色板工具 或渐变羽化工具 在选定文本上拖动,您还可以将渐变效果应用到文本。

注意:

要创建反白文字,可以将文本的填充颜色更改为白色或 [纸色],将框架的填充颜色更改为深色。还可以通过在文本后面使用段落线来创建反白文字;但是,如果段落线为黑色,您将需要将文字更改为白色。

更改文本的颜色和渐变

可以使用“色板”面板对字符的描边和填色应用颜色和渐变。对于链接的文章,可以应用由链接的 InDesign 版面定义的任何颜色或渐变。对于独立的文章,可以应用您为文档创建的任何默认颜色或新颜色。

注意:

您无法在 InCopy 中创建渐变。只有在从 InDesign 导入渐变后,才会显示渐变。

op_st_11
Swatches

A. Swatch affects fill or stroke B. Swatch affects container or text C. Tint percentage 

更改文本颜色

  1. 使用“文字”工具 ,选择要着色的文本。
  2. 在“色板”面板(选择“窗口”>“色板”)中,单击一个颜色色板或渐变色板。

注意:

可以在条样、文章或版面视图中对文本应用颜色;但是,只有在版面视图中,颜色变化才可见。

指定要显示的色板的类型

  1. 选择“窗口”>“色板”以打开“色板”面板。
  2. 在此面板的底部,指定以下按钮之一:
    • 要显示所有的颜色色板、色调色板和渐变色板,请单击“显示全部色板”按钮。

    • 要只显示印刷色色板、专色色板和色调色板,请单击“显示颜色色板”按钮。

    • 要只显示渐变色板,请单击“显示渐变色板”按钮。

向文本添加透明效果

使用“效果”面板向文本中添加透明效果(如投影)。

Mike Rankin 在 InDesign Eye Candy(第 I 部分)中提供了有关透明效果的示例。

  1. 使用“选择”工具 选择文本框架。
  2. 选择“对象”>“效果”>“[效果]”。
  3. 从“设置”菜单中选择“文本”。

    如果要将您选择的效果应用于文本框架的描边、填色以及其内部的文本,则可以选择“对象”。

  4. 指定效果属性,然后单击“确定”。

    如果要更改文本的混合模式或不透明度设置,请在“效果”面板中进行这些更改。

为文本指定一种语言

为文本指定语言将决定要使用的拼写和连字词典。指定语言并不会更改实际的文本。

  1. 执行以下操作之一:
    • 要只将此语言应用于选定文本,请选择文本。

    • 要更改 InDesign 中使用的默认词典,请在没有打开任何文档的情况下选择语言。

    • 要更改特定文档的默认词典,请打开文档,选择“编辑”>“全部取消选择”,然后选择语言。

  2. 在“字符”面板中,从“语言”菜单选择适当的词典。

InDesign 使用 Proximity(和用于某些语言的 WinSoft)词典的拼写和连字规则。这些词典甚至允许您为文本中的单一字符指定不同的语言。每个词典都包含数十万条带有标准音节分段的字。更改默认语言不会影响现有文本框架和文档。

可以自定语言词典,以确保系统能够正确识别和处理您所使用的任何唯一性词汇。

InDesign 包含语言锁定功能,可防止为 CJK 文本指定非 CJK 语言。

op_12
How dictionaries affect hyphenation

A. “Glockenspiel” in English B. “Glockenspiel” in Traditional German C. “Glockenspiel” in Reformed German 

更改文字的大小写

“全部大写字母”或“小型大写字母”命令用于更改文本的外观,而非文本本身。相反,“更改大小写”命令用于更改选定文本的大小写设置。当搜索文本或对文本进行拼写检查时,这种区别很重要。例如,假如您在文档中键入“spiders”,然后对此单词应用“全部大写字母”。当使用“查找/更改”(同时选择了“区分大小写”)搜索“SPIDERS”时,将不会找到应用了“全部大写字母”的“spiders”。要达到更好的搜索和拼写检查效果,请使用“更改大小写”而非“全部大写字母”命令。

Anne-Marie Concepcion 在小型大写字母与 OpenType 全部小型大写字母的对比中提供了一篇有关小型大写字母的文章。

将文本更改为全部大写字母或小型大写字母

全部大写字母方法用于将所有罗马字文本变成大写形式。小型大写字母方法用于将所有罗马字文本变成大写形式并使其具有小写字符的大小。

InDesign 可以自动更改所选文本的大小写。当您将文本格式设置为小型大写字母时,InDesign 会自动使用作为字体一部分设计的小型大写字母字符(如果可用)。否则,InDesign 使用缩小版的大写字母来合成小型大写字母。合成小型大写字母的大小可在“文字首选项”对话框中设置。

op_10
Before (top) and after (bottom) setting BC and AD in small caps to complement old-style numerals and surrounding text

如果选择 OpenType 字体中的“全部大写字母”或“小型大写字母”,InDesign 就可以创建更精美的文字。如果使用的是 OpenType 字体,则还可以从“字符”面板菜单或“控制”面板中选择“全部小型大写字母”。(请参阅应用 OpenType 字体属性。)

  1. 选择文本。
  2. 在“字符”面板菜单或“控制”面板中选择“全部大写字母”或“小型大写字母”。如果文本在原来键入时就全部是大写字母,则选择“小型大写字母”不会更改此文本。

指定小型大写字母的大小

  1. 选择“编辑”>“首选项”>“高级文字”(Windows) 或“InCopy”>“首选项”>“高级文字”(Mac OS)。
  2. 在“小型大写字母”中,为设置为小型大写字母格式的文本键入相对原始字体大小的百分比。然后单击“确定”。

更改大小写

  1. 选择文本。
  2. 在“文字”>“更改大小写”子菜单中,选择下列选项之一:
    • 要将所有字符更改为小写,请选择“小写”。

    • 要使每个单词的第一个字母成为大写,请选择“标题大小写”。

    • 要将所有字符更改为大写,请选择“大写”。

    • 要使每个句子的第一个字母成为大写,请选择“句子大小写”。

注意:

“句首大写”命令假设句号 (.)、感叹号 (!) 和问号 (?) 字符代表句子的结尾。当以其他方式使用这些字符时(如在缩写、文件名或 Internet URL 中使用时),应用“句子大小写”可能会导致意外的大小写更改。此外,专名可能会在应当为大写的场合变为小写。

缩放文字

您可以相对字符的原始宽度和高度,指定文字高度和宽度的比例。未缩放字符的值为 100%。有些字体系列包括真正的扩展字体,这种字体设计的水平宽度要比普通字体样式宽一些。缩放操作会使文字失真,因此通常最好使用已紧缩或扩展的字体(如果有的话)。

op_08
Scaling fonts horizontally

A. Unscaled type B. Unscaled type in condensed font C. Scaled type in condensed font 

调整垂直或水平缩放

  1. 选择要缩放的文本。
  2. 在“字符”面板或“控制”面板中键入一个数值,以更改“垂直缩放” 或“水平缩放” 的百分比。

如果在首选项中选择了“直排时使用新建垂直缩放”,则在直排文本中用于罗马字形的 X 和 Y 缩放将被还原,以使行中的所有文本在相同方向上缩放。(请参阅更改 CJK 排版首选项。) 如果在“字符”面板菜单中选择了“根据字符缩放调整行高”选项,则字形的 Y 缩放将影响行高。在缩放框架网格时,Y 缩放会受到影响,因此需要调整行高,以免在缩放的网格上使用自动强制行数。

在 InDesign 中通过调整文本框架大小来缩放文本

  1. 执行以下操作之一:
    • 使用“选择工具”,按住 Ctrl 键 (Windows) 或 Command 键 (Mac OS),然后拖动文本框架的一个角点来调整其大小。

    • 使用“缩放工具” ,调整框架的大小。

确定文本缩放值的显示方式

当您更改框架的缩放比例时,框架内的文本也会被缩放。例如,当您将文本框架的大小加大一倍时,文本大小亦加大一倍;20 点文本将增加为 40 点。

David Blatner 在利用 InDesign 制作放大镜文本框架中提供了一篇有关缩放文本框架的文章。

可以更改首选项来指示缩放文本在面板中的显示方式:

  • 默认情况下,选择“应用于内容”,“控制”面板和“字符”面板中的“字体大小”框中将列出文本新的大小(例如“40 点”)。如果选择“调整缩放百分比”选项,则“字体大小”框中将显示文本的原始大小和缩放大小,例如“20 点 (40)”。

  • “变换”面板中的缩放值代表缩放框架的水平和垂直百分比。默认情况下,选择“应用于内容”,在缩放文本后缩放值仍显示为“100%”。如果选择“调整缩放百分比”选项,则缩放值将反应框架的缩放情况。因而,如果将框架比例加大一倍,则此值将显示“200%”。

如果必须将框架及其内部的文本恢复为其原始大小,则跟踪对框架所做的比例更改将是非常有用的。如果要找出框架大小的更改量,此方法也非常有用。要跟踪对框架和框架内部的文本所做的比例更改,请执行以下操作:

  1. 选择“编辑”>“首选项”>“常规”(Windows) 或“InDesign”>“首选项”>“常规”(Mac OS)。

  2. 选择“调整缩放百分比”,然后单击“确定”。

注意下列事项:

  • “调整缩放百分比”首选项只应用于打开此首选项之后缩放的框架,而非现有框架。

  • “调整缩放百分比”首选项对于文本始终起作用。即使关闭“调整缩放百分比”首选项,再次缩放框架时括号中也会继续显示缩放点大小。

  • 要从“变换”面板中删除缩放点大小,请在“变换”面板中选择“将缩放比例重新定义为 100%”。选择此选项不会更改缩放框架的外观。

  • 在选择“调整缩放百分比”首选项的情况下,如果在串接的框架内编辑文本或缩放框架,则即使文本移到另一个框架中也会被缩放。不过,如果选择“应用于内容”,则在编辑之后移到另一框架中的任何文本都不会再被缩放。

倾斜文字

  1. 选择文本。
  2. 在“字符”面板中,键入一个数值以进行倾斜 。正值表示文字向右倾斜;负值表示文字向左倾斜。

请注意,对文字应用角度并不会产生真正的斜体字符。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略