导入图形

InCopy 允许将图形导入到现有框架中。当内容是在版面之前创建时此功能尤其有用,因为您可以在编写时为文章选择图形。

只能将图形导入现有框架中。只有 InDesign 用户可以创建图形框架。在独立的 InCopy 文档中,可以将图形插入默认文本框架中,使其成为随文图。

InCopy 与 InDesign 支持同样多的图形文件格式。其中包括使用 Adobe® Illustrator® 8.0 和更高版本创建的图形,诸如 PDF、PSD、TIFF、GIF、JPEG 和 BMP 等位图格式,以及诸如 EPS 的矢量格式。您甚至可以将 InDesign (INDD) 页面作为图像导入。其他支持的格式包括 DCS、PICT、WMF、EMF、PCX、PNG 和 Scitex CT (.SCT)。

有关在 InCopy 中置入图形的说明

将图形导入 InCopy 时,请注意下列准则:

  • 对于受管理的内容,必须先注销框架,然后才能导入图形。

  • 一旦导入图形,即可以在框架内变换(移动、缩放、旋转、切变)该图形,使图形适合框架,以及控制图形的外观。您也可以通过从上下文菜单中选择命令,对所选框架进行标记,以备将来用于 XML。

  • 当 InDesign 用户创建新框架时,他们将指定该框架是文本、图形还是未分配框架。InCopy 用户不能在 InCopy 内更改此框架类型。因此,如果尝试将某个图形导入文本框架内,它可能显示为一个较大的随文图。

  • 您可以在 InCopy 中选择和修改图形,但不能选择和修改框架,除非它们是嵌套框架或随文框架。只有 InDesign 用户可以修改图形框架。

  • 您可以将图形置入、粘贴或拖到定位、浮动或随文图框架内。仅当文本框架具有现用插入点或是随文图框架时,才能将图形导入该文本框架内。

  • 如果将图形导入嵌套框架内,则将图形导入到指针下方最深层的框架内。与顶级框架不同,包含图形的嵌套框架可以使用“位置”工具进行选择。(请参阅位置工具概述。)

  • 如果在 InDesign 中将诸如透明度、投影或羽化等效果应用到框架,则该效果将显示在 InCopy 中打开的任务文件或 InDesign (.indd) 文件内。在 InCopy 中打开链接 (.icml) 文件时,其中不会显示此文件。

将图形置入 InCopy 文档

  1. 执行以下操作之一:
    • 要将图形置入独立的 InCopy 文档中,请将插入点置入文本框架内。

    • 要将图形置入链接的文档中,请确保已注销图形框架。“编辑”图标  显示在该框架的左上角。

  2. 选择“文件”>“置入”,然后选择一个图形文件。
  3. 要设置特定格式的导入选项,请选择“显示导入选项”以查看特定格式设置,然后单击“打开”。

    注意:

    当使用显示导入选项对话框置入在 Illustrator 9.0 或更高版本中创建的图形时,其中的选项与用于 PDF 文件的选项相同。置入 Illustrator 8.x 图形时,其中的选项与处理 EPS 文件时的选项相同。

  4. 如果显示其他对话框,则请选择导入选项并单击“确定”。
  5. 要导入到框架中,请单击框架中的载入的图形图标 。要置入多页 PDF 文档的指定页面,请单击框架内载入的图形图标。

    注意:

    如果意外地使用置入的图像替换了现有图形,请按 Ctrl+Z 组合键 (Windows) 或 Command+Z 组合键 (Mac OS),使原始图像返回框架中,并显示载入的图形图标。

将图形拖到框架内

  1. 执行以下操作之一:
    • 要将图形置入现有图形框架中,确保已注销该框架,然后将图形文件的图标从文件系统拖动到框架内。

    • 要在现用文本插入点置入图形,请将图形文件的图标拖到文本框架内的任意位置。这种方法仅在版面视图中可用。

将图形粘贴到框架内

  1. 确保已注销图形框架。“编辑”图标  显示在该框架的左上角。
  2. 剪切或复制图形。
  3. 将“抓手”工具置于图形框架上方,右键单击 (Windows) 或按住 Control 键单击 (Mac OS),然后选择“粘贴到”。

创建随文图

  1. 确保已注销文本框架。“编辑”图标  显示在该框架的左上角。
  2. 执行以下操作之一:
    • 要将图形置入现有随文图框架内,请使用“置入”或“剪切”命令选择一个图形。单击框架内载入的图形图标。

    • 要在现用文本插入点置入图形,请将图形文件的图标拖到文本框架内的任意位置,或者使用“置入”命令导入图形。

图形的导入选项

图形导入选项因要导入的图像类型而异。要显示导入选项,务必在“置入”对话框中选中“显示导入选项”。

封装 PostScript (.eps) 导入选项

置入 EPS 图形(或使用 Illustrator 8.0 或更低版本存储的文件)并在“置入”对话框中选择“显示导入选项”后,将会看到一个包含以下选项的对话框:

读取嵌入的 OPI 图像链接

此选项指示 InCopy 从包含(或嵌入)在图形中的图像的 OPI 注释中读取链接。

如果您正在使用基于代理的工作流程,并计划让服务提供商使用他们的 OPI 软件执行图像替换,则取消选择此选项。取消选择此选项后,InDesign 将保留 OPI 链接,但不读取它们。当打印或导出时,代理及链接将会传递到输出文件中。

如果您正在使用基于代理的工作流程,并希望 InDesign(而不是服务提供商)在输出最终文件时执行图像替换,请选择此选项。选择此选项后,OPI 链接将显示在“链接”面板中。

如果所导入 EPS 文件中包含的 OPI 注释不是基于代理的工作流程的组成部分,也需要选择此选项。例如,如果所导入 EPS 文件包含忽略的 TIFF 或位图图像的 OPI 注释,则需要选择此选项,以便 InDesign 可以在您输出文件时访问 TIFF 信息。

应用 Photoshop 剪切路径

无论是否选择此选项,置入的 EPS 文件都在 InDesign 中包含剪切路径。但是,取消选择此选项可能导致定界框大小不同。

代理生成

此选项用于将文件绘制到屏幕上时,创建图像的低分辨率位图代理。下列设置用于控制代理的生成方式:

使用 TIFF 或 PICT 预览

某些 EPS 图像包含嵌入预览。选择此选项可以生成现有预览的代理图像。如果不存在预览,则会通过将 EPS 栅格化成屏外位图来生成代理。

栅格化 PostScript

选择此选项将忽略嵌入预览。此选项通常速度较慢,但可以提供最高品质的结果。

注意:

向同一文档中导入多个文件时,所有实例将共享导入文件的第一个实例的代理设置。

位图导入选项

在文档中使用颜色管理工具时,可以将颜色管理选项应用于各个导入的图形。还可以导入与在 Photoshop 中创建的图像存储在一起的剪切路径或 Alpha 通道。这样,可以直接选择图像并修改其路径,而不必更改图形框架。

注意:

尽管 Adobe InCopy 不包括颜色管理选项,但在将置入 InCopy 中的图像转移到 InDesign 时,还是会与这些导入选项产生关系。

置入 PSD、TIFF、GIF、JPEG 或 BMP 文件并在“置入”对话框中选择“显示导入选项”后,将会看到一个包含以下选项的对话框:

应用 Photoshop 剪切路径

如果此选项不可用,则表示图像在存储时并未包含剪切路径,或文件格式不支持剪切路径。如果位图图像没有剪切路径,可以在 InDesign 中创建一个。

Alpha 通道

选择一个 Alpha 通道,以便将图像中存储为 Alpha 通道的区域导入 Photoshop 中。InCopy 将使用 Alpha 通道在图像上创建透明蒙版。此选项仅对至少包含一个 Alpha 通道的图像可用。

单击“颜色”选项卡,查看下列选项:

df_03
Image imported without clipping path (left) and with clipping path (right)

配置文件

如果选择了“使用文档默认设置”,则使此选项保持不变。否则,选择一个与用于创建图形的设备或软件的色域匹配的颜色源配置文件。此配置文件使 InDesign 能够将它的颜色正确地转换为输出设备的色域。

渲染方法

选择将图形的颜色范围调整为输出设备的颜色范围时要使用的方法。一般情况下选择“可感知(图像)”,因为它可以精确地表示出照片中的颜色。“饱和度(图形)”、“相对比色”和“绝对比色”选项更适合于纯色区域,但是不能很好地重现照片。“渲染方法”选项对位图、灰度和索引颜色模式的图像不可用。

便携网络图形 (.png) 导入选项

置入 PNG 图像并在“置入”对话框中选择“显示导入选项”后,将会看到一个包含三个导入设置部分的对话框。其中两个部分包含的选项与可用于其他位图图像格式的选项相同。另一个部分“PNG 设置”包含下列设置:

使用透明信息

默认情况下,当 PNG 图形包含透明度时,将启用此选项。如果导入的 PNG 文件包含透明度,则图形只在背景透明的位置交互。

白色背景

默认情况下,如果 PNG 图形不包含文件定义的背景颜色,将选中此选项。但是,只有激活“使用透明信息”才会启用该选项。如果选择了此选项,则在应用透明信息时会以白色用作背景颜色。

文件定义的背景颜色

默认情况下,如果使用非白色背景颜色存储 PNG 图形,并选择了“使用透明信息”,则会选择此选项。如果不想使用默认背景颜色,可以单击“白色背景”,导入具有白色背景的图形;或取消选择“使用透明信息”,导入没有任何透明度的图形(显示当前透明的图形区域)。某些图像编辑程序无法为 PNG 图形指定非白色背景颜色。

应用灰度系数校正

选择此选项,可以在置入 PNG 图形时调整其灰度系数(中间调)值。使用此选项,可以使图像灰度系数与用于打印或显示图形的设备(如低分辨率或非 PostScript 打印机或计算机显示器)的灰度系数匹配。取消选择此选项,将在不应用任何灰度系数校正的情况下置入图像。默认情况下,如果 PNG 图形存储有灰度系数值,则会选中此选项。

灰度系数值

此选项(仅当选择了“应用灰度系数校正”时可用)显示与图形存储在一起的灰度系数值。要更改此值,请键入一个介于 0.01 和 3.0 之间的正数。

导入 PNG 文件后,“图像导入选项”对话框中的设置将始终以选定文件为基础,而不是以默认设置或上次使用的设置为基础。

Acrobat (.pdf) 和 Illustrator (.ai) 导入选项

将保留置入的 PDF 中的版面、图形和排版规则。与其他置入的图形一样,不能在 InCopy 中编辑置入的 PDF 页面。可以控制分层的 PDF 中图层的可视性。还可以置入多页面 PDF 的多个页面。

置入存储有密码的 PDF 时,系统会提示您输入所需的密码。如果 PDF 文件存储有使用限制(例如,无法编辑或打印),但未存储密码,则可以置入此文件。

置入 PDF(或使用 Illustrator 9.0 或更高版本存储的文件)并在“置入”对话框中选择“显示导入选项”后,将会看到一个包含下列选项的对话框:

显示预览

在置入 PDF 中的页面之前,可以先预览该页面。如果是从包含多个页面的 PDF 置入页面,请单击箭头,或在预览图像下键入页码,以便预览特定页面。

页面

指定要置入的页面:预览中显示的页面、所有页面或一定范围的页面。对于 Illustrator 文件,您可以指定要置入的画板

注意:

如果指定多个页面,请在置入文件时按住 Alt 键 (Windows) 或 Option 键 (Mac OS),以便按照逐张叠放的方式同时置入所有页面。

裁切到

指定要置入的 PDF 页面的范围:

定界框

置入 PDF 页的边框,或包围页面中对象的最小区域,包括页面标记。“定界框(仅限可见图层)”选项只使用 PDF 文件的可见图层的定界框。“定界框(所有图层)”选项会置入 PDF 文件的所有图层区域的定界框,即使这些图层是隐藏的。

作品区

仅置入作者作为可置入图稿(例如,剪贴图)创建的矩形所限定区域中的 PDF 页面。

裁切

将 PDF 仅置入 Adobe Acrobat 显示或打印的区域中。

成品尺寸

标识制作过程中将物理裁切最终制作页面的地方,如果有裁切标记。

出血

仅置入表示应剪切所有页面内容的区域,如果有出血区域。此信息在将页面输出到制作环境时有用。请注意,打印页可能包含落在出血区域以外的页面标记。

媒体

置入表示原 PDF 文档物理纸张大小的区域(例如 A4 纸的尺寸),包括页面标记。

df_06
Options for cropping placed PDFs

A. Media B. Trim C. Bleed D. Content E. Crop F. Art 

透明背景

选择此选项,以显示在 InCopy 版面中位于 PDF 页面下方的文本或图形。取消选择此选项,将置入带有白色不透明背景的 PDF 页面

注意:

如果在包含 PDF 图形的框架中使其背景变得透明,以后可以通过向此框架添加填色,使其变成不透明状态。

InDesign (.indd) 导入选项

InDesign 会保留置入的 INDD 文件中的版面、图形和排版规则。不过,尽管可以控制图层的可视性并可以选择要导入多页面 INDD 文件中的哪些页面,但文件仍被视为对象,并且无法对其进行编辑。

置入 InDesign 文件并在“置入”对话框中选择“显示导入选项”后,将会看到一个包含以下选项的对话框:

显示预览

置入页面之前可以先预览它。要预览多页面文档中的某一页面,可以键入页码或单击箭头。

页面

指定要置入的页面:预览中显示的页面、所有页面或一定范围的页面。

裁剪为

指定要置入多大页面、页面本身或粘贴板上的出血或辅助信息区。

使图形适合其框架

当您将一个图形置入或粘贴到框架中时,默认情况下,它出现在框架的左上角。如果框架及其内容的大小不同,您可以使用“适合”命令实现完美吻合。

  1. 使用“位置”工具 选择图形。
  2. 选择“对象”>“适合”,以及下列选项之一:

    内容适合框架

    调整内容大小以适合框架并允许更改内容比例。框架不会更改,但是如果内容和框架具有不同比例,则内容可能显示为被拉伸。

    内容居中

    将内容放置在框架的中心。框架及其内容的比例会被保留。

    按比例适合内容

    调整内容大小以适合框架,同时保持内容的比例。框架的尺寸不会更改。如果内容和框架的比例不同,将会导致一些空白区。

    按比例填充框架

    调整内容大小以完全适合框架,同时保持内容的比例。框架的尺寸不会更改。

    注意:

    “适合”命令会调整内容的外边缘以适合框架描边的中心。如果框架的描边较粗,内容的外边缘将被遮盖。您可以将框架的描边对齐方式调整为与框架边线的中心、内边或外边对齐。

“链接”面板中列出了文档中置入的所有文件。其中包括本地文件(位于磁盘上)和在服务器上管理的资源。但是,从 Internet Explorer 中的某个网站粘贴而来的文件并不显示在此面板中。

在 InCopy 中,“链接”面板还可以显示链接的文章。当您在“链接”面板中选中一个链接的文章时,“链接信息”部分会显示这些信息,例如:附注数量、管理状态以及修订状态。

df_GraphicsLinks1
Links panel

A. Category columns B. Show/Hide Link Information C. One or more instances modified icon D. Modified icon E. Missing-link icon F. Embedded-link icon 

同一个图形在文档中出现多次时,其链接将合并到“链接”面板中一个明显的三角形下。如果链接的 EPS 图形或 InCopy 文档包含链接,那么这些链接也会合并到那个明显的三角形下。

可以通过以下任何方式,将链接的文件显示在“链接”面板中:

最新

最新文件的“状态”列中是空白的。

已修改

此图标意味着磁盘上的文件版本比文档中的版本新。例如,如果将一个 Photoshop 图形导入 InCopy,然后您或其他用户在 Photoshop 中编辑并存储该原始图形,那么便会显示此图标。

修改图形时,如果更新它的一个或多个实例,但其他实例保持不变,“已修改”图标将变得略有不同。

缺失

图形不再位于导入时的位置,但仍存在于某个地方。如果导入文件后,将原始文件删除或移至另一个文件夹或服务器,则可能会出现缺失链接的情况。在找到其原始文件前,无法知道缺失的文件是否是最新版本。如果在显示此图标的状态下打印或导出文档,则文件可能无法以全分辨率打印或导出。

嵌入

嵌入链接文件的内容会导致该链接的管理操作暂停。如果选定链接当前处于“正在编辑”操作中,则不能使用此选项。取消嵌入文件,就会恢复对相应链接的管理操作。

如果链接对象未显示在特定文档页面上,则会通过下列代码指示该对象的显示位置:PB(粘贴板)、MP(主页)、OV(溢流文本)和 HT(隐藏文本)。

有关使用“链接”面板的视频教程,请参阅 www.adobe.com/go/lrvid4027_id_cn

InDesign Secrets 在通过“链接”面板节省时间中提供了一份有关“链接”面板提示和技巧的视频广播。

  • 要显示“链接”面板,请选择“窗口”>“链接”。每个链接文件和自动嵌入的文件都通过名称来标识。
  • 要选择并查看链接的图形,可以在“链接”面板中选择相关链接,然后单击“转到链接”按钮 ;在“页面”栏中单击该链接的页码;或在“链接”面板菜单中选择“转到链接”。InCopy 以选定的图形为中心来显示内容。要查看隐藏对象,请显示图层(如果该隐藏对象为定位对象,则显示条件)。
  • 要展开或折叠嵌套链接,请单击链接左侧的三角形图标。同一图形在文档中出现多次,或者链接的 EPS 图形或 InCopy 文档包含链接时,便会形成嵌套链接。
  • 要对面板中的链接排序,请单击“链接”面板顶部的相应类别标题,便会按该类别排序。再次单击该类别可反转排序顺序。例如,如果单击“页面”类别,则链接将按从第一页到最后一页的顺序显示。如果再次单击“页面”,则链接将按从最后一页到第一页的顺序排序。使用“面板选项”向“链接”面板添加栏。

您可以在“链接”面板中显示其他类别(如“创建日期”和“图层”),以显示有关图形的更多信息。对于每个类别,您可以确定该信息是否显示为“链接”面板及“链接”面板底部“链接信息”部分中的一栏。

  1. 从“链接”面板菜单中选择“面板选项”。
  2. 选中“显示栏”下面的复选框,以在“链接”面板中添加栏。

    Folder 0 是包含链接文件的文件夹,Folder 1 是包含 Folder 0 的文件夹,依此类推。

  3. 选中“在链接信息中显示”下面的复选框,以在“链接”面板底部的“链接信息”部分中显示信息。
  4. 单击“确定”。

通过选择栏并将其拖动到另一位置,可以更改栏的顺序。拖动栏边界可更改栏宽。单击类别标题可按该类别对链接进行升序排序。再次单击可按降序排序。

  1. 从“链接”面板菜单中选择“面板选项”。
  2. 对于“行大小”,选择“小行”、“常规行”或“大行”。
  3. 对于“缩览图”,确定是否在“名称”栏和“链接”面板底部的“链接信息”部分中显示图形的缩览图表示形式。
  4. 单击“确定”。

“链接”面板的“链接信息”部分会列出有关所选链接文件的信息。

注意:

要更改“链接”面板“链接信息”部分中显示的信息,请从“链接”面板菜单中选择“面板选项”,然后选中“在链接信息中显示”栏中的复选框。

  1. 双击链接,或选择链接并单击“显示/隐藏链接信息”图标,此三角形图标显示在面板的左侧。

如果链接的或嵌入的文件包含元数据,则可以使用“链接”面板查看元数据。您无法编辑或替换与链接文件关联的元数据。

  1. 在“链接”面板中选择一个文件,然后从面板菜单中选择“实用程序”>“XMP 文件信息”

使用“链接”面板检查任一链接的状态,或使用更新文件或替代文件替换文件。

更新或重新建立(重新链接)文件链接时,将保留 InCopy 中已执行的所有变换,前提是在“文件处理”首选项中选中了“重新链接保留尺寸”。例如,如果导入一个正方形图形并将其旋转 30°,然后将其重新链接到一个未旋转的图形,InCopy 会将后者旋转 30°,以便匹配要替换的图形的版面。

注意:

置入的 EPS 文件可能包含 OPI 链接,这些链接将显示在“链接”面板中。OPI 链接的重新链接对象只能是 EPS 文件创建者初始希望链接的文件,否则,可能导致字体下载和分色出现问题。

选择如何缩放重新链接的图形

通过重新链接操作将一个图形替换成另外一个源文件时,可以保持被替换文件的图像尺寸不变,也可以按实际尺寸显示引入的文件。

  1. 选择“编辑”>“首选项”>“文件处理”(Windows),或“InCopy”>“首选项”>“文件处理”(Mac OS)。

  2. 如果希望图像的显示尺寸与被替换的图像相同,请选择“重新链接时保留图像尺寸”。如果取消选择此选项,重新链接的图像将按其实际尺寸显示。

InDesign 首先会在文件夹(当前会话中已经重新链接了该文件夹中的另一个文件)中查找缺失的链接。接下来,InDesign 会在文档所在的同一文件夹中查找链接。如果仍未找到,则会在该文档的上级文件夹中查找。

经过修改的链接也称为“过时”链接。

  1. 在“链接”面板中,执行以下操作之一:
    • 要更新特定链接,请选择一个或多个标记有“修改的链接”图标 的链接。然后单击“更新链接”按钮 ,或从“链接”面板菜单中选择“更新链接”。

    • 要更新所有经过修改的链接,请从“链接”面板菜单中选择“更新所有链接”,或选择某个经过修改的链接,然后按住 Alt (Windows) 或 Option (Mac OS) 键并单击“更新链接”按钮。

    • 若同一图形链接在文档中出现多次,而您只想更新其中一个链接,请仅选择该子链接,然后选择“更新链接”。如果选择“父”链接,可以更新指向已修改图形的所有链接。

  1. 在“链接”面板中选择任一链接,然后单击“重新链接”按钮 ,或从“链接”面板菜单中选择“重新链接”。如果选择了多个实例的“父”链接,请从“链接”面板菜单中选择“重新链接 [Filename] 的所有实例”。

    在受管理的文章中,重新链接是禁用的,直到注销该文章。

  2. 如果希望 InCopy 在文件夹中搜索与其他缺失的链接文件同名的文件,请在出现的对话框中选择“在此文件夹中搜索缺失的链接”。如果未选择此选项,则仅重新链接所选图像。
  3. 选择“显示导入选项”,控制新源文件的导入方式。
  4. 找到并双击新的源文件。
  5. 如果单击了“显示导入选项”选项,请选择导入选项。(请参阅图形的导入选项。)
  1. 要恢复缺失的链接,请在“链接”面板中选择任何标记有缺失链接图标 的链接,然后单击“重新链接”按钮
  2. 在出现的对话框中,选择“在此文件夹中搜索缺失的链接”,以重新链接指定文件夹中显示的所有缺失文件。找到并双击一个文件。

默认情况下,InCopy 会在您打开文档时检查缺失的链接并尝试解析它们。首选项中有两个选项可以让 InCopy 在您打开文档时自动检查并查找缺失的链接。

打开文档前检查链接

如果关闭此选项,InCopy 将立即打开文档,且链接保持挂起状态,直到确定它们的状态是最新、缺失还是已修改。如果打开此选项,InCopy 将检查已修改或缺失的链接。

打开文档前查找缺失链接

如果关闭此选项,InCopy 则不会尝试解析缺失的链接。如果链接影响到服务器的性能,或是发生异常链接,您可能希望关闭此选项。如果关闭了“打开文档前检查链接”,此选项将灰显。

搜索缺失的链接

使用“搜索缺失的链接”命令可搜索并解析文档中的缺失链接。如果关闭了首选项中在打开文档时检查缺失链接的那个选项,而现在发现了缺失的链接,可以使用此命令帮助解决问题。如果存储图像的服务器是在打开文档之后装入的,也会用到此命令。

  • 要更改链接设置,请打开“首选项”对话框的“文件处理”部分,并确定“打开文档前检查链接”和“打开文档前查找缺失链接”两个选项是否已选中。
  • 要让 InCopy 尝试解析缺失的链接,请从“链接”面板菜单中选择“实用程序”>“搜索缺失的链接”。

    如果文档不包含缺失链接,此命令将灰显。

  1. 在“首选项”对话框中,选择“文件处理”。
  2. 从“默认重新链接文件夹”菜单中选择以下选项之一,然后单击“确定”:

    最近使用的重新链接文件夹

    此选项显示的最近使用的文件夹是您在重新链接时选择的文件夹,这与 InCopy CS3 的行为相同。

    原始链接文件夹

    此选项显示链接文件的原始位置,这与 InCopy CS2 和更早版本的行为相同。

通过“将链接复制到”命令,可以将图形文件复制到另一个文件夹,然后将链接重定向到所复制的文件。在将文件移动到另一驱动器(例如将文件从 DVD 移动到硬盘驱动器)时,此命令尤为有用。

  1. 选择指向要复制的文件的链接,然后从“链接”面板菜单中选择“实用程序”>“将链接复制到”。
  2. 指定复制链接文件的目标文件夹,然后选择“选择”(Windows/Mac OS)。

使用“重新链接到文件夹”命令时,目标文件夹可以包含与过期链接同名的文件。例如,如果当前链接指向低分辨率图像,则可以指定包含高分辨率图像的其他文件夹。可以为文件指定其他扩展名,例如可以将链接从 .jpg 更改为 .tiff。

在受管理的 InCopy 文章中,“重新链接到文件夹”命令是灰显的,直到注销该文章。

  1. 在“链接”面板中选择一个或多个链接。
  2. 从“链接”面板菜单中选择“重新链接到文件夹”。
  3. 指定新文件夹的位置。
  4. 要使用其他扩展名,请选择“匹配相同文件名及此扩展名”,然后指定新扩展名(如 AI、TIFF 或 PSD)。
  5. 单击“选择”(Windows/Mac OS)。

使用“重新链接文件扩展名”命令,可以根据文件扩展名来替换图像。例如,如果文档中有多张 JPEG 图像,您可以将这些图像替换为 PSD 文件。具有不同扩展名的文件必须与要替换的链接文件位于同一文件夹中。

  1. 请确保具有不同文件扩展名的文件与原始文件位于同一文件夹中。
  2. 在“链接”面板中选择一个或多个链接。
  3. 从“链接”面板菜单中选择“重新链接文件扩展名”。
  4. 指定要替换选定文件的文件扩展名,然后单击“重新链接”。

使用置入命令替换导入的文件

  1. 执行以下操作之一:
    • 要替换图形框架的内容(如导入的图形),请使用“选择”工具 选择框架。

      要替换图形框架的内容(如导入的图形),请使用“位置”工具选择所需图像。

    • 要替换文本框架的内容,请使用“文字”工具单击文本框架,置入一个插入点,然后选择“编辑”>“全选”

  2. 选择“文件”>“置入”。
  3. 找到新文件并选择它。
  4. 确保选中了“替换所选项目”,然后单击“打开”。
  5. 单击“打开”。

您可以复制链接图像的完整路径,也可以复制平台样式路径。如果复制图像的完整路径,可以让团队成员知道图形的位置。例如,可以复制完整路径,然后将其粘贴到电子邮件中。如果复制平台路径,对于脚本编写或在数据合并中指定图像字段有很大帮助。

  1. 在“链接”面板中选择一个链接。
  2. 从“链接”面板菜单中选择“复制信息”>“复制完整路径”或“复制平台样式路径”。
  3. 粘贴该路径。

编辑原始图稿

通过使用“编辑原稿”命令,您可以在创建图形的应用程序中打开大多数图形,以便在必要时对其进行修改。存储原始文件之后,将使用新版本更新链接该文件的文档。

注意:

在 InDesign 中,如果您注销并选择受管理的图形框架(已导出到 InCopy 的图形框架)而不是图形本身,则图形将在 InCopy 中打开。

使用默认应用程序编辑原始图稿

默认情况下,InCopy 依靠操作系统来确定用于打开原始文件的应用程序。

  1. 在页面上或“链接”面板中选择一张或多张图像。
  2. 执行以下操作之一:
    • 在“链接”面板中,单击“编辑原稿”按钮 .

    • 选择“编辑”>“编辑原稿”。

  3. 在原始应用程序中进行更改后,存储文件。

使用其他应用程序编辑原始图稿

  1. 选择图像。
  2. 选择“编辑”>“编辑工具”,然后指定将用于打开文件的应用程序。如果没有显示该应用程序,请选择“其他”,浏览并找到该应用程序。

控制导入图像中的图层可视性

导入 Photoshop PSD 文件、分层的 PDF 和 INDD 文件时,可以控制顶层图层的可视性。通过在 InCopy 中调整图层的可视性,可以方便地根据上下文更改插图。例如,在多语言出版物中,可以创建这样一个插图:其中的每个文本图层都对应一种语言。

既可以在置入文件时调整图层可视性,也可以使用“对象图层选项”对话框调整。此外,如果 Photoshop 文件包含图层复合,则可以显示所需的复合。

设置图层可视性

  1. 执行以下操作之一:
    • 要在不创建框架的情况下导入图形,请确保未选择文档中的任何内容。

    • 要将图形导入到现有框架中,请选择此框架。

    • 要替换现有图像,请选择图形框架。

  2. 选择“文件”>“置入”,然后选择一个图形文件。
  3. 要替换选中的对象,请选择“替换所选项目”。
  4. 选择“显示导入选项”,然后单击“打开”。
  5. 在“图像导入选项”或“置入”对话框中,单击“图层”选项卡。
  6. 要查看图像预览,单击“显示预览”。
  7. (仅限 PDF 文件)如果是从多页面 PDF 置入页面,请单击箭头,或在预览图像下键入页码,以便预览特定页面。
  8. (仅限 Photoshop PSD 文件)如果图像包含图层复合,请从“图层复合”弹出菜单中选择要显示的图层复合。
  9. 执行以下操作之一:
    • 要打开或关闭图层组,请单击文件夹图标左侧的三角形。

    • 要隐藏图层或图层组,请单击图层或图层组旁边的眼睛图标。

    • 要显示图层或图层组,请单击图层或图层组旁边空的眼睛图标列。

    • 要只显示特定图层或图层组的内容,请按住 Alt 键 (Windows) 或 Option 键 (Mac OS) 并单击其眼睛图标。再次按住 Alt 键或 Option 键并单击眼睛图标,可恢复其他图层的原始可视性设置。

    • 要更改多个项目的可视性,请用鼠标将对应项目拖过眼睛图标列。

  10. 根据需要设置“更新链接的时间”选项:

    使用 Photoshop/PDF 的图层可视性

    更新链接时,使图层可视性设置与所链接文件的可视性设置匹配。

    保持图层可视性优先

    维护文件最初置入时原有的图层可见性设置。

  11. 单击“确定”。
  12. 单击“确定”,并执行以下操作之一:
    • 要导入到新的框架中,请在版面中希望显示图形左上角的位置单击载入的图形图标

    • 要导入到现有的未选定框架中,请在该框架中的任意位置单击载入的图形图标。

    • 要导入到现有的选定框架中,则不必执行任何操作。图像会自动显示在该框架中。

    注意:

    如果意外地使用置入的图像替换了现有图形,请按住 Ctrl+Z 组合键 (Windows) 或 Command+Z 组合键 (Mac OS),使原始图像返回框架中,并显示载入的图形图标。

对置入的 AI、PSD、PDF 和 INDD 文件设置图层可视性

置入 Photoshop PSD 或分层的 PDF、Illustrator AI 文件或 InDesign INDD 文件之后,可以使用“对象图层选项”对话框控制其图层可视性。如果 Photoshop PSD 文件包含图层复合,则可以选择要显示的复合。此外,还可以选择在每次更新链接时是保持可视性设置还是匹配原始文件的设置。

  1. 在 InCopy 文档中选择该文件。
  2. 选择“对象”>“对象图层选项”。
  3. 要查看图像预览,选择“预览”。
  4. (仅限 Photoshop PSD 文件)如果图像包含图层复合,请从“图层复合”弹出菜单中选择要显示的图层复合。
  5. 执行以下操作之一:
    • 要打开或关闭图层组,请单击文件夹图标左侧的三角形。

    • 要隐藏图层或图层组,请单击图层或图层组旁边的眼睛图标。

    • 要显示图层或图层组,请单击图层或图层组旁边空的眼睛图标列。

    • 要只显示特定图层或图层组的内容,请按住 Alt 键 (Windows) 或 Option 键 (Mac OS) 并单击其眼睛图标。再次按住 Alt 键或 Option 键并单击眼睛图标,可恢复其他图层的原始可视性设置。

    • 要更改多个项目的可视性,请用鼠标将对应项目拖过眼睛图标列。

  6. 根据需要设置“更新链接选项”:

    使用图层可视性

    更新链接时,使图层可视性设置与所链接文件的可视性设置匹配。

    保持图层可视性优先

    维护文件最初置入时原有的图层可见性设置。

  7. 单击“确定”。

导入 InDesign (.indd) 页面

使用“置入”命令,可以将一个 InDesign 文档中的页面导入另一个 InDesign 文档中。可以导入文档中的一个页面、一定范围的页面或所有页面。页面会作为对象导入(与导入 PDF 文件非常相似)。

向文档中添加页面以便存放要导入的页面。在选择“文件”>“置入”并选择 INDD 文件之后,可以选择“显示导入选项”,然后选择要导入哪些页面、要使哪些图层可见以及如何裁切导入的页面。可以在“预览”窗口中滚动,以仔细查看缩略图页面。选择的页面以图形图标的方式载入。如果置入多个页面,InCopy 将随下一页面载入图形图标,方便您依次导入各个页面。

注意:

“链接”面板中列出了每个导入页面的名称。如果导入的页面中包含以前导入该页面的图形或其他项,则该项也在“链接”面板中列出。这些二级导入项的名称列在“链接”面板中一个明显的三角形下面,以便与导入的页面相区分。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略