Set Library view options

  1. Lightroom Classic User Guide
  2. Introduction to Lightroom Classic
    1. What's new in Lightroom Classic
    2. Lightroom Classic system requirements
    3. Lightroom Classic | Common Questions
    4. Lightroom Classic Key Concepts
    5. Lightroom Classic tutorials
    6. Feature summary | Lightroom CC 2015.x/Lightroom 6.x releases
  3. Lightroom and Adobe services
    1. Creative Cloud Libraries
    2. Using Adobe Stock in Creative Cloud apps
  4. Lightroom for mobile, TV, and the web
    1. Adobe Photoshop Lightroom for mobile and Apple TV | FAQ
    2. Sync Lightroom Classic with Lightroom ecosystem
    3. Photoshop family of mobile apps
  5. Import photos
    1. Import photos from a camera or card reader
    2. Import photos from a folder on a hard drive
    3. Import photos automatically
    4. Import photos from Photoshop Elements
    5. Import photos from a tethered camera
    6. Specify import options
    7. Set import preferences
    8. The Filename Template Editor and Text Template Editor
  6. Workflows
    1. Apply Masking in photos
    2. Export and save your photos as JPEGs
    3. Export and watermark your photos
    4. Import your photos
    5. Adjustment Brush: the basics
    6. Adjustments with the Tone Curve
    7. Advanced video slideshows
    8. Control white balance
    9. Create a contact sheet
    10. Enhance your workflow with Lightroom Classic
  7. Workspace
    1. Workspace basics
    2. Set preferences for working in Lightroom Classic
    3. Display the Library on a second monitor
    4. Personalize identity plates and module buttons
    5. Watermark your photos in Lightroom Classic
    6. Color management
  8. Viewing photos
    1. View photos
    2. Browse and compare photos
    3. Set Library view options
    4. Share photos for comments and feedback
    5. Smart Previews
  9. Manage catalogs and files
    1. Lightroom Classic catalog FAQ
    2. How Lightroom Classic catalogs work
    3. Create and manage catalogs
    4. Back up a catalog
    5. Locate missing photos
    6. Create and manage folders
    7. Manage photos within folders
  10. Maps
    1. Work with the Map module
  11. Organize photos in Lightroom Classic
    1. Face recognition
    2. Work with photo collections
    3. Group photos into stacks
    4. Flag, label, and rate photos
    5. Use keywords
    6. Metadata basics and actions
    7. Find photos in the catalog
    8. Work with video in Lightroom Classic
    9. Advanced metadata actions
    10. Use the Quick Develop panel
  12. Process and develop photos
    1. Develop module basics
    2. Create panoramas and HDR panoramas
    3. Flat-Field Correction
    4. Correct distorted perspective in photos using Upright
    5. Improve image quality using Enhance
    6. Work with image tone and color
    7. Masking
    8. Apply local adjustments
    9. HDR photo merge
    10. Develop module options
    11. Retouch photos
    12. Cure red eye and pet eye effects
    13. Use the Radial Filter tool
    14. Use the enhanced Spot Removal tool
  13. Export photos
    1. Export files to disk or CD
    2. Export photos from Lightroom Classic
    3. Publish photos online
    4. Export to hard drive using publish services
    5. Presets for export, and other settings
  14. Work with external editors
    1. External Editing preferences
    2. Open and edit Lightroom Classic photos in Photoshop or Photoshop Elements
  15. Slideshows
    1. Create slideshows
    2. Slideshow module panels and tools
    3. Specify the slide layout
    4. Add overlays to slides
    5. Play and export slideshows
  16. Print photos
    1. Print module basics
    2. Print module layouts and templates
    3. Work with print job options and settings
  17. Photo books
    1. Create photo books
  18. Web galleries
    1. Create web galleries
    2. Use the Web module panels and tools
    3. Work with web gallery layouts
    4. Work with web gallery templates and settings
    5. Preview, export, and upload web photo galleries
  19. Keyboard shortcuts
    1. Keyboard shortcuts

Set Library view options for the Grid view

The Library View Options determine how photos look in the Grid view. You can specify different combinations of elements, ranging from showing only thumbnails, to thumbnails accompanied with photo information, filters, and Rotation buttons.

  1. In the Library module, choose View > View Options.
  2. In the Grid View tab of the Library View Options dialog box, select Show Grid Extras to view information and icons in the photo thumbnail cells. (Show Grid Extras is selected by default.)

    Deselecting this option shows photo thumbnails with no additional information in the Grid view.

  3. In the Options area of the dialog box, select any of the following items:

    Show Clickable Items On Mouse Over Only

    Shows clickable items, such as Rotation buttons and flags, only when the pointer moves over the cell. Deselecting this option means that clickable items are always displayed.

    Tint Grid Cells With Color Labels

    Displays the label colors in the background of each cell.

    Show Image Info Tooltips

    Displays a description of an item, such as a photo, badge, or pick flag, when you hold the pointer over the item.

  4. In the Cell Icons area of the dialog box, select any of the following items to appear in cells:

    Flags

    Makes Pick or Rejected flags available in the upper-left corner of the thumbnail cell.

    Quick Collection Markers

    Shows the Quick Collection marker in the upper-right corner of the photo thumbnail.

    Thumbnail Badges

    Shows thumbnail badges indicating which photos have keywords, cropping applied, or image adjustments.

    Unsaved Metadata

    When you’ve added metadata or keywords to a photo in Lightroom Classic without saving the metadata to file, the Metadata File Needs To Be Updated icon  appears in the upper-right corner of the cell area. See View unsaved metadata.

  5. In the Compact Cell Extras area, select any of the following to appear in compact cells:

    Index Number

    Shows the order number of the photo in the Grid view.

    Rotation

    Makes Rotation buttons available.

    Top Label

    Shows the top label you choose from the menu.

    Bottom Label

    Shows the bottom label you choose from the menu.

  6. In the Expanded Cell Extras area, select any of the following to appear in expanded cells:

    Show Header With Labels

    Shows the header area of the thumbnail cell. The header area can display up to four labels that you choose from the menus.

    Show Rating Footer

    Shows the footer items you select.

    Use Defaults

    Restores the Grid view options to their factory-set defaults.

  7. From the Show Grid Extras menu, choose one of the following to set the size of the thumbnail cells in the Grid view:

    Expanded Cells

    Displays the most photo information available in the Grid view, including a header with up to four metadata labels.

    Compact Cells

    Displays smaller cells with less photo information so that more thumbnails are visible in the Grid view.

Change the Grid view options

You can quickly change the Grid view options by choosing from the Grid View Style menu. The views are based on the default or custom view options set in the Library View Options.

  1. In the Grid view, choose View > Grid View Style and choose any of the following:

    Show Extras

    Shows or hides cell extras set in the Library View Options.

    Show Badges

    Shows or hides keyword tags, cropping, and image adjustment badges.

    Compact Cells

    Shows compact cells in the Grid view.

    Expanded Cells

    Shows expanded cells in the Grid view.

    Cycle View Style

    Cycles through the different views available in the Grid View Style menu.

Set Library view options for Loupe view

The Library View Options determine what information displays with your photos in the Loupe view. You can specify two different sets of information.

  1. In the Library module, choose View > View Options.
  2. In the Loupe View tab of the Library View Options dialog box, select Show Info Overlay to display information with your photos. (Show Info Overlay is selected by default.)

    Deselecting this option displays photos with no information overlay in the Loupe view.

  3. In the Loupe Info 1 and Loupe Info 2 areas of the dialog box, use the menus to choose what displays in the two Info Overlays in the Loupe view. You can select up to three items in each overlay, including the filename, metadata, or no data.
  4. Select Show Briefly When Photo Changes to briefly display the Info Overlays only when photos change in the Loupe view.
  5. Under General area of the dialog box, select Show Messages When Loading Or Rendering Photos to display overlays in the Loupe view during a process.
  6. From the Show Info Overlay menu, choose Info 1 or Info 2 to select the currently active Info Overlays in Loupe view.

Change the Loupe view info overlay

  1. In the Library module, choose View > Loupe Info and then choose any of the following:

    Show Info Overlay

    Displays the Info Overlay specified in the Library View Options.

    Info 1

    Displays the Info 1 Overlay.

    Info 2

    Displays the Info 2 Overlay.

    Cycle Info Display

    Cycles through the two Info Overlay sets.

Scroll By Row

You can choose to scroll the grid by row instead of pixels. To select this option, do the following:

  1. In the Library module, choose View > Scroll By Row.

Adobe logo

Sign in to your account