User Guide Cancel

Make selections in your composites

  1. Photoshop User Guide
  2. Introduction to Photoshop
    1. Dream it. Make it.
    2. What's new in Photoshop
    3. Edit your first photo
    4. Create documents
    5. Photoshop | Common Questions
    6. Photoshop system requirements
    7. Migrate presets, actions, and settings
    8. Get to know Photoshop
  3. Photoshop and other Adobe products and services
    1. Work with Illustrator artwork in Photoshop
    2. Work with Photoshop files in InDesign
    3. Substance 3D Materials for Photoshop
    4. Photoshop and Adobe Stock
    5. Use the Capture in-app extension in Photoshop
    6. Creative Cloud Libraries
    7. Creative Cloud Libraries in Photoshop
    8. Use the Touch Bar with Photoshop
    9. Grid and guides
    10. Creating actions
    11. Undo and history
  4. Photoshop on the iPad
    1. Photoshop on the iPad | Common questions
    2. Get to know the workspace
    3. System requirements | Photoshop on the iPad
    4. Create, open, and export documents
    5. Add photos
    6. Work with layers
    7. Draw and paint with brushes
    8. Make selections and add masks
    9. Retouch your composites
    10. Work with adjustment layers
    11. Adjust the tonality of your composite with Curves
    12. Apply transform operations
    13. Crop and rotate your composites
    14. Rotate, pan, zoom, and reset the canvas
    15. Work with Type layers
    16. Work with Photoshop and Lightroom
    17. Get missing fonts in Photoshop on the iPad
    18. Japanese Text in Photoshop on the iPad
    19. Manage app settings
    20. Touch shortcuts and gestures
    21. Keyboard shortcuts
    22. Edit your image size
    23. Livestream as you create in Photoshop on the iPad
    24. Correct imperfections with the Healing Brush
    25. Create brushes in Capture and use them in Photoshop
    26. Work with Camera Raw files
    27. Create and work with Smart Objects
    28. Adjust exposure in your images with Dodge and Burn
  5. Photoshop on the web beta
    1. Common questions | Photoshop on the web beta 
    2. Introduction to the workspace
    3. System requirements | Photoshop on the web beta
    4. Keyboard shortcuts | Photoshop on the web beta
    5. Supported file types | Photoshop on the web beta
    6. Open and work with cloud documents
    7. Collaborate with stakeholders
    8. Apply limited edits to your cloud documents
  6. Cloud documents
    1. Photoshop cloud documents | Common questions
    2. Photoshop cloud documents | Workflow questions
    3. Manage and work with cloud documents in Photoshop
    4. Upgrade cloud storage for Photoshop
    5. Unable to create or save a cloud document
    6. Solve Photoshop cloud document errors
    7. Collect cloud document sync logs
    8. Share access and edit your cloud documents
    9. Share files and comment in-app
  7. Workspace
    1. Workspace basics
    2. Learn faster with the Photoshop Discover Panel
    3. Create documents
    4. Use the Touch Bar with Photoshop
    5. Tool galleries
    6. Performance preferences
    7. Use tools
    8. Touch gestures
    9. Touch capabilities and customizable workspaces
    10. Technology previews
    11. Metadata and notes
    12. Default keyboard shortcuts
    13. Touch capabilities and customizable workspaces
    14. Place Photoshop images in other applications
    15. Preferences
    16. Default keyboard shortcuts
    17. Rulers
    18. Show or hide non-printing Extras
    19. Specify columns for an image
    20. Undo and history
    21. Panels and menus
    22. Place files
    23. Position elements with snapping
    24. Position with the Ruler tool
    25. Presets
    26. Customize keyboard shortcuts
    27. Grid and guides
  8. Web, screen, and app design
    1. Photoshop for design
    2. Artboards
    3. Device Preview
    4. Copy CSS from layers
    5. Slice web pages
    6. HTML options for slices
    7. Modify slice layout
    8. Work with web graphics
    9. Create web photo galleries
  9. Image and color basics
    1. How to resize images
    2. Work with raster and vector images
    3. Image size and resolution
    4. Acquire images from cameras and scanners
    5. Create, open, and import images
    6. View images
    7. Invalid JPEG Marker error | Opening images
    8. Viewing multiple images
    9. Customize color pickers and swatches
    10. High dynamic range images
    11. Match colors in your image
    12. Convert between color modes
    13. Color modes
    14. Erase parts of an image
    15. Blending modes
    16. Choose colors
    17. Customize indexed color tables
    18. Image information
    19. Distort filters are unavailable
    20. About color
    21. Color and monochrome adjustments using channels
    22. Choose colors in the Color and Swatches panels
    23. Sample
    24. Color mode or Image mode
    25. Color cast
    26. Add a conditional mode change to an action
    27. Add swatches from HTML CSS and SVG
    28. Bit depth and preferences
  10. Layers
    1. Layer basics
    2. Nondestructive editing
    3. Create and manage layers and groups
    4. Select, group, and link layers
    5. Place images into frames
    6. Layer opacity and blending
    7. Mask layers
    8. Apply Smart Filters
    9. Layer comps
    10. Move, stack, and lock layers
    11. Mask layers with vector masks
    12. Manage layers and groups
    13. Layer effects and styles
    14. Edit layer masks
    15. Extract assets
    16. Reveal layers with clipping masks
    17. Generate image assets from layers
    18. Work with Smart Objects
    19. Blending modes
    20. Combine multiple images into a group portrait
    21. Combine images with Auto-Blend Layers
    22. Align and distribute layers
    23. Copy CSS from layers
    24. Load selections from a layer or layer mask's boundaries
    25. Knockout to reveal content from other layers
    26. Layer
    27. Flattening
    28. Composite
    29. Background
  11. Selections
    1. Select and Mask workspace
    2. Make quick selections
    3. Get started with selections
    4. Select with the marquee tools
    5. Select with the lasso tools
    6. Select a color range in an image
    7. Adjust pixel selections
    8. Convert between paths and selection borders
    9. Channel basics
    10. Move, copy, and delete selected pixels
    11. Create a temporary quick mask
    12. Save selections and alpha channel masks
    13. Select the image areas in focus
    14. Duplicate, split, and merge channels
    15. Channel calculations
    16. Selection
    17. Bounding box
  12. Image adjustments
    1. Perspective warp
    2. Reduce camera shake blurring
    3. Healing brush examples
    4. Export color lookup tables
    5. Adjust image sharpness and blur
    6. Understand color adjustments
    7. Apply a Brightness/Contrast adjustment
    8. Adjust shadow and highlight detail
    9. Levels adjustment
    10. Adjust hue and saturation
    11. Adjust vibrance
    12. Adjust color saturation in image areas
    13. Make quick tonal adjustments
    14. Apply special color effects to images
    15. Enhance your image with color balance adjustments
    16. High dynamic range images
    17. View histograms and pixel values
    18. Match colors in your image
    19. How to crop and straighten photos
    20. Convert a color image to black and white
    21. Adjustment and fill layers
    22. Curves adjustment
    23. Blending modes
    24. Target images for press
    25. Adjust color and tone with Levels and Curves eyedroppers
    26. Adjust HDR exposure and toning
    27. Filter
    28. Blur
    29. Dodge or burn image areas
    30. Make selective color adjustments
    31. Replace object colors
  13. Adobe Camera Raw
    1. Camera Raw system requirements
    2. What's new in Camera Raw
    3. Introduction to Camera Raw
    4. Create panoramas
    5. Supported lenses
    6. Vignette, grain, and dehaze effects in Camera Raw
    7. Default keyboard shortcuts
    8. Automatic perspective correction in Camera Raw
    9. How to make non-destructive edits in Camera Raw
    10. Radial Filter in Camera Raw
    11. Manage Camera Raw settings
    12. Open, process, and save images in Camera Raw
    13. Repair images with the Enhanced Spot Removal tool in Camera Raw
    14. Rotate, crop, and adjust images
    15. Adjust color rendering in Camera Raw
    16. Feature summary | Adobe Camera Raw | 2018 releases
    17. New features summary
    18. Process versions in Camera Raw
    19. Make local adjustments in Camera Raw
  14. Image repair and restoration
    1. Remove objects from your photos with Content-Aware Fill
    2. Content-Aware Patch and Move
    3. Retouch and repair photos
    4. Correct image distortion and noise
    5. Basic troubleshooting steps to fix most issues
  15. Image transformations
    1. Transform objects
    2. Adjust crop, rotation, and canvas size
    3. How to crop and straighten photos
    4. Create and edit panoramic images
    5. Warp images, shapes, and paths
    6. Vanishing Point
    7. Use the Liquify filter
    8. Content-aware scaling
    9. Transform images, shapes, and paths
    10. Warp
    11. Transform
    12. Panorama
  16. Drawing and painting
    1. Paint symmetrical patterns
    2. Draw rectangles and modify stroke options
    3. About drawing
    4. Draw and edit shapes
    5. Painting tools
    6. Create and modify brushes
    7. Blending modes
    8. Add color to paths
    9. Edit paths
    10. Paint with the Mixer Brush
    11. Brush presets
    12. Gradients
    13. Gradient interpolation
    14. Fill and stroke selections, layers, and paths
    15. Draw with the Pen tools
    16. Create patterns
    17. Generate a pattern using the Pattern Maker
    18. Manage paths
    19. Manage pattern libraries and presets
    20. Draw or paint with a graphics tablet
    21. Create textured brushes
    22. Add dynamic elements to brushes
    23. Gradient
    24. Paint stylized strokes with the Art History Brush
    25. Paint with a pattern
    26. Sync presets on multiple devices
  17. Text
    1. Add and edit the text
    2. Unified Text Engine
    3. Work with OpenType SVG fonts
    4. Format characters
    5. Format paragraphs
    6. How to create type effects
    7. Edit text
    8. Line and character spacing
    9. Arabic and Hebrew type
    10. Fonts
    11. Troubleshoot fonts
    12. Asian type
    13. Create type
    14. Text Engine error using Type tool in Photoshop | Windows 8
  18. Video and animation
    1. Video editing in Photoshop
    2. Edit video and animation layers
    3. Video and animation overview
    4. Preview video and animations
    5. Paint frames in video layers
    6. Import video files and image sequences
    7. Create frame animations
    8. Creative Cloud 3D Animation (Preview)
    9. Create timeline animations
    10. Create images for video
  19. Filters and effects
    1. Use the Liquify filter
    2. Use the Blur Gallery
    3. Filter basics
    4. Filter effects reference
    5. Add Lighting Effects
    6. Use the Adaptive Wide Angle filter
    7. Use the Oil Paint filter
    8. Layer effects and styles
    9. Apply specific filters
    10. Smudge image areas
  20. Saving and exporting
    1. Save your files in Photoshop
    2. Export your files in Photoshop
    3. Supported file formats
    4. Save files in graphics formats
    5. Move designs between Photoshop and Illustrator
    6. Save and export video and animations
    7. Save PDF files
    8. Digimarc copyright protection
  21. Printing
    1. Print 3D objects
    2. Print from Photoshop
    3. Print with color management
    4. Contact Sheets and PDF Presentations
    5. Print photos in a picture package layout
    6. Print spot colors
    7. Duotones
    8. Print images to a commercial printing press
    9. Improve color prints from Photoshop
    10. Troubleshoot printing problems | Photoshop
  22. Automation
    1. Creating actions
    2. Create data-driven graphics
    3. Scripting
    4. Process a batch of files
    5. Play and manage actions
    6. Add conditional actions
    7. About actions and the Actions panel
    8. Record tools in actions
    9. Add a conditional mode change to an action
    10. Photoshop UI toolkit for plug-ins and scripts
  23. Color Management
    1. Understanding color management
    2. Keeping colors consistent
    3. Color settings
    4. Work with color profiles
    5. Color-managing documents for online viewing
    6. Color-managing documents when printing
    7. Color-managing imported images
    8. Proofing colors
  24. Content authenticity
    1. Learn about content credentials
    2. Identity and provenance for NFTs
    3. Connect accounts for creative attribution
  25. 3D and technical imaging
    1. Photoshop 3D | Common questions around discontinued 3D features
    2. Creative Cloud 3D Animation (Preview)
    3. Print 3D objects
    4. 3D painting
    5. 3D panel enhancements | Photoshop
    6. Essential 3D concepts and tools
    7. 3D rendering and saving
    8. Create 3D objects and animations
    9. Image stacks
    10. 3D workflow
    11. Measurement
    12. DICOM files
    13. Photoshop and MATLAB
    14. Count objects in an image
    15. Combine and convert 3D objects
    16. 3D texture editing
    17. Adjust HDR exposure and toning
    18. 3D panel settings

Use the Object Selection tool, Select Subject, Quick Selection, or Magic Wand tools to make selections in Photoshop.

  Get the latest features and improvements for Photoshop   Learn More

Topics in this article:

With selections, define an area that you can further edit to enhance your images and composites. You can easily use any of the various selection tools in Photoshop to quickly make a selection.

Auto-select an object an hover

Object Selection tool

Updated in Photoshop 24.0 (October 2022 release)

The Object Selection tool simplifies the process of selecting an object or region in your image — people, cars, pets, sky, water, buildings, mountains, and moreYou can simply draw a rectangle or lasso around an object or region or let the Object Selection tool automatically detect and select an object or region within the image. Selections made with the Object Selection tool are now more precise and preserve details on the edges of the selection, which means you spend less time getting those perfect selections.

You can access the Object Selection tool at the following locations:

Object selection tool and Select and Mask workspace

To select objects or regions in an image using the Object Selection tool, follow these steps:

  1. Access the Object Selection tool

    Select the Object Selection tool from the toolbar.

    Note:

    Not seeing the Object Selection tool in your toolbar? See Tools missing from the toolbar.

  2. Make a selection with the Object Selection tool

    In the Object Selections Options bar, ensure the Object Finder is enabled. Once enabled, you'll see a spinning refresh icon beside the Object Finder option. Hover over and select the desired object or region in your image. By default, the Object Finder is turned on. 

    If you don't want to use the automatic selection, turn off the Object Finder in the Options bar, choose a selection Mode: Rectangle or Lasso, and drag along to make your selection.

    Object Selection tool options bar

    • Rectangle: Drag the pointer to define a rectangular region around the object or region.
    • Lasso: Draw a rough lasso outside the object's boundary or region.
  3. Subtract from or add to the selection

    In the options bar, click one of the selection options: New, Add To, Subtract From, or Intersect With the selection. New is the default option if nothing is selected. After making the initial selection, the option changes automatically to Add To

    Add to the selection: Hold the Shift key or select Add To Selection in the options bar, then hover over/draw a new rectangle or a lasso around the missing region. Repeat this process for all the missing regions you want to add to the selection.

    Subtract from the selection: There are two options to subtract from the selection: 

    • Use the Subtract From Selection option in the Options bar: Hold the Option (Mac)/ Alt (Win) key or select Subtract From Selection in the options bar, then hover over/draw a rectangle or a lasso around the boundary of the region you want to subtract from the selection. 
    • Enable Object Subtract from the additional options (gear icon in the options bar)Object Subtract is especially useful when removing the background regions inside the current object selection. You can think of the Object Subtract option as equivalent to Object Selection inverted. 
  4. Object selection options

    Sample All Layers: Creates a selection based on all layers instead of just the currently selected layer.

    Hard Edge: Enables hard edges on the selection boundary.

  5. Further refine the selection edge in the Select And Mask workspace

    Feedback dialog for object selection

    To further adjust the selection boundary or view the selection against different backgrounds or as a mask, click Select And Mask in the options bar.

    Also, make use of the Selection Feedback dialog to share details about the selection achieved using the Object Selection tool and help us improve.

Selection improvements

Introduced in Photoshop 24.0 (October 2022 release)

Select elements like the sky, water, natural ground, plants, or architecture in one click using the powerful Object Selection Tool

Refine your selection in the Select and Mask workspace or use the improved auto-detection feature to perform other specific adjustments. 

Use Object Selection Tool in the existing object detection/selection tool in the left panel and then the Select and Mask workspace to make better and faster selections.

Selection improvements in Photoshop

Follow these steps if you want to select, say, the sky with a single click: 

  1. Select the Object Selection tool in the Tools panel.

  2. Select the Object Finder checkbox. Change the overlay color to a color different from the sky color. Make your color selection from the Overlay Options

  3. Hover over the sky in your image to see the overlay. This is possible when the Object Selection tool and Object Finder are enabled. You can now make additional refinements to your sky selection.  

  4. Create Color Fill adjustment layers using the Object Selection Tool sky selection.

One-click Delete and Fill

Introduced in Photoshop 24.0 (October 2022 release)

Use the one-click Delete and Fill Selection feature to remove unwanted objects from your images or to retouch images with complex backgrounds.

Simply use the Object Selection Tool to make your selection and use the following keyboard shortcut to remove it:

  • macOS: Shift + Delete
  • Windows: Shift + Backspace

But if you're working with the Lasso Tool or any other Photoshop tool, right-click the mouse to access the contextual menu and select Delete and Fill Selection to delete unwanted objects from your image. 

Make improved hair selections

With Photoshop 23.4 (June 2022) release, the Object Selection tool has been enhanced for making better hair selections in human portrait images. Object Selection tool can now recognize portraits and apply hair refinement to get a mask as good as that delivered by Select Subject.

Simply open your portrait image and select the Object Selection tool from the toolbar and make your selection by either clicking on the portrait or by creating a lasso or marquee around the person and obtain the mask with all the hair details captured. 

Preserve hair details with the Object Selection tool enhancement

After your selection is done using the Object Selection tool, you can further improve the mask results with the Refine Hair option in the Select And Mask workspace in the options bar for images other than human portraits like pets/animals/fur more naturally.

Mask all objects in a layer in a single click

Use this huge timesaver that leverages the power of Adobe Sensei to generate masks for all objects in the desired layer in a single click.

Choose Layer > Mask All Objects and watch Photoshop easily generate masks for all the objects detected within your layer with just a single click.

Mask all objects in a layer
Choose "Mask All Objects"

masked object layer created
Layer mask created for all objects detected in your layer in a single click.

Select Subject

Optimized for better portrait selections in Photoshop 21.2 (June 2020 release)

Beginning with Photoshop 21.2 (June 2020 release), Select Subject is now content-aware and applies new custom algorithms when it detects a person is in the image. When creating a selection of portrait images, treatment around the hair area has been vastly improved to create a detailed selection of hair. To temporarily turn off the content awareness, you can press and hold the Shift key while performing Select Subject.  

Select Subject in Photoshop

The Select Subject command lets you select the most prominent subject in an image in a single click. Powered by advanced machine learning technology, Select Subject is trained to identify a variety of objects in an image—people, animals, vehicles, toys, and more. 

  1. Select subjects automatically

    Select Subject automatically selects the prominent subjects in your image. To access Select Subject, do one of the following:

    • While editing an image, choose Select > Subject.
    • While using the Object Selection, Quick Selection, or Magic Wand tools, click Select Subject in the options bar.
    • While using the Object  Selection or Quick Selection tools in the Select & Mask workspace, click Select Subject in the options bar.
  2. Add to or subtract from the selection

    Use any of the Selection tools with their Add to selection and Subtract from selection options to clean up the initial selection, if necessary. See Adjust selections manually.

  3. Fine-tune the selection in the Select and Mask workspace

    Choose Select > Select and Mask to open the image in the Select and Mask workspace. Use the tools and sliders in the workspace to clean up the selection further. 

    See Select and Mask workspace.

Select subject cloud service

Make improved selections and get high-quality images with cloud processing in Select Subject.

Simply navigate to the Image Processing section in the Preferences dialog box and toggle between the Cloud mode or Device mode to get your desired results. 

Navigate to the Select Subject cloud service in Photoshop
Navigate to the Select Subject cloud service

Choose from Device or Cloud for Select Subject Processing in Photoshop
Choose from Device or Cloud for Select Subject Processing

Choose from Device or Cloud from the Select & Mask workspace in Photoshop

You can also make your selection from within the Select & Mask workspace. 

How is the Object Selection tool different from the Select Subject command?

The Object Selection tool is useful when you only need to select one of the objects or part of an object within an image that contains multiple objects. While the Select Subject command is designed to select all the main subjects in the image.

To learn more about the Select Subject command, read the next topic described in this article below.

Quick Selection tool

You can use the Quick Selection tool  to quickly "paint" a selection using an adjustable round brush tip. As you drag, the selection expands outward and automatically finds and follows defined edges in the image.

  1. Select the Quick Selection tool  . (If the tool isn't visible, hold down the Magic Wand tool  .)
  2. In the options bar, click one of the selection options: New, Add To, or Subtract From.

    New is the default option if nothing is selected. After making the initial selection, the option changes automatically to Add To.

  3. To change the brush tip size, click the Brush pop-up menu in the options bar, and type in a pixel size or drag the slider. Use the Size pop‑up menu options to make the brush tip size sensitive to pen pressure or a stylus wheel.
    Note:

    When creating a selection, press the right bracket (]) to increase the Quick Selection tool brush tip size; press the left bracket ([) to decrease the brush tip size.

  4. Choose Quick Selection options:

    Sample All Layers: Creates a selection based on all layers instead of just the currently selected layer.

    Enhance Edge: Reduces roughness and blockiness in the selection boundary. Enhance Edge automatically flows the selection further toward image edges and applies some of the edge refinement you can apply manually in the Select and Mask workspace.

  5. Paint inside the part of the image you want to select. The selection grows as you paint. If updating is slow, continue to drag to allow time to complete work on the selection. As you paint near the edges of a shape, the selection area extends to follow the contours of the shape edge.

    Photoshop Paint with the Quick Selection tool
    Painting with the Quick Selection tool to extend the selection

    • To subtract from a selection, click the Subtract From option in the options bar, then drag over the existing selection.
    • To temporarily switch between add and subtract modes, hold down the Alt (Win) or Option (Mac) key.
    • To change the tool cursor, choose Edit > Preferences > Cursors > Painting Cursors (Win) or Photoshop > Preferences > Cursors > Painting Cursors (Mac). Normal Brush Tip displays the standard Quick Selection cursor with a plus or minus sign to show the selection mode.
    Note:

    If you stop dragging and then click or drag in a nearby area, the selection will grow to include the new area.

  6. Click Select and Mask to further adjust the selection boundary. 

Magic Wand tool

The Magic Wand tool lets you select a consistently colored area (for example, a red flower) without having to trace its outline. You specify the selected color range, or tolerance, relative to the original color you click.

Note:

You cannot use the Magic Wand tool on an image in Bitmap mode or on 32‑bits-per-channel images.

  1. Select the Magic Wand tool  . (If the tool isn't visible, access it by holding down the Quick Selection tool  .)
  2. Specify one of the selection options in the options bar. The Magic Wand tool's pointer changes depending on which option is selected.
    Photoshop Selection options
    Selection options

    A. New B. Add To C. Subtract From D. Intersect With 

  3. In the options bar, specify any of the following:

    Tolerance: Determines the color range of selected pixels. Enter a value in pixels, ranging from 0 to 255. A low value selects the few colors very similar to the pixel you click. A higher value selects a broader range of colors.

    Anti-aliased: Creates a smoother-edged selection.

    Contiguous: Selects only adjacent areas using the same colors. Otherwise, all pixels in the entire image using the same colors are selected.

    Sample All Layers: Selects colors using data from all the visible layers. Otherwise, the Magic Wand tool selects colors from the active layer only.

  4. In the image, click the color you want to select. If Contiguous is selected, all adjacent pixels within the tolerance range are selected. Otherwise, all pixels in the tolerance range are selected.
  5. Click Select and Mask to further adjust the selection boundary or view the selection against different backgrounds or as a mask. 

Adobe logo

Sign in to your account