Problém

V aplikaci sady Microsoft Office 2003, XP nebo 2000 (například v aplikaci Access, Excel nebo Word) není k dispozici ikona doplňku PDFMaker (Převést do Adobe PDF) a nabídka aplikace Acrobat.

Řešení

Vyzkoušejte jedno nebo více z následujících řešení:

Řešení 1: Odeberte položku Adobe PDF ze seznamu Zakázané položky v aplikaci Microsoft Office.

  1. Otevřete aplikaci Microsoft Office (Word, Excel, Publisher nebo Access).
  2. Zvolte možnost Nápověda > O aplikaci [název aplikace].
  3. Klikněte na možnost Zakázané položky.
  4. Vyberte v seznamu položku Adobe PDF a klikněte na tlačítko Povolit.
  5. Ukončete aplikaci Microsoft Office a poté ji znovu spusťte.

Poznámka: Aplikace Microsoft Office z bezpečnostních důvodů zakážou doplňky, pokud je aplikace předčasně ukončena (například pokud nebyl systém správně vypnut nebo došlo k chybě aplikace).

Řešení 2: Zkontrolujte, zda jsou nainstalovány komponenty doplňku PDFMaker.

  1. V nabídce Start klikněte na příkaz Spustit, do pole Otevřít zadejte výraz appwiz.cpl a kliknutím na tlačítko OK otevřete dialogové okno Přidat nebo odebrat programy.
  2. Vyhledejte aplikaci Adobe Acrobat 7 nebo Adobe Acrobat 8, vyberte ji a klikněte na tlačítko Změnit nebo odebrat.
  3. Jakmile se zobrazí průvodce, klikněte na tlačítko Další.
  4. Vyberte možnost Změnit a znovu klikněte na tlačítko Další.
  5. Rozbalte stromové zobrazení položky Vytvořit Adobe PDF a poté klikněte na šipku dolů u objektu Acrobat PDFMaker.
  6. Vyberte možnost „Tato funkce bude nainstalována na místní pevný disk.“, klikněte na tlačítko Další a poté na tlačítko Aktualizovat.

Řešení 3: Povolte v aplikaci Office soubor doplňku modelu COM.

  1. Spusťte aplikaci Office.
  2. Zvolte možnost Nápověda > O aplikaci [aplikace].
  3. Klikněte na možnost Zakázané položky.
  4. Vyhledejte v seznamu položku PDFMakerOfficeAddin:
    • Pokud je v seznamu uvedena, vyberte ji a klikněte na tlačítko Povolit. Zavřete všechna dialogová okna a spusťte aplikaci Office znovu.
    • Pokud není v seznamu uvedena, zkontrolujte, zda je ve složce Acrobat 7.0/PDFMaker/Office (Acrobat 7, Acrobat 3D) nebo Acrobat 8.0/PDFMaker/Office (Acrobat 8) uložen soubor PDFMOfficeAddin.dll. Pokud soubor chybí, přeinstalujte aplikaci Acrobat.

Řešení 4: Přejmenujte soubor Normal.dot.

Pokud nechcete, aby měla nastavení formátování a automatického textu a makra uložená v globální šabloně (Normal.dot) vliv na chování aplikace Microsoft Word a dalších aplikací, přejmenujte globální šablonu (Normal.dot). Díky tomu můžete jednoduše zjistit, zda je příčinou potíží globální šablona.

Důležité upozornění: Při přejmenování šablony Normal.dot obnovíte výchozí nastavení několika možností, včetně vlastních stylů, vlastních panelů nástrojů, maker a automatického textu. Společnost Microsoft proto odstranění souboru Normal.dot nedoporučuje.

U některých konfigurací může být vytvořeno více souborů Normal.dot. Tato situace může nastat například v případě, že je v počítači spuštěno více verzí aplikace Word nebo pokud se v jednom počítači nachází více instalací pracovní stanice.

Přejmenování souboru Normal.dot:

Poznámka: Následující postup platí pro aplikaci Microsoft Word, ale s menšími obměnami jej lze použít i u dalších aplikací Microsoft Office. Po dokončení tohoto postupu neprovádějte restart aplikace Word nebo jiné aplikace pomocí přepínače /a.

V systému Windows 2000:

  1. Ukončete všechny instance aplikace Word i aplikaci Outlook, pokud aplikaci Word používáte k úpravám zpráv.
  2. Zvolte možnost Start > Hledat > Soubory nebo složky.
  3. Do pole Vyhledat soubory a složky s názvem zadejte název Normal.dot.
  4. V poli Oblast hledání vyberte místní pevný disk.
  5. Kliknutím na tlačítko Hledat vyhledejte soubor.
  6. U každého souboru Normal.dot, který je uveden v dialogovém okně Výsledky hledání, postupujte následovně:
    • Pravým tlačítkem klikněte na soubor a vyberte příkaz Přejmenovat.
    • Zadejte nový název souboru (například OldNormal.dot nebo Normal-1.dot) a poté stiskněte klávesu Enter.
  7. Ukončete hledání kliknutím na příkaz Zavřít v nabídce Soubor a poté znovu spusťte aplikaci Word.

V systému Windows XP:

  1. Ukončete všechny instance aplikace Word i aplikaci Outlook, pokud aplikaci Word používáte k úpravám zpráv.
  2. V nabídce Start klikněte na příkaz Hledat.
  3. V části Co hledáte? vyberte možnost Všechny soubory a složky.
  4. Do pole Část nebo celý název souboru zadejte název Normal.dot.
  5. V rozbalovací nabídce Cíl vyhledávání vyberte místní pevný disk (případně jiné umístění uživatelské šablony, pokud aplikaci Word spouštíte ze síťového serveru).
  6. Klikněte na tlačítko Hledat.
  7. U každého souboru Normal.dot, který je uveden v dialogovém okně Výsledky hledání, postupujte následovně:
    • Pravým tlačítkem klikněte na soubor a vyberte příkaz Přejmenovat.
    • Zadejte nový název souboru (například OldNormal.dot nebo Normal-1.dot) a poté stiskněte klávesu Enter.
  8. V nabídce Soubor klikněte na příkaz Zavřít a poté znovu spusťte aplikaci Word.

Pokud se problém vyřeší po přejmenování globální šablony, byl způsoben poškozenou šablonou Normal.dot.

Řešení 5: Změňte úroveň zabezpečení maker v aplikaci Office.

K načtení souboru doplňku modelu COM v systému Windows je nutné, aby byla na kartě Důvěryhodní vydavatelé uvedena společnost Adobe Inc., případně je potřeba upravit nastavení zabezpečení.

V aplikaci Office 2000, XP nebo 2003:

  1. V nabídce Nástroje zvolte možnost Makro > Zabezpečení.
  2. Klikněte na kartu Důvěryhodní vydavatelé:
    1. Pokud je společnost Adobe Inc. uvedena v seznamu, nejsou nutné žádné změny.

    2. Pokud není společnost Adobe Inc. uvedena v seznamu, pokračujte krokem 3.

  3. Zvolte jedno z následujících nastavení:
    • Na kartě Zabezpečení nastavte velmi vysokou úroveň zabezpečení a na kartě Důvěryhodní vydavatelé zaškrtněte políčko Důvěřovat všem nainstalovaným doplňkům a šablonám.
    • Na kartě Zabezpečení nastavte vysokou úroveň zabezpečení a na kartě Důvěryhodní vydavatelé zrušte zaškrtnutí políčka Důvěřovat všem nainstalovaným doplňkům a šablonám.
  4. Zavřete všechna dialogová okna a spusťte aplikaci znovu.

Řešení 6: Přidejte soubor doplňku modelu COM do registru systému Windows.

  1. V Průzkumníku Windows najděte soubor doplňku modelu COM (PDFMOfficeAddin.dll) a poznamenejte si přesnou cestu k němu (včetně případných mezer).
  2. V nabídce Start klikněte na příkaz Spustit.
  3. Zadejte výraz regsvr32, za ním mezeru a potom v uvozovkách cestu, kterou jste si poznamenali v kroku 1. Například:

    regsvr32 "C:\Program Files\Adobe\Acrobat 8.0\PDFMaker\Office"
  4. Klikněte na tlačítko OK a poté spusťte aplikaci Office.

Řešení 7: Ukončete všechny aplikace a spusťte opravu instalace aplikace Acrobat.

  1. Ukončete všechny aplikace a restartujte systém Windows.
  2. Spusťte aplikaci Acrobat.
  3. Zvolte možnost Nápověda > Detekovat a opravit a postupujte podle pokynů na obrazovce.
  4. Po dokončení opravy restartujte počítač.

Řešení 8: Odeberte aplikaci Acrobat a znovu ji nainstalujte ve zjednodušeném režimu.

Ovladače zařízení a software, které se automaticky načítá se systémem Windows (například spořiče obrazovky a antivirová ochrana), mohou způsobit konflikt s instalačním programem aplikace Acrobat, což může být příčinou problémů. Tomuto konfliktu můžete zabránit, pokud aplikaci Acrobat nainstalujete znovu ve zjednodušeném režimu systému Windows. Ve zjednodušeném režimu jsou zakázány nestandardní ovladače zařízení a software po spuštění.

Odebrání aplikace Acrobat:

  1. Všechny osobní soubory přesuňte ze složky aplikace Acrobat a jejích podsložek do jiného umístění.
  2. V nabídce Start zvolte možnost Nastavení > Ovládací panely a dvakrát klikněte na ikonu Přidat nebo odebrat programy.
  3. Vyberte aplikaci Adobe [produkt Acrobat] a klikněte na tlačítko Odebrat. Při odebrání aplikace postupujte podle pokynů na obrazovce.
  4. Restartujte počítač.

Opětovná instalace aplikace Acrobat ve zjednodušeném režimu:

  1. Ukončete všechny otevřené aplikace.
  2. V Průzkumníku Windows přesuňte všechny ikony a zástupce z následujícího umístění do jiné složky:
    • Documents and Settings/All Users/Start Menu/Programs/Startup
    • Documents and Settings/ [uživatelský profil] /Start Menu/Programs/Startup
  3. Restartujte systém Windows.
  4. Klikněte pravým tlačítkem na hlavní panel a zvolte možnost Správce úloh.
  5. Klikněte na kartu Aplikace.
  6. Vyberte všechny spuštěné aplikace a klikněte na tlačítko Ukončit úlohu.
  7. Dvakrát klikněte na soubor Setup.exe uložený na instalačním médiu a dokončete instalaci podle zobrazených pokynů.
  8. Chcete-li po instalaci znovu povolit položky po spuštění, přesuňte ikony a zástupce, s nimiž jste manipulovali v kroku 2, zpět do příslušných složek Startup.

Řešení 9: Odeberte z aplikace Word makra.

  1. Zvolte možnost Nástroje > Šablony a doplňky.
  2. Vyberte všechny položky a klikněte na tlačítko Odebrat.
  3. Ukončete aplikaci Word a znovu ji spusťte.



    Poznámka:
    Pokud ikona Převést do PDF stále není k dispozici, zvolte možnost Nástroje > Šablony a doplňky a přesvědčte se, že odebrané položky zůstaly odebrány. V opačném případě odeberte z aplikace Word příslušné makro nebo odeberte aplikaci, která makro do aplikace Word nainstalovala.

Řešení 10: Odeberte z aplikace Word ostatní soubory doplňků modelu COM.

  1. Spusťte aplikaci Word.
  2. Zvolte možnost Nástroje > Vlastní.
  3. Klikněte na kartu Příkazy a v seznamu Kategorie vyberte položku Nástroje.
  4. Vyberte položku Doplňky modelu COM a přetáhněte ji na panel nástrojů v aplikaci Word.
  5. Na panelu nástrojů aplikace Word klikněte na nabídku Doplňky modelu COM.
  6. Vyberte a odeberte všechny doplňky s výjimkou doplňků Web Page Wizard a Microsoft Word Fonts Tool.
  7. Ukončete aplikaci Word a znovu ji spusťte.

Řešení 11: Opravte instalaci aplikace Access. (Pouze aplikace Access)

Pokud jste aplikaci Access 2000 nainstalovali po instalaci sady Office XP nebo Office 2003, je nejdříve nutné opravit instalaci sady Office. Teprve poté se zobrazí nabídka doplňku PDFMaker.

  1. V nabídce Start zvolte možnost Nastavení > Ovládací panely > Přidat nebo odebrat programy (Windows 2000) nebo Ovládací panely > Přidat nebo odebrat programy (Windows XP).
  2. Vyberte sadu Microsoft Office a klikněte na tlačítko Změnit.
  3. V dialogovém okně Instalace zvolte možnost Přeinstalovat (Office 2003) nebo Opravit (Office XP) a poté klikněte na tlačítko Další.
  4. Zvolte možnost Rozpoznat a opravit chyby v instalaci produktu Office a poté klikněte na tlačítko Instalovat.

Řešení 12: Upravte možnosti panelů nástrojů. (Pouze aplikace Access)

  1. Vyberte možnost Zobrazení > Panely nástrojů > Vlastní.
  2. Na kartě Panely nástrojů vyberte možnost Nástroj 1 a Řádek nabídek.
  3. Klikněte na tlačítko Vlastnosti.
  4. Vyberte možnost Povolit zobrazení či skrytí.

Řešení 13: Odeberte ze systému předchozí verze souborů doplňku PDFMaker.

  1. V nabídce Start klikněte na příkaz Hledat.
  2. Vyberte možnost Všechny soubory a složky.
  3. Do pole Část nebo celý název souboru zadejte výraz PDFMaker.*.
  4. Klikněte na tlačítko Hledat.

    Poznámka: V závislosti na rychlosti systému může hledání chvíli trvat.
  5. Odstraňte všechny vyhledané soubory, které jsou systémové (například soubory PDFMaker.DOT nebo PDFMaker.XLA). Vytvořené dokumenty, u kterých jste zadali název PDFMaker (například PDFMaker.doc nebo PDFMaker.pdf), můžete ponechat.

Řešení 14: Odeberte sadu Microsoft Works.

Společnost Adobe ověřila, že sada Microsoft Works způsobuje konflikt s aplikací Microsoft Word a brání zobrazení nabídky Převést do Adobe PDF v aplikaci Word. Sada Microsoft Works je v řadě počítačů předinstalována.

Odebrání sady Microsoft Works:

  1. V nabídce Start klikněte na příkaz Spustit, do pole Otevřít zadejte výraz appwiz.cpl a kliknutím na tlačítko OK otevřete dialogové okno Přidat nebo odebrat programy.
  2. Vyhledejte sadu Microsoft Works, vyberte ji a klikněte na tlačítko Změnit nebo odebrat.
  3. Jakmile se zobrazí průvodce, klikněte na tlačítko Další.
  4. Vyberte možnost Odebrat, klikněte na tlačítko Další a postupujte podle zobrazených pokynů.

Další informace

Aplikace Acrobat 7.0–8.0 nainstaluje do složky Acrobat 7.0/PDFMaker/Office nebo Acrobat 8.0/PDFMaker/Office soubor doplňku modulu COM. Díky tomuto souboru lze v aplikaci Word, Excel, PowerPoint, Access, Publisher a Project zobrazit ikonu a příkazy nabídky doplňku PDFMaker. Soubor doplňku modulu COM musí být nejprve přidán do registru systému Windows, aby se mohl v aplikacích zobrazit.

Ikony doplňku PDFMaker se na panelu aplikace Office nezobrazí, jestliže dojde k chybě aplikace, kvůli níž je zakázán soubor doplňku modulu COM.

Některé jiné soubory doplňků modulu COM a makra mohou způsobovat konflikt se souborem doplňku PDFMaker modulu COM a bránit zobrazení ikon Převést do PDF na panelu nástrojů.

Pokud v aplikaci Access není povoleno zobrazení panelu nástrojů Nástroj 1, ikony doplňku PDFMaker se nezobrazí.

329044: Po kliknutí pravým tlačítkem na soubor se při převodu do formátu PDF zobrazí chyba „Chybí soubory PDFMakeru.“

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online