Zjistěte, jak přizpůsobit aplikaci Dreamweaver, aby rozpoznala nové typy souborů, a to úpravou souborů Extensions.txt a MMDocumentTypes.xml.

Tento článek si přečtěte, pokud chcete odstranit následující problémy v aplikaci Dreamweaver:

  • Při otevírání souboru se zobrazí tato chybová zpráva: „Nelze najít platný editor pro tuto příponu souboru.“
  • Barevné kódování v zobrazení kódu neodpovídá barevnému kódování pro požadovaný typ souboru.
  • Funkce modelu serveru není pro váš typ souboru k dispozici.
  • Stránku nelze otevřít v zobrazení návrhu. Stránka se otevře pouze v zobrazení kódu.
  • Když kliknete na možnost Soubor > Uložit nebo Soubor > Otevřít, nezobrazí se požadovaný typ souboru.

Součástí aplikace Dreamweaver je i schopnost upravovat a zobrazovat mnoho různých typů souborů. Tento článek se zaměřuje na přizpůsobení aplikace Dreamweaver úpravou souborů Extensions.txt a MMDocumentTypes.xml, aby aplikace rozpoznávala nové typy souborů. Jako uživatel můžete také určit nastavení Otevřít v zobrazení kódu, aby nové typy souborů bylo možné zobrazit v zobrazení návrhu.

  • Soubor Extensions.txt
    Soubor Extensions.txt je textový soubor s přehledem všech typů souborů rozpoznaných aplikací Dreamweaver. Tento soubor lze upravovat v libovolném externím textovém editoru, jako je Poznámkový blok nebo Textový editor, a přidat do seznamu rozpoznaných typů souborů. Neměňte konfigurační soubory aplikace Dreamweaver přímo v aplikaci Dreamweaver.
  • Soubor MMDocumentTypes.xml
    Soubor MMDocumentTypes.xml obsahuje definice typů dokumentů a seznam přípon souborů přidružených k jednotlivým rozpoznaným typům dokumentů. Přidání přípon souborů do souboru Extensions.txt pouze aplikaci Dreamweaver umožní tuto příponu souboru rozpoznat a povolit otevření souborů tohoto typu v aplikaci Dreamweaver. Přidání přípon souborů do souboru MMDocumentTypes.xml aplikaci Dreamweaver říká, jak má s touto novou příponu souboru zacházet a k jakému typu dokumentu tato přípona souboru patří.

    V tomto článku jsou zmíněny pouze základní aspekty úpravy souboru MMDocumentTypes.xml. Podrobný přehled úpravy tohoto souboru najdete v části Rozšíření aplikace Dreamweaver v aplikaci Dreamweaver. Klikněte na možnost Nápověda > Rozšíření aplikace Dreamweaver a vyhledejte soubor MMDocumentTypes.xml.

  • Otevřít v zobrazení kódu
    Předvolba Otevřít v zobrazení kódu označuje přípony souborů, které neumožňují zobrazení návrhu. Chcete-li umožnit úpravu souborů v zobrazení návrhu, odeberte příponu souboru (pokud je uvedena) z předvolby Otevřít v zobrazení kódu. Chcete-li tuto předvolbu nastavit, klikněte na možnost Úpravy > Předvolby (Windows) nebo Dreamweaver > Předvolby (macOS) a vyhledejte kategorii Typy souborů / Editory.

Úprava souboru Extensions.txt

Při otevírání souboru, který aplikace Dreamweaver nerozpozná, se zobrazí chybová zpráva „Nelze najít platný editor pro tuto příponu souboru“. Nové přípony můžete přidat do seznamu přípon, které aplikace Dreamweaver rozpoznává. Pokud chcete přidat nové přípony, upravte soubor Extensions.txt. Záznamy v souboru Extensions.txt také určují pořadí, ve kterém jsou soubory uvedené v dialogových oknech Soubor > Otevřít a Soubor > Uložit. Jako příklad přidejte do aplikace Dreamweaver typ souboru .inc.

Poznámka: Tento postup vyžaduje, abyste vyhledali skryté soubory, skryté složky a přípony známých typů souborů. Průzkumník Windows ve výchozím nastavení nezobrazuje skryté soubory, složky ani přípony názvů souborů, které systém rozpozná.

Zobrazení skrytých souborů, skrytých složek a přípon známých typů souborů:

  1. V Průzkumníku Windows proveďte jednu z následujících akcí:

    • V systému Windows XP vyberte možnost Nástroje > Možnosti složky.
    • V systému Windows Vista vyberte možnost Uspořádat > Možnosti složky a hledání.
  2. V dialogovém okně Možnosti složky klikněte na kartu Zobrazení.

  3. V části Upřesnit nastavení vyberte možnost Zobrazovat skryté soubory a složky.

  4. Zrušte zaškrtnutí políčka Skrýt příponu souborů známých typů.

  5. Klikněte na tlačítko OK.

Přidání typů souborů do souboru Extensions.txt

Postup při přidávání typů souborů do souboru Extensions.txt:

  1. V konfigurační složce uživatele aplikace Dreamweaver vyhledejte soubor Extensions.txt. Umístění této složky závisí na používaném operačním systému a verzi aplikace Dreamweaver:

    • Dreamweaver CS3 v systému Windows Vista:
      C:\Users\[uživatelské jméno]\AppData\Roaming\Adobe\Dreamweaver 9\Configuration
    • Dreamweaver 8 v systému Windows Vista:
      C:\Users\[uživatelské jméno]\AppData\Roaming\Macromedia\Dreamweaver 8\Configuration
    • Dreamweaver CS3 v systému Windows XP:
      C:\Documents and Settings\[uživatelské jméno]\Application Data\Adobe\Dreamweaver 9\Configuration
    • Dreamweaver 8 v systémech Windows XP a 2000:
      C:\Documents and Settings\[uživatelské jméno]\Application Data\Macromedia\Dreamweaver 8\Configuration
    • Dreamweaver CS3 v systému Mac OS X:
      Mac HD:Users:[uživatelské jméno]:Library:Application Support:Adobe:Dreamweaver 9:Configuration
    • Dreamweaver 8 v systému Mac OS X:
      Mac HD:Users:[uživatelské jméno]:Library:Application Support:Macromedia:Dreamweaver 8:Configuration

    Poznámka: Úpravy tohoto souboru jsou k dispozici pouze pro aktuálního uživatele. Změny provedené v souborech v rámci profilu uživatele nejsou k dispozici jiným uživatelům. Další informace o ruční úpravě konfiguračních souborů aplikace Dreamweaver v prostředí s více uživateli najdete v článku Přizpůsobení aplikace Dreamweaver v prostředí s více uživateli.

  2. Otevřete soubor Extensions.txt v libovolném externím textovém editoru, jako je Poznámkový blok nebo Textový editor.

    Neměňte konfigurační soubory aplikace Dreamweaver přímo v aplikaci Dreamweaver.

  3. Přidejte příponu na řádek Všechny dokumenty. Přípony musí být velkými písmeny a odděleny čárkami. Například HTML,HTM,SHTM,SHTML,INC.

  4. Chcete-li přidat přípony do existující skupiny dokumentů, přidejte příponu do seznamu přípon pro požadovanou skupinu. Pokud chcete přidat novou skupinu dokumentů, přidejte nový řádek, který bude obsahovat nový typ dokumentu a výpis přidružených přípon. Například: INC:Zahrnout soubory

    Tento řádek lze také přidat do seznamu zahrnutí na straně serveru, který se již nachází v souboru.

  5. Soubor uložte a restartujte aplikaci Dreamweaver.
  6. Chcete-li zobrazit změny, spusťte aplikaci Dreamweaver a otevřete soubor s nově přidanou příponu souboru. Soubor se otevře pouze v zobrazení kódu v aplikaci Dreamweaver.

    Vyberte možnost Soubor > Uložit jako a klikněte na místní nabídku Uložit jako typ. V možnosti Zahrnout soubory je možnost *.inc zobrazena jako rozpoznaná přípona souboru. Stejná možnost je zobrazena v místní nabídce Soubory typu v možnosti Soubor > Otevřít.

    Poznámka:

    Pořadí, ve kterém jsou soubory uvedené, je pořadí, ve kterém budou zobrazeny v dialogových oknech Soubor > Otevřít a Soubor > Uložit.

    Chcete-li, aby fungovalo zobrazení návrhu, barevné kódování a funkce chování serveru, je nutné upravit soubor MMDocumentTypes.xml, jak je popsáno v následujících částech.

Přidání přípon do souboru MMDocumentTypes.xml

Soubor MMDocumentTypes.xml obsahuje informace o modelu serveru, styl barevného kódování, popisy apod. pro každý známý typ dokumentu.

Kromě přidání přípon do souboru Extension.txt je nutné nové přípony přidat také do seznamů přípon souborů pro přidružený typ dokumentu. Jinak aplikace Dreamweaver nebude umět tento typ souboru zobrazit. Aplikace Dreamweaver poté soubor ve výchozím nastavení otevře v zobrazení kódu.

Pokud tato přípona není přidružena k žádnému definovanému typu dokumentu, je vytvořen nový typ dokumentu. Pokyny k vytvoření nového typu dokumentu najdete v části Rozšíření aplikace Dreamweaver v aplikaci Dreamweaver. Klikněte na možnost Nápověda > Rozšíření aplikace Dreamweaver a vyhledejte soubor MMDocumentTypes.xml.

Poznámka: V tomto článku se „definice typu dokumentu“ vztahuje na soubory, které obsahují informace o dokumentech rozpoznaných aplikací Dreamweaver. Definice typu dokumentů nemá být zaměňována s deklaracemi „DTD“ uvedenými v dokumentaci XML.

Pomocí následujícího postupu přidáte přípony do definice typu dokumentu v souboru MMDocumentTypes.xml:

  1. Vyhledejte soubor MMDocumentTypes.xml v hlavní konfigurační složce aplikace Dreamweaver (ne v konfigurační složce uživatele aplikace Dreamweaver). Umístění této složky závisí na používaném operačním systému a verzi aplikace Dreamweaver:
    • Dreamweaver CS3 v systémech Windows Vista a XP:

      C:\Program Files\Adobe\Adobe Dreamweaver CS3\Configuration\DocumentTypes
    • Dreamweaver 8 v systémech Windows Vista, XP a 2000:

      C:\Program Files\Macromedia\Dreamweaver 8\Configuration\DocumentTypes
    • Dreamweaver CS3 v systému Mac OS X:

      Mac HD:Applications:Adobe Dreamweaver CS3:Configuration:Document Types
    • Dreamweaver 8 v systému Mac OS X:

      Mac HD:Applications:Macromedia Dreamweaver 8:Configuration:Document Types
  2. Otevřete soubor MMDocumentTypes.xml v libovolném externím textovém editoru, jako je Poznámkový blok nebo Textový editor.

    Neměňte konfigurační soubory aplikace Dreamweaver pomocí aplikace Dreamweaver.

  3. Najděte tag nastavený pro požadovaný typ dokumentu.

    V následující části je uvedena definice výchozího typu dokumentu pro dokumenty HTML ze souboru MMDocumentTypes.xml:

    <documenttype id="HTML" internaltype="HTML" winfileextension="html,htm,shtml,shtm,stm,tpl,lasso,xhtml" macfileextension="html,htm,shtml,shtm,tpl,lasso,xhtml,ssi" writebyteordermark="false">

  4. Přidejte požadovanou příponu do atributů winfileextension a macfileextension tagu documenttype. Například winfileextension="html,htm,shtml,shtm,stm,tpl,lasso,xhtml,inc"

    Výše uvedený kód přidá příponu souboru INC do seznamu souborů, s nimiž aplikace Dreamweaver zachází jako se soubory HTML. Po přidání přípon do seznamů pro tento typ souboru v systémech macOS a Windows aplikace Dreamweaver tento typ souboru otevře v zobrazení návrhu.

  5. Soubor MMDocumentTypes.xml uložte a restartujte aplikaci Dreamweaver.
  6. Chcete-li zobrazit změny, spusťte aplikaci Dreamweaver a otevřete soubor, který má nově přidanou příponu souboru.

    Zobrazení návrhu, barevné zvýraznění kódu a funkce chování serveru (v případě potřeby) nyní fungují.

    Poznámka:

    Pořadí, ve kterém jsou přípony uvedeny, je důležité. První přípona v seznamu rozšíření je výchozí příponou používanou pro tento typ souboru.

    Pokud jste vytvořili zálohu souboru MMDocumentTypes.xml a nechali ji ve složce Configuration/DocumentTypes, zobrazí se při spuštění aplikace Dreamweaver několik upozornění.

    Zobrazí se například tyto chybové zprávy: „Typ dokumentu „HTML“ nebude přidán, protože používá příponu souboru, která je již přidružena k předchozímu typu dokumentu.“

    Tato chybová zpráva se zobrazí také v případě, že je v souboru MMDocumentTypes.xml uveden stejný typ souboru vícekrát.

    Chcete-li zobrazování těchto upozornění zastavit, přesuňte záložní kopii souboru MMDocumentTypes.xml mimo složku Configuration/DocumentTypes.

Předvolba Upravit v zobrazení kódu

Posledním krokem je kontrola nastavení předvoleb Typy souborů / Editory (Úpravy > Předvolby) a ujištění, že není tato předpona souboru uvedena v poli Otevřít v zobrazení kódu. Ve výchozím nastavení je přípona souboru INC v tomto seznamu uvedena. Pokud odeberete příponu „.inc“ ze seznamu Otevřít v zobrazení kódu, můžete soubory s touto příponou zobrazit v zobrazení návrhu.

Povolení barevného zvýraznění kódu ve vlastních typech souborů

Když provedete postup přidání souboru MMDocumentTypes.xml, pomocí následujícího postupu povolíte barevné zvýraznění kódu ve vlastních typech souborů.

  1. Ukončete aplikaci Dreamweaver.

  2. Otevřete soubor brackets.json z následujícího umístění pomocí textového editoru:

    • Windows: %appdata%\Adobe\Dreamweaver CC xxxx\cs_CZ\Configuration\Brackets\brackets.json
    • macOS: ~/Library/Application Support/Adobe/Dreamweaver CC XXXX/cs_CZ/Configuration/Brackets/brackets.json

    Výraz xxxx se vztahuje na verzi aplikace Dreamweaver. Například 2017.

  3. V souboru .json zadejte za poslední dvojicí klíče/hodnoty následující oddělovač , (čárka) a uveďte tento text:
    "language.fileExtensions": { ".ext": "php" }

    Nahraďte výraz .ext seznamem přípon souborů oddělených čárkami, pro které je nutné přidat barevné zvýraznění kódu.

    Nahraďte výraz php požadovaným typem dokumentu. Mezi podporované typy dokumentů patří:

    • bash
    • c
    • clojure
    • coffeescript
    • cpp
    • csharp
    • css
    • dart
    • diff
    • ejs
    • erb_html (Embedded Ruby)
    • groovy
    • handlebars
    • haskell
    • html
    • hx (Haxe)
    • java
    • javascript
    • json
    • jsx
    • less
    • lua
    • markdown
    • perl
    • php
    • properties
    • python
    • ruby
    • sass
    • scala
    • scss
    • sql
    • stylus
    • svg
    • turtle (RDF Turtle)
    • vb
    • vbscript
    • xml
    • yaml
  4. Soubor uložte a spusťte aplikaci Dreamweaver.

Další informace

Další informace o změnách typů souborů v aplikaci Dreamweaver najdete v části Rozšíření Dreamweaveru.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online