A Character Animator project is a collection of puppets, scenes, and supporting items (for example, artwork and audio files). You can create separate projects to organize related work, such as for an episode of a cartoon or for a specific client. Each project is stored on disk as a separate folder.

Create and open projects

The default project Character Animator Project is located in your user Documents/Adobe/Character Animator/Preview (Mac) or Documents\Adobe\Character Animator\Preview (Win) folder. You can switch to a different project at any time. When Character Animator launches, it reopens the recent project you had closed so you can continue your work. If the current project cannot be found, it reopens or recreates the default project.

Create a project

Choose File > New Project. Specify the location and name for the project, and click Save. A project folder with the default project file (.chproj file) both using the name specified, are created.

Bemærk:

As you work in a project, Character Animator is continually creating and updating files in the project’s folder on disk. Avoid creating and working on projects located in folders actively synced or backed up.

Open a project

Choose File > Open Project (Ctrl+O), select the Ch project (.chproj), then click Open.

Open a recent project

Choose the project from the File > Open Recent submenu. The current project is the first one listed.

Locate the current project on disk

To show and select the current project’s folder on disk, choose File > Reveal Project in Explorer (Windows) or File > Reveal Project in Finder (Mac OS).

Import contents of another project

You can import the contents of another project and reuse its scenes and puppets in the current project.

To import a project’s contents:

  • Choose File > Import, then select the .chproj file in that project’s folder.

A new folder is created in the Project panel, and a copy of that project’s contents are placed in the folder.

If the source media (artwork and audio) files are originally in the imported project’s Ch Media folder (or one of its subfolders) on disk, copies of those files are added to the current project’s Ch Media folder. These files are added in a Gathered Media subfolder.

If the source files existed outside of the project folder, the imported items reference their current location instead of making a copy.

Supported file formats

JPEG support for puppets and cycles

  • Single JPEG (*.jpg or *.jpeg) file can be imported as single-layered puppets (click File > Import). 
  • JPEG image sequences can be imported as cycles (click File > Import Cycle).

EPS and SVG format support for puppet artwork

Puppet artwork in EPS (.eps) and SVG (.svg or .svgz) formats are supported in Character Animator. As these formats are vector-based, the Render as Vector option and the Wiggler behavior can be applied to them.

Bemærk:

Older versions of the EPS and SVG file formats might not be able to retain the full layer hierarchy, so some parts might appear flattened in the Puppet panel.

Illustrator (vector artwork) rasterization

Use the Resolution property in the Puppet section of the Properties panel to control the maximum quality of the vector artwork when it is rasterized. The default is set to 200%. It can be increased to up to 400%. Reduce it to a draft (50%) or low (100%) resolution if scaling down and to preserve more memory.

Bemærk:

Scenes sent through Dynamic Link to After Effects, Premiere Pro, or Adobe Media Encoder are rasterized. If you want to scale up the footage in those other applications, use a larger scene size in Character Animator to retain details.

Using Adobe Animate CC (.fla) content

Use artwork from an Adobe Animate CC (.fla) document for use in Character Animator by exporting the artwork in SVG format.

Bemærk:

Only the current frame in an Adobe Animate scene will be exported.

To export Adobe Animate artwork as SVG for use in Character Animator, follow these steps:

  1. Open the scene in the Adobe Animate document.

  2. Choose File > Publish Settings.

  3. Set the Output Format to SVG Image, Output name to the location and name for the .svg file, and any other option you want.

  4. Click Publish.

    The published .svg file can then be imported into Character Animator.

Organize project items

Within the current project, you can rearrange project items in the Project panel into different folders to suit your needs. 

You can sort the items in the Project panel by name or type. Click a column heading to toggle sorting direction.

Add a folder

To add a folder, choose File > New Folder, type the name for the folder, then press Enter or click away from the text field.

A new folder is created at the same level as the outermost selected project item, or inside the selected folder.

To duplicate artwork, puppet, and audio in the Project panel, select the item that you want to duplicate and choose Edit > Duplicate.

Remove a folder

To remove a folder, select it, then choose Edit > Delete (Delete or Backspace).

Move items between folders

To move items between folders, select the items, then drag them into a different folder.

Rename a project item

To rename a project item (puppet, scene, folder, and so on), select it, and press Enter. To save changes, type the new name and press Enter, or click away from the text field. Press Esc instead to cancel your edits.

Bemærk:

Dragging an item into a folder containing another item of the same name causes the dragged item to be renamed. Renaming an item to match an existing item in the same folder is disallowed— a red ‘x’ appears next to the text field. Hover the pointer above the ‘x’ to show the error message.

Delete an item

To delete an item, select it, then press Delete or Backspace or choose Edit > Delete.

Locate imported files on disk

To locate imported files on disk, context + right-click a puppet, artwork, or audio item in the Project panel. Now choose Reveal in Finder (Mac) /Explorer (Windows) from the context menu. For puppets, the artwork file for the bottom-most layer is revealed.

Copy imported artwork and audio files into a project

To gather copies of imported artwork and audio files into the project folder for easier project sharing, choose File > Copy Media Files into Project Folder. The files are copied into the Gathered Media subfolder of the project’s Ch Media folder. The files in the original locations are not deleted.

Undo, redo, and history

Character Animator provides unlimited undo and redo, even between Character Animator sessions. Your Character Animator project saves changes automatically.

Undo or redo changes

To undo or redo changes, do either of the following:

  • Choose Edit > Undo Action (Cmd/Ctrl+Z) or Redo Action (Shift+Cmd/Ctrl+Z).
  • Select the action from the History panel (Window > History).

Clear undo history

To clear the undo history, choose File > Clear History, then click Clear History.

Use history bookmarks

Use history bookmarks to remember a specific state of a project. Create these markers in a project’s history and recall them later to restore the state of your project. Bookmarks let you keep track of different variations of a project all within the same project.

Bemærk:

You cannot undo creating, renaming, or deleting a bookmark as that would affect project history. Also, clearing history (File > Clear History menu command) deletes all project history and bookmarks.

Using History Bookmarks

  1. To create a new bookmark for the current state, click the New History Bookmark button in the bottom-left corner of the panel or choose File > New History Bookmark.

    A new bookmark appears in the top section of the History panel with a solid bookmark icon, and the corresponding history state appears in the bottom section with a smaller bookmark icon to indicate that the state is bookmarked. Hover over the bookmark to display the exact date and time of its creation.

    Using bookmarks
    Using bookmarks
  2. To restore project history to a bookmark’s state, click the bookmark.

    Bemærk:

    If the Scene panel is not showing the expected results, try clicking the Refresh Scene button in the panel.

  3. To rename a bookmark, right-click the bookmark and choose the Rename command or, if the bookmark is selected, press Return (macOS) or Enter (Windows). Change the name, then press Return/Enter.

  4. To delete a bookmark, either right-click the bookmark and choose the Delete command or hover over the bookmark and then click the 'x' button.

    Tip: You don’t have to select a bookmark (and restore project history to that state) to rename or delete a bookmark.

Auto Bookmarks

The following actions create Auto bookmarks:

  • If you undo a few operations and then to do some new operation (for example, create a folder), the previous redoable operations no longer appear in the current undo/redo history. An auto bookmark is created for the previous state of the project, and is named as the last state plus the number of redoable operations. For example, 'Record Performance + 5 redos'.
  • If you select a bookmark with a history state that isn‘t within the current undo/redo history, an auto bookmark is created for the previous state of the project, named as the last state plus the number of redoable operations (if any). For example, Set Scale to 80 or Set Scale to 75 + 1 redo.
  • When you delete a bookmark, an auto bookmark is created. The auto bookmark is named after the deleted bookmark, and shows when the bookmark was originally created and later deleted below the auto bookmark’s name.
  • When you open a project, an auto bookmark is created for the state of the project at the time it was opened.

View Auto Bookmarks

Select the Show Auto Bookmarks option from the History panel menu. Deselect to show manually created bookmarks.

Show auto bookmarks option
Show auto bookmarks option

Auto Bookmarks appear with outlined bookmark icons to differentiate them from manually created bookmarks. The most recent Auto Bookmark appears at the bottom of the list. You can restore, rename, and delete auto-created bookmarks. Renaming an auto-bookmark makes it a regular bookmark, and switches the top section of the History panel to view it.

Create a copy of a project

You can save your project under a new name to easily experiment with changes or to save different versions of your work.

To save the project under a new name, choose File > Save As, then specify the new location and name for the project. The saved project contains copies of the puppets, scenes, and recordings, including artwork and audio files that had been previously saved in the Ch Media subfolder. Character Animator does not copy any files that were outside of the project’s folder and the history is cleared.

Dette arbejde har licens under en Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Opslag på Twitter™ og Facebook er ikke omfattet af vilkårene for Creative Commons.

Juridiske meddelelser   |   Politik for beskyttelse af personlige oplysninger online