Guía del usuario Cancelar

Seguimiento de caras

  1. Guía del usuario de After Effects
  2. Versiones beta
    1. Descripción general del programa beta
    2. Comunidad beta de After Effects
  3. Introducción
    1. Introducción a After Effects
    2. Novedades de After Effects 
    3. Notas de la versión | After Effects
    4. Requisitos del sistema para After Effects
    5. Métodos abreviados de teclado en After Effects
    6. Formatos de archivo admitidos | After Effects
    7. Recomendaciones de hardware
    8. Planificación y configuración
    9. Configuración e instalación
  4. Espacios de trabajo
    1. Elementos generales de la interfaz de usuario
    2. Familiarización con la interfaz de After Effects
    3. Flujos de trabajo
    4. Espacios de trabajo, paneles y visores
  5. Proyectos y composiciones
    1. Proyectos
    2. Conceptos básicos sobre composiciones
    3. Precomposición, anidamiento y preprocesamiento
    4. Ver información de rendimiento detallada con el Perfilador de composición
    5. Procesador de composición de Cinema 4D
  6. Importación de material de archivo
    1. Preparación e importación de imágenes fijas
    2. Importación desde After Effects y Adobe Premiere Pro
    3. Importación e interpretación de vídeo y de audio
    4. Preparación e importación de archivos de imagen 3D
    5. Importación e interpretación de elementos de material de archivo
    6. Uso de elementos de material de archivo
    7. Metadatos de XMP
  7. Uso de texto y gráficos
    1. Texto
      1. Formato de caracteres y el panel Carácter
      2. Efectos de texto
      3. Creación y edición de capas de texto
      4. Aplicación de formato a párrafos y el panel Párrafo
      5. Extrusión de capas de texto y formas
      6. Animación del texto
      7. Ejemplos y recursos para animación de texto
      8. Plantillas de texto interactivo
    2. Gráficos animados
      1. Trabajar con plantillas de gráficos animados en After Effects
      2. Uso de expresiones para crear listas desplegables en plantillas de gráficos animados
      3. Trabajo con propiedades esenciales para crear plantillas de gráficos animados
      4. Reemplazo de imágenes y vídeos en plantillas de gráficos animados y propiedades esenciales
  8. Dibujo, pintura y trazados
    1. Descripción general de las capas de forma, trazados y gráficos vectoriales
    2. Herramientas de pintura: Pincel, Tampón de clonar y Borrador
    3. Estrechamiento de trazos de forma
    4. Atributos de forma, operaciones de pintura y operaciones de trazado para capas de forma
    5. Uso del efecto de forma Desplazar trazados para modificar formas
    6. Creación de formas
    7. Creación de máscaras
    8. Elimine objetos de sus vídeos desde el panel Relleno según el contenido
    9. Pincel tipo rotoscopia y Perfeccionar mate
  9. Uso de capas
    1. Selección y organización de capas
    2. Modos de fusión y estilos de capas
    3. Capas 3D
    4. Propiedades de capa
    5. Creación de capas
    6. Administración de capas
    7. Marcadores de capa y marcadores de composición
    8. Cámaras, luces y puntos de interés
  10. Animación, fotogramas clave, seguimiento del movimiento y efecto de clave
    1. Animación
      1. Conceptos básicos sobre animaciones
      2. Animación con herramientas de marioneta
      3. Administración y animación de trazados de formas y máscaras
      4. Animación de formas de Sketch y Capture con After Effects
      5. Herramientas de animación varias
      6. Trabajo con animación basada en datos
    2. Fotograma clave
      1. Interpolación de fotogramas clave
      2. Ajuste, selección y eliminación de fotogramas clave
      3. Edición, desplazamiento y copia de fotogramas clave
    3. Seguimiento de movimiento
      1. Seguimiento y estabilización del movimiento
      2. Seguimiento de caras
      3. Seguimiento de máscara
      4. Referencia de máscara
      5. Velocidad
      6. Ampliación del tiempo y reasignación del tiempo
      7. Unidades de visualización de tiempo y código de tiempo
    4. Incrustación
      1. Incrustación
      2. Efectos de incrustación
  11. Transparencia y composición
    1. Descripción general y recursos sobre composición y transparencia
    2. Canales alfa, máscaras y mates
  12. Ajuste del color
    1. Conceptos básicos sobre colores
    2. Uso de la extensión Temas de Adobe Color
    3. Gestión de color
    4. Efectos de corrección de color
  13. Ajustes preestablecidos de animación y efectos
    1. Visión general de efectos y ajustes preestablecidos de animación
    2. Lista de efectos
    3. Efectos de simulación
    4. Efectos de Estilizar
    5. Efectos de audio
    6. Efectos de distorsión
    7. Efectos de perspectiva
    8. Efectos de canal
    9. Efectos de generación
    10. Efectos de transición
    11. El efecto Reparación de obturación de desplazamiento
    12. Efectos Desenfocar y Enfocar
    13. Efectos de canal 3D
    14. Efectos de utilidad
    15. Efectos mate
    16. Efectos Ruido y Granulado
    17. Efecto Mejora de conservación de detalles
    18. Efectos obsoletos
  14. Expresiones y automatización
    1. Expresión
      1. Conceptos básicos sobre expresiones
      2. Comprensión del lenguaje de expresión
      3. Uso de los controles de expresión
      4. Diferencias de sintaxis entre los motores de expresiones de JavaScript y ExtendScript heredado
      5. Edición de expresiones
      6. Errores de expresiones
      7. Uso del editor de expresiones
      8. Uso de expresiones para editar y acceder a las propiedades de texto
      9. Referencia del lenguaje de expresión
      10. Ejemplos de expresiones
    2. Automatización
      1. Automatización
      2. Scripts
  15. Vídeo inmersivo, RV y 3D
    1. Construcción de entornos de RV en After Effects
    2. Aplicar efectos de vídeo envolvente
    3. Herramientas de composición para vídeos de VR/360
    4. Seguimiento del movimiento de la cámara 3D
    5. Trabajo en espacios de diseño 3D
    6. Previsualización de los cambios en diseños 3D en tiempo real con el motor en tiempo real
    7. Adición de diseño interactivo a los gráficos 
  16. Vistas y previsualizaciones
    1. Previsualización
    2. Previsualización de vídeo con Mercury Transmit
    3. Modificación y utilización de vistas
  17. Procesamiento y exportación
    1. Principios básicos del procesamiento y la exportación
    2. Exportación de un proyecto de After Effects como un proyecto de Adobe Premiere Pro
    3. Conversión de películas
    4. Procesamiento de varios fotogramas
    5. Procesamiento automático y en red
    6. Procesamiento y exportación de imágenes fijas y secuencias de imágenes fijas
    7. Uso del códec de GoPro CineForm en After Effects
  18. Uso de otras aplicaciones
    1. Dynamic Link y After Effects
    2. Uso de After Effects y otras aplicaciones
    3. Sincronización de la configuración en After Effects
    4. Colaborar con Proyectos de equipo
    5. Uso compartido y administración de cambios con los colaboradores del Team Project
    6. Bibliotecas Creative Cloud en After Effects
    7. Plugins
    8. Cinema 4D y Cineware
  19. Memoria, almacenamiento y rendimiento
    1. Memoria y almacenamiento
    2. Mejora del rendimiento
    3. Preferencias
    4. Requisitos de la GPU y del controlador de la GPU para After Effects

Información general sobre el seguimiento de caras

El seguimiento de caras permite detectar y rastrear rostros con gran precisión. El seguimiento simple de máscaras permite aplicar efectos rápidamente solo a una cara, como la corrección de color selectiva o el desenfoque de la cara de una persona, etc.

Sin embargo, con el seguimiento de caras se pueden seguir puntos específicos de la cara como las pupilas, la boca y la nariz, lo que le permite aislar estos rasgos faciales y trabajar en ellos con mayor detalle. Por ejemplo, cambie el color de los ojos o exagere los movimientos de la boca sin ajustar cada fotograma.

After Effects también le permite medir rasgos faciales. El seguimiento de medidas faciales indica detalles como el grado de apertura de la boca y de cada ojo. Si aísla cada punto de datos, puede perfeccionar el contenido en gran medida. Asimismo, puede exportar datos de seguimiento detallados en Adobe Character Animator para animar personajes según su actuación.

El rastreador de cara funciona en gran parte automáticamente, pero puede obtener un mejor resultado si inicia el análisis en un fotograma que muestre un plano con una vista frontal vertical de la cara. La iluminación adecuada de la cara puede mejorar la precisión de la detección de caras.

En el panel Rastreador, hay dos opciones de seguimiento de caras:

  • Seguimiento de la cara (solo contorno): utilice esta opción si solo desea rastrear el contorno de la cara.
  • Seguimiento de la cara (facciones detalladas): utilice esta opción si desea detectar la ubicación de los ojos (con la ceja y la pupila), la nariz y la boca y, opcionalmente, extraer las medidas de varias facciones. Necesitará esta opción si desea utilizar los datos de seguimiento en Character Animator.

    Si utiliza la opción Facciones detalladas, se aplica un efecto Puntos de seguimiento de la cara a la capa. El efecto contiene varios puntos de control de efectos bidimensionales con fotogramas clave, cada uno de los cuales se asocia con los rasgos faciales detectados (por ejemplo, las comisuras de los ojos y la boca, la ubicación de las pupilas, la punta de la nariz).

Seguimiento del contorno de una cara

  1. En After Effects, seleccione Archivo > Importar > Archivo. Vaya a la ubicación del material de archivo y añádalo al proyecto.

    Panel Proyecto

  2. Arrastre el material de archivo desde el panel Proyecto a una composición para añadir una capa.

    Adición de una capa a la composición

  3. Coloque el indicador de tiempo actual (CTI) en un fotograma que muestre un plano con una vista frontal y vertical de la cara que desee rastrear.

    Nota:

    La detección de caras mejorará si el fotograma inicial del seguimiento contiene una cara de frente y vertical.

    Detección de cara

  4. Dibuje una máscara cerrada relajada alrededor de la cara, que incluya los ojos y la boca. La máscara define la región de búsqueda para localizar las facciones. Si hay varias máscaras seleccionadas, se utiliza la máscara superior.

    Dibujo de una máscara

  5. Con la máscara seleccionada, elija Ventana > Rastreador para abrir el panel Rastreador. Defina el método de seguimiento como Seguimiento de la cara (solo contorno).

    Selección de un método de seguimiento

  6. En el panel Rastreador, siga hacia adelante o hacia atrás de fotograma en fotograma para asegurarse de que el seguimiento funcione correctamente y, a continuación, haga clic en el botón para comenzar a analizar todos los fotogramas.

  7. Una vez finalizado el análisis, los datos de seguimiento de la cara aparecerán dentro de la composición.

Seguimiento de facciones detalladas y extracción de medidas faciales

  1. En After Effects, seleccione Archivo > Importar > Archivo. Vaya a la ubicación del material de archivo y añádalo al proyecto.

  2. Arrastre el material de archivo desde el panel Proyecto a una composición para añadir una capa.

  3. Coloque el indicador de tiempo actual en un fotograma que muestre un plano con una vista frontal y vertical de la cara que desee rastrear.

    Nota:

    La detección de caras mejorará si el fotograma inicial del seguimiento contiene una cara de frente y vertical.

  4. Dibuje una máscara cerrada relajada alrededor de la cara, que incluya los ojos y la boca. La máscara define la región de búsqueda para localizar las facciones. Si hay varias máscaras seleccionadas, se utiliza la máscara superior.

  5. Con la máscara seleccionada, elija Ventana > Rastreador para abrir el panel Rastreador. Defina el método de seguimiento como Seguimiento de la cara (facciones detalladas).

  6. En el panel Rastreador, siga hacia adelante o hacia atrás de fotograma en fotograma para asegurarse de que el seguimiento funcione correctamente y, a continuación, haga clic en el botón para comenzar a analizar todos los fotogramas.

  7. Una vez finalizado el análisis, los datos de seguimiento aparecerán en un efecto nuevo llamado Puntos de seguimiento de la cara. Puede elegir acceder a los datos de seguimiento de la cara dentro la composición o en el panel Efectos (Ventana > Controles de efectos).

    Controles de efecto de puntos de seguimiento de la cara

  8. Mueva el indicador de tiempo actual hasta un fotograma que muestre una expresión neutra en la cara (la pose de descanso). Las medidas de cara en otros fotogramas son relativas al fotograma de pose de descanso. En el panel Rastreador, haga clic en Definir pose de descanso.

  9. En el panel Rastreador, haga clic en Extraer y copiar medidas de la cara. Se añade un efecto Medidas de la cara a la capa y se crean fotogramas clave en función de los cálculos realizados a partir de los datos del fotograma clave Puntos de seguimiento de la cara. Los datos del fotograma clave de Medidas de la cara se copian en el portapapeles del sistema para utilizarlos en Character Animator.

    Nota:

    Los fotogramas clave de las medidas de la cara se generan en función de los datos de fotograma clave de los Puntos de seguimiento de la cara, en relación con la pose de descanso (consulte el paso 8).

    Controles de efecto de medidas de la cara

Referencia de datos de seguimiento de caras

Puntos de seguimiento de la cara

El efecto Rastreador de caras crea los puntos de control de efecto de varias facciones, que puede consultar en el panel Línea de tiempo.

Medidas de la cara

Si ha utilizado la opción de facciones detalladas, puede extraer aún más información como medidas paramétricas de rasgos faciales, lo que se denomina Medidas de la cara. Todas las medidas de la cara rastreada son relativas al fotograma de pose de descanso.

Desplazamiento de la cara

Indica la posición de la cara, con un desplazamiento de 0 % en el fotograma de pose de reposo. Están disponibles los puntos de datos siguientes, que indican los valores de desplazamiento en los ejes x, y y z:

  • Desplazamiento X
  • Desplazamiento Y
  • Desplazamiento Z

Orientación de la cara

Indica las orientaciones tridimensionales de la cara. La orientación se mide con los puntos de datos siguientes, que indican los ejes x, y y z:

  • Orientación X
  • Orientación Y
  • Orientación Z

Ojo izquierdo

Indica distintos puntos de medida del ojo izquierdo e incluye los puntos de datos siguientes:

  • Distancia de la ceja izquierda
  • Apertura del párpado izquierdo
  • Mirada X del ojo izquierdo
  • Mirada Y del ojo izquierdo

Ojo derecho

Indica distintos puntos de medida del ojo derecho e incluye los puntos de datos siguientes:

  • Distancia de la ceja derecha
  • Apertura del párpado derecho
  • Mirada X del ojo derecho
  • Mirada Y del ojo derecho

Boca

Indica distintos puntos de medida de la boca e incluye los puntos de datos siguientes:

  • Desplazamiento X de la boca
  • Desplazamiento Y de la boca
  • Anchura de escala de la boca
  • Altura de escala de la boca
Logotipo de Adobe

Inicia sesión en tu cuenta