Deshacer y rehacer en el panel Historial

  1. Guía del usuario de Adobe Animate
  2. Introducción a Animate
    1. Novedades de Animate
    2. Glosario visual
    3. Requisitos del sistema para Animate
    4. Métodos abreviados de teclado de Animate
    5. Trabajar con varios tipos de archivo en Animate
  3. Animación
    1. Aspectos básicos de animaciones en Animate
    2. Cómo utilizar los fotogramas y fotogramas clave en Animate
    3. Animación fotograma a fotograma en Animate
    4. Uso de la animación de interpolación clásica en Animate
    5. Herramienta Pincel
    6. Guía de movimiento
    7. Interpolación de movimiento y ActionScript 3.0
    8. Acerca de la animación de interpolación de movimiento
    9. Animaciones de interpolación de movimiento
    10. Creación de una animación de interpolación de movimiento
    11. Uso de fotogramas clave de propiedad
    12. Animación de la posición con una interpolación
    13. Edición de interpolaciones de movimiento con el editor de movimiento
    14. Edición del trazado de movimiento de una animación de interpolación
    15. Manipulación de las interpolaciones de movimiento
    16. Adición de aceleraciones personalizadas
    17. Creación y aplicación de ajustes preestablecidos de movimiento
    18. Configuración de grupos de interpolación de animación
    19. Uso de interpolaciones de movimiento guardadas como archivos XML
    20. Interpolaciones de movimiento e interpolaciones clásicas
    21. Interpolación de forma
    22. Uso de la animación de la herramienta Hueso en Animate
    23. Trabajar con el rigging de personajes en Animate
    24. Uso de las capas de máscara en Adobe Animate
    25. Uso de escenas en Animate
  4. Interactividad
    1. Creación de botones en Animate
    2. Conversión de proyectos de Animate a otros formatos de documento
    3. Creación y publicación de documentos de HTML5 Canvas en Animate
    4. Adición de interactividad con fragmentos de código en Animate
    5. Creación de componentes HTML5 personalizados
    6. Uso de componentes en HTML5 Canvas
    7. Creación de componentes personalizados: Ejemplos
    8. Fragmentos de código para componentes personalizados
    9. Prácticas recomendadas - Publicidad con Animate
    10. Autoría y publicación de realidad virtual
  5. Espacio de trabajo y flujo de trabajo
    1. Creación y administración de pinceles
    2. Uso de Google Fonts en documentos HTML5 Canvas
    3. Utilización de las Bibliotecas Creative Cloud y Adobe Animate
    4. Utilización del Escenario y el panel Herramientas en Animate
    5. Flujo de trabajo y espacio de trabajo de Animate
    6. Uso de las fuentes web en documentos de HTML5 Canvas
    7. Líneas de tiempo y ActionScript
    8. Trabajo con varias líneas de tiempo
    9. Configuración de preferencias
    10. Utilización de los paneles de edición de Animate
    11. Creación de capas de la línea de tiempo en Animate
    12. Exportación de animaciones para aplicaciones móviles y motores de juegos
    13. Desplazamiento y copia de objetos
    14. Plantillas
    15. Buscar y reemplazar en Animate
    16. Deshacer y rehacer en el panel Historial
    17. Métodos abreviados de teclado
    18. Uso de la Cronología en Animate
    19. Creación de extensiones HTML
    20. Opciones de optimización para Imágenes y archivos GIF animados
    21. Configuración de exportación de imágenes y archivos GIF
    22. Panel de Recursos en Animate
  6. Multimedia y vídeo
    1. Transformación y combinación de objetos gráficos en Animate
    2. Crear y trabajar con instancias de símbolo en Animate
    3. Calco de imagen
    4. Cómo utilizar el sonido en Adobe Animate
    5. Exportación de archivos SVG
    6. Creación de archivos de vídeo para su uso en Animate
    7. Cómo añadir un vídeo a Animate
    8. Trabajo con puntos de referencia de vídeo
    9. Dibujo y creación de objetos en Animate
    10. Remodelado de líneas y formas
    11. Trazos, rellenos y degradados en Animate CC
    12. Uso de Adobe Premiere Pro y After Effects
    13. Paneles de color en Animate CC
    14. Apertura de archivos de Flash CS6 con Animate
    15. Uso de texto clásico en Animate
    16. Colocación de ilustraciones en Animate
    17. Mapas de bits importados en Animate
    18. Gráficos 3D
    19. Trabajo con símbolos en Animate
    20. Dibujo de líneas y formas en Adobe Animate
    21. Uso de bibliotecas en Animate
    22. Exportación de sonidos
    23. Selección de objetos en Animate CC
    24. Trabajo con archivos AI de Illustrator en Animate
    25. Aplicación de patrones con el pincel rociador
    26. Aplicación de modos de mezcla
    27. Organización de objetos
    28. Automatización de tareas con el menú Comandos
    29. Texto en varios idiomas
    30. Utilización de la cámara en Animate
    31. Uso de Animate con Adobe Scout
    32. Trabajo con archivos de Fireworks
    33. Filtros de gráficos
    34. Sonido y ActionScript
    35. Preferencias de dibujo
    36. Dibujo con la herramienta Pluma
  7. Plataformas
    1. Conversión de proyectos de Animate a otros formatos de documento
    2. Compatibilidad con plataformas personalizadas
    3. Creación y publicación de documentos de HTML5 Canvas en Animate
    4. Creación y publicación de un documento de WebGL
    5. Empaquetado de aplicaciones para AIR para iOS
    6. Publicación de aplicaciones de AIR for Android
    7. Publicación para Adobe AIR para escritorio
    8. Configuración de publicaciones de ActionScript
    9. Prácticas recomendadas - Organización de ActionScript en una aplicación
    10. Uso de ActionScript con Animate
    11. Prácticas recomendadas - Directrices de accesibilidad
    12. Accesibilidad en el espacio de trabajo de Animate
    13. Cómo escribir y gestionar scripts
    14. Activación de la compatibilidad con plataformas personalizadas
    15. Información general sobre compatibilidad con plataformas personalizadas
    16. Creación de contenido accesible
    17. Uso de plugins de compatibilidad con plataformas personalizadas
    18. Depuración de ActionScript 3.0
    19. Activación de la compatibilidad con plataformas personalizadas
  8. Exportación y publicación
    1. Exportación de archivos de Animate CC
    2. Publicación de OAM
    3. Exportación de archivos SVG
    4. Exportación de gráficos y vídeos con Animate
    5. Publicar documentos de AS3
    6. Exportación de animaciones para aplicaciones móviles y motores de juegos
    7. Exportación de sonidos
    8. Exportación de archivos de vídeo QuickTime
    9. Control de reproducción de vídeo externo con ActionScript
    10. Prácticas recomendadas - Sugerencias para crear contenido para dispositivos móviles
    11. Prácticas recomendadas - Convenciones de vídeo
    12. Prácticas recomendadas - Directrices de edición de aplicaciones SWF
    13. Prácticas recomendadas - Estructuración de archivos FLA
    14. Prácticas recomendadas de optimización de archivos FLA para Animate
    15. Configuración de publicaciones de ActionScript
    16. Especificación de configuración de publicación para Animate
    17. Exportación de archivos de proyector
    18. Exportar imágenes y archivos GIF animados
    19. Plantillas de publicación HTML
    20. Uso de Adobe Premiere Pro y After Effects
    21. Compartir y publicar animaciones rápidamente

Comandos Deshacer, Rehacer y Repetir

Para deshacer o rehacer acciones en objetos individuales o en todos los objetos del documento actual, especifique los comandos Deshacer o Rehacer a nivel del documento o a nivel del objeto (Edición > Deshacer o Edición > Rehacer). De forma predeterminada, estos comandos se aplican a todo el documento.

Para elegir las opciones de deshacer a nivel de objeto o a nivel de documento, haga lo siguiente:

  1. En Animate CC, seleccione Editar> Preferencias.
  2. En la ficha General, seleccione Deshacer a nivel de objeto del menú desplegable Deshacer.

Tenga en cuenta que, si se aplica a un objeto, el comando Deshacer no permite deshacer algunas acciones. como entrar y salir del modo de edición; seleccionar, editar y desplazar elementos de biblioteca o crear, eliminar y desplazar escenas.

Para reaplicar un paso al mismo objeto o a un objeto distinto, se utiliza el comando Repetir. Por ejemplo, si mueve una forma denominada forma_A, puede seleccionar Edición > Repetir para volver a mover la forma, o bien seleccionar otra forma, forma_B, y elegir Edición > Repetir para mover la segunda forma en la misma cantidad.

De forma predeterminada, Animate admite 100 niveles de deshacer para el comando de menú Deshacer. Seleccione el número de niveles de deshacer y rehacer, entre 2 y 300, en Preferencias de Animate.

De forma predeterminada, al deshacer un paso con Edición > Deshacer o el panel Historial, no se cambia el tamaño de archivo del documento, incluso si se elimina un elemento del documento. Por ejemplo, si importa un archivo de vídeo a un documento y después deshace la importación, el tamaño de archivo del documento sigue incluyendo el tamaño del archivo de vídeo. Los elementos que se eliminan de un documento al ejecutar un comando Deshacer se conservan para que sea posible restaurarlos con el comando Rehacer.

Utilización del panel Historial

El panel Historial (Ventana > Historial) muestra una lista de los pasos realizados en el documento activo desde que se abrió o creó, hasta un número máximo de pasos determinado. (El panel Historial no muestra los pasos que se han realizado en otros documentos.) El deslizador del panel Historial señala inicialmente el último paso realizado.

  • Para deshacer o rehacer pasos individuales o varios pasos a la vez, utilice el panel Historial. Los pasos del panel del historial se pueden aplicar al mismo objeto o a un objeto distinto del documento. Sin embargo, no se puede reorganizar el orden de los pasos del panel Historial. El panel Historial es un registro de los pasos en el orden en el que se han realizado.

    nota: si deshace un paso o una serie de pasos y después realiza una acción nueva en el documento, ya no se pueden rehacer los pasos del panel Historial; desaparecen del panel.

  • De forma predeterminada, Animate admite 100 niveles de deshacer para el panel Historial. Seleccione el número de niveles de deshacer y rehacer, entre 2 y 300, en Preferencias de Animate.

  • Para eliminar la lista del historial del documento actual, borre la información del panel Historial. Después de borrar la lista del historial, no se podrán deshacer los pasos que se han borrado. Si se borra la lista del historial no se deshacen pasos; sólo se elimina el registro de esos pasos de la memoria del documento actual.

Al cerrar un documento se borra su historial. Para utilizar los pasos de un documento después de cerrarlo, copie los pasos con el comando Copiar pasos o guárdelos como comando.

Cómo deshacer pasos con el panel Historial

Si se deshace un paso, el paso aparece de color más claro en el panel Historial.

  • Para deshacer el último paso realizado, arrastre el deslizador del panel Historial hasta el paso anterior en la lista.

  • Para deshacer varios pasos, arrastre el deslizador hasta cualquiera de los pasos o haga clic a la izquierda de un paso en la línea del control deslizante. El control deslizante se desplaza automáticamente a dicho paso y se deshacen los pasos por los que se desplaza.

nota: desplazarse hasta un paso (y seleccionar los pasos posteriores) es distinto de seleccionar un paso individual. Para desplazarse hasta un paso, haga clic a la izquierda del paso.

Reproducción de pasos con el panel Historial

Al repetir pasos con el panel Historial, los pasos que se reproducen son los que están seleccionados (resaltados) en el panel Historial, no necesariamente el paso que señale en ese momento el deslizador.

Los pasos del panel Historial se pueden aplicar a cualquier objeto seleccionado del documento.

Reproducción de un paso

  1. En el panel Historial, seleccione un paso y haga clic en el botón Reproducir.

Reproducción de una serie de pasos adyacentes

  1. Seleccione los pasos del panel Historial realizando uno de los siguientes procedimientos:
    • Arrastre desde un paso hasta otro. (No arrastre el deslizador; arrastre la etiqueta de texto de un paso hasta la etiqueta de texto de otro paso.)

    • Seleccione el primer paso y, con la tecla Mayús presionada, haga clic en el último paso; o bien, seleccione el último paso y, con la tecla Mayús presionada, haga clic en el primer paso.

  2. Haga clic en Reproducir. Los pasos se reproducen por orden y en el panel Historial aparece un paso nuevo denominado Reproducir pasos.

Reproducción de pasos no adyacentes

  1. Seleccione un paso del panel Historial y, con la tecla Control (Windows) o Comando (Macintosh) presionada, haga clic en otros pasos. Para anular la selección de un paso, haga clic con la tecla Control o Comando presionada.
  2. Haga clic en Reproducir.

Cómo copiar y pegar pasos entre documentos

Cada documento abierto tiene su propio historial de pasos. Para copiar pasos de un documento y pegarlos en otro, utilice el comando Copiar pasos del menú de opciones del panel Historial. Si se copian pasos en un editor de texto, los pasos se pegan como código JavaScript™.™

  1. En el documento que contiene los pasos que va a volver a utilizar, seleccione los pasos en el panel Historial.
  2. En el menú de opciones del panel Historial, seleccione Copiar pasos.
  3. Abra el documento en el que va a pegar los pasos.
  4. Seleccione un objeto en el que va a aplicar los pasos.
  5. Seleccione Edición > Pegar para pegar los pasos. Los pasos se reproducen conforme se pegan en el panel Historial del documento. El panel Historial los muestra como un solo paso denominado Pegar pasos.
Logotipo de Adobe

Inicia sesión en tu cuenta