Guía del usuario Cancelar

Uso de ayudas visuales al diseñar

  1. Guía del usuario de Dreamweaver
  2. Introducción
    1. Conceptos básicos sobre diseño web adaptable
    2. Novedades de Dreamweaver
    3. Desarrollo web con Dreamweaver: información general
    4. Dreamweaver / Preguntas frecuentes
    5. Métodos abreviados de teclado
    6. Requisitos del sistema para Dreamweaver
    7. Resumen de funciones
  3. Dreamweaver y Creative Cloud
    1. Sincronizar la configuración de Dreamweaver con Creative Cloud
    2. Bibliotecas Creative Cloud en Dreamweaver
    3. Uso de archivos de Photoshop en Dreamweaver
    4. Trabajar con Adobe Animate y Dreamweaver
    5. Extraer archivos SVG optimizados para la Web desde bibliotecas
  4. Espacios de trabajo y vistas de Dreamweaver
    1. El espacio de trabajo de Dreamweaver
    2. Optimización del espacio de trabajo de Dreamweaver para la implementación visual
    3. Buscar archivos por nombre de archivo o contenido | Mac OS
  5. Configuración de sitios
    1. Acerca de los sitios de Dreamweaver
    2. Configuración de una versión local del sitio
    3. Conectar con servidores de publicación
    4. Configuración de un servidor de prueba
    5. Importación y exportación de la configuración de un sitio de Dreamweaver
    6. Traer sitios web existentes desde un servidor remoto a la raíz del sitio local
    7. Funciones de accesibilidad en Dreamweaver
    8. Ajustes avanzados
    9. Configuración de las preferencias de sitio para transferir archivos
    10. Especificación de la configuración del servidor proxy en Dreamweaver
    11. Sincronizar la configuración de Dreamweaver con Creative Cloud
    12. Uso de Git en Dreamweaver
  6. Administrar archivos
    1. Creación y apertura de documentos
    2. Administración de archivos y carpetas
    3. Carga de archivos al servidor y descarga desde el mismo
    4. Desprotección y protección de archivos
    5. Sincronizar archivos
    6. Comparación de archivos para detectar diferencias
    7. Ocultación de archivos y carpetas en el sitio de Dreamweaver
    8. Activación de Design Notes para sitios de Dreamweaver
    9. Prevención de la posible actuación repentina de Gatekeeper
  7. Maquetación y diseño
    1. Usar ayudas visuales al diseñar
    2. Información sobre el uso de CSS para diseñar la página
    3. Diseño de sitios web interactivos con Bootstrap
    4. Creación y uso de consultas de medios en Dreamweaver
    5. Presentación de contenido en tablas
    6. Colores
    7. Diseño interactivo mediante diseños de cuadrícula fluida
    8. Extract en Dreamweaver
  8. CSS
    1. Aspectos básicos de las hojas de estilos en cascada
    2. Diseño de páginas con el Diseñador de CSS
    3. Uso de preprocesadores de CSS en Dreamweaver
    4. Configuración de las preferencias de estilos CSS en Dreamweaver
    5. Mover reglas CSS en Dreamweaver
    6. Conversión de CSS en línea en una regla CSS en Dreamweaver
    7. Uso de etiquetas div
    8. Aplicación de degradados al fondo
    9. Creación y edición de efectos de transición de CSS3 en Dreamweaver
    10. Formatear código
  9. Contenido de página y activos
    1. Definición de las propiedades de la página
    2. Configuración de propiedades de encabezado CSS y propiedades de vínculo CSS
    3. Uso de texto
    4. Buscar y reemplazar texto, etiquetas y atributos
    5. Panel DOM
    6. Editar en la Vista en vivo
    7. Codificación de documentos en Dreamweaver
    8. Selección y visualización de elementos de la ventana de documento
    9. Configuración de las propiedades de texto en el inspector de propiedades
    10. Revisión ortográfica de una página web
    11. Uso de las reglas horizontales en Dreamweaver
    12. Añadir y modificar combinaciones de fuentes en Dreamweaver.
    13. Trabajo con activos
    14. Inserción y actualización de fechas en Dreamweaver
    15. Creación y gestión de activos favoritos en Dreamweaver
    16. Insertar y editar imágenes en Dreamweaver
    17. Adición de objetos multimedia
    18. Adición de vídeos en Dreamweaver
    19. Insertar vídeo HTML5
    20. Insertar archivos SWF
    21. Adición de efectos de sonido
    22. Insertar audio HTML5 en Dreamweaver
    23. Trabajar con elementos de bibliotecas
    24. Uso de texto árabe y hebreo en Dreamweaver
  10. Establecimiento de vínculos y navegación
    1. Acerca del establecimiento de vínculos y la navegación
    2. Vinculación
    3. Mapas de imágenes
    4. Vínculos de solución de problemas
  11. Widgets y efectos de jQuery
    1. Uso de interfaz de usuario y widgets móviles de jQuery en Dreamweaver
    2. Uso de efectos jQuery en Dreamweaver
  12. Programación de sitios web
    1. Acerca de la programación en Dreamweaver
    2. Entorno de programación en Dreamweaver
    3. Configuración de las preferencias de programación
    4. Personalización de los colores del código
    5. Escritura y edición de código
    6. Sugerencias de código y completado de código
    7. Contraer y expandir código
    8. Reutilizar código con fragmentos
    9. Depuración de código mediante linting
    10. Optimización del código
    11. Edición de código en Vista de diseño
    12. Trabajo con el contenido de Head para páginas
    13. Inserción del lado del servidor incluida en Dreamweaver
    14. Uso de bibliotecas de etiquetas en Dreamweaver
    15. Importación de etiquetas personalizadas a Dreamweaver
    16. Uso de comportamientos de JavaScript (instrucciones generales)
    17. Aplicación de comportamientos JavaScript incorporados
    18. Acerca de XML y XSLT
    19. Realización de transformaciones XSL del lado del servidor en Dreamweaver
    20. Realización de transformaciones XSL en el lado del cliente en Dreamweaver
    21. Adición de entidades de caracteres para XSLT en Dreamweaver
    22. Formatear código
  13. Flujos de trabajo de varios productos
    1. Instalación y uso de extensiones para Dreamweaver
    2. Actualizaciones integradas en Dreamweaver
    3. Insertar documentos de Microsoft Office en Dreamweaver (solo Windows)
    4. Trabajo con Fireworks y Dreamweaver
    5. Edición de contenido en sitios de Dreamweaver con Contribute
    6. Integración de Dreamweaver Business Catalyst
    7. Crear campañas de correo electrónico personalizado
  14. Plantillas
    1. Acerca de las plantillas de Dreamweaver
    2. Reconocimiento de plantillas y documentos basados en plantillas
    3. Crear una plantilla de Dreamweaver
    4. Crear regiones editables en plantillas
    5. Creación de tablas y regiones repetidas en Dreamweaver
    6. Usar regiones opcionales en plantillas
    7. Definición de atributos de etiqueta editables en Dreamweaver
    8. Creación de plantillas anidadas en Dreamweaver
    9. Edición, actualización y eliminación de plantillas
    10. Exportar e importar contenido xml en Dreamweaver
    11. Aplicación o eliminación de una plantilla de un documento existente
    12. Edición de contenido en plantillas de Dreamweaver
    13. Reglas de sintaxis de etiquetas de plantilla en Dreamweaver
    14. Configuración de preferencias de resaltado en regiones de plantillas
    15. Ventajas de usar plantillas en Dreamweaver
  15. Móvil y multipantalla
    1. Creación de consultas de medios
    2. Cambio de la orientación de página para dispositivos móviles
    3. Creación de aplicaciones web para dispositivos móviles con Dreamweaver
  16. Sitios, páginas y formularios web dinámicos
    1. Aspectos básicos de las aplicaciones web
    2. Configuración del ordenador para desarrollo de aplicaciones
    3. Solución de problemas de conexiones a bases de datos
    4. Eliminación de secuencias de comandos de conexión en Dreamweaver
    5. Diseñar páginas dinámicas
    6. Introducción a las fuentes de contenido dinámico
    7. Definir fuentes de contenido dinámico
    8. Añadir contenido dinámico a las páginas
    9. Cambio de contenido dinámico en Dreamweaver
    10. Visualización de registros de bases de datos
    11. Proporcionar datos en vivo y solucionar sus problemas en Dreamweaver
    12. Añadir comportamientos de servidor personalizados en Dreamweaver
    13. Crear formularios con Dreamweaver
    14. Uso de formularios para recopilar información de los usuarios
    15. Crear y activar formularios de ColdFusion en Dreamweaver
    16. Crear formularios web
    17. Compatibilidad mejorada con HTML5 para elementos de formulario
    18. Desarrollar un formulario con Dreamweaver
  17. Creación visual de aplicaciones
    1. Creación de las páginas maestra y de detalles en Dreamweaver
    2. Crear páginas de búsqueda y resultados
    3. Crear una página de inserción de registros
    4. Crear una página de actualización de registros en Dreamweaver
    5. Creación de páginas de eliminación de registros en Dreamweaver
    6. Usar comandos ASP para modificar una base de datos en Dreamweaver
    7. Crear una página de registro
    8. Crear una página de inicio de sesión
    9. Creación de una página para acceso exclusivo de usuarios autorizados
    10. Protección de carpetas en ColdFusion con Dreamweaver
    11. Uso de componentes de ColdFusion en Dreamweaver
  18. Prueba, vista previa y publicación de sitios web
    1. Vista previa de páginas
    2. Vista previa de páginas web de Dreamweaver en varios dispositivos
    3. Comprobación del sitio de Dreamweaver

 

Utilice las ayudas visuales para diseñar en Dreamweaver, que incluyen la configuración de las reglas y de las guías de diseño, así como la utilización de guías con plantillas, cuadrículas de diseño e imágenes de rastreo.

Establecimiento de reglas

Las reglas ayudan a medir, organizar y planificar el diseño. Pueden aparecer en los bordes izquierdo y superior de la página, expresadas en píxeles, pulgadas o centímetros.

  • Para activar y desactivar las reglas, elija Ver > Reglas > Mostrar/Ocultar.
  • Para cambiar el origen, arrastre a cualquier parte de la página el icono de origen de la regla (situado en la esquina superior izquierda de la vista Diseño de la ventana de documento).
  • Para restablecer el origen a su posición predeterminada, seleccione Ver > Opciones de vista de diseño > Restablecer origen.
  • Para cambiar la unidad de medida, seleccione Ver > Reglas y elija Píxeles, Pulgadas o Centímetros.

Establecimiento de guías de diseño

Las guías son líneas que puede arrastrar sobre el documento desde las reglas. Con ellas puede situar y alinear objetos de forma más precisa. También puede utilizar guías para medir el tamaño de los elementos de la página o emular los pliegues (áreas visibles) de los navegadores Web.

Con el fin de ayudarle a alinear elementos, puede ajustar elementos a las guías y ajustar guías a los elementos. (Los elementos deben tener posición absoluta para que funcione la función de ajuste.) También puede bloquear las guías para impedir que otro usuario las mueva accidentalmente.

Creación de una guía horizontal o vertical

  1. Arrastre la guía desde la regla correspondiente.
  2. Sitúe la guía en la ventana de documento y suelte el botón del ratón (vuelva a colocar la guía arrastrándola de nuevo).
    Nota:

    De manera predeterminada, las guías se registran como medidas absolutas en píxeles desde la parte superior o el lado izquierdo del documento y se muestran como relativas al origen de la regla. Para registrar la guía como porcentaje, presione la tecla Mayús mientras crea o mueve la guía.

Visualización u ocultación de guías

  1. Seleccione Ver > Guías > Mostrar guías.

Ajuste de elementos a las guías

  • Para ajustar elementos a guías, seleccione Ver > Opciones de vista de diseño> Guías > Ajustar a guías.
  • Para ajustar guías a elementos, seleccione Ver > Opciones de vista de diseño> Guías > Ajustar guías a elementos.
Nota:

Puede cambiar el tamaño de elementos, como elementos con posición absoluta (elementos PA), tablas e imágenes; los elementos cuyo tamaño cambia se ajustan a las guías.

Bloqueo o desbloqueo de todas las guías

Seleccione Ver > Opciones de vista de diseño> Guías > Bloquear guías.

Visualización y desplazamiento de una guía a una ubicación concreta

  1. Mantenga el puntero del ratón sobre la guía para ver su posición.
  2. Haga doble clic en la guía.
  3. Introduzca la nueva posición en el cuadro de diálogo Mover guía y haga clic en OK.

Visualización de la distancia entre guías

Presione Control (Windows) o Comando (Macintosh) y pase el puntero del ratón por cualquier lugar situado entre las dos guías.
Nota:

La unidad de medida es la misma que la utilizada para las reglas.

Emulación del pliegue (área visible) de un navegador Web

Seleccione Ver > Opciones de vista de diseño > Guías y luego seleccione un tamaño de navegador predefinido del menú.

Eliminación de una guía

Arrastre la guía hacia fuera del documento.

Cambio de la configuración de guías

  1. Seleccione Ver > Opciones de vista de diseño > Guías > Editar guías, establezca las siguientes opciones y haga clic en OK.

    Color de guías

    Establece el color de las líneas de la guía. Haga clic en la muestra de color y seleccione un color en el Selector de colores o escriba un número hexadecimal en el cuadro de texto.

    Color de distancia

    Especifica el color de las líneas que aparecen como indicadores de distancia al pasar el puntero del ratón entre las guías. Haga clic en la muestra de color y seleccione un color en el Selector de colores o escriba un número hexadecimal en el cuadro de texto.

    Mostrar guías

    Hace que las guías estén visibles en la vista Diseño.

    Ajustar a guías

    Hace que los elementos de la página se ajusten a las guías al mover los elementos por la página.

    Bloquear guías

    Bloquea las guías en el lugar en que se encuentran.

    Ajustar guías a elementos

    Ajusta las guías a los elementos de la página al arrastrar las guías.

    Borrar todo

    Borra todas las guías de la página.

Utilización de guías con plantillas

Cuando se añaden guías a una plantilla de Dreamweaver, todas las instancias de la plantilla heredan las guías. Las guías de instancias de plantilla, sin embargo, se consideran regiones editables para que los usuarios puedan modificarlas. La ubicación original de las guías modificadas en las instancias de plantilla se restaura cuando se actualiza la instancia con la plantilla maestra.

También puede añadir sus propias guías a instancias de una plantilla. Las guías añadidas de esta forma no se sobrescriben cuando la instancia de la plantilla se actualiza con la plantilla maestra.

Uso de la cuadrícula de diseño

La cuadrícula muestra una serie de líneas horizontales y verticales en la ventana de documento. Resulta útil para colocar objetos con precisión. Puede hacer que los elementos de la página con posición absoluta se ajusten automáticamente a la cuadrícula cuando los mueva y cambiar la cuadrícula o controlar el comportamiento de ajuste especificando una configuración. El ajuste funciona independientemente de si la cuadrícula se encuentra o no visible.

Visualización u ocultación de la cuadrícula

Seleccione Ver > Opciones de vista de diseño > Cuadrícula > Mostrar cuadrícula.

Activación o desactivación del ajuste

Seleccione Ver > Opciones de vista de diseño > Cuadrícula > Ajustar a cuadrícula.

Cambio de la configuración de cuadrícula

  1. Seleccione Ver > Opciones de vista de diseño > Cuadrícula > Configuración de cuadrícula.

  2. Configure las opciones y haga clic en OK para aplicar los cambios.

    Color

    Establece el color de las líneas de la cuadrícula. Haga clic en la muestra de color y seleccione un color en el Selector de colores o escriba un número hexadecimal en el cuadro de texto.

    Mostrar cuadrícula

    Hace que la cuadrícula esté visible en la vista Diseño.

    Ajustar a cuadrícula

    Hace que los elementos de la página se ajusten a las líneas de la cuadrícula.

    Espaciado

    Controla la separación entre las líneas de la cuadrícula. Introduzca un número y seleccione Píxeles, Pulgadas o Centímetros en el menú.

    Visualización

    Especifica si las líneas de la cuadrícula deben mostrarse como líneas o como puntos.

    Nota:

    Si no está seleccionada la opción Mostrar cuadrícula, la cuadrícula no aparecerá en el documento y los cambios no serán visibles.

Utilización de una imagen de rastreo

Puede utilizar una imagen de rastreo como guía para recrear un diseño de página creado en una aplicación gráfica como Adobe Freehand o Fireworks.

Una imagen de rastreo es una imagen JPEG, GIF o PNG que se sitúa en el fondo de la ventana de documento. Puede ocultar la imagen, configurar su opacidad y cambiar su posición.

La imagen de rastreo solo se encuentra visible en Dreamweaver; no puede verse en la página desde un navegador. Cuando está visible la imagen de rastreo, la imagen y el color de fondo reales no están visibles en la ventana de documento; no obstante, se encontrarán visibles cuando la página se muestre en un navegador.

Colocación de una imagen de rastreo en la ventana de documento

  1. Siga uno de estos procedimientos:
    • Seleccione Ver > Opciones de vista de diseño > Imagen de rastreo > Cargar.

    • Seleccione Archivo > Propiedades de la página y, a continuación, en la categoría Imagen de rastreo, haga clic en Examinar (situado junto al cuadro de texto Imagen de rastreo).

  2. Navegue hasta el archivo de imagen y haga clic en OK.

  3. En el cuadro de diálogo Propiedades de la página, especifique la transparencia de la imagen arrastrando el control deslizante Transparencia y luego haga clic en OK.

    Para cambiar a otra imagen de rastreo o cambiar la transparencia de la imagen de rastreo actual en cualquier momento, seleccione Archivo > Propiedades de la página.

Visualización u ocultación de la imagen de rastreo

Seleccione Ver > Opciones de vista de diseño > Imagen de rastreo > Mostrar.

Cambio de la posición de una imagen de rastreo

  1. Seleccione Ver > Opciones de vista de diseño > Imagen de rastreo > Ajustar posición.

    • Para especificar de forma precisa la posición de la imagen de rastreo, introduzca valores de coordenadas en los cuadros X e Y.

    • Para mover la imagen de píxel en píxel, utilice las teclas de flecha.

    • Para mover la imagen de cinco en cinco píxeles, presione Mayús y una tecla de flecha.

Restablecimiento de la posición de la imagen de rastreo

  1. Seleccione Ver > Opciones de vista de diseño > Imagen de rastreo > Restablecer posición.

    La imagen de rastreo regresará a la esquina superior izquierda de la ventana de documento (0,0).

Alineación de la imagen de rastreo con un elemento seleccionado

  1. Seleccione un elemento de la ventana de documento.
  2. Seleccione Ver > Opciones de vista de diseño > Imagen de rastreo > Alinear con selección.

    La esquina superior izquierda de la imagen de rastreo se alineará con la esquina superior izquierda del elemento seleccionado.

 Adobe

Obtén ayuda de forma más rápida y sencilla

¿Nuevo usuario?