Interface Overview

Learn about the interface and workspace of Substance 3D Designer.

Designer might seem intimidating at first, but, once you know what each part of the interface is for, it becomes much easier to understand.

A diagram showing a simplified version of Designer's UI layout, with labels pointing to each section.

A. Main Toolbar B. Explorer C. Graph D. Properties E. 2D View F. 3D View G. Library 

Nota:

You might not recognize some of the terms on this page. If you find an unfamiliar word or concept, check the Glossary for definitions or read about Core Concepts of Substance Designer.

Main Toolbar

Find primary menus and useful quick-access buttons.

The File menu lets you:

  • Save and open packages
  • Create packages and graphs
  • Reload all content
  • Quit the application

The Edit menu lets you Undo and Redo actions. The Edit menu also gives you access to the Preferences window where you can adjust application settings.

The Tools menu lets you adjust Substance Engine options. The Substance Engine is the process that calculates Substance graphs. In the Tools menu, you can pause, reset, and adjust settings of the Engine. The Tools menu also gives you access to the Plugin Manager.

The Windows menu lets manage the windows that make up the Designer interface. You can open new windows, toggle individual window visibility, or use Windows > Reset Layout to return Designer to its default state.

From the Help menu you can access resources such as Designer's documentation, tutorials, and release notes. You can also send us feedback and report bugs, or find more information on licensing and versions.

The Explorer Panel

Manage packages and resources.

Two examples of the right click menu open in the Explorer panel. The first image shows the right click menu for a package, the second image shows the right click menu for a graph.
The right click menu changes depending on which resource type you click on. On the left you can see the right click menu for a package, while on the right you can see the menu for a graph.

The Explorer panel is your main way of interacting with files and resources in Designer. 

The Explorer panel lists all opened packages and shows their content. Right click packages, graphs, or other resources for a context-sensitive menu. All resources have a set of standard options that includes

  • Opening
  • Closing
  • Renaming
  • Copying and pasting

Some resources have unique options that are only available in the right click menu. You can also right click an empty space in the Explorer panel to create a new, empty package.

There are buttons at the top of the Explorer panel to manage your resources. To enable these buttons, first select a package or graph.

If you click any resource, the Properties panel will update and show you the properties of the current selection.

You can open multiple Explorer panels. Use Windows > New Explorer to open another Explorer panel.

The Graph Viewport

Create and build node-based graphs.

A screenshot of Designer's graph window. This image shows the graph toolbar at the top of the window and the graph viewport below the toolbar.
The Graph Viewport consists of the Graph toolbar, and the Graph Display. The Node toolbar is a part of the Graph toolbar

The Graph viewport is where you'll spend most of your time in Designer. It displays the graphs you build or open with Designer, and is where you can add, remove, and organize nodes.

There are two distinct areas: the toolbar and the display area.

Graph Toolbar

A cropped screenshot of the Graph toolbar.

The graph toolbar holds tools to help manage your graph and many of the most commonly used nodes. To help simplify things, buttons with colored backgrounds are nodes while other buttons are tools. 

You can find the following tools on the main toolbar:

  •  Focus — brings your selection back in view. If you don't have a node selected, focus will instead show the entire graph. Focus helps you quickly navigate or find your selection. Hotkey F has the same function.
  •  Reset Zoom — sets the zoom level back to the default 1:1 level. Hotkey Z has the same function.
  •  Screenshot — save a PNG screenshot of your entire graph, with transparency. A file dialog will open so you can set the filename and location.
  •  Information — opens a dropdown where you can toggle Connector Names, Node Badges, Node Size, and Node Timings. When enabled, these options add information to Nodes in the display area.
  •  Search — search nodes and parameters within the graph by filtering on type and text.
  •  Highlight Flow — clarify which nodes are connected to the current selection. Unconnected nodes are dimmed.
  •  Node Toolbar — toggles display of the buttons for atomic nodes. 
  •  Parent Toolbar — toggles display of the Parent Resolution control in the toolbar.
  •  Link Creation Modes — lets you choose which of the three Link Modes to use (Standard, Material, or Compact Material). Keyboard shortcuts 1, 2, and 3 perform the same functions.
  •  Rectangle Links — toggles whether links are smooth curves or rectangular angles.
  •  Timing Control — allows you to reset timing displays. Timing Control is only relevant if Node Timings are enabled in the Information dropdown.
  •  Tools — allows you to access a drop-down list with miscellaneous options. 
    • Clean removes unused nodes from the graph.
    • Export Outputs brings up the Export dialog allowing you to export bitmap files.
    • Reexport Outputs performs a previous output again with the same options, without presenting you with the dialog.
    • PSD Exporter opens the additional PSD Exporter panel. The PSD Exporter panel appears to the right of the graph View.
  •  Thumbs Toolbar — toggles the display of the thumbnails options dropdown on the toolbar.
  •  Align Tools — toggles the display of the Align tools on the toolbar. The Align tools lets you align and organize your nodes on the graph's grid.

 

Node Toolbar

Nodes Toolbar

Click a node in the node toolbar to add it to the graph. The node toolbar holds Designer's atomic nodes. Atomic nodes are the fundamental nodes of Designer graphs, they're the building blocks you can use to create complex networks. For more information about nodes, see the Nodes Overview page.

Nota:

The node toolbar is just one way to add nodes, and there are many more nodes available beyond those in the toolbar. The Build a Graph article has more information.

Graph display

Graph View

The graph display area holds the nodes that make up the graph. Place and connect nodes to create a graph that generates your textures. 

Refer to the Build a Graph page for more information on working with the graph.

The Properties Panel

Modify context-sensitive properties.

Side by side screenshots of the properties panel. The first image shows the properties panel as it appears when the graph is selected. The second image shows how the panel appears when a blend node is selected.
The Properties panel changes appearance depending on what resource you have selected. The left image shows how the Properties panel appears with a graph selected. The right image shows how the Properties panel appears with a blend node selected.

The Properties panel is context-sensitive and displays parameters that change the behavior of your selected resource or node. Combined, the Graph panel and the Properties panel are where you'll spend most of your time in Designer.

Because of the high number of controls that can be shown at once, the Properties panel has categories to keep controls organized. Below you can read a description of the main categories:

  • Base parameters is a category present on graph resources and every node. It lets you change core parameters related to graph resolution and set-up. Some important ones are listed below.
    • Output Size - sets the resolution of the graph or node. 
    • Output Format - sets the format or precision of the graph or node. 
    • Tiling Mode - sets if an image will wrap outside of its boundaries.
    • Random Seed - changes the random seed used for procedural generation.

The behavior of base parameters depends on inheritance method (). Relative means the node's behavior is defined elsewhere (either by the graph, or by a previously connected node). Absolute means it's set using the parameter controls. If a base parameter is grayed out, it's probably because the inheritance mode is set to Relative.

  • Attributes contains metadata related to the graph or node. You can use metadata to create categories in the Library.
  • Input Parameters is only visible for graphs. You can find all your exposed parameters here.
  • Instance/Specific Parameters is only visible for nodes. The name differs between atomic and instance nodes, but the functionality is the same: it allows you to tweak settings specific to this node. You can change the color of a node's output, the opacity of a blend operation, or the scale of a noise for example.
  • Inputs is only visible for graphs. It lists all input nodes or exposed parameters and allows you to set up names and properties for them. 
  • Input Values is only visible for nodes. It allows you to add value inputs to a node. You only use input values in advanced workflows.
  • Outputs is only visible for graphs. It lists all output nodes (or slots) and allows you to set up names and properties for them from a central location.

2D Viewport

Get a context-sensitive image preview.

2D View

The 2D viewport displays the contents of your nodes. Double-click an image node in the graph and the 2D view displays the node's output.

Your interaction with the 2D viewport is limited to zooming and panning when zoomed in. You can zoom in and out by scrolling. Use the buttons in the lower right of the 2D viewport to control the zoom. You can also reset the zoom with the shortcut Z or focus on the canvas with F.

At the top of the 2D viewport you can find the following controls:

  •  Background Image — sets a background image to show if there are transparent pixels.
  •  Save View — lets you save the current image in the 2D viewport to a bitmap file.
  •  Copy to Clipboard — copies the 2D viewport's content to the clipboard. 
  •  Select Output — lets you switch between the different outputs of your node.
  •  Select UV set — allows you to select which UV channel to display. This button is grayed out unless Display UVs in 2D View from the 3D viewport's Scene menu is active.

At the lower-left of the 2D view, buttons with additional functions can be found:

  •  Channel Display — lets you toggle R, G, and B channels on and off. Best used in grayscale mode.
  •  Transparency display — toggles if transparent pixels show as a checker texture or as flat black.
  •  Grayscale/Color Toggle — switches between displaying the 2D viewport in color or in grayscale.
  •  Repeated Tiling — Tiles the image across the 2D viewport. This way you can find tiling artifacts easily. While your mouse is over the 2D viewport Spacebar acts as a shortcut.
  •  Use Physical Size — toggles use of physical size info for the display of the preview.
  •  Image Information — opens an image information panel, displaying exact values for pixels you hover the cursor over.
  •  Histogram — opens up a panel showing a Histogram analysis of the current preview.
  •  sRGB Toggle — toggles display in sRGB color space on or off.
  •  Premultiply Toggle — toggles pre-multiplying of pixels that have an alpha channel,  with the background color.

3D Viewport

Interact with a 3D preview of your full material.

3D View

The 3D viewport displays your material. Unlike the 2D Viewport, by default it uses the output maps of your graph to render a full material. In the 3D viewport you can see how your channels, like base color, normal, and roughness, combine to create a final result.

To view your material in the 3D Viewport, right-click on an empty area in the graph display area, and select View Outputs in 3D View. You can also send individual maps to the 3D View by right-clicking on the node and selecting View in 3D View

You can use a 3-button mouse and keyboard to interact with the viewport as follows:

  • Left-mouse drag orbits the camera around the mesh.
  • Drag with middle-mouse to pan the camera.
  • Right-mouse drag or scroll to zoom in and out from the mesh.
  • Keyboard shortcute F focuses the camera back on the central mesh, in case you lose track of it.
  • Ctrl + shift + right-mouse (Cmd + shift + right-mouse on Mac) rotates the environment lights.

The seven top menus are outlined below:

  • Scene lets you change the mesh displayed in the viewport. You can also save and load the state of the viewport. To view your custom mesh in the 3D Viewport, double-click it in the Explorer panel.
  • Materials shows you all material slots on your mesh and lets you choose what shader and parameters are used. In this menu you can set up options such as UV-tiling, height displacement, and non-PBR rendering.
  • Lights is a menu from early versions of Designer. The lights in this menu are disabled by default and we recommend not using them unless opening old files. Choose the Edit option to access light settings.
  • Camera lets you jump between pre-defined camera angles. It also lets you save out rendered captures from the 3D viewport. Choose Edit to change post-processing settings.
  • Environment has options to adjust the image-based lighting of the scene. To change the HDR image in the 3D View, drag-and-drop a resource from the 3D View category of the Library panel.
  • Display lets you change a few miscellaneous settings for the viewport, such as wireframe and resolution display.
  • Renderer is an important menu that allows you to change from real-time OpenGL rendering to GPU-accelerated IRay raytracing. When IRay is chosen as the renderer, more IRay options become available.

The Library Panel

Find resources for your graphs.

Library View

In the Library panel, you have access to all of Designer's default content. To better understand the different types of nodes in the library, look at the Nodes Overview.

You can add content from the Library to your graph by simply dragging it into the graph display area. You can also use the spacebar or tab keyboard shortcuts while hovering over the graph display area to open a menu to quickly search for nodes.

The Library panel's large thumbnails can help you when looking for content. Adjust thumbnail size with the dropdown in the upper right ().

What's next?

With the interface covered, you're ready to jump into the Core Concepts of Designer. 

Have a question or an idea?

If you have a question or an idea to share, join other Designer users in the Substance 3D Designer Community. Get help, make suggestions that could be incorporated into Designer, or show off your work and techniques.

If you have new ideas for Designer nodes or features, share them with us here!

Logotipo de Adobe

Inicia sesión en tu cuenta