Create a material

Learn how to use layers and filters to create a material in Substance 3D Sampler.

Sampler is a powerful tool for creating materials. With resources from the Starter Assets included with Sampler, you can create stunning results, or use the Image to Material workflow to bring the real world into 3D.

Workflows

With Sampler, you can create materials following two workflows:

  • Blend materials from the Assets panel or use filters to create something new.
  • Use the Bitmap to material tools to create a material based on an image or photograph.

Create a project

Sampler projects are containers that can hold materials and environment lights. Projects are a useful way to organize assets.

If you've just opened Sampler, you should see the Welcome Screen.

From the Welcome Screen, you can:

  • Choose Create New to make a new project. 
  • Choose Open to browse to an existing project.
  • See a list of recent projects that you've worked on in Sampler. Select a project to keep working on it.
  • Choose About Sampler to see details about your version of Sampler.
  • Choose Documentation to open Sampler's documentation.

If you don't see the Welcome Screen, you can create and open projects with the File menu. You can access the documentation and other helpful information from the Help menu.

Each new project in Sampler automatically opens with a blank material that should be visible in the viewport and the Project panel.

Create a material from Starter Assets

Sampler includes assets to help you get started. You can find them under Starter Assets in the Assets panel

Starter Assets contains two folders:

  • The Materials folder contains many materials such as snow, rust, wood, and denim. The Materials folder also holds some atlas materials for sticks, leaves, and pebbles. We'll explain how to use both types of material below.
  • The Filters folder holds filters that you can use to adjust or modify your materials. Filters can be simple like Blur or Invert, or more advanced like the Pavement Pattern filter.

To use assets in your project, add them to the layer stack. You can see the layer stack in the Layers panel. Newly created materials don't have any layers in the layer stack.

Work with the Layers and Properties panels to create a material

To start building your material you will need to add materials and filters to the layer stack. Below, we'll walk through the process of creating a garden path material.

To start your new material, add a Rock material layer to the layer stack:

  1. In the Assets panel, open Starter Assets.

  2. Open the Materials folder.

  3. Find the Rock material.

  4. Drag the Rock material over the viewport or into the layer stack. The Rock material will be added to the layer stack, and you should see the viewport update to display the Rock material.

How the rock layer appears in the viewport, the layer panel, and the properties panel.
The appearance of the rock layer in the Viewport, the Layers panel, and the Properties panel.

Adjust the parameters for this layer to add some visual interest:

  1. Select the Rock layer you created.

  2. In the Properties panel, there are parameters to control the appearance of the layer.

  3. Increase the Stone Color Variation to 1 by dragging the slider.

  4. Increase the Grain Intensity to 0.65 by dragging the slider.

Nota:

You can undo most changes in Sampler with ctrl + z (cmd + z on Mac). If you undo something unintentionally, you can redo it with ctrl + y (cmd + y on Mac). Undo and redo controls are also available in the Edit menu.

The material still looks a little bland, use a filter to take it up a notch.

  1. At the top of the Layers panel, click the Add a layer button.

  2. Type "pavement" into the search box.

  3. Select the Pavement Pattern filter.

You can also use the Assets panel to find the Pavement Pattern filter. Look under Starter Assets > Filters > Generator and drag it onto the viewport just like you added the Rock material.

As with the Rock layer, you can select the Pavement Pattern layer to adjust its parameters. Try changing the Pattern Type to find a style you like (we're using Brush Rock in the screenshots).

A screenshot of Sampler with the rock broken up by the pavement pattern filter.
The Pavement Pattern filter breaks up the rock to create a tileable pattern.

At the moment, the material looks too clean. Add some mud to help fix that. As with the rock layer, use the Assets panel to find the Mud material under Starter Assets > Materials. Add the Mud to the layer stack just like you added the Rock material earlier. 

The Mud material automatically blends with the rock path based on the height of both materials.

Notice that the mud layer has two icons:

  • Click the left icon to adjust the mud's appearance in the Properties panel.
  • Click the right icon to adjust the blend options, or how the mud blends with the layers beneath it.

To make the mud look more realistic, try to make it mainly fill the crevices and cracks between the rocks:

  • In your Pavement Pattern layer, decrease the Joint Height so that mud is visible between the rocks.
  • Select the blend options icon of the Mud Layer. Change the Offset value to adjust the amount of visible mud.
A screenshot of Sampler displaying the addition of the mud layer.
The material appearance after adjusting parameters in the Mud blend properties and the Pavement Pattern filter properties.

Finish this material by adding some detail. Let's add some scattered leaves. 

To add leaves, use a combination of a filter and a material. In the same way that you added the Pavement Pattern filter, add the Atlas Scatter filter to the layer stack.

The Atlas Scatter node uses another layer as an input. Notice that under the Atlas Scatter layer, there is a space that can hold a material. If the input is empty, the Atlas Scatter layer will have no impact on your material.

A screenshot of Sampler after adding the Atlas Scatter filter.
Notice the empty space under the Scatter Layer filter - this is where you can add an atlas material to scatter across your material.

With the Atlas Scatter material in the layer stack, look for the Dry Laurel Leaves material in the Assets panel. Drag the Dry Laurel Leaves material into the Atlas Scatter layer's input.

The Atlas Scatter filter scatters the leaves across your material. You can adjust how the leaves appear by selecting the Dry Laurel Leaves input. Adjust how the leaves scatter and blend with the rock path by selecting the Atlas Scatter layer.

Nota:

In computer graphics and animation, an atlas is a special type of material or image that holds a collection of individual elements.

A screenshot of Sampler after adding the leaves to the scatter filter.
Adjust the parameters of your layers to reach a result that you like. Try increasing the resolution at the top of the viewport to see your material in higher quality.

Congratulations, you've created a garden path material! Try adding more detail with sticks or pebbles. You can also use filters like Water and Snow to add different weather effects. When you're happy with your material, find out how to export it for other applications in this article.

Use the Bitmap to Material workflow

The Image to Material filter helps you to create materials from standard bitmap images. Follow the steps below to get started with Image to Material:

  1. Create a material.

  2. Drag an image into the layer stack from your file browser. If you have imported folders to the Assets panel, you can also add images from there.

  3. The Material Creation Template window appears. Select Image to Material and click Ok.

  4. Sampler will create layers for your material. The Image to Material (AI Powered) filter process the image layer beneath it to generate data for each of the material channels. 

  5. Tweak the parameters of the Image to Material (AI Powered) to fine tune values.

A screenshot of Sampler using the Image to Material workflow.
A basic example of Image to Material using a picture of mulch taken with a cellphone camera.

You now have the foundations of your material. To find out how to make your material tile or fix artifacts, watch this tutorial for more information.

What's next?

Now that you know how to create materials, you may want to use them in other applications. Find out how to export your assets here.

Have a question or an idea?

If you have a question or an idea to share, join other Sampler users in the Substance 3D Sampler Community. Get help, make suggestions, or show off your work and techniques.

If you have ideas for new Sampler features, share them with us!

Logotipo de Adobe

Inicia sesión en tu cuenta