What's covered

There are some known issues when you try to import or export Adobe Illustrator files with Adobe Fireworks. 

Fireworks Version

CS4, CS5

Import issues

  • Symbol libraries from Adobe Illustrator are not maintained.

    Workaround: Recreate the Document Library in Adobe Fireworks.
  • Some effects applied to objects in an Illustrator file are lost.

    Note: This can occur because the effect is not supported in Adobe Fireworks. Rasterizing the effect will remove edit ability but maintain the appearance.

    Workaround:
    1. In Adobe Illustrator, use the Selection tool to select objects that are not imported correctly into Adobe Fireworks.
    2. Choose Object > Rasterize.
    3. Choose a desired setting for the objects in the Rasterize dialog box and click OK.
    4. Re-save the file and import into Fireworks.
  • A second path is placed outside of the canvas when importing an AI file on a Japanese operating system.

    Workaround: After placing the AI file, select the second path and delete it.
  • AI elements are imported as a group when the file contains double-byte characters. Ungrouping the text will place each character in a separate text element.

    Workaround: Copy each text element and add it to a common Text Block.

Export issues

  • Indents and indent spacing are lost when exporting to the Adobe Illustrator format if the file contains double-byte characters.

    Workaround:
    1. In Adobe Fireworks, select the double-byte text block and choose Text > Convert to Paths.
    2. Choose File > Save As and select Illustrator <version number> from the Save As drop down list.
    3. Open the saved AI file in Illustrator.
  • Text Blocks are converted to plug symbols when exporting to the AI format if the file contains double-byte characters.

    Workaround:
    1. In Adobe Fireworks, select the double-byte text block and choose Text > Convert to Paths.
    2. Choose File > Save As and select Illustrator <version number> from the Save As drop-down.
    3. Open the saved AI file in Illustrator.
  • Vertical double-byte text is converted to horizontal text when exporting as an Adobe Illustrator 8 format.

    Workaround:
    1. In Adobe Fireworks, select the double-byte text block and choose Text > Convert to Paths.
    2. Choose File > Save As and select Illustrator <version number> from the Save As drop-down.
    3. Open the saved AI file in Illustrator.
  • Some effects applied to objects in Fireworks are lost when exporting to the Illustrator 8 format.

    Note: The font is rasterized on export in the PDF format.

    Workaround:
    1. Using Adobe Fireworks, choose File > Export.
    2. Select Adobe PDF and click Export.
    3. Open the saved PDF document in Illustrator.
  • Fonts are converted to Adobe Illustrator default font if the original file was exported from Adobe Fireworks in the AI format.

    Note: The font is rasterized on export in the PDF format.

    Workaround:
    1. Using Adobe Fireworks, choose File > Export.
    2. Select Adobe PDF and click Export.
    3. Open the saved PDF document in Illustrator.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy