November 2011

Adobe recommends that all users upgrade to the latest version of Adobe Flash Player for the most recent features, bug fixes, and security fixes. For more information on the new features in Flash Player 11, please visit www.adobe.com/products/flashplayer/.

For more information on system requirements, fixed issues, and known issues, see the release notes at www.adobe.com/go/flashplayer_releasenotes.

To confirm which version of Flash Player you have currently installed, see www.adobe.com/software/flash/about/.

Users should only install Players that have been downloaded from trusted sources, such as www.adobe.com/.

Your use of this player is governed by the Adobe End User License Agreement found at www.adobe.com/products/eulas/players/flash/.

Privacy

Adobe is committed to preserving the privacy of end users. For more information on configuring client-side privacy, visit the Settings Manager documentation.

Installation instructions

Installing using the plugin tar.gz

  • Unpack the plugin tar.gz and copy the files to the appropriate location.
  • Save the plugin tar.gz locally and note the location the file was saved to.
  • Launch terminal and change directories to the location the file was saved to.
  • Unpack the tar.gz file. Once unpacked you will see the following:
    • libflashplayer.so
    • /usr
  • Identify the location of the browser plugins directory, based on your Linux distribution and Firefox version
  • Copy libflashplayer.so to the appropriate browser plugins directory. At the prompt type:
    • $ cp libflashlayer.so <BrowserPluginsLocation>
  • Copy the Flash Player Local Settings configurations files to the /usr directory. At the prompt type:
    • $ sudo cp –r usr/* /usr

Install the plug-in using RPM:

  • As root, enter in terminal:
    • # rpm -Uvh <rpm_package_file>
    • Click Enter and follow prompts

Install the standalone player:

  • Unpack the tar.gz file
  • To execute the standalone player:
    • Double-click, or
    • Enter in terminal: ./flashplayer

Removal instructions

Manual removal (for users who installed the plug-in via Install script):

  • Delete libflashplayer.so binary and flashplayer.xpt file in directory /home/<user>/.mozilla/plugins/

RPM removal:

  • As root, enter in terminal:
    • # rpm -e flash-plugin
    • Click Enter and follow prompts

Internationalization

Flash Player 11 is internationalized for a number of languages. Flash Player determines the language setting from the environment variable LANG. If LANG is not set, the player defaults to English.

The following examples show two methods of setting the LANG environment variable for Spanish:

  • To set LANG in .bashrc: export LANG=spanish
  • To set LANG in .cshrc: setenv LANG es

These locales are currently recognized:



Language

Set LANG to

Or

English

C, LC, POSIX, english

en_*

German

de, deutsch, german

de_*

Spanish

spanish

es_*

French

francais, french

fr_BE, fr_CA, fr,FR, fr_LU

Italian

italian

it_IT, it_CH

Japanese

japanese

ja_JP

Korean

korean

ko_KR

Chinese Simp

-

zh_CN

Chinese Trad

-

zh_TW

To see the many options for en, de and es:

  • locale -a | grep en
  • locale -a | grep de
  • locale -a | grep es

Technical issues and reporting bugs

The Adobe Flash Player Support Center at www.adobe.com/support/flashplayer/ is a free online resource for support and troubleshooting information. Requests for technical assistance with installation should go through this site.

Developers can file Adobe Flash Player issues in the Flash Player Public Bug and Issue Management System.

The Flash Player Public Bug and Issue Management System is located at: https://bugbase.adobe.com/. An Adobe ID is required to submit and vote.

Additional Information

List of library dependencies for FP9 and FP10 on Linux

 

Flash Player 9 Dependencies

* libdl.so.2

* libpthread.so.0

* libX11.so.6

* libXext.so.6

* libXt.so.6

* libfreetype.so.6

* libfontconfig.so.1

* libgtk-x11-2.0.so.0

* libgobject-2.0.so.0

* libglib-2.0.so.0

* libm.so.6

* libc.so.6

* glibc>= 2.3

support for V4L1

 

Flash Player 10 Dependencies

* libdl.so.2

* libpthread.so.0

* libX11.so.6

* libXext.so.6

* libXt.so.6

* libfreetype.so.6

* libfontconfig.so.1

* libgtk-x11-2.0.so.0

* libgobject-2.0.so.0

* libglib-2.0.so.0

* libm.so.6

* libc.so.6

* glibc>= 2.3

* glibc>= 2.4

* libnss3

* cURL

support for V4L1

support for V4L2

 

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy