Working with markers

  1. Adobe Premiere Pro User Guide
  2. Beta releases
    1. Beta Program Overview
    2. Premiere Pro Beta Home
    3. Features in Beta
      1. New import & export in Premiere Pro (Beta)
      2. FAQ | New import and export in Premiere Pro (Beta)
  3. Getting started
    1. Get started with Adobe Premiere Pro
    2. What's new in Premiere Pro
    3. Release Notes | Premiere Pro
    4. Keyboard shortcuts in Premiere Pro
    5. Accessibility in Premiere Pro
  4. Hardware and operating system requirements
    1. Hardware recommendations
    2. System requirements
    3. GPU and GPU Driver requirements
    4. GPU Accelerated Rendering & Hardware Encoding/Decoding
  5. Creating projects
    1. Creating projects
    2. Open projects
    3. Move and delete projects
    4. Work with multiple open projects
    5. Work with Project Shortcuts
    6. Backward compatibility of Premiere Pro projects
    7. Open and edit Premiere Rush projects in Premiere Pro
    8. Best Practices: Create your own project templates
  6. Workspaces and workflows
    1. Workspaces
    2. Working with Panels
    3. Windows touch and gesture controls
  7. Capturing and importing
    1. Capturing
      1. Capturing and digitizing footage
      2. Capturing HD, DV, or HDV video
      3. Batch capturing and recapturing
      4. Setting up your system for HD, DV, or HDV capture
    2. Importing
      1. Transferring and importing files
      2. Importing still images
      3. Importing digital audio
    3. Importing from Avid or Final Cut
      1. Importing AAF project files from Avid Media Composer
      2. Importing XML project files from Final Cut Pro 7 and Final Cut Pro X
    4. Supported file formats
    5. Digitizing analog video
    6. Working with timecode
  8. Editing
    1. Sequences
      1. Create and change sequences
      2. Add clips to sequences
      3. Rearrange clips in a sequence
      4. Find, select, and group clips in a sequence
      5. Edit from sequences loaded into the Source Monitor
      6. Simplify sequences
      7. Rendering and previewing sequences
      8. Working with markers
      9. Scene edit detection
    2. Video
      1. Create and play clips
      2. Trimming clips
      3. Synchronizing audio and video with Merge Clips
      4. Render and replace media
      5. Undo, history, and events
      6. Freeze and hold frames
      7. Working with aspect ratios
    3. Audio
      1. Overview of audio in Premiere Pro
      2. Audio Track Mixer
      3. Adjusting volume levels
      4. Editing, repairing and improving audio using Essential Sound panel
      5. Monitor clip volume and pan using Audio Clip Mixer
      6. Audio balancing and panning
      7. Advanced Audio - Submixes, downmixing, and routing
      8. Audio effects and transitions
      9. Working with audio transitions
      10. Apply effects to audio
      11. Measure audio using the Loudness Radar effect
      12. Recording audio mixes
      13. Editing audio in the timeline
      14. Audio channel mapping in Premiere Pro
      15. Use Adobe Stock audio in Premiere Pro
    4. Advanced editing
      1. Multi-camera editing workflow
      2. Editing workflows for feature films
      3. Set up and use Head Mounted Display for immersive video in Premiere Pro
      4. Editing VR
    5. Best Practices
      1. Best Practices: Mix audio faster
      2. Best Practices: Editing efficiently
  9. Video Effects and Transitions
    1. Overview of video effects and transitions
    2. Effects
      1. Types of effects in Premiere Pro
      2. Apply and remove effects
      3. Effect presets
      4. Automatically reframe video for different social media channels
      5. Color correction effects
      6. Change duration and speed of clips
      7. Adjustment Layers
      8. Stabilize footage
    3. Transitions
      1. Applying transitions in Premiere Pro
      2. Modifying and customizing transitions
      3. Morph Cut
  10. Graphics, Titles, and Animation
    1. Graphics and titles
      1. Create titles and motion graphics
      2. Applying text gradients in Premiere Pro
      3. Using Motion Graphics templates for titles
      4. Replace images or videos in Motion Graphics templates
      5. Use data-driven Motion Graphics templates
      6. Best Practices: Faster graphics workflows
      7. Add Responsive Design features to your graphics
      8. Working with captions
      9. Speech to Text
      10. Speech to Text in Premiere Pro | FAQ
      11. Upgrade Legacy titles to Source Graphics
    2. Animation and Keyframing
      1. Adding, navigating, and setting keyframes
      2. Animating effects
      3. Use Motion effect to edit and animate clips
      4. Optimize keyframe automation
      5. Moving and copying keyframes
      6. Viewing and adjusting effects and keyframes
  11. Compositing
    1. Compositing, alpha channels, and adjusting clip opacity
    2. Masking and tracking
    3. Blending modes
  12. Color Correction and Grading
    1. Overview: Color workflows in Premiere Pro
    2. Get creative with color using Lumetri looks
    3. Adjust color using RBG and Hue Saturation Curves
    4. Correct and match colors between shots
    5. Using HSL Secondary controls in the Lumetri Color panel
    6. Create vignettes
    7. Looks and LUTs
    8. Lumetri scopes
    9. Display Color Management
    10. HDR for broadcasters
    11. Enable DirectX HDR support
  13. Exporting media
    1. Workflow and overview for exporting
    2. Quick export
    3. Exporting for the Web and mobile devices
    4. Export a still image
    5. Exporting projects for other applications
    6. Exporting OMF files for Pro Tools
    7. Export to Panasonic P2 format
    8. Exporting to DVD or Blu-ray Disc
    9. Best Practices: Export faster
  14. Working with other Adobe applications
    1. After Effects and Photoshop
    2. Dynamic Link
    3. Audition
    4. Prelude
  15. Organizing and Managing Assets
    1. Working in the Project panel
    2. Organize assets in the Project panel
    3. Playing assets
    4. Search assets
    5. Creative Cloud Libraries
    6. Sync Settings in Premiere Pro
    7. Using Productions
    8. How clips work across projects in a Production
    9. Consolidate, transcode, and archive projects
    10. Managing metadata
    11. Best Practices
      1. Best Practices: Working with Productions
      2. Best Practices: Learning from broadcast production
      3. Best Practices: Working with native formats
  16. Improving Performance and Troubleshooting
    1. Set preferences
    2. Reset preferences
    3. Working with Proxies
      1. Proxy overview
      2. Ingest and Proxy Workflow
    4. Check if your system is compatible with Premiere Pro
    5. Premiere Pro for Apple silicon
    6. Eliminate flicker
    7. Interlacing and field order
    8. Smart rendering
    9. Control surface support
    10. Best Practices: Working with native formats
    11. Knowledge Base
      1. Green and pink video in Premiere Pro or Premiere Rush
      2. How do I manage the Media Cache in Premiere Pro?
      3. Fix errors when rendering or exporting
      4. Troubleshoot issues related to playback and performance in Premiere Pro
  17. Monitoring Assets and Offline Media
    1. Monitoring assets
      1. Using the Source Monitor and Program Monitor
      2. Using the Reference Monitor
    2. Offline media
      1. Working with offline clips
      2. Creating clips for offline editing
      3. Relinking offline media

 

Add markers to clips, use markers to position and arrange clips, copy and paste markers, display marker comments, and share markers with After Effects.

Markers indicate important points in time and help you position and arrange clips. You can use a marker to identify an important action or sound in a sequence or clip. Markers are for reference only and do not alter the video.

The following types of markers are available in Premiere Pro:

Marker

Description

Comment

A comment or note about the selected part of the Timeline.

Chapter

Chapter markers in the project  allow viewers seeing the finished video use the markers to quickly jump to those points in the video.

Segmentation Marker

Segmentation markers help you define ranges in the video to automate workflows. For example, you can identify certain areas as being leader or as segment where commercials go.

Web Link

Add a URL that provides more info about the selected part of the movie clip.

You can add markers to a sequence, or to a source clip. Markers are color-coded for easier identification.

Markers panel

Use the Marker panel (Window > Markers) to see all the markers in an open clip or sequence. Details associated with clips such as color-coded tags, In points, Out points, and comments are displayed. Clicking a clip thumbnail in the Markers panel moves the playhead to the location of the corresponding marker.

Note:

Click a marker in the Markers panel, and then the playhead moves to that position of marker in the Timeline.

A marker on a clip or in a sequence shows the In and Out points in the Marker panel. You can scrub the In or Out point to turn the marker from a single frame in time to one covering a range of time.

Add markers in the Timeline

You can add markers on the Source monitor, Program monitor, or on the Timeline. Markers added to Program monitor are reflected in the Timeline. Similarly, markers added to the Timeline are reflected on the Program Monitor.

In Premiere Pro, multiple markers can be added, allowing a user to add multiple notes and comment on clips on the same location in the Timeline.

  1. Move the playhead to the point where you want to add a marker.

  2. Select Marker > Add Marker, or press the M key. The default color of a marker is green.

  3. To edit the marker, double-click the marker icon to open the Marker dialog box.

    Note:

    You can create a keyboard shortcut to open the Marker dialog box.

  4. Set any of the following options:

    Name

    Type a name for the marker.

    Duration

    Drag the duration value or click the value to highlight it, type a new value, and press Enter/Return. When using markers for URL links and chapter markers, you can set sequence markers to be longer than one frame in duration.

    Comments

    Type a comment you want associated with the marker.

    Chapter Marker

    Check this box if you want to make the marker a chapter marker.

    Web Link

    Check this box if you want to associate the marker with a hyperlink.

    URL

    This field is enabled only when Web Link is checked. Enter the address of the web page you want to open.

    Note:

    When the movie is included in a web page and the marker is reached in the movie, the web page automatically opens. Web links work only with supported formats such as QuickTime.

    Frame Target

    This field is enabled only when Web Link is checked. Enter the target frame for a web page if using an HTML frameset.

  5. To enter comments or specify options for other sequence markers, click Prev or Next.
  6. Click OK.

Add markers to clips

Markers can be added to clips in the Source Monitor, or selected clips in the Timeline.

To add a marker to a clip in the Source Monitor, do the following:

  1. Open the clip in the Source Monitor from the Timeline or the Project panel.

  2. Place the Playhead where you want to place the marker.

  3. Choose Marker > Add Marker, or press M. The marker is added to the clip.

To add a marker to a clip in the Timeline, do the following:

  1. Set up a keyboard shortcut for Add Clip Marker in Edit > Keyboard Shortcuts (Windows), or Premiere Pro > Keyboard Shortcuts (macOS).

  2. Select the clip. Place the Playhead where you want to place the marker.

  3. Press the keyboard shortcut you created for Add Clip Marker. The marker is added to the clip.

You can inspect the marker dialog box by double-clicking the marker in the Source Monitor.

Create markers in the Effect Controls panel

In the Effect Controls panel, you can view all of the markers that you created in the Timeline panel. You can also add markers to your sequence to designate where you would like to place effects in the Effect Controls panel. In addition, you can create and manipulate markers directly in the Effect Controls panel.

  1. Drag the playhead to the place where you want to create a marker.

  2. Right-click (Windows) or Control-click (Mac OS) in the timeline ruler. Then select Add Marker, or press the M key.

Change default marker colors

The default color of a marker is green. To change this preference, you can set keyboard shortcuts for each marker color.

  1. Open the Keyboard Shortcuts dialog box. 

    • In Windows, choose Edit > Keyboard Shortcuts.
    • In macOS, choose Premiere Pro > Keyboard Shortcuts.
  2. In the Command section, add keyboard shortcuts for each different marker color.

    Adding keyboard shortcuts for different marker colors
    Adding keyboard shortcuts for different marker colors

For more information, see Customize keyboard shortcuts.

Find, move, and delete markers

You can find markers by using the marker navigation tools. You can move them from their original locations by dragging them, or you can delete them altogether.

Navigate among markers

  1. Click the marker icon.

  2. Do one of the following:

    • Select Marker > Go to Next Marker.
    • Select Marker > Go to Previous Marker.

Move a marker

  1. Do one of the following:
    • To move a clip marker in a clip that’s in a sequence, open the clip in the Source Monitor and drag the Marker icon in the Source Monitor’s time ruler. (You can’t manipulate clip markers in the Timeline panel).
    • To move a sequence marker, drag the marker in a Timeline panel or the Program Monitor’s time ruler.
    • Dragging a marker in the Source or Program Monitor’s time ruler moves the corresponding marker icon in a Timeline panel.
    Note:

    Sequence markers in a nested sequence appear as clip markers (with a slightly different color) in the parent sequence and in the Source Monitor. To adjust a nested marker, open the nested sequence in a Timeline panel, and then drag the marker.

Delete markers

  1. Do one of the following:
    • To delete a clip marker, cue the playhead to the clip marker, and then open the clip in the Source Monitor.
    • To delete a sequence marker, cue the playhead to the marker.
  2. To clear a marker, select Marker > Clear Selected Marker. To clear all the markers, select Marker > Clear All Markers.

    When you use the Clear All Markers option, Premiere Pro removes all sequence markers and all clip markers on selected clips.

    Note:

    You can’t remove a sequence marker by dragging it away from the time ruler.

    Note:

    Clear a marker by right-clicking (Windows), or Ctrl-clicking (Mac OS) on a marker, and then choose Clear Current Marker from the context menu.

Display marker comments

Once a marker is set, hovering over it in the time ruler produces a tool tip which displays the marker information. You can quickly scan marker contents without opening the Marker dialog box.

The sequence marker tool tip displays the following information on up to four items:

  • Marker name (optional, shown only if entered)

  • Timecode start (always displayed)

  • Duration (optional, shown only if the marker has a duration)

  • Comment text (optional, shown only if entered)

Note:

When the Show Audio Time Units option is selected, the tool tips show marker location and duration in audio time units instead of timecode units.

Copy and paste sequence markers

You can include sequence markers when copying and pasting items from the timeline to bring all markers and their information along with a single copy/paste action. All marker information such as color, notes, duration, marker type, is preserved during the copy/paste operation.

To include sequence markers during copy/paste, check Markers > Copy Paste Includes Sequence Markers.

Option to include sequence markers during copy and paste
Option to include sequence markers during copy and paste

The start time of a marker, and whether that start time lies within the range inclusively defined by an In and Out point or one or more selected items, is what determines if the marker is included while copying and pasting.

Here is an example indicating when the (red) marker is included.

Example where the red marker is included during copy and paste operations
Example where the red marker is included during copy and paste operations

In the below example, if you copy and paste the feet_fountain.MOV clip, only the red marker is included in the copy and paste operation.

Example where the purple marker is excluded during copy and paste operations
Example where the purple marker is excluded during copy and paste operations

View sequence timecode for Marker panel

You can view sequence timecodes for your clip markers in the markers panel so that you can accurately pinpoint to markers in the timeline. Clip markers from the timeline only appear in the markers panel when a clip is highlighted.

To display sequence timecode:

  • In the markers panel menu, select the Sequence Timecode option. The marker panel timecode display changes from clip to sequence timecode.

When in sequence timecode mode, only the clip markers in the current sequence are displayed in the Markers panel. Any clip markers outside the in/out range of a clip are not shown. Sequence timecode automatically updates if sequence timebase is changed.

Sharing markers with After Effects

You can share markers between Premiere Pro and After Effects in any of the following ways.

  • When you import a Premiere Pro project into After Effects, After Effects converts the sequence markers to composition markers.

  • When you copy a sequence from a Premiere Pro Project panel and paste it into After Effects, the resulting composition keeps the sequence markers as composition markers, and the clip markers as layer markers. The copy-and-paste operation therefore preserves the markers in the way you would expect.

  • When you export a sequence from Premiere Pro through Adobe Media Encoder into a container format, such as AVI, the sequence markers are saved into the file as XMP temporal metadata. When you use the video file as the source for a layer, After Effects converts these sequence markers to layer markers.

Filter markers by color

Premiere Pro allows you to filter markers in the markers panel by color. To display only those colored markers in the list, click one or more of the colored checkboxes at the top of the Markers panel .   

Adobe logo

Sign in to your account