在執行階段共享元件庫資源

關於執行階段共享元件庫資源

共享元件庫資源可讓您將來自某個 FLA 檔案中的資源用於另一個 FLA 檔案中。這在下列狀況中很有用:

  • 當一個以上的 FLA 檔案必須使用相同的圖案或其他資源時。

  • 當設計人員與開發人員希望可以在不同的 FLA 檔案中編輯聯合專案的圖稿與 ActionScript 程式碼時。

程式庫資源的共享方式如下:

  • 關於執行階段共享資源的部分,來源文件中的資源會以外部檔案的形式,在目的文件中形成連結。執行階段的資源會在文件播放時 (亦即執行階段),載入目的文件中。當您在編寫目的文件時,即使區域網路尚未提供包含共享資源的來源文件亦無妨。您必須將來源文件發佈至 URL 上,目的文件方能於執行階段取得共享資源。

使用執行階段共享資源

使用執行階段共享元件庫資源涉及兩道程序:第一,來源文件的作者定義來源文件中的共享資源,並輸入資源的識別名稱字串和要發佈來源文件的 URL (只限 HTTP 或 HTTPS)

第二,目的文件的作者定義目的文件中的共享資源,並輸入和用於來源文件中的共享資源相同的識別名稱字串和 URL。不然,目的文件的作者也可以將共享資源從已發佈的來源文件拖曳到目的文件的元件庫中。「發佈」設定中的 ActionScript 版本設定必須與來源文件的 ActionScript 版本相符。

無論是哪種情況,都必須將來源文件發佈到指定的 URL,讓目的文件可以取得共享資源。

定義來源文件中的執行階段共享資源

若要定義來源文件中資源的共用屬性,以便讓資源可以連結到目的文件,請使用「元件屬性」對話方塊或「連結屬性」對話方塊。

  1. 開啟來源文件,選取「視窗 > 元件庫」:
  2. 請執行下列其中一項:
    • 在「元件庫」面板中選取某個影片片段、按鈕或圖像元件,然後在「元件庫面板」選單中選取「屬性」。請按一下「進階」。

    • 選取字體元件、聲音或點陣圖,然後在「元件庫面板」選單中選取「連結」。

  3. 對於「連結」,選取「匯出給執行階段共享」讓資源可以連結到目的文件。
  4. 輸入元件的識別名稱。請勿輸入空格。連結至目的文件時,Animate 便會使用此名稱來辨識出該資源。

    註解:

    Animate 也會使用連結識別名稱,辨識 ActionScript 中當做物件使用的影片片段或按鈕。 

  5. 輸入將發佈包含共享資源之 SWF 檔的 URL,然後按一下「確定」。

    發佈 SWF 檔時,您必須將 SWF 檔發佈至您指定的 URL,這樣目的文件才能取得共享資源。

若要連結至共享資源,您可以輸入其 URL 或將該資源拖曳至目的文件中。

  1. 在目的文件中,選取「視窗 > 元件庫」。
  2. 請執行下列其中一項:
    • 在「元件庫」面板中選取某個影片片段、按鈕、圖像元件、點陣圖或聲音,然後在「元件庫面板」選單中選取「屬性」。請按一下「進階」。

    • 選取字體元件,然後在「元件庫面板」選單中選取「連結」。

  3. 關於「連結」的部分,請選取「匯入給執行階段共享」,連結至來源文件中的資源。
  4. 請輸入元件、點陣圖或聲音的識別名稱 (與來源文件中元件使用的識別名稱相同)。請勿輸入空格。
  5. 輸入將發佈包含共享資源的 SWF 來源檔案的 URL,然後按一下「確定」。
  1. 在目的文件中,執行下列步驟之一:
    • 選取「檔案 > 開啟舊檔」。

    • 選取「檔案 > 匯入 > 開啟外部元件庫」。

  2. 選取來源文件,再按一下「開啟」。
  3. 將共享資源從來源文件「元件庫」面板拖曳到目的文件的「元件庫」面板中或舞台上。

關閉目的文件中某個元件的共享

  1. 請在目的文件中,選取「元件庫」面板中的連結元件,然後執行下列步驟之一:
    • 如果資源是影片片段、按鈕或圖像元件,請在「元件庫面板」選單中選取「屬性」。

    • 如果資源是字體元件,請在「元件庫面板」選單中選取「連結」。

  2. 取消選取「匯入給執行階段共享」,然後按一下「確定」。

在編寫階段共享程式庫資源

在編寫階段共享資源有下列優點:

  • 避免在多個 FLA 檔案中使用資源的不同複本。例如,如果您要開發適用於網路瀏覽器的 FLA、適用於 iOS 的 FLA,以及適用於 Android 的 FLA,則可以在這 3 個檔案之間共用資源。

  • 如果您在其中一個 FLA 檔案中編輯共享資源,然後開啟或切換到其他使用此資源的 FLA 檔案,那些 FLA 檔案中就會反映更改結果。

在編寫階段,有 2 種方法可以共享元件庫資源:

  • 從另一個 FLA 檔案中的元件連結至外部 FLA 檔案中的元件,以使用外部 FLA 檔案中的元件。

  • 在「專案」面板中,在屬於同一個 Animate 專案的 FLA 檔案之間共享元件。如需有關使用「專案」面板的資訊,請參閱使用 Animate 專案

透過連結至不同 FLA 檔案中的元件來進行分享的運作方式如下:

  • 針對在編寫階段共享的資源,您使用區域網路上可用的其他任何 FLA 檔案中的任何元件,更新或取代您正在編寫的 FLA 檔案中的任何元件。

  • 您可以在編寫文件時更新目的文件中的元件。

  • 目的文件中的元件會沿用它原本的名稱和屬性,但它的內容會以所選取的元件內容更新或取代。

使用「專案」面板來分享元件的運作方式如下:

  • 在「專案」面板中建立專案,然後在專案中建立 FLA 檔案。

  • 在該 FLA 中,透過在「元件庫」面板中核取每個所需項目的共用核取方塊,您指定要與其他檔案共用的元件。

  • 在專案中建立第二個 FLA 檔案。

  • 將第一個 FLA 檔案中舞台上的圖層、影格或項目複製並貼到第二個 FLA 檔案。

  • Animate 會將所貼上元素中的共享元件庫項目,移動到專案資料夾內另一個名為 AuthortimeSharedAssets.FLA 的檔案。

在專案內可以共享下列資源類型:

資源類型

可單獨共享?

在影片片段內時可共享?

影片片段元件

圖像元件

按鈕元件

字體元件

FLV 視訊

內嵌視訊

聲音 (任何格式)

點陣圖 (任何格式)

編譯後的影片片段 (SWC)

組件 (以元件為基礎)

更新或取代共享元件

您可以使用可在區域網路上存取之 FLA 檔中的元件,更新或取代文件中的影片片段、按鈕或圖像元件。目的文件中的元件會沿用原本的名稱和屬性,但元件的內容會以所選取元件內容取代。選取的元件所使用的任何資源,也會複製到目的文件中。

  1. 開啟文件之後,在「元件庫」面板中選取影片片段、按鈕或圖像元件,然後從面板的「選項」選單中選取「屬性」。
  2. 如果沒有顯示「元件屬性」對話方塊的「連結」和「來源」區域,請按一下「進階」。
  3. 如果要選取新的 FLA 檔,請按一下「瀏覽」。
  4. 瀏覽至包含要用來更新或取代「元件庫」面板中所選取元件的 FLA 檔,然後按一下「開啟」。
  5. 瀏覽至某個元件,然後按一下「確定」。
  6. 請執行下列其中一項:
    • 在「元件屬性」對話方塊的「來源」底下,選取「發佈前一定更新」,然後按一下「確定」。

    • 在「元件屬性」對話方塊的「製作階段共享」底下,選取「自動更新」,然後按一下「確定」

定義在專案中共享的資源

在專案中的 FLA 檔案之間共享資源時,您可以在一個檔案中編輯資源,然後看到更改反映在其他使用此資源的 FLA 檔案中。

  1. 建立 Animate 專案。 

  2. 在專案的 FLA 檔案中,針對您要與專案中其他 FLA 檔案共用的每個元件庫資源,執行下列其中一個步驟:

    • 開啟「元件庫」面板,然後選取資源名稱旁的「連結」核取方塊。

    • 在「元件庫」面板中選取資源後,從面板的「選項」選單中選擇「屬性」,然後按一下「與專案共用」按鈕。

  3. 在時間軸或舞台上,複製包含共享資源的圖層、影格或舞台項目。

  4. 在同一個專案的另一個 FLA 檔案中,將圖層、影格或舞台項目貼到同一個專案的另一個 FLA 檔案中。

視訊與教學課程

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策