問題

開啟任何 Adobe 應用程式時,您收到「您必須安裝 Java SE 6 執行階段」錯誤訊息。

Legacy Java error

解決方法

若為 Mac OS 10.7 (Lion) 和更新版本,Java 執行階段已不會在安裝作業系統時一併自動安裝。請使用以下任一方法安裝 Java 執行階段。

方法 1

您可以從 Java 網站下載並安裝最新的 Java 執行階段 - 下載免費 Java 軟體

註解:

如果是 Mac OS 10.10 (Yosemite),則您在啟動任何 Adobe 產品時,可能會收到「應用程式已被移動,而且其路徑已更改...」的警告訊息。

按一下「立即修復」「更新」按鈕即可更新位置並解決問題。出現密碼提示時,請輸入您的系統密碼以完成操作。

應用程式遭移動的警告訊息

方法 2

如果未安裝 Java 執行階段,系統就會在您首次啟動任何 Adobe 時提示您安裝。請遵循 Java 要求通知對話方塊中的螢幕指示進行安裝。

方法 3 (Mac OS 10.7 和 10.8)

使用下列方法可啟動 Java 執行階段安裝或確認是否已成功安裝。

  1. 前往「應用程式 > 公用程式 > Java 偏好設定」。
  2. 開啟「Java 偏好設定」。
  3. 如果未安裝 Java,您就會收到以下訊息:「若要開啟『Java 偏好設定』,您必須安裝 Java 執行階段。您要立即安裝嗎?」

    「未安裝 Java」訊息
  4. 按一下「安裝」並接受授權合約。此時會下載並安裝 Java 執行階段。
    Java 下載進度
    「Java 偏好設定」顯示 Java 已安裝

其他資訊

許多 Adobe 應用程式需要 Oracle Java Runtime Environment (JRE) 才能讓部分功能運作。Apple 最近變更了 Mac OS 中包含 Java 的方式,而且 Lion 版本已不再預先安裝 Java,而是您必須選取的選用安裝項目。 

由於我們已在 Apple 進行這些變更之前建立了現行的 Adobe 安裝程式及應用程式,因此 Adobe 軟體會預期系統已安裝 Java。Adobe 和 Apple 已共同合作,確保您可以在安裝 OS 時一併安裝 Java。或者,您也可以在日後安裝 Adobe 應用程式前安裝 Java。在執行階段中,如果您在尚未安裝 Java 的情況下啟動 Adobe 應用程式,系統就會提示您進行安裝。如果您沒有先安裝 Java 便執行 Adobe 應用程式,部分功能可能會遺失或運作異常。如果您遇到任何問題,請安裝 Java 予以修正。Adobe 建議企業的 IT 部門預先安裝 Java (或確認 Java 可透過防火牆/安全防護安裝 Java),以避免 Adobe 應用程式出現衝突。

如果未安裝 Java 執行階段,會出現的部分已知問題如下 -

  • 啟動失敗。
  • 嘗試使用應用程式時出現安裝 Java 執行階段的提示。
  • 應用程式當機或結束。

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策