Puppets are the objects/characters that are created from your Photoshop or Illustrator artwork, and are what you control to create a performance. At any time, you can switch to Photoshop or Illustrator to make artwork changes or use tagging in Character Animator to control behavior.

A puppet has layers, some of which are groups. The layers that have twirl-down arrows are referred as groups. You can select layers to modify their properties, assemble a puppet from parts in the Project panel (including parts from multiple puppets or artwork files), rearrange and reposition layers, and hide or show layers.

You can create a puppet from a properly structured artwork file or by starting with a blank puppet and building it from pieces of other puppets or imported artwork files. You can also duplicate a puppet to create a different version for additional work.

You can then select layers and handles and assign them tags to control their behavior. For information on assigning tags, see Prepare artwork.

Characterizer, powered by Adobe Sensei, generates a stylized Character Animator puppet in seconds. Webcam-captured image of the user and any piece of reference art is used to generate puppets. For more information, see Create puppet using Characterizer.

Create a puppet in Character Animator from your artwork

To create a puppet from a PSD or AI file:
  1. Choose File > Import (Cmd/Ctrl+I).

  2. Select one or more .ai or .psd files, then click Open.

    For each selected artwork file, a puppet (named after the artwork’s filename) is created in the Project panel.

Create a puppet from a template

To create a puppet from a template PSD or AI file, use the Chloe puppet link in the Start workspace. A copy of the template PSD or AI file is copied to the project folder, imported into the project, added to a new scene, and the PSD or AI file is opened in Photoshop or Illustrator for making changes. After saving changes to the file, switch back to Character Animator. The puppet updates to match.

Create an empty puppet

To create an empty puppet, choose Puppet > New Empty Puppet, then name the puppet item.

Note:

An empty puppet does not have any default behaviors applied.

Duplicate a puppet

To duplicate a puppet, select it, then choose Edit > Duplicate (Cmd/Ctrl+D).

Duplicating a puppet item in the Project panel makes a separate copy of all groups and layers in the puppet. This allows you to keep changes in one puppet from affecting the duplicate puppet.

Share a puppet

Share a puppet with other Character Animator users by exporting your puppet as a .puppet file. The puppet file is a ready-to-import, self-contained file that includes all the artwork associated with the puppet.

  1. In the Project panel, select or open the puppet.

  2. Choose File > Export > Puppet and name the .puppet file.

  3. Send the .puppet file to the other user via shared link or any other sharing method.

  4. To open a shared puppet, import the .puppet file via File > Import or by dragging it into the Project panel.

    Note:

    • You can relink the puppet to a shared instance of the artwork.
    • Parameter changes to a puppet when selected in the timeline, or any recorded takes for a puppet track, are not included in a .puppet file.
    • Behaviors that are on the imported puppet are updated to use the versions of the behaviors available in the current project.

Cycle puppets

Create a cycle-enabled puppet from a sequence of images (in PNG format) that you want to use with the Cycle Layers behavior. This behavior displays each of the puppet’s layers in order which can be useful to repeat a pattern.

Create a cycle puppet

  1. Open a puppet in the Puppet panel and click Add Cycle or choose File > Import Cycle

  2. If you are creating the cycle puppet using the Add Cycle option, choose a PNG or JPEG file from your sequence.

    Note:

    Sequences are PNG files with the same base name and a numerical suffix, such as Flap001.png, Flap002.png, and so on.

    A puppet with Cycle Layers applied and named after the PNG or JPEG sequence is created in the Project panel, and then added above the currently selected layer in the Puppet panel.

  3. If you are creating the cycle puppet using the Import PNG Cycle option, drag the created cycle puppet from the Project panel into the puppet in the Puppet panel.

    Note:

    • Cycle puppets created using the Import Cycle menu command and have the Cycle Layers behavior’s Start parameter set to Immediately so that adding the puppet to a scene automatically shows the cycle. 
    • Cycle puppets created using the Add Cycle button have the Start parameter set to When Triggered, which is useful if the cycle willbe triggered via key press.
    • All the layers except the first layer in the cycle puppet are turned off by default, and all the layers are set to Hide Others in Group so that clicking a layer’s eyeball automatically hides the previously displayed layer.

Place puppets in a scene

View and control a puppet by first placing it in a scene. You can place multiple puppets in a scene.

To place a puppet in a scene, do one of the following:

  • Select the puppet in the Project panel, then click Add to New Scene or choose Object > Add to New Scene.
  • Drag the puppet from the Project panel into the scene open in the Scene or Timeline panel.
  • If the Scene and Timeline panels are empty (that is, no scene is open), the dragged puppet is added to a new scene.
  • Drag the puppet into an existing scene listed in the Project panel.

The puppet appears in the scene, and a track item for the puppet appears and is selected in the Timeline panel. It is via this track item that you can adjust parameters specific to this instance of the puppet.

Note: The imported puppets are positioned at the center of the scene by default. Use the Transform behavior option to reposition a puppet in its scene.

Edit a puppet’s original artwork

The artwork associated with a puppet can be updated without needing to re-create a puppet and any applied behaviors and behavior parameter changes from scratch.

To edit the puppet's artwork, follow these steps:

  1. Select the puppet in the Project panel or the puppet layer in the Puppet panel, then choose Edit > Edit Original (Cmd/Ctrl+E). If you have your puppet file open in Photoshop or Illustrator, you can directly go and make edits to the files there and the changes are automatically synced. The default application associated with the puppet’s artwork (for example, Photoshop for .psd files, Illustrator for .ai files) launches. Open the artwork.

  2. Modify the artwork as needed, then save your changes. It is important to save changes made in artwork files for the changes to appear in Character Animator.

  3. Switch back to Character Animator. The modified file should be automatically detected and updated.

  4. If Character Animator does not detect your updated artwork, wait a few seconds.

Video: Building a puppet from scratch

Video: Building a puppet from scratch
Dave Werner

Note: The Building A Puppet From Scratch tutorial video helps you learn how to build a puppet in Photoshop from scratch and watch it come to life in Adobe Character Animator.

When a puppet is selected in the Project or opened in the Puppet panel, the Puppet section of the Properties panel shows the path for the source artwork and the tooltip shows the full path. If the artwork file cannot be found, the file name appears in yellow, with the tooltip prefix with Missing.

To relink or replace the source artwork, click the file name in the Properties panel, then select the artwork file to use.

Replace a puppet track’s source puppet

You can update or replace a puppet in a timeline, even after recording takes for it. This allows you to retain existing recordings while adding new content to a puppet, as long as the general puppet structure is retained.

To replace a puppet track’s source puppet, do either of the following:

  • Select the puppet track in the timeline. Then, hold down Option (Mac) or Alt (Win) as you drag that puppet onto the selected puppet track in the Timeline panel.
  • Select the replacement puppet in the Project panel. Then, right-click in the track header (left-side) area of the puppet track, and choose Replace with Selected Puppet in Project Panel.

Any recorded takes for parts of the original source puppet that no longer exist in the replacement puppet are removed.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy