Issue

In Photoshop, when you try and create HDR images using Merge To HDR Pro and choose Mode as 32 bit in the Merge To HDR Pro dialog, the following error message is displayed:

The command "Camera Raw filter" is not currently available.

Error message displayed when using Merge to HDR Pro in 32 Bit Mode

Product versions affected

Adobe Camera Raw 9.10 and Photoshop CC 2017

Operating systems

macOS and Windows

Additional information

In Adobe Camera Raw 9.10, directly applying the Camera Raw Filter to a 32-bit Photoshop document has now been disabled to prevent unexpected visual mismatches between Camera Raw and Photoshop. The Camera Raw plug-in always processes a 32-bit source image or Smart Object to a 8-bit/16-bit result.

Workarounds

Use any one of the methods listed below:

Method 1: Set File Handling preference and Image Mode in Photoshop

To apply the Camera Raw Filter to a 32-bit (HDR) image in Photoshop:

  1. Make sure that the 32 bit to 16/8 bit option is enabled. To enable this setting:
    • Choose Edit > Preferences > File Handling.
    • In the File Compatibility section of the Preferences dialog, check the box labeled Use Adobe Camera Raw to Convert Documents from 32 bit to 16/8 bit.
    • Click OK.
  2. Choose either Image > Mode > 8 Bits/Channel or Image > Mode > 16 Bits/Channel.

Now when you use the Merge To HDR Pro option, Photoshop brings up the Camera Raw Filter dialog. Make the desired adjustments and click OK. The resulting document in Photoshop is now either 8 bits/channel or 16 bits/channel.

Method 2: Use Lightroom's built-in HDR feature

We recommend that you use use Photo Merge > HDR instead of Edit In > Merge to HDR Pro in Photoshop. Lightroom's built-in HDR feature creates a merged HDR DNG raw file that can be tone mapped using standard raw development controls in the Develop module.

For detailed information, see HDR Photo merge.

Method 3: Use Camera Raw's built-in Merge To HDR feature

To merge images to HDR from Photoshop and apply tone mapping using the Camera Raw plug-in, we recommend that you use Camera Raw's built-in Merge to HDR feature. Camera Raw's Merge feature creates a HDR DNG raw file that can be tone mapped using Camera Raw's standard raw development controls.

For detailed steps, see HDR photo merge in Adobe Camera Raw 9.0

Method 4: 32-bit HDR Smart Objects

To apply the Camera Raw plug-in to 32-bit HDR Smart Object files, we recommend that you use Camera Raw or Lightroom's built-in Merge to HDR feature. The Merge feature creates a HDR DNG raw file that can be opened in Photoshop as a Smart Object. Double-clicking on the Smart Object layer in Photoshop will open the Camera Raw dialog and allow you to perform tone mapping on the original HDR image content using Camera Raw's standard raw development controls.

Method 5: Use recommended settings for Photoshop's Merge To HDR Pro feature

When using Photoshop's Merge to HDR Pro feature, we recommend that you use either the 8-bit or 16-bit mode (with Photoshop's built-in tone mapping options), or 32-bit mode with Complete Toning In Adobe Camera Raw deselected. You might encounter issues with the Complete Toning In Adobe Camera Raw workflow at the moment. Adobe is considering fixing this workflow in a future Photoshop release.

When selecting the 32-bit option, the resulting 32-bit HDR document can be processed in Camera Raw using Method 1: Set File Handling preference and Image Mode in Photoshop explained above.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy