Adobe Acrobat PDFMaker (PDFMaker ツールバー/タブの「Adobe PDF に変換」ボタン)は Microsoft Office アプリケーションから PDF ファイルを作成するアドインです。この機能は Acrobat Professional および Standard でインストールされます。

  • MS Office 2003 以前では、PDFMaker は Adobe PDF プリンターを使用して PostScript ファイルを作成します。続いて、Adobe PDF プリンターは、Adobe Acrobat Distiller アプリケーションとのインターフェイスで PDF ファイルを作成します。
  • MS Office 200720102016 および 365 では、PDFMaker は AdobePDF Library を使用して Microsoft Office ドキュメントを PDF に変換します。
  • また、Acrobat Distiller または Adobe PDF プリンターを使用して個々に PDF ファイルを作成することもできます。

この文書では、Acrobat PDFMaker を使用して Office アプリケーションから PDF ファイルを作成するときに発生する問題のトラブルシューティングについて説明します。この文書の内容は Microsoft Word に特化していますが、トラブルシューティングの手順は一部を除いて Microsoft PowerPoint および Microsoft Excel にも適用できます。

 

Acrobat Ribbon は、Windows の Office 2016 または Office 365 では利用できません。

Office 2016 または Office 365 バージョンの Word、Excel、PowerPoint が該当します

以下の手順に従って問題を解決します:

  1. Word アイコンを右クリックして、「管理者として実行」を選択します。

    「ユーザーアカウント制御」のプロンプトが表示されたら、「はい」をクリックします。

  2. 空白の文書を開きます - 空白の文書のテンプレートを選択します。もしくは、既存の Word 文書を開きます。

  3. 「ファイル」メニューで、「オプション」を選択します。「Word のオプション」ダイアログボックスが表示されます。

  4. オプション一覧の「アドイン」を選択します。「管理」ドロップダウンメニューで、「COM アドイン」を選択し、「設定
    」をクリックします。

    Word アドイン
  5. 「COM アドイン」ダイアログボックスで、Acrobat PDFMaker Office COM Addin にチェックがない場合、チェックを入れ、「OK」をクリックします。

    PDFMaker Office COM Addin

PDFMaker が Windows の Office 2016 および Office 365 でクラッシュする

Office 2016 の 2 月のアップデート以降、Acrobat PDFMaker が Windows の Office 2016 および Office 365 でクラッシュします。

Adobe では問題を調査しており、Microsoft と協力してできる限りの早期解決に取り組んでおります。なお、PDF ファイルの作成については、ここで対処方法をご覧ください。

Microsoft Office と Acrobat の互換性を確認する

トラブルシューティングを開始する前に、実行中の Acrobat のバージョンが Office のバージョンと互換性があることを確認します。詳細は、互換性のある Web ブラウザーと PDFMaker アプリケーション | Acrobat、Reader を参照してください。

Acrobat Distiller と Adobe PDF プリンターのトラブルシューティング(PDFMaker (MS Office 2003 以前に対応)にのみ適用)

Acrobat PDFMaker (MS Office 2003 以前に対応)では Adobe PDF プリンターを使用します。このプリンターでは Acrobat Distiller アプリケーションを使用して Word 文書を変換します。そのため、Acrobat Distiller が正しく動作しているかどうかを判断することがトラブルシューティングの最初のステップになります。

Adobe PDF プリンターで Word から PDF ファイルを作成してみる 

  1. Word で文書を開き、「ファイル/印刷」を選択します。
  2. プリンター名メニューから Adobe PDF を選択し、「OK」をクリックします。

Acrobat Distiller アプリケーションで PDF を作成してみる

注意この方法では、リンクや文書構造の維持など、PDFMaker の高度な機能はサポートされません。

  1. Word 文書を開き、続いて「ファイル/印刷」を選択します。
  2. 印刷ダイアログボックスで、PostScript プリンター(例えば、Adobe PDF プリンター)を選択し、「ファイルへの印刷」を選択し、「OK」をクリックします。

    PostScript ファイル(.ps または .prn)ファイルが作成されます。

    注意: PostScript プリンターをお持ちでない場合は、アドビ Web サイトから PostScript プリンタードライバーをダウンロードできます。ドライバーをインストールしたら、ステップ 2 を実行します。Adobe PDF プリンターを選択した場合は、「Adobe PDF にフォントを送信しない」を選択解除して PostScript ファイルを作成します。

  3. Acrobat で、「アドバンスト/Acrobat Distiller」を選択します。
  4. デフォルト設定リストから設定を選択します(またはデフォルト設定のままにする)。
  5. 「ファイル/開く」を選択し、ファイルの種類メニューの「すべてのファイル」選択し、作成した PS または PRN ファイルを選択してから「開く」をクリックします。
  6. PDF ファイルの名前と保存場所を指定して「保存」をクリックします。
  7. Windows では、次のフォルダーにある messages.log ファイルを開きます(NT、2000、XP、Vista、7): %AppData%\Adobe\Acrobat\Distiller [バージョン番号]

  8. トラブルシューティング情報について、messages.log ファイルを確認します。

    • このファイルの内容によって、Acrobat Distiller で PDF ファイルを作成できなかった理由が示される場合は、「Acrobat のヘルプとサポート」にある検索テキストボックスを使用して関連するドキュメントを検索します。例えば、このファイルに PostScript エラーが一覧表示される場合は、「PostScript エラーのトラブルシューティング」にある推奨事項に従ってエラーのトラブルシューティングを行います。
    • このファイルに、Acrobat Distiller で PDF ファイルを作成できなかった理由が示されない場合は、ほんの数ワードしかない Word 文書を作成します。続いて、Adobe PDF プリンターと Acrobat Distiller アプリケーションを使用してこの文書から PDF ファイルを作成します。
    • この新しい文書から PDF ファイルを作成できた場合、問題は PDFMaker に関連している可能性があります。Acrobat PDFMaker のトラブルシューティングに進みます。
    • この新しい文書から PDF ファイルを作成できない場合は、別のアプリケーションで作成したファイルを使用します。続いて、Acrobat Distiller を使用して PDF ファイルを作成してみます。別のアプリケーションで作成したファイルでも問題が発生した場合は、Acrobat Distiller を再インストールします。別のアプリケーションで作成したファイルで問題が発生しない場合は、関連コンテンツにリストされているドキュメントを使用して特定のビヘイビアーをトラブルシューティングします。または、Acrobat ヘルプを検索します。さらにサポートが必要な場合は、弊社テクニカルサポートにお問い合わせください。

Acrobat PDFMaker のトラブルシューティング

Adobe PDF プリンターまたは Acrobat Distiller で PDF ファイルを作成できるが、Acrobat PDFMaker では作成できない場合、Acrobat PDFMaker の機能に問題がある可能性があります。これらの機能のいずれかについて、問題の原因があるかどうかを判断するには、その機能を無効にします。続いて、PDF ファイルを作成してみます。

  1. Word で「Adobe PDF/変換設定の変更」を選択します。
  2. 変換設定メニューから「最小ファイルサイズ」を選択してください。
  3. 「Word」タブをクリックし、すべてのオプションを選択解除します。
  4. 「ブックマーク」タブをクリックし、すべてのブックマークオプションを選択解除します。
  5. 「セキュリティ」タブをクリックし、すべてのセキュリティオプションを選択解除します。
  6. 「OK」をクリックします。
  7. PDF ファイルを作成してみます。
  • PDF ファイルを作成できない場合は、「文書に固有の問題に関するトラブルシューティング」に進みます。
  • PDF ファイルを作成できる場合は、問題の原因となる機能を特定します。1 つの機能を有効にして、PDF ファイルを作成してみます。問題が再発するまでこのプロセスを繰り返します。続いて、ほんの数ワードしかない Word 文書を作成します。Acrobat PDFMaker の同じ設定を使って、この文書から PDF ファイルを作成してみます。
  • この新しい文書から PDF ファイルを作成できた場合、問題は文書に固有のものです。「文書に固有の問題に関するトラブルシューティング」に進みます。
  • この新しい文書から PDF ファイルを作成できない場合は、最も直近に有効にした機能が引き続き問題の原因になります。Acrobat PDFMaker を再インストールします。問題が解決しない場合は、弊社サポートにお問い合わせください。

文書に固有の問題に関するトラブルシューティング

問題が文書に固有のものであると判断される場合は、次のようにトラブルシューティングを行います。

文書で使用される Acrobat PDFMaker の機能のみを有効にする

例えば、文書に見出しスタイルの見出し 1 と 見出し 2 のみが含まれている場合、Acrobat PDFMaker ダイアログボックスでその他の見出しスタイルを無効にします。

Word で標準ドキュメントビューに切り替えてから、Acrobat PDFMaker を使用して PDF ファイルを作成する

Word 文書を再作成して破損をなくす

次のいずれかの操作を行います。

  • Word 文書の内容を新規文書にコピー&ペーストし、PDF ファイルを作成します。
  • 文書内のすべてのテキストを選択し、フォントを変更して文書を別名で保存します。Word は文書を書き換えて、Acrobat PDFMaker と競合を起こす要素を排除します。保存後に任意のフォントを指定してデザインし直します。
  • 文書の Word バージョンが、PDF ファイルの作成に使用するバージョンと異なる場合は、文書内に少しだけ修正を加えてから、 別名で保存します。これにより Word は文書を書き換えて、PDFMaker と競合を起こす要素を排除します。

文書に任意のカスタム見出しスタイルを再作成してから PDF ファイルを作成する

文書内で競合する要素を特定する

  1. Word 文書を作成します。
  2. 元の Word 文書の半分を新しい Word 文書にコピーします。
  3. この新しい Word 文書を Acrobat PDFMaker を使用して PDF に変換します
  • 問題が再発する場合は、この新しい Word 文書に競合する要素が存在します。競合する要素をさらに隔離するには、手順 1 〜 3 を繰り返し、2 番目の Word 文書の半分を別の新しい Word 文書にコピーします。
  • 問題が再発しない場合は、元の Word 文書に競合する要素が存在します。問題をさらに隔離するには、手順 1 〜 3 を繰り返し、元の Word 文書の半分を別の新しい Word 文書にコピーします。文書の半分の両方ともが正しく変換された場合は、実行している他のプログラム(Office アプリケーションを含む)を閉じます。.tmp ファイル(通常は Windows/Temp フォルダーにある)を削除します。

プログラムを再インストールする

Acrobat と Office の両方を削除するか、特定の Office アプリケーション(Word、PowerPoint、または Excel)を削除します。Office または特定の Office アプリケーションを再インストールしてから Acrobat を再インストールします。

Acrobat を削除するには、コントロールパネルの「プログラムの追加と削除」を使用します。Office を削除する方法の手順については、Office マニュアルを参照するか Microsoft にお問い合わせください。

Word 文書が保護された文書である場合は、保護を解除する

保護を解除する方法の手順については、Word マニュアルを参照するか Microsoft にお問い合わせください。 

Microsoft Word における他のマクロとの競合のトラブルシューティング

PDFMaker は、ウイルスチェッカー、FAX ソフトウェアなど、他のマクロと競合する可能性があります。他のトラブルシューティングを行っても問題が解決しない場合、またはサードパーティのマクロをインストールした後に PDFMaker に問題が発生した場合は、他のマクロとの競合に関するトラブルシューティングを行います。非互換性の問題が発生する既知のマクロには、Duden Korrektor Plus 2.0、ViaVoice 10 以前、Personal Translator 2002 Office Plus、OfficeReady Stuffit、Leuchter Informatic AG WordPlus、GoldMine Link to Word などがあります。

PDFMaker が他のマクロと競合しているかどうかを判別するには、他のマクロを一度に 1 つずつ削除するか無効にします(下記の該当するリンクを参照)。もう一度 PDFMaker を使用して文書を PDF ファイルに変換してみます。問題が改善された場合は、当該のマクロの提供元へお問い合わせください。

Microsoft Word における問題のトラブルシューティング

以下の手順は、Microsoft 社のナレッジベース記事に基づいています。

Microsoft Word のトラブルシューティングの詳細については、Microsoft 社の Web サイトを閲覧して関連記事を検索してください。

/a switch を使用して Word を起動し、PDFMaker を手動で追加する

/a switch は、Word を起動し、アドインとグローバルテンプレート(Normal テンプレートを含む)が自動的に読み込まれないようにします。また、/a switch は、設定ファイルをロックします。つまり、このスイッチを使用すると、設定ファイルの読み取りや変更ができません。

注意: Word の /a switch セッションの間の環境設定、カスタマイズ、またはマクロに対する変更は、Word を終了すると失われます。

/a switch を使用して Word を起動するには、以下を実行します。

  1. すべてのプログラムを終了します。
  2. 「スタート/実行」を選択します。
  3. ファイル名を指定して実行ダイアログボックスで、winword.exe /a と入力します。
  4. 「OK」をクリックします。ファイル名を指定して実行ダイアログボックスを閉じて、Word を起動します。

PDFMaker を手動でロードするには、以下を実行します(Acrobat 6.x のみ)。

  1. すべてのプログラムを終了します。
  2. 「ツール/テンプレートとアドイン」を選択します。
  3. PDFMaker.dot (PDFMakerA.dot ではない)を選択し、「OK」をクリックします。

    PDFMaker アイコンが表示されます。

Acrobat 7.x、8.x、9.x、X の場合(必要に応じて) 

PDFMaker を手動でロードするには、以下を実行します(MS Word 2003 以前)。

  1. すべてのプログラムを終了します。
  2. 「ツール/カスタマイズ」を選択し、「コマンド」タブをクリックします。
  3. カテゴリパネルで「ツール」をクリックします。
  4. マウスボタンを押したまま、COM アドインをコマンドパネルからツールメニューにドラッグします。ツールメニューにメニューコマンドが表示されたら、COM アドインを「カスタマイズ」オプションのすぐ下にドラッグし、マウスボタンを放します。
  5. 「終了」をクリックします。
  6. ツールメニューの「COM アドイン」をクリックします。
  7. 「追加」をクリックし、アドインの場所を確認し(PDFMaker アドインは [Acrobat インストールパス]\PDFMaker\Office\PDFMOfficeAddIn.dll にあります)、「OK」をクリックします。

  8. Alt + F11 キーを押して Visual Basic Editor を起動します。
  9. Ctrl + G キーを押して Immediate Window of Visual Basic Editor を起動します。
  10. Word で PDFMaker を起動するには、Application.COMAddIns("PDFMaker.OfficeAddin").Connect = True と入力します。Visual Basic Editor を閉じます。
  11. Adobe PDF メニューが Microsoft Word メニューバー上のヘルプの右側に表示されていることを確認します。

PDFMaker を手動でロードします(MS Word 2007 と 2010)。

  1. すべてのプログラムを終了します。
  2. Microsoft Office ボタンをクリックし、Word オプションをクリックします。

  3. アドインをクリックします。

  4. 「管理」ボックスの一覧で、「COM アドイン」をクリックし、「設定」をクリックします。

  5. Acrobat PDFMaker COM アドインが一覧表示され、COM アドインダイアログボックスで選択されている場合は、次の手順を実行します。一覧表示されていない場合は、手順 6 に進みます。

  6. クリックして Acrobat PDFMaker COM アドインチェックボックスを選択解除します。

  7. 「OK」をクリックして、COM アドインダイアログボックスを閉じます。

  8. 手順 1 ~ 3 を繰り返し、COM アドインダイアログボックスで、Acrobat PDFMaker COM アドインチェックボックスをクリックして選択/チェックマークを入れます。

  9. 「Acrobat」タブが MS Word リボンに表示されていることを確認します。

  10. Acrobat PDFMaker COM アドインが COM アドインダイアログボックスに表示されていない場合は、「PDFMaker を手動でロードするには(MS Word 2003 以前)」セクションにある手順 7 ~ 10 に従います。

テスト Word 文書を作成し、PDFMaker を起動します。

  1. Word 文書にテキストを入力します。
  2. 「ファイル/保存」を選択し、デスクトップにテキスト文書を保存します。
  3. 「Adobe PDF に変換」をクリックします。

/a switch を使用して Word を起動するときの問題が解決した場合は、Word の起動時にロードするコンポーネントをそれぞれ削除します。これらのコンポーネントについては、Word で表示される順序で、一度に 1 つずつ削除します。Word の起動時に、次のコンポーネントがロードされます。

  • Word の自動マクロ
  • グローバルテンプレート(Normal.dot)
  • アドイン(WLLs)
  • Word スタートアップフォルダーおよび Office スタートアップフォルダー内のテンプレート
  • COM アドイン
  • Windows レジストリ内の Word データキー
  • Windows レジストリ内の Word オプションキー
  • Word の自動マクロ

注意:その他の Word 起動時のトラブルシューティングについては、次のマイクロソフト製品サポートサービスを参照してください。

Normal.dot テンプレートファイルの名前を変更する

グローバルテンプレートファイルの名前を変更する方法の手順については、Microsoft サポート記事「Word でユーザーオプションとレジストリ設定をリセットする方法」のセクション「グローバルテンプレート(Normal.dotm または Normal.dot)」を参照してください。ページを下にスクロールして、記事をご覧ください。

重要:上記の手順を実行した後には、/a switch で Word を再起動しないでください。

グローバルテンプレートの名前を変更して問題が解決した場合、問題の原因は Normal.dot テンプレートの破損です。該当するオプションを復元するには、いくつかの設定を変更しなければならない場合があります。名前を変更した Normal.dot ファイルにカスタマイズ(再作成が難しいスタイル、マクロ、AutoText 定型句など)が含まれている場合は、Organizer を使用して、これらのカスタマイズを古い Normal.dot ファイルから新しい Normal.dot ファイルにコピーしてみてください。

Organizer を使用する方法の詳細については、次の手順を実行します。

  1. Word を起動します。
  2. 「ヘルプ/ Microsoft Word ヘルプ」を選択します。
  3. Office アシスタントまたはアンサーウィザードで、Organizer と入力します。

  4. 「検索」をクリックして、返されたトピックを表示します。

問題が解決しない場合は、新しいグローバルテンプレートではなく、古いグローバルテンプレート(Normal.dot)の使用を検討してください。古い Normal.dot テンプレートを使用するには、新しい Normal.dot テンプレートの名前を Normal.dot に変更し直します。この文書に記載された作業を行った後でも PDFMaker に問題が発生する場合は、弊社サポートにお問い合わせください。

本作品は Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License によってライセンス許可を受けています。  Twitter™ および Facebook の投稿には、Creative Commons の規約内容は適用されません。

法律上の注意   |   プライバシーポリシー