インターフェイスの概要

Substance 3D Designer のインターフェイスとワークスペースについて説明します。

Designer は、最初は難しく見えるかもしれませんが、インターフェイスの各部分について理解すれば、遥かに簡単に全体を理解できます。

Designer の UI レイアウトの簡略化された図。ラベルは各セクションを指しています。

A. メインツールバー B. エクスプローラー C. グラフ D. プロパティ E. 2D ビュー F. 3D ビュー G. ライブラリ 

注意:

このページの用語の一部に、なじみがないかもしれません。なじみがない単語や概念が見つかった場合は、用語集で定義を確認するか、「Substance Designer の主要な概念」を参照してください。

メインツールバー

主なメニューと便利なクイックアクセスボタンを確認します。

ファイルメニューでは、次の操作ができます。

  • パッケージを保存して開く
  • パッケージとグラフを作成する
  • すべてのコンテンツをリロードする
  • アプリケーションを終了する

編集メニューを使用すると、「取り消し」および「やり直し」アクションを実行できます。編集メニューから、環境設定ウィンドウにアクセスして、アプリケーションの設定を調整することもできます。

ツールメニューでは、Substance Engine オプションを調整できます。Substance Engine は、Substance グラフを計算するプロセスです。ツールメニューでは、エンジンの設定を一時停止、リセット、調整できます。ツールメニューからは、プラグインマネージャーにアクセスすることもできます。

ウィンドウメニューでは、Designer インターフェイスを構成するウィンドウを管理できます。新しいウィンドウを開いたり、個々のウィンドウの表示/非表示を切り替えたり、ウィンドウ/レイアウトをリセットを使用して Designer をデフォルトの状態に戻したりすることができます。

ヘルプメニューからは、Designer のドキュメント、チュートリアル、リリースノートなどのリソースにアクセスできます。また、フィードバックを送信してバグを報告したり、ライセンスとバージョンに関する詳細情報を参照したりすることもできます。

エクスプローラーパネル

パッケージとリソースを管理します。

エクスプローラーパネルで右クリックメニューを開く 2 つの例。最初の画像はパッケージの右クリックメニューを示し、2 番目の画像はグラフの右クリックメニューを示しています。
右クリックメニューは、クリックするリソースのタイプによって変わります。左側ではパッケージの右クリックメニュー、右側ではグラフのメニューを確認できます。

エクスプローラーパネルは、Designer でファイルやリソースを操作する主な方法です。

エクスプローラーパネルには、開いているすべてのパッケージが一覧表示され、そのコンテンツが表示されます。コンテキスト依存メニューのパッケージ、グラフ、その他のリソースを右クリックします。すべてのリソースには、以下を含む一連の標準オプションがあります。

  • 開く
  • 閉じる
  • 名前の変更
  • コピーとペースト

一部のリソースには、右クリックメニューでのみ使用できる固有のオプションがあります。エクスプローラーパネルで空のスペースを右クリックして、新しい空のパッケージを作成することもできます。

エクスプローラーパネルの上部には、リソースを管理するためのボタンがあります。これらのボタンを有効にするには、最初にパッケージまたはグラフを選択します。

リソースをクリックすると、プロパティパネルが更新され、現在選択されているプロパティが表示されます。

複数のエクスプローラーパネルを開くことができます。ウィンドウ/新規エクスプローラーを使用して、別のエクスプローラーパネルを開きます。

グラフビューポート

ノードベースのグラフを作成および構築します。

Designer のグラフウィンドウのスクリーンショット。この画像は、ウィンドウの上部にあるグラフツールバーと、ツールバーの下にあるグラフビューポートを示しています。
グラフビューポートは、グラフツールバーとグラフ表示で構成されています。ノードツールバーは、グラフツールバーの一部です

ユーザーは、Designer でのほとんどの時間をグラフビューポートで費やします。Designer で作成または開いたグラフが表示され、ノードを追加、削除、整理できます。

ツールバーと表示領域の 2 つの領域があります。

グラフツールバー

グラフツールバーの切り抜きのスクリーンショット。

グラフツールバーには、グラフとよく使用されるノードの多くを管理するためのツールが用意されています。わかりやすいように、色の付いた背景のボタンはノード、他のボタンはツールです。 

メインツールバーには次のツールがあります。

  • フォーカス - 選択した項目をビューに表示します。ノードを選択していない場合は、フォーカスでは代わりにグラフ全体が表示されます。フォーカスを使用すると、選択した項目をすばやくナビゲートしたり、検索したりできます。ホットキー F は、同じ機能です。
  • ズームをリセット - ズームレベルをデフォルトの 1:1 レベルに戻します。ホットキー Z は、同じ機能です。
  • スクリーンショット - 透明部分と一緒に、グラフ全体の PNG スクリーンショットを保存します。ファイルダイアログが開き、ファイル名と場所を設定できます。
  • 情報 - ドロップダウンが開き、コネクタ名ノードバッジノードサイズノードタイムを切り替えることができます。このオプションを有効にすると、表示領域のノードに情報が追加されます。
  • 検索 - タイプとテキストをフィルタリングして、グラフ内のノードとパラメーターを検索します。
  • フローをハイライト表示 - 現在の選択項目に接続されているノードを明確にします。未接続のノードはグレー表示されます。
  • ノードツールバー - アトミックノードのボタンの表示を切り替えます。
  • 親ツールバー - ツールバーの親解決コントロールの表示を切り替えます。
  • リンク作成モード - 3 つのリンクモード(標準マテリアル、またはコンパクトマテリアル)から使用するものを選択できます。キーボードショートカット 1、2、3 は、同じ機能です。
  • 長方形リンク - リンクがなめらかなカーブであるか、長方形の角であるかを切り替えます。
  • タイミング制御 - タイミング表示をリセットできます。タイミング制御は、情報ドロップダウンで「ノードタイミング」が有効になっている場合にのみ関係します。
  • ツール - その他のオプションを含むドロップダウンリストにアクセスできます。
    • クリーン - 未使用のノードをグラフから削除します。
    • 出力を書き出しでは、書き出しダイアログボックスが表示され、ビットマップファイルを書き出すことができます。
    • 出力を再度書き出しでは、ダイアログを表示せずに、同じオプションを使用して前の出力を再度実行します。
    • PSD エクスポーター - PSD エクスポーターパネルをさらに開きますPSD エクスポーターパネルがグラフビューの右側に表示されます。
  • サムネールツールバー - ツールバーのサムネールオプションドロップダウンの表示を切り替えます。
  • 整列ツール - ツールバーの整列ツールの表示を切り替えます。整列ツールを使用すると、グラフのグリッド上でノードを整列および整理できます。

 

ノードツールバー

ノードツールバー

ノードツールバーのノードをクリックして、グラフに追加します。ノードツールバーには、Designer のアトミックノードが含まれます。アトミックノードは Designer グラフの基本ノードであり、複雑なネットワークを作成するために使用できる構成要素です。ノードについて詳しくは、「ノードの概要」ページを参照してください。

注意:

ノードツールバーは、ノードを追加する 1 つの方法にすぎず、ツールバー以外でも多くのノードを使用できます。詳しくは、「グラフの作成」の記事を参照してください。

グラフ表示

グラフビュー

グラフ表示領域には、グラフを構成するノードが表示されます。ノードを配置して接続し、テクスチャを生成するグラフを作成します。 

グラフの操作について詳しくは、「グラフの作成」ページを参照してください。

プロパティパネル

コンテキスト依存プロパティを変更します。

プロパティパネルの横並びのスクリーンショット。最初の画像は、グラフを選択したときに表示されるプロパティパネルを示しています。2 番目の画像は、ブレンドノードを選択したときにパネルがどのように表示されるかを示しています。
プロパティパネルの外観は、選択したリソースによって変わります。左の画像は、グラフが選択された状態でプロパティパネルがどのように表示されるかを示しています。右の画像は、ブレンドノードが選択された状態でプロパティパネルがどのように表示されるかを示しています。

プロパティパネルはコンテキストに依存し、選択したリソースまたはノードの動作を変更するパラメーターを表示します。グラフパネルプロパティパネルの組み合わせで、ユーザーは Designerでのほとんどの時間を費やします。

一度に表示できるコントロールの数が多いため、プロパティパネルにはコントロールを整理するためのカテゴリがあります。以下は、主要カテゴリの説明です。

  • ベースパラメーターは、グラフリソースおよびすべてのノードに存在するカテゴリです。グラフの解像度とセットアップに関連する主要なパラメーターを変更できます。いくつかの重要なパラメーターを以下に示します。
    • 出力サイズ - グラフまたはノードの解像度を設定します。
    • 出力形式 - グラフまたはノードの形式または精度を設定します。
    • タイリングモード - 画像が境界の外側に折り返されるかどうかを設定します。
    • ランダムシード - プロシージャル生成に使用されるランダムシードを変更します。

ベースパラメーターの動作は継承方法によって異なります()。相対は、ノードの動作が別の場所(グラフまたは以前に接続されたノードによって)で定義されることを意味します。絶対は、パラメーターコントロールを使用して設定されることを意味します。ベースパラメーターがグレー表示されている場合は、継承モードが相対に設定されている可能性があります。

  • 属性には、グラフまたはノードに関連するメタデータが含まれます。メタデータを使用して、ライブラリにカテゴリを作成できます。
  • 入力パラメーターはグラフでのみ表示されます。ここには、すべてのパラメーターが表示されます。
  • インスタンス/特定のパラメーターは、ノードでのみ表示されます。名前はアトミックノードとインスタンスノードで異なりますが、機能は同じです。このノードに固有の設定を調整できます。ノードの出力のカラー、ブレンド操作の不透明度、ノイズのスケールなどを変更できます。
  • 入力はグラフでのみ表示されます。すべての入力ノードまたは表示されるパラメーターが一覧表示され、それらの名前とプロパティを設定できます。
  • 入力値はグラフノードでのみ表示されます。ノードに入力値を追加できます。入力値は、高度なワークフローでのみ使用できます。
  • 出力は、グラフでのみ表示されます。すべての出力ノード(またはスロット)が一覧表示され、中央の場所から名前とプロパティを設定できます。

2D ビューポート

コンテキスト依存の画像プレビューを取得します。

2D ビュー

2D ビューポートには、ノードのコンテンツが表示されます。グラフ内の画像ノードをダブルクリックすると、2D ビューにそのノードの出力が表示されます。

2D ビューポートの操作は、ズームイン時はズームとパンに限定されます。スクロールすると、ズームインとズームアウトができます。2D ビューポートの右下にあるボタンを使用して、ズームを制御します。ショートカットの Z キーを使用してズームをリセットしたり、F キーを使用してキャンバスにフォーカスしたりすることもできます。

2D ビューポートの上部には、次のコントロールがあります。

  • 背景画像 - 透明ピクセルがあるかどうかを示す背景画像を設定します。
  • ビューを保存 - 2D ビューポートの現在の画像をビットマップファイルに保存できます。
  • クリップボードにコピー - 2D ビューポートのコンテンツをクリップボードにコピーします。
  • 出力を選ぶ - ノードの出力を切り替えることができます。
  • UV セットを選択 - 表示する UV チャンネルを選択できます。3D ビューポートのシーンメニューの「2D ビューで「UV を表示」がアクティブでない限り、このボタンはグレー表示されます。

2D ビューの左下には、その他の機能のボタンがあります。

  • チャンネルを表示 - R、G、B の各チャンネルのオン/オフを切り替えることができます。グレースケールモードでの使用に最適です。
  • 透明表示 - 透明ピクセルをチェッカーテクスチャと平坦な黒のどちらで表示されるかどうかを切り替えます。
  • グレースケール/カラー切り替え - 2D ビューポートの表示をカラーまたはグレースケールで切り替えます。
  • 繰り返しタイリング - 2D ビューポート全体に画像をタイル表示します。これにより、タイリングのアーティファクトを簡単に見つけることができます。マウスを 2D ビューポートスペースバーの上に合わせると、ショートカットとして機能します。
  • 物理サイズを使用 - プレビューの表示での物理サイズ情報の使用を切り替えます。
  • 画像情報 - 画像情報パネルが開き、カーソルを合わせたピクセルの正確な値が表示されます。
  • ヒストグラム - 現在のプレビューのヒストグラム分析を示すパネルが開きます。
  • sRGB 切り替え - sRGB カラースペース表示のオン/オフを切り替えます。
  • プリマルチプライ切り替え - 背景色においてアルファチャンネルを持つピクセルのプリマルチプライを切り替えます。

3D ビューポート

完全なマテリアルの 3D プレビューを操作します。

3D ビュー

3D ビューポートには、マテリアルが表示されます。2D ビューポートとは異なり、デフォルトでは、グラフの出力マップを使用して完全なマテリアルがレンダーされます。3D ビューポートでは、ベースカラー、法線、粗さなどのチャンネルがどのように結合して最終的な結果を作成するかを確認できます。

3D ビューポートでマテリアルを表示するには、グラフ表示領域で空の領域を右クリックし、3D ビューで出力を表示を選択します。ノードを右クリックして、3D ビューで表示を選択して、3D ビューに個別のマップを送信することもできます。

次のように、3 ボタンのマウスとキーボードを使用してビューポートを操作できます。

  • マウスの左ボタンでドラッグすると、カメラはメッシュの周囲を軌道に沿って回ります。
  • マウスの中央ボタンでドラッグすると、カメラはパンします。
  • マウスの右ボタンでドラッグまたはスクロールすると、メッシュをズームインまたはズームアウトします。
  • キーボードショートカットの F キーは、カメラのトラックが失われた場合、カメラのフォーカスを中央のメッシュに戻します。
  • Ctrl キーと Shift キーを押しながらマウスの右ボタン(Mac の場合は Cmd キーと Shift キーを押しながらマウスの右ボタン)を押すと、環境光が回転します。

ここでは、よく使用される 7 つのメニューの概要を説明します。

  • シーンでは、ビューポートに表示されるメッシュを変更できます。ビューポートの状態を保存したり、ロードしたりすることもできます。3D ビューポートでカスタムメッシュを表示するには、エクスプローラーパネルでダブルクリックします。
  • マテリアルは、メッシュ上のすべてのマテリアルスロットを表示し、使用するシェーダーとパラメーターを選択できます。このメニューでは、UV タイリング、高さのディスプレイスメント、PBR 以外のレンダリングなどのオプションを設定できます。
  • ライトは、Designer の初期バージョンのメニューです。このメニューのライトはデフォルトで無効になっています。古いファイルを開く場合を除いて、使用しないことをお勧めします。ライト設定にアクセスするには、「編集」オプションを選択します。
  • カメラでは、定義済みのカメラアングル間を切り替えられます。また、3D ビューポートからレンダーされたキャプチャを保存することもできます。「編集」を選択してポストプロセス設定を変更します。
  • 環境には、シーンの画像ベースの照明を調整するオプションがあります。3D ビューで HDR 画像を変更するには、ライブラリパネル3D ビューカテゴリからリソースをドラッグアンドドロップします。
  • 表示では、ワイヤフレームや解像度表示など、ビューポートのその他の設定を変更できます。
  • レンダラーは、リアルタイム OpenGL レンダリングから GPU アクセラレーション対応の Iray レイトレーシングに変更できる重要なメニューです。レンダラーとして Iray を選択すると、より多くの Iray オプションが使用可能になります。

ライブラリパネル

グラフのリソースを検索します。

ライブラリビュー

ライブラリパネルでは、Designer のデフォルトコンテンツのすべてにアクセスできます。ライブラリ内のさまざまなタイプのノードについて理解を深めるには、「ノードの概要」を参照してください。

ライブラリのコンテンツをグラフ表示領域にドラッグするだけで、グラフに追加できます。また、グラフ表示領域の上にカーソルを合わせてスペースバーまたはタブのキーボードショートカットを使用すると、メニューを開いてノードをすばやく検索することもできます。

ライブラリパネルの大きなサムネールは、コンテンツを検索するときに役立ちます。右上のドロップダウンでサムネールサイズを調整します()。

次にやること

インターフェイスを理解したので、Designer の主要な概念に進む準備が整いました。

ご質問やアイデアはありますか?

共有するご質問またはご意見がある場合は、Substance 3D Designer コミュニティで他の Designer ユーザーとつながりましょう。サポートを受けたり、Designer に組み込むことができるような提案をしたり、仕事やテクニックを公開することができます。

Designer のノードや機能に関する新しいアイデアがある場合は、ここで共有してください

アドビのロゴ

アカウントにログイン