XML로 문서 내용 내보내기

InDesign 문서의 내용을 XML로 내보내려면 먼저 다음을 수행해야 합니다.

  • 요소 태그를 만들거나 불러옵니다.

  • 문서의 페이지에 있는 항목에 태그를 적용합니다.

  • 필요한 경우 [구조] 창에서 태그 있는 요소의 계층 구조를 조정합니다.

문서에 있는 XML 내용의 전부 또는 일부를 내보낼 수 있습니다. 태그 있는 내용만 내보낼 수 있습니다.

참고:

표가 있는 문서를 내보내려면 표에 태그를 지정해야 합니다. 그렇지 않으면 InDesign에서 표를 XML의 일부로 내보낼 수 없습니다.

  1. 문서의 일부분만 내보낼 경우에는 [구조] 창에서 내보내기를 시작할 요소를 선택합니다.
  2. [파일] > [내보내기]를 선택합니다.
  3. [파일 형식](Windows) 또는 [형식](Mac OS)에서 [XML]을 선택합니다.
  4. XML 파일의 이름과 위치를 지정한 다음 [저장]을 클릭합니다.
  5. [XML 내보내기] 대화 상자의 [일반] 탭에서 다음 중 원하는 항목을 선택합니다.

    DTD 선언 포함

    XML 파일과 함께 DTD에 대한 참조를 내보냅니다. 이 옵션은 [구조] 창에 DOCTYPE 요소가 있는 경우에만 사용할 수 있습니다.

    XML 보기 프로그램

    내보낸 파일을 브라우저, XML 편집 응용 프로그램 또는 텍스트 편집기에서 엽니다. 목록에서 브라우저 또는 응용 프로그램을 선택합니다.

    선택한 요소에서 내보내기

    [구조] 창에서 선택한 요소에서 내보내기를 시작합니다. 이 옵션은 [파일] > [내보내기]를 선택하기 전에 요소를 선택한 경우에만 사용할 수 있습니다.

    CALS XML로 태그 없는 표 내보내기

    태그가 지정되지 않은 표를 CALS XML 형식으로 내보냅니다. 내보내려면 태그 있는 프레임 안에 표가 있어야 하며 표에는 태그가 지정되지 않아야 합니다.

    줄바꿈, 공백 및 특수 문자 다시 매핑

    나누기, 공백 및 특수 문자를 문자 그대로 내보내지 않고 10진수 문자 엔티티로 내보냅니다.

    XSLT 적용

    수정된 XML 트리 또는 HTML 등으로 내보낸 XML의 변형을 정의할 스타일 시트를 적용합니다. [찾아보기](Windows) 또는 [선택](Mac OS)을 선택하여 파일 시스템에서 XSLT를 선택합니다. 기본 설정인 [XML의 스타일 시트 사용]은 내보내기에 적용된 XML에서 참조되는 경우 XSLT 변형 지침을 사용합니다.

  6. [인코딩] 메뉴에서 인코딩 유형을 선택합니다.
  7. 이미지에 대해 내보내기 옵션을 지정하려면 [이미지] 탭을 클릭하고 다음 옵션 중 하나 이상을 선택합니다.

    원본 이미지

    원본 이미지 파일의 사본을 이미지 하위 폴더로 가져옵니다.

    최적화된 원본 이미지

    원본 이미지 파일을 최적화하고 압축한 다음 해당 사본을 이미지 하위 폴더로 가져옵니다.

    최적화된 서식 있는 이미지

    회전 또는 크기 조정 등의 변형이 포함되어 있는 원본 이미지 파일을 최적화하고 이미지 하위 폴더로 가져옵니다. 예를 들어, 문서에 포함된 두 이미지 중에서 하나는 잘리고 나머지 하나는 잘리지 않은 경우에는 잘린 이미지만 최적화되어 이미지 하위 폴더로 복사됩니다.

  8. 이전 단계에서 [최적화된 원본 이미지] 또는 [최적화된 서식 있는 이미지]를 선택한 경우에는 이미지를 최적화하는 옵션을 선택합니다.
  9. [내보내기]를 클릭합니다.

참고:

자동 페이지 번호 문자와 같은 모든 특수 문자는 XML에서 지원되지 않습니다. 내보낸 XML 파일에 포함할 수 없는 문자에 대해서는 경고 메시지가 표시됩니다. 이 경고 메시지는 표에 태그를 지정하지 않은 경우에도 표시됩니다.

최적화된 이미지 내보내기 옵션

[XML 내보내기] 대화 상자의 [이미지] 탭에서 [최적화된 원본 이미지] 또는 [최적화된 서식 있는 이미지]를 선택한 경우 다음과 같은 옵션을 사용할 수 있습니다.

이미지 변환

변환된 이미지에 사용할 파일 형식을 지정합니다. [자동]을 선택하면 이미지에 따라 가장 적합한 파일 유형이 선택됩니다. 이 경우 [GIF 옵션] 및 [JPEG 옵션]을 지정할 수 있습니다.

GIF 옵션

XML로 내보낼 때 GIF 형식으로 변환되는 이미지에 대해 서식을 지정합니다. 다음과 같은 옵션을 설정할 수 있습니다.

팔레트

이미지를 변환할 때 기준이 될 색상 팔레트를 지정합니다. XML 내용의 최종 화면 표시 형식에 사용할 팔레트를 선택합니다. [주 색상(디더 없음)]은 주로 단색으로 구성된 이미지에 적합하고 최종 출력물이 여러 가지 형식일 경우 사용할 수 있습니다.

인터레이스

한 번에 전체 이미지를 다운로드하지 않고 매번 두 줄마다 이미지를 다운로드합니다. 인터레이스를 사용하면 최종 품질에 도달할 때까지 매번 연속적으로 시도할 때마다 해상도가 높아지면서 다운로드할 이미지의 미리 보기 속도가 빨라집니다.

JPEG 옵션

XML로 내보낼 때 JPEG 형식으로 변환되는 이미지에 대해 형식을 지정합니다. 다음과 같은 옵션을 설정할 수 있습니다.

이미지 품질

변환된 이미지의 품질을 지정합니다. 품질을 높게 설정할수록 파일 크기가 증가하고 다운로드 시간이 길어집니다.

포맷 방법

JPEG 이미지를 다운로드할 때 사용할 포맷 방법을 지정합니다. [기준선]을 선택하면 최종 품질의 이미지가 한 번에 다운로드되어 파일이 열리면 바로 최종 품질로 표시됩니다. 이 포맷은 [점진적]으로 포맷된 이미지보다 다운로드 시간이 오래 걸릴 수 있습니다. [점진적]을 선택하면 연속적으로 매번 이미지를 다운로드합니다. 첫 번째 시도에서는 저해상도 버전으로 표시되고 최종 품질에 도달할 때까지 매번 연속적으로 시도할 때마다 이미지의 해상도가 높아집니다.

태그만 XML로 저장

태그를 InDesign 문서로 불러와서 사용할 수 있도록 태그만 저장합니다.

  1. [태그] 패널 메뉴에서 [태그 저장]을 선택합니다.
  2. 이름을 입력하고 위치를 지정한 다음 [저장]을 클릭합니다.

    문서의 태그가 태그에 할당된 색상과 함께 XML 파일에 저장됩니다.

내보낸 XML 파일 편집

InDesign을 사용하여 XML 파일을 만들고 내보낸 후에는 다음 방법 중 하나를 사용하여 XML을 변경할 수 있습니다.

  • XML 파일에서 직접 변경하려면 텍스트 또는 XML 편집기에서 XML 파일을 엽니다.
  • 변경한 후 변경 내용을 소스 문서에 유지하려면 XML을 내보냈던 소스 InDesign 파일을 엽니다. InDesign에서 내용을 변경한 다음 원본 XML 파일을 바꾸려면 원본 XML 파일 이름을 사용하여 다시 XML로 내보내면 됩니다.

이 작업에는 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License의 라이센스가 부여되었습니다.  Twitter™ 및 Facebook 게시물은 Creative Commons 약관을 적용받지 않습니다.

법적 고지 사항   |   온라인 개인 정보 보호 정책