Apilamiento de objetos

En las capas, Animate apila los objetos en el orden en el que se crearon; el último objeto creado es el primero de la pila. El orden de apilamiento de los objetos determina cómo aparecen cuando se solapan. El orden de apilamiento puede modificarse en cualquier momento.

Las líneas y formas siempre aparecen por debajo de los grupos y los símbolos en la pila. Para moverlos hacia arriba en la pila, es necesario agruparlos o convertirlos en símbolos.

Las capas también afectan al orden de apilamiento. Todo lo que hay en la capa 2 aparece encima de todo lo que hay en la capa 1, etc. Para cambiar el orden de las capas, arrastre el nombre de la capa en la línea de tiempo a otra posición.

  1. Seleccione el objeto.
  2. Realice uno de los siguientes pasos:
    • Seleccione Modificar > Organizar > Traer al frente o Enviar al fondo para mover el objeto o el grupo al principio o al final del orden de apilamiento.

    • Seleccione Modificar > Organizar > Hacia delante o Hacia atrás para mover el objeto o el grupo una posición hacia arriba o hacia abajo en el orden de apilamiento.

Si se selecciona más de un grupo, éstos se sitúan delante o detrás de todos los grupos no seleccionados, al mismo tiempo que mantienen su orden entre sí.

Alineación de objetos

El panel Alinear permite alinear objetos seleccionados a lo largo de los ejes vertical y horizontal. Puede alinear objetos verticalmente a lo largo del borde derecho, del centro o del borde izquierdo de los objetos seleccionados, o bien, horizontalmente a lo largo del borde superior, del centro o del borde inferior de dichos objetos.

Para obtener un tutorial sobre las herramientas de diseño en Animate, consulte Utilización de herramientas de diseño en la página de tutoriales de Animate.

  1. Seleccione los objetos que desea alinear.
  2. Seleccione Ventana > Alinear.
  3. En el panel Alinear, seleccione En escenario para aplicar modificaciones de alineación relativas a las dimensiones del escenario.
  4. Para modificar los objetos seleccionados, seleccione los botones de alineación.

Agrupación de objetos

Para poder manipular los elementos como un único objeto, debe agruparlos. Por ejemplo, después de crear un dibujo, agrupe los elementos del dibujo para facilitar la selección y el desplazamiento del mismo como un todo.

Al seleccionar un grupo, el inspector de propiedades visualiza las coordenadas x e y del grupo y sus dimensiones en píxeles.

Se pueden editar grupos sin desagruparlos. También se puede seleccionar un solo objeto de un grupo para editarlo, sin desagrupar los demás objetos.

  1. Seleccione los objetos que desea agrupar. Pueden seleccionarse formas, otros grupos, símbolos, texto, etc.
    • Para agrupar objetos, seleccione Modificar > Agrupar, o presione Control+G (Windows) o Comando+G (Macintosh).

    • Para desagrupar objetos, seleccione Modificar > Desagrupar, o presione Ctrl+Mayús+G (Windows) o Comando+Mayúsculas+G (Macintosh).

Edición un grupo o un objeto dentro de un grupo

  1. Seleccione el grupo y, a continuación, elija Edición > Editar seleccionado o haga doble clic en el grupo con la herramienta Selección.

    Todos los elementos de la página que no forman parte del grupo aparecen atenuados, lo que indica que no se puede acceder a ellos.

  2. Edite cualquier elemento del grupo.
  3. Seleccione Edición > Editar todo, o haga doble clic en un punto vacío del escenario con la herramienta Selección.

    Animate restablece los elementos del grupo a elementos individuales para poder trabajar con otros elementos del escenario.

Separación de grupos y objetos

Para convertir grupos, instancias y mapas de bits en elementos editables no agrupados, sepárelos. Verá cómo se reduce significativamente el tamaño de archivo de los gráficos importados.

Aunque pueda elegir Edición > Deshacer inmediatamente después de separar un grupo u objeto, esta separación no es del todo reversible. Afecta a los objetos del modo siguiente:

  • Corta el vínculo de las instancias del símbolo con su símbolo maestro.

  • Descarta todo excepto el fotograma actual de un símbolo animado.

  • Convierte un mapa de bits en un relleno.

  • Coloca cada carácter en un bloque de texto separado cuando se aplica a bloques de texto.

  • Convierte los caracteres en contornos cuando se aplica a un solo carácter de texto.

    No se debe confundir el comando Separar con el comando Desagrupar. El comando Desagrupar separa objetos agrupados y devuelve los elementos agrupados al estado anterior a la agrupación. No separa tipos, mapas de bits ni instancias, ni convierte tipos en contornos.

  1. Seleccione el grupo, el mapa de bits o el símbolo que desea separar.
  2. Seleccione Modificar > Separar.

Nota:

no se recomienda la separación de símbolos animados o grupos dentro de una animación interpolada, ya que puede tener resultados imprevisibles. La separación de símbolos complejos y bloques grandes de texto puede requerir mucho tiempo. Para separar correctamente objetos complejos, puede ser necesario un aumento de la asignación de memoria para la aplicación.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea