Comandos Deshacer, Rehacer y Repetir

Para deshacer o rehacer acciones en objetos individuales o en todos los objetos del documento actual, especifique los comandos Deshacer o Rehacer a nivel del documento o a nivel del objeto (Edición > Deshacer o Edición > Rehacer). De forma predeterminada, estos comandos se aplican a todo el documento.

Para elegir las opciones de deshacer a nivel de objeto o a nivel de documento, haga lo siguiente:

  1. En Animate CC, seleccione Editar> Preferencias.
  2. En la ficha General, seleccione Deshacer a nivel de objeto del menú desplegable Deshacer.

Tenga en cuenta que, si se aplica a un objeto, el comando Deshacer no permite deshacer algunas acciones. como entrar y salir del modo de edición; seleccionar, editar y desplazar elementos de biblioteca o crear, eliminar y desplazar escenas.

Para reaplicar un paso al mismo objeto o a un objeto distinto, se utiliza el comando Repetir. Por ejemplo, si mueve una forma denominada forma_A, puede seleccionar Edición > Repetir para volver a mover la forma, o bien seleccionar otra forma, forma_B, y elegir Edición > Repetir para mover la segunda forma en la misma cantidad.

De forma predeterminada, Animate admite 100 niveles de deshacer para el comando de menú Deshacer. Seleccione el número de niveles de deshacer y rehacer, entre 2 y 300, en Preferencias de Animate.

De forma predeterminada, al deshacer un paso con Edición > Deshacer o el panel Historial, no se cambia el tamaño de archivo del documento, incluso si se elimina un elemento del documento. Por ejemplo, si importa un archivo de vídeo a un documento y después deshace la importación, el tamaño de archivo del documento sigue incluyendo el tamaño del archivo de vídeo. Los elementos que se eliminan de un documento al ejecutar un comando Deshacer se conservan para que sea posible restaurarlos con el comando Rehacer.

Utilización del panel Historial

El panel Historial (Ventana > Historial) muestra una lista de los pasos realizados en el documento activo desde que se abrió o creó, hasta un número máximo de pasos determinado. (El panel Historial no muestra los pasos que se han realizado en otros documentos.) El deslizador del panel Historial señala inicialmente el último paso realizado.

  • Para deshacer o rehacer pasos individuales o varios pasos a la vez, utilice el panel Historial. Los pasos del panel del historial se pueden aplicar al mismo objeto o a un objeto distinto del documento. Sin embargo, no se puede reorganizar el orden de los pasos del panel Historial. El panel Historial es un registro de los pasos en el orden en el que se han realizado.

    nota: si deshace un paso o una serie de pasos y después realiza una acción nueva en el documento, ya no se pueden rehacer los pasos del panel Historial; desaparecen del panel.

  • De forma predeterminada, Animate admite 100 niveles de deshacer para el panel Historial. Seleccione el número de niveles de deshacer y rehacer, entre 2 y 300, en Preferencias de Animate.

  • Para eliminar la lista del historial del documento actual, borre la información del panel Historial. Después de borrar la lista del historial, no se podrán deshacer los pasos que se han borrado. Si se borra la lista del historial no se deshacen pasos; sólo se elimina el registro de esos pasos de la memoria del documento actual.

Al cerrar un documento se borra su historial. Para utilizar los pasos de un documento después de cerrarlo, copie los pasos con el comando Copiar pasos o guárdelos como comando.

Cómo deshacer pasos con el panel Historial

Si se deshace un paso, el paso aparece de color más claro en el panel Historial.

  • Para deshacer el último paso realizado, arrastre el deslizador del panel Historial hasta el paso anterior en la lista.

  • Para deshacer varios pasos, arrastre el deslizador hasta cualquiera de los pasos o haga clic a la izquierda de un paso en la línea del control deslizante. El control deslizante se desplaza automáticamente a dicho paso y se deshacen los pasos por los que se desplaza.

nota: desplazarse hasta un paso (y seleccionar los pasos posteriores) es distinto de seleccionar un paso individual. Para desplazarse hasta un paso, haga clic a la izquierda del paso.

Reproducción de pasos con el panel Historial

Al repetir pasos con el panel Historial, los pasos que se reproducen son los que están seleccionados (resaltados) en el panel Historial, no necesariamente el paso que señale en ese momento el deslizador.

Los pasos del panel Historial se pueden aplicar a cualquier objeto seleccionado del documento.

Reproducción de un paso

  1. En el panel Historial, seleccione un paso y haga clic en el botón Reproducir.

Reproducción de una serie de pasos adyacentes

  1. Seleccione los pasos del panel Historial realizando uno de los siguientes procedimientos:
    • Arrastre desde un paso hasta otro. (No arrastre el deslizador; arrastre la etiqueta de texto de un paso hasta la etiqueta de texto de otro paso.)

    • Seleccione el primer paso y, con la tecla Mayús presionada, haga clic en el último paso; o bien, seleccione el último paso y, con la tecla Mayús presionada, haga clic en el primer paso.

  2. Haga clic en Reproducir. Los pasos se reproducen por orden y en el panel Historial aparece un paso nuevo denominado Reproducir pasos.

Reproducción de pasos no adyacentes

  1. Seleccione un paso del panel Historial y, con la tecla Control (Windows) o Comando (Macintosh) presionada, haga clic en otros pasos. Para anular la selección de un paso, haga clic con la tecla Control o Comando presionada.
  2. Haga clic en Reproducir.

Cómo copiar y pegar pasos entre documentos

Cada documento abierto tiene su propio historial de pasos. Para copiar pasos de un documento y pegarlos en otro, utilice el comando Copiar pasos del menú de opciones del panel Historial. Si se copian pasos en un editor de texto, los pasos se pegan como código JavaScript™.™

  1. En el documento que contiene los pasos que va a volver a utilizar, seleccione los pasos en el panel Historial.
  2. En el menú de opciones del panel Historial, seleccione Copiar pasos.
  3. Abra el documento en el que va a pegar los pasos.
  4. Seleccione un objeto en el que va a aplicar los pasos.
  5. Seleccione Edición > Pegar para pegar los pasos. Los pasos se reproducen conforme se pegan en el panel Historial del documento. El panel Historial los muestra como un solo paso denominado Pegar pasos.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea