Troubleshoot issues with saving files

Experiencing issues while saving a file in Illustrator? Here are some troubleshooting steps that you can try.

When the .ai file is reported as damaged, try the following resolutions to recover the affected file contents:

Resolution

Steps 

Save the file with a different file format

  • Change the .ai file to a different format (.svg, .png, .jpg) and then try to save the file again.
  • Save the file in Post-Script (PS) format
    1. Choose File Print.
    2. Specify the desired print settings.
    3. Choose Adobe Postscript File from the Printer menu and click Save.
    4. Type a filename that includes a .ps extension (for example, Filename.ps), and then click OK (Windows) or Save (macOS).
    5. Open the PostScript file in Illustrator and then try to save it in the .ai format.

Note: To perform this solution you must have a PostScript printer driver installed. For information about installing Postscript printers in Windows, see the Windows Help.

Copy contents to a new file

  • Remove unwanted items, such as stray points, unpainted objects, empty text paths, from the artwork. Choose Object Path Cleanup to .
  • Retain layers for the artwork in the new file. In the Layers Panel > More Options, choose Paste Remembers Layers.
  • Select the artwork and choose Edit > Copy.
  • Choose File New to create a new file.
  • In the new file, choose Edit Paste In Front to paste the artwork in the correct position on the page.

Identify and remove damaged components

To determine whether an object is damaged, delete it from the new file, and then save and reopen the file. 

  • Identify the damaged pattern, gradient, or custom color
    • Choose Edit > Select All and change the fill and stroke to process black.
    • If the issue does not recur in the new file, re-create the pattern, gradient, or spot color in the original file.
      Note: You may lose transparency and layer information.
  • Delete damaged swatches, custom colors, color groups, brushes, symbols, or styles
    Choose Select All Unused from the Swatches panel menu, from the Brushes panel menu, from the Symbols panel menu, and from the Styles panel menu, and then press Delete.
  • Convert the damaged text object to outlines or change its font
    • Choose Object > Unlock All.
    • Choose Edit > Select All.
    • Choose Type > Font and select a font that is not used in the document.
      Note: To prevent text objects from becoming damaged in the future, reinstall the problematic font from the original disk.

Issue still not resolved?

  • If no resolution works, re-create the file in Illustrator after re-saving or re-creating graphics, templates, and custom colors used in the original file. 
  • You may be facing a different file-related issue, such as issues related to memory, access permissions, network, removable media. To know more about this issue, check out the Identify and troubleshoot file issues article.

Join the conversation

Ask the community

If you have a question to ask or an idea to share, come and participate in Adobe Illustrator Community. We'd love to hear from you.

„Adobe“ logotipas

Prisijunkite prie savo paskyros