Improve performance

  1. After Effects User Guide
  2. Beta releases
    1. Beta Program Overview
    2. After Effects Beta Home
  3. Getting started
    1. Get started with After Effects
    2. What's new in After Effects 
    3. Release Notes | After Effects
    4. After Effects system requirements
    5. Keyboard shortcuts in After Effects
    6. Supported File formats | After Effects
    7. Hardware recommendations
    8. Planning and setup
    9. Setup and installation
  4. Workspaces
    1. General user interface items
    2. Get to know After Effects interface
    3. Workflows
    4. Workspaces, panels, and viewers
  5. Projects and compositions
    1. Projects
    2. Composition basics
    3. Precomposing, nesting, and pre-rendering
    4. View detailed performance information with the Composition Profiler
    5. CINEMA 4D Composition Renderer
  6. Importing footage
    1. Preparing and importing still images
    2. Importing from After Effects and Adobe Premiere Pro
    3. Importing and interpreting video and audio
    4. Preparing and importing 3D image files
    5. Importing and interpreting footage items
    6. Working with footage items
    7. XMP metadata
  7. Working with text and graphics
    1. Text
      1. Formatting characters and the Character panel
      2. Text effects
      3. Creating and editing text layers
      4. Formatting paragraphs and the Paragraph panel
      5. Extruding text and shape layers
      6. Animating text
      7. Examples and resources for text animation
      8. Live Text Templates
    2. Motion Graphics
      1. Work with Motion Graphics templates in After Effects
      2. Use expressions to create drop-down lists in Motion Graphics templates
      3. Work with Essential Properties to create Motion Graphics templates
      4. Replace images and videos in Motion Graphics templates and Essential Properties
  8. Drawing, painting, and paths
    1. Overview of shape layers, paths, and vector graphics
    2. Paint tools: Brush, Clone Stamp, and Eraser
    3. How to taper shape strokes
    4. Shape attributes, paint operations, and path operations for shape layers
    5. Use Offset Paths shape effect to alter shapes
    6. Creating shapes
    7. Create masks
    8. Remove objects from your videos with the Content-Aware Fill panel
    9. Roto Brush and Refine Matte
  9. Working with layers
    1. Selecting and arranging layers
    2. Blending modes and layer styles
    3. 3D layers
    4. Layer properties
    5. Creating layers
    6. Managing layers
    7. Layer markers and composition markers
    8. Cameras, lights, and points of interest
  10. Animation, keyframing, motion tracking, and keying
    1. Animation
      1. Animation basics
      2. Animating with Puppet tools
      3. Managing and animating shape paths and masks
      4. Animating Sketch and Capture shapes using After Effects
      5. Assorted animation tools
      6. Work with Data-driven animation
    2. Keyframe
      1. Keyframe interpolation
      2. Setting, selecting, and deleting keyframes
      3. Editing, moving, and copying keyframes
    3. Motion tracking
      1. Tracking and stabilizing motion
      2. Face Tracking
      3. Mask Tracking
      4. Mask Reference
      5. Speed
      6. Time-stretching and time-remapping
      7. Timecode and time display units
    4. Keying
      1. Keying
      2. Keying effects
  11. Transparency and compositing
    1. Compositing and transparency overview and resources
    2. Alpha channels, masks, and mattes
  12. Adjusting color
    1. Color basics
    2. Use the Adobe Color Themes extension
    3. Color management
    4. Color Correction effects
  13. Effects and animation presets
    1. Effects and animation presets overview
    2. Effect list
    3. Simulation effects
    4. Stylize effects
    5. Audio effects
    6. Distort effects
    7. Perspective effects
    8. Channel effects
    9. Generate effects
    10. Transition effects
    11. The Rolling Shutter Repair effect
    12. Blur and Sharpen effects
    13. 3D Channel effects
    14. Utility effects
    15. Matte effects
    16. Noise and Grain effects
    17. Detail-preserving Upscale effect
    18. Obsolete effects
  14. Expressions and automation
    1. Expression
      1. Expression basics
      2. Understanding the expression language
      3. Using expression controls
      4. Syntax differences between the JavaScript and Legacy ExtendScript expression engines
      5. Editing expressions
      6. Expression errors
      7. Using the Expressions editor
      8. Use expressions to edit and access text properties
      9. Expression language reference
      10. Expression examples
    2. Automation
      1. Automation
      2. Scripts
  15. Immersive video, VR, and 3D
    1. Construct VR environments in After Effects
    2. Apply immersive video effects
    3. Compositing tools for VR/360 videos
    4. Tracking 3D camera movement
    5. Work in 3D Design Space
    6. Preview changes to 3D designs real time with the Real-Time Engine
    7. Add responsive design to your graphics 
  16. Views and previews
    1. Previewing
    2. Video preview with Mercury Transmit
    3. Modifying and using views
  17. Rendering and exporting
    1. Basics of rendering and exporting
    2. Export an After Effects project as an Adobe Premiere Pro project
    3. Converting movies
    4. Multi-frame rendering
    5. Automated rendering and network rendering
    6. Rendering and exporting still images and still-image sequences
    7. Using the GoPro CineForm codec in After Effects
  18. Working with other applications
    1. Dynamic Link and After Effects
    2. Working with After Effects and other applications
    3. Sync Settings in After Effects
    4. Collaborate with Team Projects
    5. Share and manage changes with Team Project collaborators
    6. Creative Cloud Libraries in After Effects
    7. Plug-ins
    8. CINEMA 4D and Cineware
  19. Memory, storage, performance
    1. Memory and storage
    2. Improve performance
    3. Preferences
    4. GPU and GPU driver requirements for After Effects

You can improve performance by optimizing your computer system, After Effects, your project, and your workflow. Some of the suggestions here improve performance not by increasing rendering speed but by decreasing time that other operations require, such as opening a project.

Note:

By far, the best way to improve performance overall is to plan ahead, run early tests of your workflow and output pipeline, and confirm that what you are delivering is what your client actually wants and expects. (See Planning your work.)

Lloyd Alvarez provides the BG Renderer script on the After Effects Scripts website, which allows you to render and export compositions in the background while you continue to work in After Effects.

Improve performance before starting After Effects

  • Make sure that you’ve installed the current version of After Effects, including any available updates. To check for and install updates, choose Help > Updates.
  • Make sure that you’ve installed the latest versions of drivers and plug-ins, especially video card drivers. To download updates for drivers and plug-ins, go to the provider’s website.
  • Make sure that your system has enough RAM. Optimum performance is achieved with computer systems with at least 2 GB of installed RAM per processor core. See the documentation for your operating system and computer for details on how to check the amount of installed RAM and how to install RAM.
  • Quit applications that are not necessary for your work. If you run applications other than those with which After Effects shares a memory pool, and you don’t allocate adequate memory to other applications, performance can be greatly reduced when the operating system swaps RAM to the hard disk. (See Memory (RAM) usage in 64-bit After Effects.)
  • Stop or pause resource-intensive operations in other applications, such as video previews in Adobe Bridge.
  • Make sure that your system includes a display card that supports OpenGL 2.0 or later. Though After Effects can function without it, OpenGL accelerates various types of rendering, including rendering to the screen for previews. See Render with OpenGL.
  • When possible, keep the source footage files for your project on a fast local disk drive. If your source footage files are on a slow disk drive (or across a slow network connection), then performance will be poor. Ideally, use separate fast local disk drives for source footage files and rendered output.
  • A separate fast disk (or disk array) to assign the disk cache folder to, is ideal. Because of their speed, SSDs work well for this function.

Improve performance by optimizing memory, cache, and multiprocessing settings

  • Allocate adequate memory for other applications.
  • Enable caching frames to disk for previews by selecting the Enable Disk Cache preference. In After Effects, assign as much space as possible to the Disk Cache folder (on a separate fast drive) for best performance. See Disk cache.

Todd Kopriva provides more information about optimum memory and processor settings on the Adobe website.

See Memory preferences for additional information.

Improve performance using Global Performance Cache | CC, CS6

Import projects from After Effects CS5.5 and earlier into After Effects to take advantage of the Global Performance Cache. For details, see Disk Cache.

Persistent disk cache improves performance by retaining frames stored in the disk cache between sessions, saving rendering time as you work on a project or other projects that might use the same cached frames.

Improve performance by simplifying your project

By simplifying and dividing your project, you can prevent After Effects from using memory and other resources to process elements that you are not currently working with. Also, by controlling when After Effects performs certain processing, you can greatly improve overall performance. For example, you can avoid repeating an action that needs to happen only once, or you can postpone an action until it is more convenient for you.

  • Delete unused elements from your project. See Remove items from a project.
  • Divide complex projects into simpler projects, and then recombine them before you render the finished movie. To recombine projects, import all of the projects into a single project. See Import an After Effects project.
  • Before rendering, put all of your source footage files on a fast, local disk—not the one that you’re rendering and exporting to. A good way to do this is with the Collect Files command. See Collect files in one location.
  • Pre-render nested compositions. Render a completed composition as a movie so that After Effects doesn’t rerender the composition every time it is displayed. See Pre-render a nested composition.
  • Substitute a low-resolution or still-image proxy for a source item when not working directly with that item. See Placeholders and proxies.
  • Lower the resolution for the composition. See Resolution.
  • Isolate the layer you’re working on by using the Solo switch. See Solo a layer.

Improve performance by modifying screen output

You can improve performance in many ways that don’t affect how After Effects treats your project data, only how output is drawn to the screen as you work. Although it is often useful to see certain items and information as you work, After Effects uses memory and processor resources to update this information, so be selective in what you choose to display as you work. You will likely need to see different aspects of your project at different points in your workflow, so you may apply the following suggestions in various combinations at various stages.

  • Turn off display color management and output simulation when not needed. See Simulate how colors will appear on a different output device. The speed and quality of color management for previews are controlled by the Viewer Quality preferences. See Viewer Quality preferences.
  • Enable hardware acceleration of previews, which uses the GPU to assist in drawing previews to the screen. Choose Edit > Preferences > Display (Windows) or After Effects > Preferences > Display (Mac OS), and select Hardware Accelerate Composition, Layer, And Footage Panels.
  • Close unneeded panels. After Effects must use memory and processor resources to update open panels, which may slow the work that you are doing in another panel.
  • Create a region of interest. If you are working on a small part of your composition, limit which portion of the composition is rendered to the screen during previews. See Region of interest (ROI).
  • Deselect Show Cache Indicators in the Timeline panel menu to prevent After Effects from displaying green and blue bars in the time ruler to indicate cached frames. See Caches: RAM cache, disk cache, and media cache.
  • Deselect the Show Rendering Progress In Info Panel And Flowchart preference to prevent the details of each render operation for each frame from being written to the screen. See Display preferences.
  • Hide Current Render Details in the Render Queue panel by clicking the triangle beside Current Render Details in the Render Queue panel. See Information shown for current render operations.
  • Press Caps Lock to prevent After Effects from updating Footage, Layer, or Composition panels. When you make a change that would otherwise appear in a panel, After Effects adds a red bar with a text reminder at the bottom of the panel. After Effects continues to update panel controls such as motion paths, anchor points, and mask outlines as you move them. To resume panel updates and display all changes, press Caps Lock again.
Note:

Pressing Caps Lock suspends updates (disables refresh) of previews in viewers during rendering for final output, too, although no red reminder bar appears.

  • Lower the display quality of a layer to Draft. See Layer image quality and subpixel positioning.
  • Select Draft 3D in the Timeline panel menu, which disables all lights and shadows that fall on 3D layers. It also disables the depth-of-field blur for a camera.
  • Use fast draft mode while laying out and previewing a ray-traced 3D composition by selecting an option other than "Off" from the Fast Previews button.
  • Deselect Live Update in the Timeline panel menu to prevent After Effects from updating compositions dynamically. See Preview modes and Fast Previews preferences.
  • Display audio waveforms in the Timeline panel only when necessary. See Showing properties and groups in the Timeline panel (keyboard shortcuts).
  • Disable pixel aspect ratio correction by clicking the Toggle Pixel Aspect Ratio Correction button at the bottom of a Composition, Layer, or Footage panel. The speed and quality of pixel aspect ratio correction and other scaling for previews are controlled by the Viewer Quality preferences. See Viewer Quality preferences.
  • Deselect Mirror On Computer Monitor when previewing video on an external video monitor. See Preview on an external video monitor.
  • Hide layer controls, such as masks, 3D reference axes, and layer handles. See Show or hide layer controls in the Composition panel.
  • Lower the magnification for a composition. When After Effects displays the Composition, Layer, and Footage panels at magnifications greater than 100%, screen redraw speed decreases. (See Zoom an image for preview.)
  • Set the Resolution/Down Sample Factor value of the composition to Auto in the Composition panel, which prevents the unnecessary rendering of rows or columns of pixels that aren’t drawn to the screen at low zoom levels. See Resolution.

Improve performance when using effects

Some effects, such as blurs and distortions, require large amounts of memory and processor resources. By being selective about when and how you apply these effects, you can greatly improve overall performance.

  • Apply memory-intensive and processor-intensive effects later. Animate your layers and do other work that requires real-time previews before you apply memory-intensive or processor-intensive effects (such as glows and blurs), which may make previews slower than real time.
  • Temporarily turn off effects to increase the speed of previews. See Delete or disable effects and animation presets.
  • Limit the number of particles generated by particle effects. See Simulation effects.
  • Rather than apply the same effect with the same settings to multiple layers, apply the effect to an adjustment layer. When an effect is applied to an adjustment layer, it is processed once, on the composite of all of the layers beneath it. See Create an adjustment layer.
Adobe logo

Sign in to your account