تحديد خلايا وصفوف وأعمدة جدول

عند قيامك بتحديد جزء أو كل النص في خلية، فإن هذا النص المحدد يبدو بنفس مظهر النص المحدد خارج حدود الجدول. ومع ذلك، في حالة امتداد التحديد إلى أكثر من خلية، يتم تحديد النص والخلايا.

إذا كان الجدول ممتدًا على أكثر من إطار، يؤدي استمرار وضع مؤشر الماوس فوق أي صف رأس أو تذييل ليس صف الرأس أو التذييل الأول إلى ظهور أيقونة الإقفال، مما يعني أنه ليس بإمكانك تحديد النص أو الخلايا في هذا الصف. لتحديد النص في صف رأس أو تذييل، عليك بالذهاب إلى بداية الجدول.

تحديد خلايا

  1. باستخدام أداة Type ، قم بتنفيذ أي من الأمور التالية:
    • لتحديد خلية واحدة، انقر داخل خلية ما، أو حدد نصًا، ثم اختر Table > Select > Cell.

    • لتحديد خلايا متعددة، اسحب عبر حواف الخلية. يرجى مراعاة عدم سحب خط حدود العمود أو الصف حتى لا يؤدي ذلك إلى تغيير حجم الجدول.

ملاحظة:

للتبديل بين تحديد كل النص في خلية وتحديد الخلية، اضغط على المفتاح Esc.

تحديد أعمدة أو صفوف بأكملها

  1. باستخدام أداة Type ، قم بتنفيذ أي من الأمور التالية:
    • انقر داخل خلية ما، أو حدد نصًا، ثم اختر Table > Select > Column or Row.

    • قم بتحريك المؤشر فوق الحد العلوي لعمود أو الحد الأيسر لصف حتى يتغير شكل المؤشر ويصبح شكل السهم ( أو )، ثم انقر لتحديد العمود أو الصف الحالي بأكمله.

se_01
Before and after selecting Row
  1. انقر داخل الجدول أو حدد نصًا.
  2. اختر Table > Select > Header Rows، أو Body Rows، أو Footer Rows.

تحديد الجدول بأكمله

  1. باستخدام أداة Type ، قم بتنفيذ أي من الأمور التالية:
    • انقر داخل الجدول أو حدد نصًا ثم اختر Table > Select > Table.

    • قم بتحريك المؤشر فوق ركن الجدول بأعلى اليسار حتى يتغير شكل المؤشر ويصبح شكل السهم , ثم انقر لتحديد الجدول بأكمله.

    se_02
    Before and after selecting table
    • اسحب الأداة Type عبر الجدول بأكمله.

ملاحظة:

يمكنك كذلك تحديد جدول بنفس الطريقة المتبعة في تحديد رسومات مرتبطة؛ قم بوضع نقطة الإدراج قبل أو بعد الجدول مباشرةً، ثم استمر في الضغط على مفتاح Shift أثناء الضغط على مفتاح سهم يسار أو سهم يمين لتحديد الجدول.

إدخال صفوف وأعمدة

يمكنك إدخال صفوف وأعمدة باستخدام عدد من الطرق المختلفة.

إدخال صف

  1. ضع نقطة الإدراج في صف أسفل أو أعلى المكان الذي تريد أن يظهر فيه الصف الجديد.
  2. اختر Table > Insert > Row.
  3. حدد عدد الصفوف الذي تريده.
  4. حدد إذا كان سيظهر الصف أو الصفوف الجديدة أعلى أو أسفل الصف الحالي، ثم انقر فوق OK.

تتضمن الخلايا الجديدة نفس التنسيق الموجود بالنص في الصف الذي وضعت فيه نقطة الإدخال.

ملاحظة:

يمكنك أيضًا إنشاء صف جديد عن طريق الضغط على Tab عندما تكون نقطة الإدراج عند آخر خلية.

إدخال عمود

  1. ضع نقطة الإدراج في العمود المجاور للمكان الذي تريد أن يظهر فيه العمود الجديد.
  2. اختر Table > Insert > Column.
  3. حدد عدد الأعمدة الذي تريده.
  4. حدد إذا كان سيظهر العمود أو الأعمدة الجديدة قبل أو بعد العمود الحالي، ثم انقر فوق OK.

تتضمن الخلايا الجديدة نفس التنسيق الموجود بالنص في العمود الذي وضعت فيه نقطة الإدخال.

إدخال صفوف وأعمدة متعددة

  1. مع وجود نقطة الإدراج في خلية ما، اختر Table > Table Options > Table Setup.
  2. حدد عددًا مختلفًا من الصفوف والأعمدة، ثم انقر فوق OK.

تُضاف صفوف جديدة في أسفل الجدول؛ وتُضاف أعمدة جديدة للجهة اليمنى للجدول.

ملاحظة:

يمكنك أيضًا تغيير عدد الصفوف والأعمدة باستخدام اللوحة Table panel. لعرض لوحة الجدول، اختر Window > Type & Tables > Table.

إدراج صف أو عمود عن طريق السحب

عند إضافة الأعمدة، إذا قمت بسحب أكثر من مرة أو مرة ونصف من عرض العمود الذي يتم سحبه، فسيتم إضافة أعمدة جديدة بنفس عرض العمود الأصلي. إذا قمت بالسحب لإدراج عمود واحد فقط، يمكن أن يكون لهذا العمود عرض أضيق أو أوسع من العمود الذي تم السحب من عنده. ويتم نفس الوضع في حالة الصفوف، ما لم يتم ضبط الخيارAt Least لارتفاع الصف الذي يتم سحبه. في هذه الحالة إذا قمت بالسحب لإنشاء صف واحد فقط، سيقوم InDesign بتغيير حجم الصف الجديد، إذا لزم الأمر، حتى يكون بالطول الكافي لاحتواء النص.

  1. ضع أداة Type  أعلى حدود عمود أو صف حتى تظهر أيقونة السهم المزدوج ( أو ).
  2. اضغط لأسفل زر الماوس، ثم اضغط لأسفل على المفتاح Alt (في حالة نظام التشغيل Windows) أو على المفتاح Option (في حالة نظام التشغيل Mac OS) بينما تقوم بالسحب لأسفل لإنشاء صف جديد أو لليمين لإنشاء عمود جديد. (إذا قمت بالضغط على المفتاح Alt أو Option قبل الضغط لأسفل على زر الماوس، فستظهر أداة اليد-- لذلك تأكد من بدأ عملية السحب قبل أن تقوم بضغط مفتاح Alt أو Option.)

ملاحظة:

لا يعمل السحب لإدراج صفوف أو أعمدة عند الحواف العليا أو اليسرى للجدول. تستخدم هذه الحقول لتحديد صفوف أو أعمدة.

ملاحظة:

لا يعمل سحبها إدراج صفوف أو أعمدة في أعلى أو يسار حواف الجدول في الجداول الأفقية، أو في أعلى أو يمين حواف الجدول في الجداول الرأسية. تستخدم هذه الحقول لتحديد صفوف أو أعمدة.

حذف صفوف أو أعمدة أو جداول

  • لحذف صف أو عمود أو جدول، ضع نقطة الإدراج داخل جدول أو حدد نص في الجدول ثم اختر Table > Delete > Row، أو Column، أو Table
  • لحذف صفوف وأعمدة باستخدام مربع الحوار Table Options، اختر Table > Table Options > Table Setup. حدد عددًا مختلفًا من الصفوف والأعمدة، ثم انقر فوق OK. تُحذَف الصفوف من أسفل الجدول؛ وتُحذَف الأعمدة من الجهة اليمنى للجدول.

ملاحظة:

في الجدول الرأسي، يتم حذف الصفوف من الجانب الأيسر للجدول؛ وتُحذَف الأعمدة من أسفل الجدول.

  • لحذف صف أو عمود باستخدام الماوس، ضع المؤشر فوق حدود الجانب الأيمن أو السفلي للجدول حتى تظهر أيقونة السهم المزدوج ( أو ) اضغط لأسفل على زر الماوس؛ ثم اضغط على مفتاح Alt (في حالة نظام التشغيل Windows) أو على المفتاح Option (في حالة نظام التشغيلMac OS) بينما تقوم بالسحب إما لأعلى لحذف الصفوف أو لليسار لحذف الأعمدة.

ملاحظة:

إذا قمت بالضغط على المفتاح Alt أو Option قبل الضغط لأسفل على زر الماوس، فستظهر الأداة Hand -- لذلك اضغط على المفتاح Alt أو Option بعد بدء السحب.

  • لحذف محتويات خلايا دون حذف الخلايا، قم بتحديد الخلايا التي تحتوي على النص الذي تريد حذفه أو استخدم الأداة Type لتحديد النص داخل الخلايا. اضغط على Backspace or Delete أو اختر Edit > Clear.

تغيير محاذاة جدول داخل إطار

يتماشى الجدول طبقًا لعرض الفقرة أو خلية الجدول الذي تم إنشاؤه خلالهم. ومع ذلك، فإنه يمكنك تغيير حجم إطار النص أو الجدول مما يؤدي إلى جعل عرض الجدول أكثر أو أقل عرضاً من الإطار. في مثل هذه الحالات، يمكنك أن تقرر إذا ما كنت تريد جعل الجدول محاذيا للإطار أم لا.

  1. ضع نقطة الإدراج على يمين أو يسار الجدول. تأكد من أن نقطة إدراج النص موضوعة في فقرة الجدول وليست خارج الجدول. يصبح طول نقطة الإدراج مكافئًا لطول الجدول في الإطار.
  2. انقر فوق زر محاذاة (على سبيل المثال، الزر Align Center) في اللوحة Paragraph panel أو Control panel.

استخدم Tab أو مفاتيح الأسهم للتنقل في الجدول. يمكنك أيضًا الانتقال إلى صف معين، ويعتبر ذلك مفيدًا في الجداول الطويلة.

الانتقال في جدول باستخدام Tab

  • اضغط على المفتاح Tab للانتقال إلى الخلية التالية. إذا قمت بالضغط على المفتاح Tab في آخر خلية في الجدول، فسيتم إنشاء صف جديد. للحصول على معلومات عن إدراج حروف جدولة ومسافات إزاحة في جدول، راجع تنسيق نص ضمن جدول.
  • اضغط على مفتاحي Shift+Tab للتحرك إلى الخلية السابقة. إذا ضغطت على المفتاحين Shift+Tab في أول خلية في الجدول، تتحرك نقطة الإدراج إلى آخر خلية في الجدول.

ملاحظة:

تختلف الخلية الأولى والخلية الأخيرة والخلية السابقة والخلية التالية بناء على اتجاه كتابة المجموعة النصية. بالنسبة للكتابة الأفقية، تكون الخلية الأولى في الركن الأيسر العلوي، والخلية الأخيرة في الركن الأيمن السفلي، والخلية السابقة هي الخلية الموجودة على اليسار (الخلية السابقة لخلية على الحافة اليسرى هي الموجودة أقصى اليمين في الصف أعلاه)، والخلية التالية هي الخلية الموجودة على اليمين (الخلية التالية من الخلية على الحافة السفلية هي الموجودة في أقصى اليسار على السف أدناه). بالنسبة للكتابة الرأسية، تكون الخلية الأولى في الركن الأيمن العلوي، والخلية الأخيرة في الركن الأيسر السفلي، والخلية السابقة هي الخلية الموجودة في الأعلى (الخلية السابقة لخلية على الحافة العليا هي الخلية السفلية من الصف على اليمين)، والخلية التالية هي الخلية الموجودة أسفلها (الخلية التالية من الخلية على الحافة السفلية هي الخلية العليا للصف الموجود على اليسار).

الانتقال في جدول باستخدام مفاتيح الأسهم

  1. اضغط على مفاتيح الأسهم للتحرك داخل وبين خلايا الجدول. إذا قمت بالضغط على مفتاح السهم الأيمن عندما تكون نقطة الإدراج عند نهاية آخر خلية في الصف، تتحرك نقطة الإدراج لبداية الخلية الأولى في الصف نفسه. بطريقة مماثلة، إذا قمت بالضغط على مفتاح السهم الأسفل عندما تكون نقطة الإدراج عند نهاية آخر خلية في العمود، تتحرك نقطة الإدراج لبداية الخلية الأولى في العمود نفسه.
  2. إذا قمت بالضغط على مفتاح السهم لأسفل عندما تكون نقطة الإدراج عند نهاية آخر خلية في الصف في الجدول الرأسي، تتحرك نقطة الإدراج لبداية الخلية الأولى في الصف نفسه. بطريقة مماثلة، إذا قمت بالضغط على مفتاح السهم الأيسر عندما تكون نقطة الإدراج عند نهاية آخر خلية في عمود في جدول رأسي، تتحرك نقطة الإدراج لبداية الخلية الأولى في العمود نفسه.

الانتقال إلى صف محدد في جدول

  1. اختر Table > Go To Row.
  2. قم بأي من الأمور التالية:
    • حدد رقم الصف الذي تريد الذهاب إليه ثم انقر فوق OK.

    • إذا كان صف الرأس أو التذييل محددًا في الجدول الحالي، فقم باختيار الرأس أو التذييل من القائمة، ثم انقر فوق OK.

قص ونسخ ولصق محتويات جدول

عند تحديد نص داخل خلية تكون عمليات القص والنسخ واللصق مماثلة لهذه العمليات عند إجرائها على النص المحدد خارج الجدول. يمكنك أيضًا قص ونسخ ولصق الخلايا ومحتواها. إذا كانت نقطة الإدراج في الجدول عند اللصق تظهر خلايا ملصقة متعددة مثل الجدول داخل جدول. يمكنك أيضًا تحريك أو نسخ الجدول بأكمله.

  1. اختر الخلايا التي تريد قصها أو نسخها ثم اختر Edit > Cut أو Copy.
  2. قم بأي من الأمور التالية:
    • لإدراج جدول داخل جدول، ضع نقطة الإدراج في الخلية التي تريد أن يظهر فيها الجدول ثم اختر Edit > Paste.

    • لاستبدال خلايا موجودة، قم بتحديد خلية أو أكثر في الجدول -- مع التأكد من وجود خلايا كافية أسفل ويمين الخلية المحددة -- ثم اختر Edit > Paste.

تحريك أو نسخ جدول

  1. لتحديد الجدول بأكمله، ضع نقطة الإدراج في الجدول ثم اختر Table > Select > Table.
  2. اختر Edit > Cut أو Copy، حرك نقطة الإدراج حيث تريد أن يظهر الجدول، ثم اختر Edit > Paste.

تحويل الجداول إلى نص

  1. باستخدام أداة Type ، ضع علامة الإدخال في داخل الجدول، وحدد النص الموجود في الجدول.
  2. اختر Table > Convert Table To Text.
  3. بالنسبة إلى كلٍّ من فاصل العمود وفاصل الصف، قم بتحديد الفواصل التي تود استخدامها.

    للحصول على أفضل النتائج، استخدم فاصلاً مختلفًا لكلٍّ من الأعمدة أو الصفوف، فمثلاً، استخدم حروف الجدولة للأعمدة والفقرات للصفوف.

  4. انقر فوق OK.

عند قيامك بتحويل جدول إلى نص، فسيتم حذف خطوط الجدول وإدراج الفاصل الذي قمت بتحديده في نهاية كل صف وعمود.

تجميع الجداول

استخدم أمر اللصق لدمج جدولين أو أكثر في جدول واحد.

  1. في الجدول المستهدف، قم بإدخال على الأقل عدد مساوٍ من الصفوف الفارغة حسب ما تلصقه من جداول أخرى. (إذا قمت بإدخال صفوف أقل مما هو منسوخ، فلا يمكنك اللصق.)
  2. في الجدول الأصل، جدد الخلايا التي تريد نسخها. (إذا قمت بنسخ أكثر من الخلايا المتوفرة في الجدول المستهدف، فلا يمكنك اللصق.)
  3. حدد خلية واحدة على الأقل حيث تريد إدراج الصفوف الواردة، ثم اختر Edit > Paste.

ملاحظة:

إذا كانت الصفوف الملصوقة تستخدم تنسيقًا مختلفًا عن بقية الجدول، فعرِّف نمط خلية أو أكثر، ثم قم بتطبيق أنماط خلايا على الخلايا الملصوقة. اضغط مع الاستمرار على المفتاح Alt (في Windows) أو المفتاح Option (في Mac OS) أثناء النقر على نمط الخلية لتتخطى التنسيق الموجود.

تقدم آن ماري كونسبسيو مقالة عن دمج الجداول في ربط الجداول.

العمل باستخدام الجداول في Story Editor

عندما تختار Edit > Edit In Story Editor، تظهر الجداول ومحتوياتها في Story Editor. يمكنك تحرير الجداول في Story Editor.

se_TablesIDStory
Editing tables in Story Editor

A. Table icon B. Overset graphic 
  • لتمديد أو تقليص الجدول في Story Editor، انقر فوق المثلث الموجود على يسار أيقونة الجدول أعلى الجدول.

  • لتحدد إذا ما كان الجدول مرتبًا بالصف أو بالعمود، انقر بزر الماوس الأيمن (في Windows) أو انقر مع الضغط على المفتاح Ctrl (في Mac OS) على أيقونة الجدول واختر Arrange By Rows أو Arrange By Columns.

  • استخدم عرض Layout لتعديل وتنسيق الجدول. لا يمكنك تحديد الأعمدة أو الصفوف في Story Editor.

العمل باستخدام الجداول في طريقة العرض Galley أو Story

عندما تعمل في طريقة عرض Galley أو Story، يمكنك تحرير الجداول ومحتوياتها.

se_TablesICStory
Editing tables in Story view
  • لتمديد أو تقليص الجدول في عرض المجموعة النصية، انقر فوق المثلث الموجود على يسار أيقونة الجدول أعلى الجدول.

  • لتحديد ما إذا كان الجدول مرتبًا بالصف أو بالعمود، فانقر بزر الماوس الأيمن (في Windows) أو انقر مع الضغط على مفتاح Ctrl (في Mac OS) على أيقونة الجدول واختر By Rows أو Arrange By Columns.

  • استخدم عرض Layout لتعديل وتنسيق الجدول. بإمكانك تحديد الأعمدة أو الصفوف في عرض لوحة Galley أو Story.

تم ترخيص هذا العمل بموجب الترخيص العام غير المعدل الخاص بالإسناد وعدم التجارة والمشاركة الإصدار 3.0 ‏من ‏‏Creative Commons‏‏  إن بنود Creative Commons لا تشمل منشورات Twitter™‎ وFacebook.

إشعارات قانونية   |   سياسة الخصوصية على الإنترنت