خطأ "...الخطوط غير متوفرة في الوقت الحالي..." | InCopy، InDesign

المشكلة

عند فتح مستند أو استيراد نص أو رسومات أو تحويل ملفات PageMaker 6.5 - 7.x أو QuarkXPress 3.3x - 4.1، تتلقى الخطأ التالي:

"المستند [اسم الملف] يستخدم واحد أو أكثر من الخطوط التي لا تتوفر حاليًا على نظامك. سوف يستخدم النص خطًا بديلاً حتى يصبح الخط الأصلي متاحًا."

التفاصيل

  • يعرض التطبيق قائمة بالخطوط المفقودة مع رسالة التنبيه.
  • تظهر الخطوط المفقودة في القسم Missing في الجزء العلوي من قائمة Font.
  • يمكن تمييز النص الذي يستخدم الخطوط المفقودة باللون الوردي.

الحل 1: قم بتثبيت الخطوط المفقودة أو تنشيطها.

قم بتثبيت الخطوط المفقودة (راجع "تثبيت الخطوط" في تعليمات InDesign أو InCopy للحصول على مزيد من المعلومات). إذا كانت الخطوط مثبتة بالفعل وتستخدم أداة لإدارة الخطوط، فتأكد من تنشيط الخطوط. إذا كنت تستخدم أداة لإدارة الخطوط، فراجع الوثائق المضمنة مع الأداة للحصول على التعليمات.

الحل 2: قم بتثبيت نمط الخط أو استخدام أنماط الخطوط المثبتة فقط.

يدعم InDesign وInCopy أنماط الخطوط المثبتة فقط. لا تتضمن بعض الخطوط، مثل Critter، أنماطًا غامقة أو مائلة. في مثل هذه الحالات، حدد النسخة العادية للخط في InDesign أو InCopy. وتأكد من تثبيت نمط الخط (على سبيل المثال، Tekton Bold وOptima Oblique) أو تغيير نمط الخط إلى النمط المتوفر في InDesign أو InCopy.

الحل 3: أعد تثبيت الخطوط المفقودة

تأكد من ظهور الخط في تطبيق آخر للتحقق من تثبيت الخط بشكل صحيح. إذا لم يظهر الخط في تطبيق آخر، فأعد تثبيت الخط. بعد تثبيت الخط، من الضروري في بعض الأحيان إعادة تشغيل الكمبيوتر حتى يصبح الخط متاحًا.

 يقوم Mac OS X بتثبيت الخطوط وإدارتها بشكل مختلف عن الإصدارات السابقة من نظام Mac OS. لمزيد من المعلومات، راجع استكشاف مشاكل الخطوط وإصلاحها (Mac OS X) أو راجع مقالة دعم Apple "Mac OS X: مواقع الخطوط وأغراضها" على موقع الويب الخاص بشركة Apple في http://docs.info.apple.com/article.html?artnum=106417.

الحل 4: قم باستبدال الخطوط المفقودة.

استخدم الأمر البحث عن خط لاستبدال كل مثيل للخط المفقود بخط مثبت.

لا يقوم الأمر البحث عن خط باستبدال الخطوط الموجودة في الرسومات المستوردة. إذا كان الخط المفقود في ملف EPS أو PDF موضوع، فقم بتثبيت الخط المفقود. أو قم بإعادة إنشاء ملف EPS أو PDF وتضمين الخط.

يمكن أن يؤدي استبدال خط إلى تغيير مظهر المستند إذا كان الخط الذي تم تثبيته يشغل مساحة أكبر أو أصغر من الخط المفقود.

لاستبدال خط مفقود:

  1. افتح المستند.
  2. اختر Type > Find Font.
  3. في مربع الحوار Find Font، حدد الخط المفقود من قائمة Fonts In Document.
  4. اختر نمط خط جديدًا وعائلة الخط من قوائم Replace With.
  5. انقر فوق Find First ثم Change or Change/Find لتمييز وتغيير المثيلات الفردية للخط المفقود، أو انقر فوق Change All لاستبدال جميع تكرارات الخط المفقود.

الحل 5: تأكد من أن خطوط Type 1‏ (PostScript) بها ملف نقطي وملف مخطط.

إذا كان الخط المفقود هو Type 1‏ (PostScript)، فتأكد من أن يوجد كلاً من الملف المخطط والملف النقطي في المجلدات التالية على مستوى النظام:

إذا كنت تستخدم أداة لإدارة الخطوط، مثل ATM Deluxe، فيمكن تخزين الخطوط في مكان آخر على القرص الصلب. لم يتم اختبار ATM على نظام التشغيل Vista وهي غير معتمدة رسميًا على نظام التشغيل هذا.

على نظام Windows XP:

  • الملفات المخططة (.pfm)‏: X:/Windows/Fonts حيث "X" هو محرك أقراص النظام
  • الملفات النقطية (.pfb, .afm)‏: X:/Windows/Fonts حيث "X" هو محرك أقراص النظام

على نظام Windows 2000:

  • الملفات المخططة (.pfm)‏: X:/Winnt/Fonts حيث "X" هو محرك أقراص النظام
  • الملفات النقطية (.pfb, .afm)‏: X:/PSFONTS حيث "X" هو محرك أقراص النظام

على نظام التشغيل macOS:

 تستخدم الملفات النقطية من نوع Adobe Type 1‏ (PostScript) اسم الخط. تستخدم الملفات المخططة نسخة قصيرة من اسم الخط (مثل "Isabe" للخط Isabella). حدد الملف للتحقق من ما إذا كان الملف عبارة عن ملف من النوع Type 1 Outline أو Bitmap أو Suitcase أو TrueType أو خط OpenType من ملف Adobe. ثم اختر File > Get Info في Finder وابحث في الحقل Kind.

  • Library/Fonts
  • System Folder/Fonts
  • User/Library/Fonts
  • User/Library/Application Support/Adobe/Fonts
  • Applications/Adobe InCopy [الإصدار] /Fonts
  • Applications/Adobe InDesign [الإصدار] /Fonts

الحل 6: أعد إنشاء ملفات قائمة خطوط Adobe.

على نظام Windows:

  1. قم بإنهاء جميع تطبيقات Adobe.
  2. اختر Start > Search > For Files or Folders.
  3. البحث عن ملفات قائمة الخطوط:

    • على Windows XP وWindows Vista، اكتب ‏"Adobefnt*.lst" (بما في ذلك علامات الاقتباس) في المربع All Or Part Of The Filename، ثم انقر فوق Search.
    • على Windows 2000، اكتب ‏"Adobefnt*.lst" (بما في ذلك علامات الاقتباس) في المربع "المسمى"، ثم انقر فوق Find Now.
  4. حدد جميع الملفات المدرجة واختر File > Delete. (إذا قمت بحذف ملف قائمة الخطوط لتطبيق Adobe آخر، فيتم إعادة إنشاء الملف في المرة التالية التي يتم فيها بدء تشغيل تطبيق Adobe.)
  5. أعد تشغيل InCopy أو InDesign. يتم إعادة إنشاء ملفات قائمة الخطوط أثناء بدء التشغيل.

على نظام التشغيل macOS:

  1. قم بإنهاء جميع تطبيقات Adobe.
  2. اختر File > Find، ثم قم بتنفيذ أحد الخيارات التالية:

    • -على Mac OS X v10.4.x، انقر فوق الزر "الكمبيوتر"، اكتب Adobefnt في حقل النص بجانب File Name Is ثم انقر فوق Enter.
    • على Mac OS X v10.2.x-v10.3.x، اختر Local Disks من قائمة Search In، اكتب Adobefnt في المربع بجانب File Name Is ثم انقر فوق Search.
  3. حدد الملف، ثم اختر File > Move to Trash.

  4. كرر الخطوات من 2 إلى 3 لملفات Adobefnt05.lst وAdobefnt06.lst.
  5. أعد تشغيل InCopy أو InDesign. يتم إعادة إنشاء ملفات قائمة الخطوط أثناء بدء التشغيل.

 لنظام Mac OS 10.5x، إذا لم يتم العثور على ملف adobefnt.lst، فقم بإضافة ملفات النظام في معايير البحث في مربع الحوار File > Find.

  1. حدد Other في القائمة المنسدلة النوع وانتظر حتى يظهر مربع الحوار Select a Search Attribute
  2. اكتب النظام.
  3. حدد System Files من القائمة ثم انقر فوق OK.
  4. تحقق أيضًا من المربع في القائمة إذا كنت تريد أن تظهر ملفات النظام في المعايير الخاصة بك في المستقبل.

الحل 7: قم بتقليل عدد الخطوط النشطة أو استكشاف أخطاء الخطوط التالفة وإصلاحها.

قد لا يتعرف InCopy أو InDesign على الخطوط إذا كان هناك عدد كبير جدًا منها أو في حالة تلف واحد أو أكثر من الخطوط. لمزيد من المعلومات حول تقليل عدد الخطوط أو التحقق من الخطوط التالفة، راجع أحد المستندات التالية:

معلومات إضافية

يتحقق InCopy وInDesign من الخطوط المفقودة عند فتح الملفات أو استيراد النص أو الرسومات. إذا كان التطبيق لا يمكنه تحديد موقع الخط، فإنه يقوم بإرجاع تنبيه ويدرج الخط في القسم مفقود من القائمة الخط. بشكل افتراضي، يقوم InCopy وInDesign بتمييز جميع النصوص التي تستخدم خطًا بديلاً باللون الوردي. لتعطيل هذا التمييز، اختر File > Preferences > Composition‏ (Windows) أو InDesign > Preferences > Composition‏ (macOS)، ثم ألغ تحديد Substituted Fonts.

يستطيع InDesign العثور على خطوط Adobe إما في مجلد الخطوط على مستوى النظام أو مجلدات الخطوط الخاصة بتطبيق Adobe. يقوم InDesign بتثبيت الخطوط إلى المواقع المذكورة أدناه:

الخطوط التي يقوم InDesign وInCopy CS2 بتثبيتها

يقوم InDesign CS2 وInCopy CS2 بتثبيت خطوط OpenType التالية من Adobe في [Macintosh HD] /Library/Application Support/Adobe/Fonts/‏ (Mac OS) أو Program Files/Common Files/Adobe/Fonts/‏ (Windows):

  • Adobe Caslon Pro
  • Adobe Garamond Pro
  • Adobe Jenson Pro
  • Adobe Ming Std
  • Adobe Myungjo Std
  • Adobe Song Std
  • Caflisch Script Pro
  • Kozuka Gothic Pro
  • Kozuka Gothic Std
  • Kozuka Mincho Pro
  • Kozuka Mincho Std
  • Letter Gothic Std
  • Lithos Pro
  • Myriad Pro Condensed
  • Poplar Std
  • Ryo Text Std
  • Trajan Pro
  • Ryo Display Std

الخطوط التي يقوم InDesign وInCopy CS3 بتثبيتها

يقوم InDesign CS3 وInCopy CS3 بتثبيت خطوط OpenType التالية من Adobe في [startup drive] /Library/Fonts/ (Mac OS) أو [startup drive]\Windows\Fonts\ (Windows):

  • Adobe Caslon
  • Adobe Garamond
  • Arno
  • Bell Gothic
  • Bickham Script
  • Birch
  • Blackoak
  • BrushScript
  • Chaparral
  • Charlemagne
  • Cooper Black
  • Eccentric
  • Garamond Premier Pro
  • Giddyup
  • Hobo
  • Kozuka Gothic
  • Kozuka Mincho
  • Letter Gothic
  • Lithos
  • Mesquite
  • Minion
  • Myriad
  • Nueva
  • OCR-A
  • Orator
  • Poplar
  • Prestige Elite
  • Rosewood
  • Stencil
  • Tekton
  • Trajan

تواصل معنا

نحن نحب أن نسمع منك. شارك أفكارك مع مجتمع Adobe InDesign

شعار Adobe

تسجيل الدخول إلى حسابك