Nota:

La funcionalidad de OpenGL en After Effects CS6 es diferente de la que tiene en versiones anteriores. Este documento solo es válido para After Effects de las versiones CS4 a CS5.5. Para obtener más información sobre la funcionalidad de la GPU de After Effects CS6, vea este vídeo.

Este documento puede ayudarle a resolver problemas relacionados con OpenGL que ocurren mientras se utiliza After Effects. Los problemas de OpenGL se pueden manifestar de muy diversas formas, incluidas (aunque no únicamente) las siguientes:

  • Adobe After Effects se bloquea o se cierra sin un error mientras se inicia.
  • Bloqueo o congelación cuando arrastra la línea de tiempo o selecciona la vista previa o renderiza una composición.
  • Bloqueo cuando cambia la configuración de un efecto mientras las vistas previas de OpenGL están habilitadas.
  • Bloqueo o congelación cuando habilita o deshabilita las vistas previas de OpenGL.
  • La ventana de composición tarda mucho tiempo en redibujar.
  • Se dibujan artefactos o bloques de píxeles "basura" en la ventana de composición.
  • La ventana de composición se dibuja de forma diferente si las vistas previas de OpenGL están activadas o desactivadas.
  • Mensaje de error similar al siguiente:

    "Aviso de After Effects: ha ocurrido un problema cuando se estaban procesando los comandos de OpenGL".

    "La instrucción en '0x00fe1940' hacía referencia a la memoria en '0x000000000'. No se ha podido 'leer' la memoria".

    "AE_OpenGL: fallo al generar mapa de sombras (5065::0)"

    "Esta composición es demasiado compleja para el hardware de OpenGL".

    "Error de After Effects: AE_OpenGL: error al crear textura. (5065 :: 0)"

Para obtener más información acerca de cómo configurar las preferencias de la vista previa en After Effects para OpenGL y una lista de funciones en After Effects que se pueden renderizar con OpenGL, consulte Renderizar con OpenGL en la Ayuda de After Effects.

Para sacar el máximo provecho a este documento, realice las tareas en orden. Grabe las tareas que ejecuta y de sus resultados, incluidos los errores y problemas. El servicio de soporte técnico de Adobe puede utilizar esta información para ofrecerle una ayuda más completa, en el caso de que necesitara ponerse en contacto con ellos.

Debe haber iniciado sesión como administrador para poder realizar algunos de los procedimientos detallados en este documento.

Para Windows, algunos de estos procedimientos requieren la localización de archivos y carpetas ocultos. Algunos procedimientos requieren la localización de archivos por su nombre completo, que incluye la extensión (como por ejemplo, ejemplo_nombre_de_archivo.ini). De manera predeterminada, el Explorador de Windows no muestra los archivos ocultos, las carpetas ocultas ni las extensiones de nombre de archivo que reconoce. Consulte Mostrar archivos y carpetas ocultos en Windows para obtener más información.

Para Windows Vista, los pasos aquí descritos que mencionan el Panel de control hacen referencia a la vista clásica. Si necesita información sobre cómo activar la vista clásica del Panel de control o sobre otros procedimientos habituales de sistema operativo, consulte Common OS procedures.

Estas tareas pueden ayudarle a resolver los problemas más comunes con OpenGL. Antes de realizar cualquiera de estas tareas, haga una copia de seguridad de todos sus archivos personales (por ejemplo, los archivos de After Effects que haya creado). Siempre que se produzca un error del sistema, debe reiniciar el ordenador para actualizar su memoria. Si continúa trabajando sin reiniciar el ordenador, podría agravarse el problema.

1. Actualice a la versión más reciente de After Effects.

Para comprobar si existen actualizaciones, seleccione Ayuda > Actualizaciones en After Effects.

2. Asegúrese de que el sistema cumpla los requisitos mínimos de After Effects.

Consulte esta página para obtener una lista de requisitos del sistema para After Effects: Requisitos del sistema de Adobe After Effects.

3. Asegúrese de que la tarjeta de vídeo y los controladores cumplan los requisitos de OpenGL.

Para usar OpenGL en After Effects, se necesita una tarjeta de OpenGL compatible con OpenGL 2.0.

Para determinar qué versión de OpenGL es compatible con la tarjeta, haga clic en el botón Información de OpenGL en las preferencias de la vista previa. En Mac OS, seleccione After Effects > Preferencias > Vistas previas. En Windows, seleccione Editar > Preferencias > Vistas previas.

Para obtener información sobre el hardware de OpenGL compatible, consulte Funciones de la GPU (CUDA, OpenGL).

Los controladores de tarjetas de vídeo más recientes pueden mejorar las funciones de OpenGL de la tarjeta. Consulte Actualice el controlador de la tarjeta de vídeo.

4. Deshabilite OpenGL para determinar si está provocando el problema.

Para deshabilitar las vistas previas de OpenGL:

  1. Seleccione After Effects > Preferencias > Vistas previas (Mac OS) o Editar > Preferencias > Vistas previas (Windows).
  2. Anule la selección de la opción Habilitar OpenGL.

Nota: OpenGL no es compatible con algunas funciones de After Effects y la apariencia de la composición puede cambiar dependiendo de si utiliza las vistas previas de OpenGL o las vistas previas del software renderizado. Para obtener una lista de las funciones compatibles con OpenGL, consulte Renderizar con OpenGL en la sección Renderización y Exportación de la Ayuda de After Effects.

5. Elimine el plugin de OpenGL de la carpeta de plugins de After Effects.

Para determinar si el problema lo ha provocado OpenGL, elimine el plugin y reinicie After Effects.

Para eliminar el plugin de OpenGL:

  1. Salir de After Effects.
  2. Mac OS: arrastre el archivo AE_OpenGL.plugin desde la carpeta Aplicaciones/Adobe After Effects CS4/Plug-ins/Extensions al escritorio.

    Windows: arrastre el archivo AE_OpenGL.AEX desde la carpeta C:\Archivos de programa\Adobe After Effects CS4\Support Files\Plug-ins\Extensions al escritorio.
  3. Reinicie After Effects.

Si el problema se sigue produciendo, OpenGL no lo ha causado. Arrastre el plugin de OpenGL de nuevo a su ubicación original. Si el problema no vuelve a ocurrir, la causa del problema es OpenGL. Consulte Actualice el controlador de la tarjeta de vídeo.

6. Actualice el controlador de la tarjeta de vídeo.

Muchos problemas o conflictos de OpenGL se solucionan al actualizar el controlador de la tarjeta de vídeo. Muchos fabricantes de tarjetas de vídeo actualizan sus controladores de software con frecuencia. Si no ha actualizado recientemente el controlador de la tarjeta de vídeo, póngase en contacto con el fabricante de la tarjeta de vídeo para obtener un controlador actualizado, o descargue uno del sitio Web del fabricante.

7. Reinicie After Effects y pruebe el comportamiento que ha provocado el bloqueo. (Solo para Windows)

Al realizar un seguimiento a un bloqueo provocado por un problema de OpenGL en Windows, After Effects CS4 puede deshabilitar automáticamente la preferencia Impedir la fragmentación del espacio de dirección DLL. Esta preferencia permite a After Effects acceder a una cantidad mayor de RAM contiguas, pero puede que no sea compatible con algunos controladores de OpenGL.

Puede habilitar o deshabilitar la preferencia Impedir la fragmentación del espacio de dirección DLL seleccionando Editar > Preferencias > Memoria y caché.

Le recomendamos dejar esta preferencia habilitada a menos que experimente bloqueos relacionados con OpenGL o con la memoria. Si deshabilita la preferencia por un problema de OpenGL y más tarde actualiza los controladores de la tarjeta de vídeo, vuelva a habilitar la preferencia. A continuación, pruebe de nuevo si se da el problema.

8. Optimice la preferencia de memoria de textura.

Los bloqueos u errores de OpenGL pueden ocurrir si After Effects intentar usar demasiada memoria de textura de vídeo. La memoria de textura es la cantidad de RAM en la tarjeta de vídeo (VRAM).

Configuración de la preferencia Memoria de textura en After Effects:

  1. Multiplique la VRAM total instalada por el 80% para calcular la configuración de Memoria de textura óptima.
  2. En After Effects, seleccione After Effects > Preferencias > Vistas previas (Mac OS) o Editar > Preferencias > Vistas previas (Windows).
  3. Haga clic en Información de OpenGL.
  4. Introduzca el valor que ha calculado en el paso 1 y, a continuación, haga clic en OK.

El valor ideal para la memoria de textura es el 80% de la VRAM en la tarjeta de vídeo. (Si usa varias tarjetas de vídeo, calcule el 80% de la VRAM en la tarjeta de vídeo que está identificada en el cuadro de diálogo Información de OpenGL). Si la preferencia Memoria de textura en After Effects está configurada en más del 80% de la VRAM, es posible que no quede suficiente VRAM para que la tarjeta de vídeo gestione la interfaz del usuario u otras tareas. Por ejemplo, toda la pantalla puede quedarse en blanco. Si el valor está configurado por debajo del 80%, las vistas previas de OpenGL en After Effects pueden tardar mucho en procesar los fotogramas.

Consulte la Ayuda de Mac OS o la Ayuda de Windows para obtener más información acerca de cómo determinar la cantidad de VRAM en una tarjeta de vídeo.

9. Purgue las cachés de imagen y la memoria de vídeo.

Si After Effects muestra artefactos o "basura" (bloques de píxeles incorrectos) en la ventana de composición, la memoria de vídeo (VRAM) podría estar llena, fragmentada o dañada. Purgue la las cachés de imagen y la memoria de vídeo para vaciar la VRAM y permitir a After Effects reconstruir la vista previa de la composición.

Para purgar las cachés de imagen, seleccione Editar > Purgar > Cachés de imagen.

Para purgar la memoria de vídeo, seleccione Editar > Purgar > Memoria de vídeo.

Nota: algunos protectores de pantalla que usan OpenGL (o Direct3D en Windows) pueden dañar la memoria de vídeo si se activan mientras After Effects se está ejecutando. Cambie o deshabilite el protector de pantalla si tiene problemas a menudo con imágenes dañadas en la ventana de composición tras desactivar el protector de pantalla.

10. Cambie los ajustes de color para la tarjeta de vídeo a Más alto (32 bits) (Windows) o Millones (Mac Os).

Consulte la Ayuda de Mac OS o la Ayuda de Windows para obtener más información acerca de cómo cambiar la tarjeta de vídeo o los ajustes de pantalla.

11. Deshabilite las funciones avanzadas en la tarjeta de vídeo. (Solo para Windows)

La mayoría de controladores de tarjetas de visualización incluyen utilidades que permiten acceder a funciones avanzadas de la tarjeta. En particular, las funciones de Suavizado de contorno y el modo de 16 bits pueden entrar en conflicto con OpenGL y provocar que After Effects se bloquee. Configure las funciones avanzadas de la tarjeta en su modo predeterminado, a continuación deshabilite las opciones Suavizado de contorno y modo de 16 bits.

Si está usando varios monitores con una tarjeta Nvidia, configure la opción Multimonitor en "Compatible".

Consulte la documentación de la tarjeta de vídeo o el sitio web del fabricante para obtener instrucciones sobre cómo acceder a sus funciones avanzadas.

12. Use un solo monitor.

Si está usando varios monitores y experimenta problemas con OpenGL en After Effects, intente lo siguiente:

  • si ha colocado la ventana de aplicación de After Effects o el Panel de composición en un monitor secundario, mueva la ventana al monitor primario.
  • Desconecte todos menos un monitor.
  • Si está usando varias tarjetas de visualización, elimine todas menos una. Para obtener mejores resultados con OpenGL, use una sola tarjeta de visualización de cabeza doble.

13. Incluya el script Reducir tamaño de textura de OpenGL en la carpeta Scripts de arranque.

El script Reducir tamaño de textura de OpenGL reduce la cantidad de memoria de textura que usa After Effects y puede ofrecer una mejor compatibilidad con tarjetas de vídeo antiguas.

Para colocar el script Reducir tamaño de textura de OpenGL en la carpeta Scripts de arranque:

  1. desplácese hasta la carpeta Scripts de After Effects.

    En Mac OS: Aplicaciones/Adobe After Effects CS4/Scripts.

    En Windows: C:\Archivos de programa\Adobe\Adobe After Effects CS4\Support Files\Scripts.
  2. Mueva el archivo Reducir tamaño de textura de OpenGL.jsx desde la carpeta (soporte) hasta la carpeta Arranque.

Las funciones de OpenGL del ordenador se pueden mejorar con una tarjeta de vídeo más nueva y dejará de necesitar el script. Tras instalar una nueva tarjeta y sus controladores, mueva el script Reducir el tamaño de textura de OpenGL de nuevo a la carpeta (soporte); a continuación, restaure las preferencias de After Effects.

14. Restaure las preferencias de After Effects.

Vuelva a crear el archivo de preferencias de After Effects para eliminar los problemas que puedan causar las preferencias de OpenGL dañadas.

Para volver a crear el archivo de preferencias de After Effects, reinicie After Effects. Mantenga pulsadas Ctrl+Alt+Mayús (Windows) o Comando+Opción+Mayús (Mac OS) mientras se inicia la aplicación.

15. Póngase en contacto con el servicio de soporte técnico de Adobe.

Si ninguna de las acciones anteriores elimina el error o el bloqueo de After Effects, póngase en contacto con el servicio de soporte técnico de Adobe. Puede encontrar opciones de asistencia en el servicio de soporte de Adobe.

 

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea