Creación de animaciones fotograma a fotograma

La animación fotograma a fotograma cambia el contenido del escenario en cada fotograma. Resulta más adecuado para las animaciones complejas en las que la imagen cambia en cada fotograma en lugar de moverse por el escenario. La animación fotograma a fotograma incrementa el tamaño de archivo con mayor rapidez que la animación interpolada. En la animación fotograma a fotograma, Animate CC (anteriormente Flash Professional CC) guarda los valores de los fotogramas completos.

Para crear una animación fotograma a fotograma, defina cada fotograma como fotograma clave y cree una imagen distinta para cada uno. Inicialmente, cada fotograma clave tiene el mismo contenido que el fotograma clave inmediatamente anterior, de modo que los fotogramas pueden modificarse en la animación de forma gradual.

  1. Haga clic en el nombre de una capa para activarla y seleccione un fotograma de la capa donde debe iniciarse la animación.
  2. Si el fotograma no es un fotograma clave, seleccione Insertar > Línea de tiempo > Fotograma clave.
  3. Cree la ilustración del primer fotograma de la secuencia. Utilice las herramientas de dibujo, pegue imágenes del portapapeles o importe un archivo.
  4. Para añadir un fotograma clave cuyo contenido es igual al del primer fotograma clave, haga clic en el siguiente fotograma a la derecha de la misma fila. Seleccione Insertar > Línea de tiempo > Fotograma clave, o bien, haga clic con el botón derecho (Windows) o con la tecla Control presionada (Macintosh) y seleccione Insertar fotograma clave.

  5. Para crear el siguiente incremento de la animación, cambie el contenido de este fotograma en el escenario.
  6. Para completar la secuencia de animación fotograma a fotograma, repita los pasos 4 y 5 hasta que haya creado el movimiento deseado.
  7. Para probar la secuencia de animación, elija Control > Reproducir o haga clic en el botón Reproducir del controlador (Ventana > Barras de herramientas > Controlador).

Creación de animaciones fotograma a fotograma mediante la conversión de interpolaciones clásicas o de movimiento

Puede convertir una interpolación clásica o un grupo de interpolación de movimiento en una animación fotograma a fotograma. En una animación fotograma a fotograma, cada fotograma contiene fotogramas clave independientes (no fotogramas clave de propiedad) y cada uno de ellos incluye instancias individuales del símbolo animado. La animación fotograma a fotograma no contiene valores de propiedad interpolados.

  1. Haga clic con el botón derecho (Windows) o presione la tecla Control y haga clic (Macintosh) en el grupo de interpolación que desee convertir y seleccione Convertir en animación fotograma a fotograma en el menú contextual.

Utilización de papel cebolla

Normalmente solo se muestra un fotograma de la secuencia de animación en el escenario. Para facilitar la colocación y edición de la animación fotograma a fotograma, se pueden ver varios fotogramas a la vez en el escenario. El fotograma situado bajo la cabeza lectora aparece a todo color, y se aplican color y alfa para distinguir los fotogramas pasados de los futuros. 

El papel cebolla con código de colores se aplica de forma predeterminada. Para conservar el comportamiento anterior, cambie los fotogramas pasados y futuros al color negro.

Visualización simultánea de varios fotogramas de una animación en el escenario

  1. Haga clic en el botón Papel cebolla . Todos los fotogramas entre los marcadores Papel cebolla inicial y Papel cebolla final (en el encabezado de la línea de tiempo) aparecen superpuestos como un solo fotograma en la ventana de documentos.

    Marcadores de papel cebolla

Papel cebolla con código de colores

El código de colores en la opción de papel cebolla permite diferenciar entre los fotogramas pasados, el presente y los futuros. La transparencia de los fotogramas de papel cebolla se va reduciendo según se van alejando del fotograma activo.

Opción de papel cebolla en la línea de tiempo
Opción de papel cebolla en la línea de tiempo

Código de colores en la opción de papel cebolla
Opción de papel cebolla con códigos de colores donde se distinguen los fotogramas pasados, el presente y los futuros

Modo de contorno de papel cebolla con colores

Personalización de colores para la visualización del papel cebolla

  1. Para personalizar el color de los fotogramas con papel cebolla, seleccione Fotograma de papel cebolla en la barra de la línea de tiempo.
  2. Seleccione Edición > Preferencias.
  3. En la opción Color de papel cebolla, seleccione los botones de muestra de color para personalizar y definir colores para los fotogramas pasados, el presente y los futuros.
     

Nota:

El código de color también se aplica al modo de contorno.

Modo de línea de tiempo de papel cebolla

Aplicación de papel cebolla personalizado

  • Para cambiar la posición de los marcadores de papel cebolla, arrastre el puntero hasta la nueva ubicación. En general, los marcadores de papel cebolla se mueven de forma conjunta con el puntero del fotograma actual. Utilice Control/Comando y arrastre para aumentar o disminuir la posición en ambos lados.
  • Para poder editar todos los fotogramas situados entre los marcadores de papel cebolla, haga clic en el botón Editar varios fotogramas . En general, la opción Papel cebolla solo permite editar el fotograma actual. Puede ver y editar el contenido de cada uno de los fotogramas situados entre los marcadores de papel cebolla.
  • Para mover el intervalo de reproducción en la línea de tiempo hasta una posición que incluya la de la cabeza lectora, utilice los marcadores de la línea de tiempo, mantenga pulsada la tecla Mayús y arrastre el intervalo. 
  • Para definir los marcadores de rango, utilice la tecla Mayús y arrastre los marcadores de rango o el propio rango con los marcadores de la línea de tiempo.

Nota:

Las capas bloqueadas (con el icono del candado) no aparecen cuando se activa la opción de papel cebolla. Para evitar la confusión producida por múltiples imágenes, bloquee u oculte las capas que no desea visualizar con esta opción.

Cambio de la visualización de los marcadores de papel cebolla

  1. Haga clic en el botón Modificar marcadores de papel cebolla  y elija una opción:

    Siempre mostrar los marcadores

    Muestra los marcadores de papel cebolla en el encabezado de la línea de tiempo, esté activada o no la opción de papel cebolla.

    Definir papel transparente

    Bloquea los marcadores de papel cebolla en la posición actual en el encabezado de la línea de tiempo. Normalmente el rango de papel cebolla es relativo al puntero del fotograma actual y los marcadores de papel cebolla. Al anclar los marcadores, evita que se muevan con el puntero del fotograma actual.

    Papel cebolla 2

    Muestra dos fotogramas a cada lado del fotograma actual.

    Papel cebolla 5

    Muestra cinco fotogramas a cada lado del fotograma actual.

    Papel cebolla todo

    Muestra todos los fotogramas a cada lado del fotograma actual.

Previsualización de su trabajo

Para comprobar cómo aparecerá el papel cebolla, pase el ratón por el grupo completo de la línea de tiempo. La animación se reproducirá en contornos coloreados, lo que le proporciona una previsualización precisa de los cambios. 

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea