Proteja y desproteja archivos en los servidores locales y remotos con el sistema de protección/desprotección de Dreamweaver, WebDAV o Subversion.

Si trabaja en un entorno de colaboración, puede desproteger y proteger archivos en los servidores local y remoto. Si es la única persona que trabaja en el servidor remoto, puede utilizar los comandos Obtener y Colocar para transferir los archivos sin desprotegerlos ni protegerlos.

Nota:

Las funciones Obtener y Colocar pueden utilizarse con un servidor de prueba, a diferencia del sistema de desprotección/protección.

Proteger un archivo equivale a decir: “Estoy trabajando con este archivo. ¡No lo toquen!” Cuando un archivo se encuentra protegido, se muestra el nombre del usuario que lo ha protegido junto al icono del archivo en el panel Archivos, además de una marca de verificación roja (si un miembro del equipo ha protegido el archivo) o verde (si usted ha protegido el archivo).

Al desproteger un archivo, éste queda a disposición de otros miembros del equipo, que podrán protegerlo y editarlo. Al desproteger un archivo después de editarlo, la versión local se convierte en archivo de solo lectura y aparece un símbolo de candado junto al archivo en el panel Archivos para evitar que realice cambios en él.

Dreamweaver no convierte los archivos protegidos en archivos de solo lectura en el servidor remoto. Si transfiere archivos con una aplicación que no sea Dreamweaver, es posible que se sobrescriban los archivos protegidos. Sin embargo, en aplicaciones distintas de Dreamweaver, el archivo LCK figura al lado del archivo protegido en la jerarquía de archivos para evitar errores de ese tipo.

Configuración del sistema de desprotección/protección

Antes de utilizar el sistema de desprotección/protección, deberá asociar el sitio local a un servidor remoto.

  1. Seleccione Sitio > Administrar sitios.
  2. Seleccione un sitio y haga clic en Editar.
  3. En el cuadro de diálogo Configuración del sitio, seleccione la categoría Servidores y proceda de una de las siguiente formas:
    • Haga clic en el botón Añadir nuevo servidor para añadir un nuevo servidor

    • Seleccione un servidor existente y haga clic en el botón Editar servidor existente

  4. Especifique las opciones Básicas que sean necesarias y luego haga clic en el botón Avanzadas.
  5. Seleccione Activar protección del sitio, si trabaja en equipo (o si trabaja en solitario con distintos sistemas). Anule la selección de esta opción si desea desactivar la protección y desprotección de archivos para este sitio web.

    Esta opción resulta útil para comunicar a otros usuarios que ha protegido un archivo para editarlo. También puede servir para recordarle que ha dejado una versión más reciente de un archivo en otro equipo.

    Si no aparecen las opciones de Desproteger/proteger, ello indica que no ha configurado el servidor remoto.

  6. Seleccione la opción Proteger archivos al abrir si desea proteger automáticamente los archivos cuando haga doble clic en ellos para abrirlos desde el panel Archivos.

    Si utiliza Archivo > Abrir para abrir un archivo, éste no quedará protegido aunque haya activado esta opción.

  7. Establezca las opciones restantes:

    Nombre de protección

    El nombre de protección aparecerá en el panel Archivos junto a los archivos protegidos. De este modo, los miembros del equipo sabrán a quién dirigirse si necesitan un archivo que está protegido.

    Nota:

    Si trabaja en solitario con varios sistemas, utilice un nombre de protección distinto en cada uno (por ejemplo, JoseR-MacCasa y JoseR-PCOficina) para saber dónde se encuentra la última versión del archivo si olvida desprotegerlo.

    Dirección de correo electrónico

    Si introduce una dirección de correo electrónico al proteger un archivo, su nombre aparecerá en el panel Archivos en forma de vínculo (subrayado y azul) al lado del archivo en cuestión. Si un miembro del equipo hace clic en el vínculo, su programa de correo electrónico predeterminado abrirá un mensaje con la dirección correspondiente y un título indicando el archivo y el nombre del sitio.

Desprotección y protección de archivos en una carpeta remota

Tras configurar el sistema de protección/desprotección, puede proteger y desproteger archivos de un servidor remoto mediante el panel Archivos o desde la ventana de documento.

Protección de archivos mediante el panel Archivos

  1. En el panel Archivos (Ventana > Archivos), seleccione los archivos que desea proteger en el servidor remoto.

    Nota:

    Puede seleccionar los archivos en la vista local o remota, pero no en el servidor de prueba.

    Una marca de verificación roja indica que otro miembro del equipo tiene protegido el archivo, mientras que un símbolo de candado indica que el archivo es de solo lectura (Windows) o bloqueado (Macintosh).

  2. Siga uno de estos procedimientos para proteger los archivos:
    • Haga clic en el botón Proteger de la barra de herramientas del panel Archivos.

    • Haga clic con el botón derecho (Windows) o haga clic con la tecla Control presionada (Macintosh) y elija Proteger en el menú contextual.

  3. En el cuadro de diálogo Archivos dependientes, haga clic en Sí para descargar los archivos dependientes junto con los archivos seleccionados, o en No si prefiere no descargar dichos archivos. De manera predeterminada, los archivos dependientes no se descargan. Puede establecer esta opción en Edición > Preferencias > Sitio.

    Nota:

    Suele resultar conveniente descargar archivos dependientes cuando se protege un archivo nuevo, pero si las últimas versiones de los archivos dependientes ya se encuentran en el disco local no hay necesidad de volver a descargarlos.

    Aparece una marca de verificación verde junto al icono del archivo local para indicar que lo ha protegido usted.

    Nota:

    Si protege el archivo activo, la nueva versión protegida sobrescribirá la versión del archivo abierta actualmente.

Desprotección de archivos mediante el panel Archivos

  1. En el panel Archivos (Ventana > Archivos), seleccione archivos protegidos o nuevos.

    Nota:

    Puede seleccionar los archivos en la vista local o remota, pero no en el servidor de prueba.

  2. Siga uno de estos procedimientos para desproteger los archivos:
    • Haga clic en el botón Desproteger de la barra de herramientas del panel Archivos.

    • Haga clic con el botón derecho (Windows) o haga clic con la tecla Control presionada (Macintosh) y elija Desproteger en el menú contextual.

  3. Haga clic en Sí para cargar los archivos dependientes junto con los archivos seleccionados, o en No si prefiere no cargar dichos archivos. De manera predeterminada, los archivos dependientes no se cargan. Puede establecer esta opción en Edición > Preferencias > Sitio.

    Nota:

    Suele resultar conveniente cargar archivos dependientes cuando se desprotege un archivo nuevo, pero si las últimas versiones de los archivos dependientes ya se encuentran en el servidor remoto no hay necesidad de volver a cargarlos.

    El símbolo de candado junto al icono del archivo local indica que el archivo ha pasado a ser de solo lectura.

    Nota:

    Si desprotege el archivo activo, es posible que éste se guarde automáticamente antes de desprotegerse. Dependerá de las opciones que haya configurado.

Desprotección de un archivo abierto desde la ventana de documento

  1. Asegúrese de que el archivo que desea desproteger esté abierto en la ventana de documento.

    Nota:

    Sólo es posible desproteger los archivos abiertos de uno en uno.

  2. Siga uno de estos procedimientos:
    • Elija Sitio > Desproteger.

    • Haga clic en el icono Administración de archivos de la barra de herramientas de la ventana de documento y luego seleccione Desproteger en el menú.

      Si el archivo actual no forma parte del sitio activo del panel Archivos, Dreamweaver intentará determinar a qué sitio definido localmente pertenece. Si el archivo actual pertenece a un sitio diferente del activo en el panel Archivos, Dreamweaver abre ese sitio y realiza la operación de desprotección.

    Nota:

    Si desprotege el archivo activo, es posible que éste se guarde automáticamente antes de desprotegerse. Dependerá de las opciones que haya configurado.  

Cómo deshacer la protección de un archivo

Si protege un archivo y luego decide no editarlo (o descartar los cambios efectuados), puede deshacer la operación de protección para que el archivo recupere su estado original.

Para deshacer la protección de un archivo, siga uno de estos procedimientos:

  • Abra el archivo en la ventana de documento y seleccione Sitio > Deshacer proteger.

  • En el panel Archivos (Ventana > Archivos), haga clic con el botón derecho (Windows) o presione Control y haga clic (Macintosh) y seleccione Deshacer proteger.

    La copia local del archivo se convertirá en copia de solo lectura y se perderán los cambios realizados.

Utilización de WebDAV para desproteger y proteger archivos

Dreamweaver puede conectar con un servidor que utilice WebDAV (Web-based Distributed Authoring and Versioning: creación y control de versiones distribuido basado en la Web), un conjunto de extensiones del protocolo HTTP que permite a los usuarios colaborar en la edición y administración de archivos en servidores web remotos. Para más información, consulte www.webdav.org.

  1. Si aún no lo ha hecho, defina un sitio de Dreamweaver que especifique la carpeta local que debe utilizarse para almacenar los archivos del proyecto.
  2. Seleccione Sitio > Administrar sitios y luego haga doble clic en el sitio deseado en la lista.
  3. En el cuadro de diálogo Configuración del sitio, seleccione la categoría Servidores y proceda de una de las siguiente formas:
    • Haga clic en el botón Añadir nuevo servidor para añadir un nuevo servidor

    • Seleccione un servidor existente y haga clic en el botón Editar servidor existente

  4. En la pantalla Básicas, seleccione WebDAV del menú emergente Conectar usando y complete el resto de opciones que sean necesarias de la pantalla Básicas.
  5. Haga clic en el botón Avanzadas.
  6. Seleccione la opción Activar protección del sitio e introduzca la siguiente información:
    • En el cuadro Nombre de protección, introduzca un nombre que le identifique ante los demás miembros del equipo.

    • En el cuadro Dirección de correo electrónico, introduzca su dirección de correo electrónico.

      El nombre y las direcciones de correo electrónico se utilizan para identificar al propietario en el servidor webDAV y aparece en el panel Archivos como información de contacto.

  7. Haga clic en Guardar.

    Dreamweaver configura el sitio para acceso WebDAV. Al utilizar el comando Desproteger o Proteger en cualquier archivo de un sitio, el archivo se transfiere empleando WebDAV.

    Nota:

    Es posible que WebDAV no pueda proteger correctamente archivos con contenido dinámico, como etiquetas PHP o SSI, ya que el GET HTTP los proporciona cuando se protegen.

Uso de Subversion (SVN) para obtener o desproteger archivos

Nota:

La compatibilidad con Subversion (SVN) se ha eliminado en las versiones de Dreamweaver CC 2017 y posteriores.

Dreamweaver puede conectar con un servidor que utilice Subversion (SVN), un sistema de control de versiones que permite a los usuarios editar y administrar archivos en colaboración en servidores web remotos. Dreamweaver no es un cliente SVN completo, pero sí permite a los usuarios obtener las versiones más recientes de los archivos, realizar cambios y aceptarlos en los archivos.

Nota:

Dreamweaver CS5 utiliza la biblioteca de cliente Subversion 1.6.6 y Dreamweaver CS5.5 utiliza la biblioteca de cliente 1.6.9. Las versiones posteriores de la biblioteca de cliente Subversion no son compatibles con versiones anteriores. Tenga en cuenta que si actualiza una aplicación cliente de terceros (por ejemplo, TortoiseSVN) para que sea compatible con una versión posterior de Subversion, la aplicación Subversion actualizada actualizará los metadatos locales de Subversion y Dreamweaver no podrá establecer comunicación con Subversion. Esto no afecta a las actualizaciones del servidor de Subversion, ya que estas actualizaciones son compatibles con versiones anteriores. Si actualiza a una aplicación de cliente de terceros que es compatible con Subversion 1.7 u otra versión posterior, deberá consultar a Adobe la existencia de actualizaciones para poder volver a utilizar Subversion con Dreamweaver. Para obtener más información sobre este tema, consulte www.adobe.com/go/dw_svn_en.)

Adobe recomienda el uso de una herramienta de comparación de archivos creada por otro fabricante al controlar las versiones de archivos mediante SVN. Al comparar las diferencias de los archivos, conocerá exactamente qué cambios han realizado otros usuarios en los archivos. Para más información sobre las herramientas de comparación de archivos, utilice un motor de búsquedas, como Google Search, y busque “file comparison” (herramientas de comparación de archivos) o “diff” (herramientas de diferenciación). Dreamweaver funciona con la mayoría de herramientas de otros fabricantes.

Para ver un vídeo de introducción sobre el uso de SVN y Dreamweaver, consulte www.adobe.com/go/lrvid4049_dw.

Configuración de una conexión a SVN

Antes de utilizar Subversion (SVN) como sistema de control de versiones con Dreamweaver, debe configurar una conexión a un servidor SVN. La conexión al servidor SVN se configura en la categoría de control de versiones del cuadro de diálogo Definición del sitio.

El servidor SVN es una base de datos de archivos donde los usuarios pueden obtener y validar archivos. Es diferente del servidor remoto que se suele utilizar con Dreamweaver. Cuando se utiliza SVN, el servidor remoto es el servidor “dinámico” para las páginas web y el servidor SVN sirve para alojar la base de datos de los archivos cuyas versiones desea controlar. El flujo de trabajo normal consiste en obtener los archivos del servidor SVN y volver a validarlos en él para, a continuación, publicarlos en el servidor remoto de Dreamweaver. La configuración del servidor remoto es completamente independiente de la configuración de SVN.

Antes de iniciar la configuración, debe obtener acceso a un servidor SVN y a una base de datos de SVN. Para obtener más información sobre SVN, visite el sitio web de Subversion en http://subversion.apache.org/.

Para configurar la conexión a SVN, siga estos pasos:

  1. Seleccione Sitio > Administrar sitios, elija el sitio para el que desea configurar el control de versiones y haga clic en el botón Editar.

    Nota:

    Si aún no ha configurado las carpetas locales y remotas para un sitio de Dreamweaver, deberá configurar al menos un sitio local antes de continuar. (En esta fase no es necesario el sitio remoto, pero deberá configurarlo antes de publicar los archivos en la Web.) Para obtener más información, consulte Trabajo con sitios de Dreamweaver.

  2. En el cuadro de diálogo Configuración del sitio, seleccione la categoría Control de versión.

  3. Seleccione Subversion en el menú emergente Acceso.

  4. Defina las opciones de acceso de la siguiente manera:

    • Seleccione un protocolo en el menú emergente Protocolo. Los protocolos disponibles son HTTP, HTTPS, SVN y SVN+SSH.

    Nota:

    El uso del protocolo SVN+SSH exige una configuración especial. Para obtener más información, consulte www.adobe.com/go/learn_dw_svn_ssh_en.

    • Introduzca la dirección del servidor SVN en el cuadro de texto Dirección del servidor (normalmente tendrá el formato nombreservidor.dominio.com).

    • Introduzca la ruta de la base de datos del servidor SVN en el cuadro de texto Ruta de base de datos (normalmente tendrá el formato /svn/su_directorio_raíz. El administrador del servidor es el responsable de asignar un nombre a la carpeta raíz de la base de datos de SVN.)

    • (Opcional) Si desea utilizar un puerto de servidor que no sea el predeterminado, seleccione No predeterminado e introduzca el número de puerto en el cuadro de texto.

    • Introduzca su nombre de usuario y contraseña del servidor SVN.

  5. Haga clic en Prueba para probar la conexión o haga clic en Aceptar para cerrar el cuadro de diálogo. A continuación, haga clic en Listo para cerrar el cuadro de diálogo Administrar sitios.

Después de establecer la conexión al servidor, la base de datos de SVN está disponible y se puede visualizar en el panel Archivos. Para visualizarla, seleccione Vista de la base de datos en el menú emergente Ver o haga clic en el botón Archivos de base de datos en el panel Archivos ampliado.

Obtención de la versión más reciente de un archivo

Cuando se obtiene la versión más reciente de un archivo de la base de datos de SVN, Dreamweaver combina el contenido del archivo con el contenido de la copia local correspondiente. (En otras palabras, si otra persona actualiza el archivo después de haberse validado, las actualizaciones se combinan en la versión local del archivo en el equipo.) Si el archivo no existe aún en la unidad de disco duro local, Dreamweaver coge el archivo.

Nota:

Al obtener archivos de la base de datos por primera vez, deberá trabajar con un directorio local que esté vacío o que no contenga archivos con los mismos nombres que los de la base de datos. Dreamweaver no montará los archivos de la base de datos en la unidad local en el primer intento si la unidad local contiene archivos cuyos nombres coinciden con los de la base de datos remota.

  1. Asegúrese de haber configurado correctamente la conexión a SVN.

  2. Siga uno de estos procedimientos:

    • Para visualizar la versión local de los archivos de SVN en el panel Archivos, seleccione Vista local en el menú emergente Ver. (Si utiliza el panel Archivos ampliado, la vista local es la que se muestra automáticamente.) A continuación, haga clic con el botón derecho del ratón (Windows) o mantenga presionada la tecla Control y haga clic (Macintosh) en el archivo o la carpeta que desee y seleccione Control de versión > Obtener versiones más recientes.

    • Para mostrar los archivos de la base de datos de SVN, seleccione Vista de la base de datos en el menú emergente Ver en el panel Archivos o haga clic en el botón Archivos de base de datos en el menú Archivos ampliado. A continuación, haga clic con el botón derecho del ratón (Windows) o mantenga presionada la tecla Control y haga clic (Macintosh) en el archivo o la carpeta que desee y seleccione Obtener versiones más recientes.

Nota:

También puede hacer clic con el botón derecho del ratón en un archivo y elegir Proteger del menú contextual, o bien seleccionar el archivo y hacer clic en el botón Proteger para obtener la versión más reciente. SVN no admite el flujo de trabajo de protección, pero esta acción realmente no protege el archivo en el sentido tradicional.

Validación de archivos

  1. Asegúrese de haber configurado correctamente la conexión a SVN.

  2. Siga uno de estos procedimientos:

    • Para visualizar la versión local de los archivos de SVN en el panel Archivos, seleccione Vista local en el menú emergente Ver. (Si utiliza el panel Archivos ampliado, la vista local es la que se muestra automáticamente.) A continuación, seleccione el archivo que desea validar y haga clic en el botón Desproteger.

    • Para mostrar los archivos de la base de datos de SVN, seleccione Vista de la base de datos en el menú emergente Ver en el panel Archivos o haga clic en el botón Archivos de base de datos en el menú Archivos ampliado. A continuación, haga clic con el botón derecho del ratón (Windows) o mantenga presionada la tecla Control y haga clic (Macintosh) en el archivo que desea validar y seleccione Desproteger.

  3. Revise las acciones en el cuadro de diálogo Realizar, introduzca los cambios que desee y haga clic en Aceptar.

    Para modificar una acción, seleccione el archivo cuya acción desea modificar y haga clic en los botones situados en la parte inferior del cuadro de diálogo Realizar. Hay dos opciones disponibles: realizar validación e ignorar.

Nota:

Una marca de verificación verde en un archivo en el panel Archivos significa que el archivo se ha modificado y aún no se ha validado en la base de datos.

Actualización del estado de los archivos o carpetas de la base de datos

Puede actualizar el estado de SVN de un archivo o una carpeta individualmente. La actualización no renueva toda la pantalla.

  1. Asegúrese de haber configurado correctamente la conexión a SVN.

  2. Para mostrar los archivos de la base de datos de SVN, seleccione Vista de la base de datos en el menú emergente Ver en el panel Archivos o haga clic en el botón Archivos de base de datos en el menú Archivos ampliado.

  3. Haga clic con el botón derecho del ratón (Windows) o mantenga presionada la tecla Control y haga clic (Macintosh) en cualquier carpeta o archivo de la base de datos y seleccione Actualizar estado.

Actualización del estado de archivos o carpetas locales

Puede actualizar el estado de SVN de un archivo o una carpeta individualmente. La actualización no renueva toda la pantalla.

  1. Asegúrese de haber configurado correctamente la conexión a SVN.

  2. Para visualizar la versión local de los archivos de SVN en el panel Archivos, seleccione Vista local en el menú emergente Ver. (Si utiliza el panel Archivos ampliado, la vista local es la que se muestra automáticamente.)

  3. Haga clic con el botón derecho del ratón (Windows) o mantenga presionada la tecla Control y haga clic (Macintosh) en cualquier carpeta o archivo del panel Archivos y seleccione Actualizar estado.

Visualización de las revisiones de un archivo

  1. Asegúrese de haber configurado correctamente la conexión a SVN.

  2. Siga uno de estos procedimientos:

    • Para visualizar la versión local de los archivos de SVN en el panel Archivos, seleccione Vista local en el menú emergente Ver. (Si utiliza el panel Archivos ampliado, la vista local es la que se muestra automáticamente.) A continuación, haga clic con el botón derecho del ratón (Windows) o mantenga presionada la tecla Control y haga clic (Macintosh) en el archivo pertinente y seleccione Control de versión > Mostrar revisiones.

    • Para mostrar los archivos de la base de datos de SVN, seleccione Vista de la base de datos en el menú emergente Ver en el panel Archivos o haga clic en el botón Archivos de base de datos en el menú Archivos ampliado. A continuación, haga clic con el botón derecho del ratón (Windows) o mantenga presionada la tecla Control y haga clic (Macintosh) en el archivo pertinente y seleccione Mostrar revisiones.

  3. En el cuadro de diálogo Historial de revisiones, seleccione la revisión o revisiones que desea visualizar y realice una de las siguientes acciones:

    • Haga clic en Comparar con local para comparar la revisión seleccionada con la versión local del archivo.

    Nota:

    Deberá instalar una herramienta de comparación de archivos de otro fabricante antes de comparar los archivos. Para más información sobre las herramientas de comparación de archivos, utilice un motor de búsquedas, como Google Search, y busque “file comparison” (herramientas de comparación de archivos) o “diff” (herramientas de diferenciación). Dreamweaver funciona con la mayoría de herramientas de otros fabricantes.

    • Haga clic en Comparar para comparar las dos revisiones seleccionadas. Mantenga presionada la tecla Control y haga clic para seleccionar dos revisiones simultáneamente.

    • Haga clic en Ver para visualizar la revisión seleccionada. Esta acción no sobrescribe la copia local actual del mismo archivo. Puede guardar la revisión seleccionada en la unidad de disco duro como haría con cualquier otro archivo.

    • Haga clic en Promover para hacer que la revisión seleccionada sea la más actual en la base de datos.

Bloqueo y desbloqueo de archivos

El bloqueo de un archivo de la base de datos de SVN permite que otros usuarios sepan que está trabajando en un archivo. Los demás usuarios podrán continuar editando el archivo localmente, pero no podrán enviar el archivo hasta que usted lo haya desbloqueado. Cuando bloquee un archivo en la base de datos, verá un icono de un candado abierto sobre el archivo. Los demás usuarios verán un icono de candado cerrado.

  1. Asegúrese de haber configurado correctamente la conexión a SVN.

  2. Siga uno de estos procedimientos:

    • Para mostrar los archivos de la base de datos de SVN, seleccione Vista de la base de datos en el menú emergente Ver en el panel Archivos o haga clic en el botón Archivos de base de datos en el menú Archivos ampliado. A continuación, haga clic con el botón derecho del ratón (Windows) o mantenga presionada la tecla Control y haga clic (Macintosh) en el archivo pertinente y seleccione Bloquear o Desbloquear.

    • Para visualizar la versión local de los archivos de SVN en el panel Archivos, seleccione Vista local en el menú emergente Ver. (Si utiliza el panel Archivos ampliado, la vista local es la que se muestra automáticamente.) A continuación, haga clic con el botón derecho del ratón (Windows) o mantenga presionada la tecla Control y haga clic (Macintosh) en el archivo pertinente y seleccione Bloquear o Desbloquear.

Adición de un nuevo archivo a la base de datos

Cuando se muestra un signo más de color azul en un archivo en el panel Archivos, significa que el archivo no existe aún en la base de datos de SVN.

  1. Asegúrese de haber configurado correctamente la conexión a SVN.

  2. En el panel Archivos, seleccione el archivo que desea añadir a la base de datos y haga clic en el botón Desproteger.

  3. Asegúrese de que el archivo esté seleccionado para su validación en el cuadro de diálogo Realizar y haga clic en Aceptar.

Traslado, copia, eliminación o restitución de archivos

  • Para mover un archivo, arrástrelo a la carpeta de destino del sitio local.

    Al mover un archivo, Dreamweaver lo marca con un signo Añadir con historial en la nueva ubicación y con un signo Eliminar en la ubicación antigua. Al seleccionar Realizar para estos archivos, el archivo desaparece de la ubicación antigua.

  • Para copiar un archivo, selecciónelo, cópielo (Edición > Copiar) y péguelo (Edición > Pegar) en la nueva ubicación.

    Al copiar y pegar un archivo, Dreamweaver marca el archivo con un signo Añadir con historial en la nueva ubicación.

  • Para eliminar un archivo, selecciónelo y presione Supr.

    Dreamweaver le ofrece la oportunidad de elegir si desea eliminar la versión local del archivo solamente o tanto la versión local como la versión situada en el servidor SVN. Si desea eliminar la versión local solamente, el archivo situado en el servidor SVN no se verá afectado. Si opta por eliminar también la versión situada en el servidor SVN, la versión local se marcará con un signo Eliminar y deberá ejecutar Realizar para el archivo para que se produzca la eliminación.

  • Para restituir un archivo copiado o movido en su ubicación original, haga clic con el botón derecho del ratón en el archivo y seleccione Control de versión > Restituir.

Resolución de archivos en conflicto

Si su archivo entra en conflicto con otro archivo del servidor, podrá editarlo y marcarlo como resuelto. Por ejemplo, si intenta desproteger un archivo que entra en conflicto con los cambios realizados por otro usuario, SVN no le permitirá enviar el archivo. Puede obtener la última versión del archivo de la base de datos, realizar los cambios manualmente en su copia de trabajo y luego marcar el archivo como resuelto para poder enviarlo.

  1. Asegúrese de haber configurado correctamente la conexión a SVN.

  2. Para visualizar la versión local de los archivos de SVN en el panel Archivos, seleccione Vista local en el menú emergente Ver. (Si utiliza el panel Archivos ampliado, la vista local es la que se muestra automáticamente.)

  3. Haga clic con el botón derecho del ratón (Windows) o mantenga presionada la tecla Control y haga clic (Macintosh) en el archivo que desea resolver y seleccione Control de versión > Marcar como resuelto.

Desconexión

Es posible que le resulte cómodo desconectar para evitar el acceso a la base de datos cuando ejecute otras actividades de transferencia de archivos. Dreamweaver volverá a conectarse a la base de datos de SVN tan pronto como active una actividad para la que sea necesario estar conectado (Obtener versiones más recientes, Realizar, etc.).

  1. Asegúrese de haber configurado correctamente la conexión a SVN.

  2. Para visualizar la versión local de los archivos de SVN en el panel Archivos, seleccione Vista local en el menú emergente Ver. (Si utiliza el panel Archivos ampliado, la vista local es la que se muestra automáticamente.)

  3. Haga clic con el botón derecho del ratón (Windows) o mantenga presionada la tecla Control y haga clic (Macintosh) en cualquier archivo o carpeta del panel Archivos y seleccione Control de versión > Desconectar.

Limpieza de un sitio SVN local

Este comando le permite quitar bloqueos de los archivos para poder reanudar las operaciones no finalizadas. Deberá utilizar este comando para quitar bloqueos antiguos si recibe errores que indican que la copia de trabajo está bloqueada.

  1. Asegúrese de haber configurado correctamente la conexión a SVN.

  2. Para visualizar la versión local de los archivos de SVN en el panel Archivos, seleccione Vista local en el menú emergente Ver. (Si utiliza el panel Archivos ampliado, la vista local es la que se muestra automáticamente.)

  3. Haga clic con el botón derecho del ratón (Windows) o mantenga presionada la tecla Control y haga clic (Macintosh) en el archivo que desea limpiar y seleccione Control de versión > Limpiar.

Acerca del desplazamiento de archivos y carpetas en sitios controlados por Subversion

Cuando se desplazan las versiones locales de archivos o carpetas en un sitio controlado por Subversion, se corre el riesgo de causar problemas a otros usuarios que estén sincronizando con la base de datos de SVN. Por ejemplo, si desplaza un archivo localmente y no lo valida en la base de datos hasta pasadas unas horas, es posible que otro usuario intente obtener la versión más actual del archivo en la antigua ubicación del mismo. Es por ello que debe validar los archivos en el servidor SVN inmediatamente después de haberlos desplazado localmente.

Los archivos y las carpetas permanecen en el servidor SVN hasta que los elimine manualmente. Por tanto, aunque desplace un archivo a otra carpeta local y lo valide, la versión antigua del archivo permanece en la ubicación anterior del servidor. Para evitar la confusión, elimine las copias antiguas de los archivos o carpetas que desplace.

Cuando desplaza un archivo localmente y lo valida en el servidor SVN, el historial de las versiones del archivo se pierde.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea