W programie Animate (poprzednio Flash Professional) przyciski są symbolami zawierającymi cztery klatki. Każda klatka symbolu przycisku reprezentuje różny stan przycisku: Up, Over, Down i Hit. Stany te określają wygląd przycisku po umieszczeniu nad nim wskaźnika myszy lub kliknięciu przycisku przez użytkownika. W dokumencie opisano sposób tworzenia podstawowych i zaawansowanych przycisków.

Tworzenie podstawowego przycisku

  1. Wybierz polecenia Wstaw > Nowy symbol lub naciśnij kombinację klawiszy Control+F8 (Windows) lub Command+F8 (Mac OS).
    Uwaga: w programie Flash 3 i starszych wersjach usuń zaznaczenie wszystkiego na stole montażowym i wybierz polecenia Wstaw > Utwórz symbol.

  2. W oknie dialogowym Właściwości symbolu wprowadź nazwę symbolu nowego przycisku i z listy Zachowanie wybierz Przycisk. Kliknij przycisk OK. 

    Program Flash przełączy się do trybu edycji symboli. Na nagłówku osi czasu zostaną wyświetlone cztery kolejne klatki oznaczone Up, Over, Down i Hit. Pierwsza klatka, Up, jest pustą kluczową klatką.
  3. Aby utworzyć obraz stanu przycisku Up, użyj narzędzi rysowania, zaimportuj grafikę lub umieść wystąpienie innego symbolu na stole montażowym. W przycisku można użyć albo klipu filmowego, albo symbolu graficznego. Nie można jednak używać innego przycisku w danym przycisku. Użyj symboli klipu filmowego, aby utworzyć przycisk animowany.
  4. Wybierz drugą klatkę, oznaczoną Over, a następnie wybierz polecenia Wstaw > Klatka kluczowa. Obraz przycisku z pierwszej klatki zostanie wyświetlony na stole montażowym.
  5. Zmień obraz przycisku na potrzeby stanu Over. Powtórz czynności z kroków 4 i 5 dla klatki Down i Hit.
    Uwaga: Klatka Hit nie jest widoczna na stole montażowym podczas odtwarzania. Służy jedynie do wyznaczania obszaru przycisku reagującego na kliknięcie. Upewnij się, że grafika klatki Hit jest jednolitym obszarem o rozmiarze wystarczającym do pomieszczenia wszystkich elementów graficznych klatek Up, Down i Over. Może być także większa niż widoczny przycisk. Jeżeli klatka Hit nie zostanie określona, użyte zostaną obiekty z klatki Up.

  6. Po określeniu obrazów czterech stanów przycisku wybierz polecenia Edytuj > Edytuj film, aby wyłączyć tryb Edytuj symbole.
  7. Otwórz okno Biblioteka, wybierając polecenia Okno > Biblioteka. Znajdź przycisk w oknie Biblioteka, a następnie przeciągnij symbol przycisku z okna Biblioteka na stół montażowy. Czynność ta spowoduje utworzenie wystąpienia przycisku w filmie.

Więcej informacji o przydzielaniu operacji do wystąpienia przycisku można znaleźć w dokumentacji dotyczącej używanej wersji programu Animate. Dokumentację wskazano poniżej:

Przydzielanie prostej operacji do przycisku (Flash 5)

  1. W trybie Edytuj film wybierz wystąpienie przycisku utworzone w kroku 7 powyżej.
  2. Aby wyświetlić panel Operacje, wybierz polecenie Okno > Operacje.
  3. Z listy Przybornik w panelu po lewej stronie wybierz kategorię Podstawowe operacje, aby wyświetlić listę podstawowych operacji.
  4. Aby przydzielić operację, wykonaj jedną z następujących czynności:
    • W kategorii Podstawowe operacje kliknij dwukrotnie operację.
    • Przeciągnij operację z kategorii Podstawowe operacje po lewej stronie do listy Operacje w panelu po prawej stronie.
    • Kliknij przycisk Dodaj (+) i z menu podręcznego wybierz żądaną operację.
    • Użyj skrótu klawiaturowego.
  5. Jeżeli wybrana operacja ma powiązane parametry, zostaną one wyświetlone w okienku Parametr na dole panelu Operacje. (Jeżeli okienko Parametr nie jest widoczne, kliknij mały trójkąt w prawym dolnym rogu panelu). Wybierz lub wprowadź parametry właściwe dla tej operacji. Na przykład operacja gotoAndPlay pokazana poniżej zawiera trzy parametry: Scene, TypeFrame, i opcję Goto and Play.

Przydzielanie prostej operacji do przycisku (Flash 4 i starsze wersje)

  1. W trybie Edytuj film wybierz wystąpienie przycisku utworzone w kroku 7 powyżej.
  2. Upewnij się, że polecenie Włącz przyciski z menu Sterowanie jest wyłączone.
  3. Otwórz okno dialogowe Właściwości wystąpienia, klikając przycisk dwukrotnie.
    Uwaga: w programie Flash 2 to okno dialogowe miało nazwę Właściwości łącza: Przycisk.

  4. Przydziel operację, przechodząc do karty Operacja w oknie dialogowym Właściwości wystąpienia. Następnie kliknij przycisk (+) i kliknij dwukrotnie żądaną operację.
    Uwaga: W programie Flash 2 przydziel operację, używając menu podręcznego Operacja w oknie dialogowym Właściwości łącza: Przycisk. Do przycisku można przydzielić tylko jedną operację.

  5. Upewnij się, że polecenie Włącz przyciski z menu Sterowanie jest włączone (obok niego powinien się znajdować znacznik wyboru).

  6. Jeżeli wybrana operacja ma powiązane parametry, zostaną one wyświetlone w okienku Parametr po prawej stronie panelu Operacje. Wybierz lub wprowadź parametry właściwe dla tej operacji.

Tworzenie zaawansowanych przycisków

Po opanowaniu tworzenia prostych przycisków można przystąpić do tworzenia bardziej zaawansowanych przycisków programu Animate. Można przykładowo tworzyć przyciski niewidoczne, przyciski z animacjami i przyciski z efektami przerzucania. 

Aby tworzyć zaawansowane przyciski, trzeba rozumieć działanie stanu Hit przycisku. Kształt przycisku i jego obszar reprezentuje aktywny obszar przycisku. Aby eksperymentować ze stanem Hit, wykonaj następujące czynności:

  1. Wstaw na stół montażowy przycisk z okna Biblioteki wspólne. Edytuj przycisk.
  2. Zaznacz klatkę stanu Hit przycisku, a następnie wstaw klatkę kluczową. Przetestuj zachowanie w filmie.

  3. Znacząco zmień rozmiar obiektu w stanie Hit, a następnie przetestuj.
  4. Usuń klatkę kluczową ze stanu Hit i przetestuj przycisk.

  5. Obserwuj efekt kursora przycisku oraz klatki stanów Up, Over i Down, które są widoczne po włączeniu przycisku. 

Przyciski niewidoczne

Klatki stanów Up, Over i Down przycisku można zostawić puste. Jeżeli będą puste, zdefiniuj klatkę stanu Hit, tak aby zawierała zawartość.

Jeżeli klatka stanu Up przycisku jest pusta lub niewidoczna, przycisk jest reprezentowany na stole montażowym przez niebieski kształt. Kształt odpowiada zawartości następnej klatki kluczowej przycisku. Niebieski kształt nie będzie widoczny w ostatecznym filmie.

Przyciski animowane

Aby w programie Animate utworzyć przyciski animowane, umieść klip filmowy w klatce stanu przycisku, który ma być animowany.

  1. Utwórz klip filmowy dla każdej klatki stanu przycisku, który ma być animowany.
  2. Utwórz przycisk.
  3. Umieść klip filmowy w klatkach stanów przycisku, które mają być animowane.
  4. Umieść przycisk na stole montażowym. 
    Uwaga: W narzędziu Edytor animacji nie można testować klipów filmowych. Wybierz polecenia Sterowanie > Testuj film lub wyeksportuj go jako plik SWF w celu przetestowania.

Umieszczenie kursora w jednym obszarze filmu wpływa na inny obszar filmu

Aby utworzyć ten efekt, przenieś elementy klatki stanu Hit do innego obszaru stołu montażowego niż elementy z klatki stanu Over przycisku. Metoda ta działa w przypadku prostych efektów umieszczenia wskaźnika myszy. Aktywny obszar przycisku jest w innym obszarze stołu montażowego niż efekt umieszczenia wskaźnika myszy.

Dodatkowe informacje

Aby dowiedzieć się więcej o przyciskach i ich tworzeniu, można zapoznać z przykładowymi przyciskami dostępnymi w programie Animate. W wersji 5 te przykładowe przyciski są dostępne z poziomu menu Okno > Biblioteki wspólne > Przyciski. Jeżeli używana jest wersja 4, dostęp do tych przycisków można uzyskać, wybierając polecenia Biblioteki > Przyciski. W wersji 2 biblioteki przykładowych przycisków są dostępne w menu Dodatki.

Poradnik dotyczący tworzenia przycisków jest dostępny również w menu Lekcje dostępnym w wersji 5. W programie Flash wybierz polecenia Pomoc > Lekcje > 06 Przyciski, aby uzyskać dostęp do tej lekcji.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online