Informacje o nowościach w ostatniej wersji programu Animate CC
an_appicon_128

Wersje programu Animate CC z października 2018 (19.0) i grudnia 2018 (19.1) zawierają doskonałe nowe elementy skierowane do twórców animacji postaci, projektantów i programistów gier, a także twórców reklam, animacji i materiałów edukacyjnych. Niniejszy artykuł zawiera krótkie omówienie tych funkcji oraz łącza do materiałów z dodatkowymi informacjami.


Nowość w programie Animate CC 19.1

Obsługa pochylenia i nacisku w narzędziu Gumka

Narzędzie Gumka obsługuje teraz pochylenie i nacisk, aby ułatwić rysowanie. Za pomocą narzędzia Gumka można tworzyć pociągnięcia o zmiennej szerokości wynikającej z nacisku lub pochylenia rysika.

Przykładowa ilustracja wykonana przy użyciu narzędzia Gumka
Przykładowa ilustracja wykonana przy użyciu narzędzia Gumka

Więcej informacji można znaleźć w sekcji na temat modyfikowania przez przeciąganie w artykule Przekształcanie linii i kształtów

Ulepszenie narzędzia Wiadro z farbą

Korzystając z narzędzia Wiadro z farbą, można teraz klikać i przeciągać kontury obiektów, aby wypełniać je wybranym kolorem. Można kliknąć i przeciągnąć narzędziem w dowolnym kierunku na konturze. Narzędzie Wiadro z farbą wypełnia kolorem wszystko, co jest oznaczone kropkami w konturze.

Opcje wypełniania przez przeciąganie
Opcje wypełniania przez przeciąganie

Więcej informacji można znaleźć w artykule Modyfikowanie obszarów pomalowanych przy użyciu narzędzia Wiadro z farbą

Udoskonalony mechanizm eksportowania plików SVG

Teraz program Animate pozwala bezpośrednio eksportować pliki SVG bez potrzeby tworzenia niechcianych definicji czy identyfikatorów. Proces tworzenia kompozycji pliku SVG został ulepszony. Ta opcja eksportu pozwala uzyskać wyższą jakość plików SVG importowanych do programu Character Animator.

Więcej informacji o obiegu pracy eksportowania plików SVG można znaleźć w artykule Eksportowanie plików SVG

Nowość w programie Animate CC 19.0

Automatyczna synchronizacja z ustami

Synchronizacja z ustami zawsze była żmudnym zadaniem podczas pracy nad animacją postaci w programie Animate CC. Teraz ułożenie ust można automatycznie dostosować do wymawianych dźwięków, korzystając z mechanizmu Adobe Sensei w programie Animate. 

Funkcja automatycznej synchronizacji z ustami ułatwia umieszczanie odpowiednich kształtów ust na osi czasu w oparciu o wybraną warstwę dźwięku. Można w tym celu użyć gotowej listy położeń ust, które rysuje się przy użyciu symbolu graficznego, i nadać im etykiety odpowiadające fonemom. Po zastosowaniu automatycznej synchronizacji z ustami do symbolu graficznego program automatycznie analizuje wybraną warstwę dźwięku i tworzy klatki kluczowe w miejscach odpowiadających fonemom. Dostępne są także dalsze dopasowania oparte na normalnych obiegach pracy i próbniku klatek.

Automatyczna synchronizacja z ustami
Automatyczna synchronizacja z ustami

Więcej informacji można znaleźć w artykule Tworzenie wystąpień symboli w programie Animate CC.

Tworzenie i publikowanie materiałów VR (beta)

Twórcy gier 2D, materiałów edukacyjnych i stron internetowych mogą wykorzystać swoje umiejętności w zakresie pracy z grafiką 2D w programie Animate, aby eksportować animacje rzeczywistości wirtualnej — panoramy i 360 stopni.  

Program Animate udostępnia teraz typy dokumentów przeznaczone do pracy z materiałami VR 360 stopni i panoramami VR, które ułatwiają tworzenie atrakcyjnej zawartości tego typu. Typ dokumentu rzeczywistości wirtualnej umożliwia też importowanie modeli 3D (plików GLB) do projektu programu Animate w celu pracy z materiałami VR. 

W panelu Podgląd można klikać i przesuwać wystąpienia klipów filmowych. Program Animate automatycznie wykrywa obiekty, kiedy są one klikane i przesuwane. Zależnie od wybranego typu dokumentu przesuwanie odbywa się po ścieżce na cylindrze lub na kuli. 

Program Animate umożliwia sterowanie animacjami rzeczywistości wirtualnej w czasie wykonywania przy użyciu interfejsów API. Można na przykład dodać w środowisku VR 360 stopni obiekty, które są uaktywniane, gdy użytkownik klika przycisk. 

Próbka wyjściowa na potrzeby publikowania VR
Próbka wyjściowa na potrzeby publikowania VR

Więcej informacji można znaleźć w artykule Tworzenie i publikowanie materiałów rzeczywistości wirtualnej

Dostosowywanie zasobów na potrzeby zawartości wektorowej i rastrowej

Narzędzie Wypaczanie zasobów umożliwia teraz zniekształcanie złożonych kształtów wektorowych oraz bitmap. Animacje można tworzyć bez ponownego rysowania zasobów w każdej klatce.

Uchwyty wypaczania wyświetlane na obiektach umożliwiają zmienianie kształtu (zniekształcanie) określonych fragmentów obiektów bez wpływu na inne. Można zaznaczyć wiele obiektów przy użyciu narzędzi do zaznaczania, a następnie przy użyciu narzędzia Wypaczanie zasobów dodać do nich uchwyty wypaczania. Uchwyty wypaczania wyświetlane na wypaczanych obiektach pozwalają zmieniać kształty poszczególnych obiektów. Narzędzie Wypaczanie zasobów umożliwia tworzenie animacji klatka po klatce oraz animacji z klatkami pośrednimi dla złożonych kształtów i obrazów bitmapowych.

Ilustracja wypaczania zasobów
Ilustracja wypaczania zasobów

Więcej informacji można znaleźć w artykule Przekształcanie i łączenie obiektów graficznych.

Publikowanie tekstur w sposób zwiększający wydajność

Twórcy animacji mogą teraz pracować nad materiałami w formacie wektorowym, a eksportować je w formatach wektorowych i rastrowych na platformy HTML5. 

Kliknij opcję Plik > Ustawienia publikowania.Jeśli opcja Eksportuj animację jako teksturę na zakładce Podstawowe jest włączona, można wyświetlać opcje publikowania tekstury na zakładce Ustawienia obrazu. Domyślnie podczas publikowania tekstur są uwzględniane wszystkie symbole. Aby selektywnie wybrać symbole tekstur, kliknij przycisk Zmień.

Ustawienia publikowania tekstur
Ustawienia publikowania tekstur

Więcej informacji można znaleźć w rozdziale Publikowanie tekstur artykułu Eksportowanie animacji do aplikacji na urządzenia przenośne i platform gier.

Warstwy macierzyste i efekty warstw

Obsługa warstw macierzystych i potomnych

Program Animate pozwala ustawić jedną warstwę jako macierzystą względem innej. Dzięki temu mechanizmowi warstwa lub obiekt może w prosty sposób sterować inną warstwą lub innym obiektem w obrębie animacji. Łatwiejsze sterowanie różnymi częściami postaci pozwala twórcom animacji i gier szybciej realizować kompozycje. 

Teraz można łatwo przełączać pozy w animacjach, porządkując zasoby przy użyciu systemu warstw macierzystych i potomnych. Kiedy obiekt na warstwie macierzystej porusza się, warstwa potomna porusza się wraz z nim. 

Warstwy macierzyste
Warstwy macierzyste

Więcej informacji można znaleźć w artykule Tworzenie warstw na osi czasu w programie Animate CC.

Efekty warstwy

Do warstw można dodawać tinty i filtry, stosować wtapianie w celu ukrywania i pokazywania obiektów, wprowadzać efekt głębi pola i stosować inne modyfikacje. Wszystkie te zmiany można wprowadzać, nie modyfikując obiektów na stole montażowym. 

Filtry na poziomie klatek pozwalają modyfikować wszystkie obiekty w danym czasie w klatce. Filtry można stosować bezpośrednio do osi czasu (klatek) bez umieszczania zasobów czy animacji w klipie filmowym. Filtry mogą dotyczyć zasobów wszystkich typów — również symboli graficznych i kształtów — co zapewnia wysoką elastyczność tych narzędzi.

Korzystanie z efektów warstwy

Korzystanie z efektów warstwy
W tym materiale wideo omawiamy sposób ulepszania animacji przy użyciu głębi warstw i efektów warstw.

Więcej informacji można znaleźć w artykule Tworzenie warstw na osi czasu w programie Animate CC.

Eksportowanie w formacie GLTF (GL Transmission Format)

Twórcy animacji mogą teraz eksportować nowe animacje GLTF przeznaczone do wyświetlania w witrynach.Do listy typów dokumentów w programie Animate dodano nowe typy dokumentów WebGL GLTF Standard (beta) oraz WebGL GLTF Extended (beta).

Jest dostępny standardowy typ dokumentu umożliwiający integrację ze standardowymi pakietami odtwarzania GLTF. Rozszerzony typ dokumentu pozwala tworzyć zaawansowane animacje zawierające elementy interaktywne, które są uruchamiane w nowym środowisku wykonawczym GLTF programu Animate.

Eksportowanie w formacie WebGL GLTF (standardowym i rozszerzonym)

Eksportowanie w formacie WebGL GLTF (standardowym i rozszerzonym)
W tym materiale wideo omówiono korzystanie ze standardowego i rozszerzonego typu dokumentu WebGL GLTF w programie Animate CC.

Więcej informacji na ten temat zawiera artykuł Tworzenie i publikowanie dokumentu WebGL.

Ulepszona integracja z programem After Effects

Twórcy animacji często przygotowują animacje w programie Animate, a następnie importują je do programu After Effects w celu dalszego przetwarzania. Teraz program Animate usprawnia ten obieg pracy, udostępniając wtyczkę do programu After Effects. 

Można importować pliki FLA z programu Animate do programu After Effects, aby połączyć je z innym nagraniem wideo lub renderować jako wideo z dodatkowymi efektami kreatywnymi. Hierarchia warstw utworzona w programie Animate jest zachowywana w programie After Effects. Program After Effects umożliwia interakcję z programem Animate za pośrednictwem wtyczki. 

Obieg pracy łączący programy Animate i After Effects
Obieg pracy łączący programy Animate i After Effects

Więcej informacji można znaleźć w artykule Praca z programami Premiere Pro i After Effects.

Nowy ekran początkowy

Dzięki nowemu ekranowi początkowemu programu Animate można szybciej przystąpić do pracy. Wystarczy wybrać dowolny profil konwersji animacji, a program Animate udostępni formaty predefiniowane. Można wybrać profil konwersji spośród zakładek u góry ekranu, na przykład Animacja postaci, Sieci społecznościowe, Gra, Edukacja, Reklamy, Strony internetowe i Zaawansowane. Zakładka Zaawansowane pozwala wybrać typ dokumentu, na przykład HTML5 Canvas, ActionScript 3.0 lub VR 360 stopni (beta). 

Po wybraniu ustawień predefiniowanych dla poszczególnych profilów konwersji kliknij przycisk Utwórz, aby rozpocząć tworzenie animacji. W lewym okienku są widoczne ostatnio używane pliki. U dołu ekranu początkowego są dostępne zasoby przykładowe. 

Opcja Materiały do nauki w lewym okienku zapewnia dostęp do wielu samouczków, które ułatwiają zapoznanie się z różnorodnymi pojęciami, obiegami pracy, wskazówkami i technikami edycji. Przygotowaliśmy również samouczki obejmujące większość nowych funkcji programu Animate CC 19.0.

Podczas pracy nad animacjami można użyć polecenia Plik > Nowy, aby utworzyć nowy dokument. Są również dostępne następujące skróty:

System Windows: CTRL + N

System macOS: CMD + N

Nowy ekran początkowy
Nowy ekran początkowy

Inne zmiany

Narzędzie Wiadro z farbą. Korzystając z narzędzia Wiadro z farbą, można teraz klikać i przeciągać kontury obiektów, aby wypełniać je wybranym kolorem. Można kliknąć i przeciągnąć narzędziem w dowolnym kierunku na konturze. Narzędzie Wiadro z farbą wypełni kolorem wszystko, co jest oznaczone kropkami w konturze.

Szybkie tworzenie animacji. Teraz można szybko tworzyć animacje ze stołu montażowego, zaznaczając obiekty. Aby szybko utworzyć animację, zaznacz obiekty na stole montażowym, kliknij prawym przyciskiem myszy i wybierz jedną z animacji. Jeśli zaznaczone obiekty należą do wielu warstw, na każdej z warstw zostanie utworzona animacja trwająca jedną sekundę.

Obsługa pióra pakietu Microsoft Office. Użytkownicy komputerów Microsoft Surface uzyskują teraz najwyższą wydajność i jakość linii dzięki natywnej obsłudze pióra.

Lepszy wygląd interfejsu. Interfejs użytkownika programu Animate został udoskonalony w oparciu o platformę Spectrum, która zapewnia jego czytelność i intuicyjne działanie — podobnie jak w innych produktach Creative Cloud.

Synchronizacja klatki wyjścia symboli graficznych. Można teraz synchronizować symbole graficzne z macierzystą osią czasu podczas ich edytowania. Podczas wprowadzania i pozostawiania symboli graficznych są one synchronizowane i są zachowywane ich położenia w klatkach.

Przeprojektowana oś czasu. Zmodyfikowaliśmy opcje dostępne na osi czasu, tak aby była łatwiejsza w użyciu. Niektóre opcje zostały przeniesione do góry osi czasu. Dawniej znajdowały się one u dołu osi czasu.

Udoskonalone pędzle i ulepszona gumka. Usprawniono sposób obsługi pędzli oraz podgląd skutków malowania pędzlami. Narzędzie Pędzel otrzymało nowe opcje nacisku, pochylenia i minimalnego rozmiaru pędzla.Narzędzie Pędzel zawiera uproszczone opcje wygładzania. Narzędzie Gumka otrzymało dodatkowe opcje. Jest teraz równie elastyczne jak narzędzie Pędzel.

Więcej informacji o ulepszeniach narzędzia Gumka zawiera artykuł Modyfikowanie linii i kształtów.

Scalenie warstw

Zbiór warstw można zgrupować i scalić do jednej warstwy. Aby to zrobić, zaznacz warstwy na osi czasu i kliknij je prawym przyciskiem myszy. Wybierz opcję Scal warstwy z menu podręcznego zgodnie z poniższym zrzutem ekranu.

Scalanie warstw na osi czasu
Scalanie warstw na osi czasu

Nowe motywy

Program Animate umożliwia teraz wybranie jednego z czterech motywów kolorystycznych. Aby zmienić motyw, wybierz polecenie Edycja > Preferencje. Na karcie Ogólne kliknij listę rozwijaną Interfejs użytkownika i wybierz odpowiedni motyw.

Motywy interfejsu użytkownika
Motywy interfejsu użytkownika

Ulepszenia panelu Próbki

Panel Próbki można rozwinąć bez modyfikowania układu wyświetlanych w nim kolorów. Podczas przeciągania tego panelu jest zwiększany rozmiar próbek (patrz drugi zrzut ekranu). Jeśli zostanie on dalej przeciągnięty, w panelu Próbki zostaną wyświetlone kolejne kolumny (patrz trzeci zrzut ekranu poniżej).

Próbki w wielu kolumnach
Próbki w wielu kolumnach

Zapisane próbki można eksportować i importować. Można też używać ich ponownie. Oznaczone próbki mogą być używane ponownie w dokumentach wszystkich typów w programie Animate. 

Ulepszenie importowania wideo H.264

Podczas importowania wideo w formacie H.264 w programie Animate domyślnie jest importowany cały materiał wideo i nie jest modyfikowana liczba klatek wideo. Można dopasować liczbę klatek na sekundę w dokumencie, wybierając odpowiednią opcję w oknie dialogowym Importowanie wideo zgodnie z poniższym zrzutem ekranu.

  • Jeśli jest zaznaczona opcja Dopasuj płynność dokumentu, program Animate usuwa część klatek w celu dopasowania płynności odtwarzania wideo do płynności odtwarzania dokumentu.
  • Jeśli opcja Dopasuj płynność dokumentu nie jest zaznaczona, program nie usuwa klatek.

Domyślnie opcja Dopasuj płynność dokumentu nie jest zaznaczona.

 

Dopasowywanie liczby klatek na sekundę w dokumencie
Dopasowywanie liczby klatek na sekundę w dokumencie

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online