Dowiedz się, jak ustawić program Dreamweaver w celu rozpoznawania nowych typów plików, edytując pliki Extensions.txt i MMDocumentTypes.xml.

Przeczytaj ten artykuł, jeśli chcesz rozwiązać następujące problemy w programie Dreamweaver:

  • Podczas otwierania pliku zostaje wyświetlony następujący komunikat o błędzie: „Nie można odnaleźć prawidłowego edytora dla tego rozszerzenia pliku”.
  • Kodowanie kolorami w widoku Kod nie jest zgodne z kodowaniem kolorami dla odpowiedniego typu pliku.
  • Funkcjonalność modelu serwera nie jest dostępna dla typu pliku.
  • Nie można otworzyć strony w widoku Projekt. Stronę można otworzyć tylko w widoku Kod.
  • Po kliknięciu Plik > Zapisz lub Plik > Otwórz nie widać żądanego typu pliku.

Program Dreamweaver oferuje możliwość edycji i wyświetlania wielu różnych typów plików. Ten artykuł opisuje dostosowywanie programu Adobe Dreamweaver w celu rozpoznania nowych typów plików, edytując pliki Extensions.txt oraz MMDocumentTypes.xml. Jako użytkownik możesz także skonfigurować ustawienia Otwórz w widoku Kod, aby zobaczyć nowe typy plików w widoku Projekt.

  • Plik Extensions.txt
    Plik Extensions.txt to plik tekstowy zawierający wszystkie typy plików rozpoznawane w programie Dreamweaver. Plik ten można edytować w dowolnym zewnętrznym edytorze tekstu, np. Notatniku lub Edytorze tekstu i dodać kolejne typy do listy rozpoznawanych typów plików. Nie modyfikuj plików konfiguracyjnych programu Dreamweaver bezpośrednio w programie Dreamweaver.
  • Plik MMDocumentTypes.xml
    Plik MMDocumentTypes.xml zawiera definicje typów dokumentów oraz listę rozszerzeń plików powiązanych z poszczególnymi rozpoznawanymi typami dokumentów. Dodanie rozszerzeń plików do pliku Extensions.txt umożliwia programowi Dreamweaver tylko rozpoznanie rozszerzenia pliku i pozwala na otwieranie plików tego typu w programie Dreamweaver. Dodanie rozszerzeń pliku do pliku MMDocumentTypes.xml powoduje przekazanie do programu Dreamweaver informacji o tym, jak należy traktować to nowe rozszerzenie pliku oraz do którego typu dokumentu to rozszerzenie pliku się odnosi.

    W tym artykule omówiono tylko podstawowe aspekty edycji pliku MMDocumentTypes.xml. Szczegółowe omówienie edytowania tego pliku znajduje się w temacie Rozszerzanie programu Dreamweaver w programie Dreamweaver. Kliknij Pomoc > Rozszerzanie programu Dreamweaver i wyszukaj MMDocumentTypes.xml.

  • Otwórz w widoku Kod
    Preferencja Otwórz w widoku Kod identyfikuje rozszerzenia plików, które nie umożliwiają użycia widoku Projekt. Aby zezwolić na edycję pliku w widoku Projekt, należy usunąć rozszerzenie pliku (jeśli zostało ono podane) z preferencji Otwórz w widoku Kod. Aby ustawić tę preferencję, kliknij kolejno opcje Edytuj > Preferencje (Windows) lub Dreamweaver > Preferencje (macOS) i zlokalizuj kategorię Typy plików / Edytory.

Edytowanie pliku Extensions.txt

Podczas próby otwarcia pliku, który nie jest w programie Dreamweaver rozpoznawany, zostaje wyświetlony następujący komunikat o błędzie: „Nie można odnaleźć prawidłowego edytora dla tego rozszerzenia pliku”. Możesz dodać nowe rozszerzenia do listy rozszerzeń rozpoznawanych przez program Dreamweaver. Aby dodać nowe rozszerzenia, edytuj plik Extensions.txt. Wpisy w pliku Extensions.txt decydują również o kolejności plików w oknach dialogowych Plik > Otwórz i Plik > Zapisz. Jako przykład dodaj typ pliku .inc do programu Dreamweaver.

Uwaga: Ta procedura wymaga zlokalizowania ukrytych plików, ukrytych folderów i rozszerzeń znanych typów plików. Ukryte pliki, ukryte foldery i rozszerzenia rozpoznawanych przez system nazw plików domyślnie nie są wyświetlane w programie Windows Explorer.

Aby wyświetlić ukryte pliki, ukryte foldery i rozszerzenia znanych typów plików:

  1. W programie Windows Explorer wykonaj jedną z następujących czynności:

    • W systemie Windows XP wybierz kolejno opcje Narzędzia > Opcje folderów.
    • W systemie Windows Vista wybierz kolejno opcje Organizuj > Folder i Opcje wyszukiwania.
  2. Kliknij kartę Widok w oknie dialogowym Opcje folderów.

  3. W obszarze Ustawienia zaawansowane kliknij opcję Pokaż ukryte pliki i foldery.

  4. Usuń zaznaczenie pola wyboru Ukryj rozszerzenia znanych typów plików.

  5. Kliknij przycisk OK.

Dodawanie typów pliku do pliku Extensions.txt

Aby dodać typy plików do pliku Extensions.txt:

  1. Zlokalizuj plik Extensions.txt w obrębie folderu konfiguracyjnego użytkownika w programie Dreamweaver. Lokalizacja tego folderu zależy do systemu operacyjnego oraz wersji programu Dreamweaver:

    • Dreamweaver CS3 w systemie Windows Vista:
      C:\Users\[nazwaużytkownika]\AppData\Roaming\Adobe\Dreamweaver 9\Configuration
    • Dreamweaver 8 w systemie Windows Vista:
      C:\Users\[nazwaużytkownika]\AppData\Roaming\Macromedia\Dreamweaver 8\Configuration
    • Dreamweaver CS3 w systemie Windows XP:
      C:\Documents and Settings\[nazwa użytkownika]\Application Data\Adobe\Dreamweaver 9\Configuration
    • Dreamweaver 8 w systemie Windows XP & 2000:
      C:\Documents and Settings\[nazwaużytkownika]\Application Data\Macromedia\Dreamweaver 8\Configuration
    • Dreamweaver CS3 w systemie Mac OS X:
      Mac HD:Users:[nazwaużytkownika]:Library:Application Support:Adobe:Dreamweaver 9:Configuration
    • Dreamweaver 8 w systemie Mac OS X:
      Mac HD:Users:[nazwaużytkownika]:Library:Application Support:Macromedia:Dreamweaver 8:Configuration

    Uwaga: Poprawki w tym pliku są dostępne tylko dla bieżącego użytkownika. Zmiany wprowadzone w plikach w ramach profilu użytkownika nie są dostępne dla innych użytkowników. Więcej informacji na temat ręcznej edycji plików konfiguracyjnych w programie Dreamweaver w środowisku wielu użytkowników znajduje się w temacie Dostosowywanie programu Dreamweaver w środowisku wielu użytkowników.

  2. Otwórz plik Extensions.txt w dowolnym zewnętrznym edytorze tekstu, np. Notatniku lub Edytorze tekstu.

    Nie modyfikuj plików konfiguracyjnych programu Dreamweaver bezpośrednio w programie Dreamweaver.

  3. Dodaj rozszerzenie do wiersza Wszystkie dokumenty. Rozszerzenia muszą zawierać wielkie litery i być oddzielone przecinkami. Przykład: HTML,HTM,SHTM,SHTML,INC.

  4. Aby dodać rozszerzenia do istniejącej grupy dokumentów, dodaj rozszerzenie do listy rozszerzeń odpowiedniej grupy. Aby dodać nową grupę dokumentów, dodaj nowy wiersz, który zawiera nowy typ dokumentu oraz listę powiązanych rozszerzeń. Przykład: INC:Dołącz pliki

    Możesz również dodać ten wiersz do listy Dołącz po stronie serwera znajdującej się już w pliku.

  5. Zapisz plik i ponownie uruchom program Dreamweaver.
  6. Aby zobaczyć zmiany, otwórz program Dreamweaver i otwórz plik z niedawno dodanym rozszerzeniem pliku. Plik otwiera się tylko w widoku Kod w programie Dreamweaver.

    Wybierz kolejno opcje Plik > Zapisz jako, a następnie kliknij menu podręczne Zapisz jako typ. Zobaczysz opcję *.inc jako rozpoznawane rozszerzenie pliku w opcji Dołącz pliki. Tak samo dzieje się w przypadku menu podręcznego Pliki typu w oknie dialogowym Plik > Otwórz.

    Uwaga:

    Kolejność, w której są podawane rozszerzenia jest tą samą kolejnością, w której będą one wyświetlane w oknach dialogowych Plik > Otwórz i Plik > Zapisz.

    Aby uzyskać dostęp do widoku Projekt, kodowania kolorem i funkcjonalności serwera, należy przeprowadzić edycję pliku MMDocumentTypes.xml, zgodnie z opisem w poniższych sekcjach.

Dodawanie rozszerzeń do pliku MMDocumentTypes.xml

Plik MMDocumentTypes.xml zawiera informacje o modelu serwera, stylu kodowania kolorem, opisach itd. dla każdego znanego typu dokumentu.

Oprócz dodania rozszerzeń do pliku Extension.txt należy również dodać nowe rozszerzenia do list z rozszerzeniami plików dla powiązanego typu dokumentu. Jeśli tak się nie stanie, program Dreamweaver nie wie, jak wyświetlić ten typ pliku. Program Dreamweaver domyślnie otwiera plik w widoku Kod.

Jeśli to rozszerzenie nie jest powiązane z żadnym zdefiniowanym typem dokumentu, zostaje utworzony nowy typ dokumentu. Aby utworzyć nowy typ dokumentu, zobacz temat Rozszerzanie programu Dreamweaver w programie Dreamweaver i kliknij kolejno opcje Pomoc > Rozszerzanie programu Dreamweaver i wyszukaj opcję MMDocumentTypes.xml.

Uwaga: W tym artykule „definicja typu dokumentu” odnosi się do plików zawierających informacje o dokumentach rozpoznawanych przez program Dreamweaver. Definicja typu dokumentu nie powinna być mylona z plikami „DTD” wymienionymi w dokumentacji XML.

Wykonaj następujące kroki w celu dodania rozszerzeń do definicji typu dokumentu w pliku MMDocumentTypes.xml:

  1. Zlokalizuj plik MMDocumentTypes.xml w głównym folderze konfiguracyjnym programu Dreamweaver (nie w folderze konfiguracyjnym użytkownika w programie Dreamweaver). Lokalizacja tego folderu zależy do systemu operacyjnego oraz wersji programu Dreamweaver:
    • Dreamweaver CS3 w systemie Windows Vista & XP:

      C:\Pliki programów\Adobe\Adobe Dreamweaver CS3\Konfiguracja\TypyDokumentów
    • Dreamweaver 8 w systemie Windows Vista, XP & 2000:

      C:\Pliki programów\Macromedia\Dreamweaver 8\Konfiguracja\TypyDokumentów
    • Dreamweaver CS3 w systemie Mac OS X:

      Mac HD:Aplikacje:Adobe Dreamweaver CS3:Konfiguracja:Typy dokumentów
    • Dreamweaver 8 w systemie Mac OS X:

      Mac HD:Aplikacje:Macromedia Dreamweaver 8:Konfiguracja:Typy dokumentów
  2. Otwórz plik MMDocumentTypes.xml w dowolnym zewnętrznym edytorze tekstu, np. Notatniku lub Edytorze tekstu.

    Nie modyfikuj plików konfiguracyjnych programu Dreamweaver bezpośrednio w programie Dreamweaver.

  3. Znajdź zestaw znaczników dla odpowiedniego typu dokumentów.

    Poniżej znajduje się domyślna definicja typu dokumentu dla dokumentów HTML z pliku MMDocumentTypes.xml:

    <documenttype id="HTML" internaltype="HTML" winfileextension="html,htm,shtml,shtm,stm,tpl,lasso,xhtml" macfileextension="html,htm,shtml,shtm,tpl,lasso,xhtml,ssi" writebyteordermark="false">

  4. Dodaj odpowiednie rozszerzenie do atrybutów winfileextension oraz macfileextension znacznika documenttype. Np.: winfileextension="html,htm,shtml,shtm,stm,tpl,lasso,xhtml,inc"

    Powyższy kod dodaje rozszerzenie pliku INC do listy plików, które program Dreamweaver traktuje jako pliki HTML. Po dodaniu rozszerzeń do list dla systemu MacOS i Windows dla tego typu pliku program Dreamweaver otwiera ten typ pliku w widoku Projekt.

  5. Zapisz plik MMDocumentTypes.xml i uruchom ponownie program Dreamweaver.
  6. Aby zobaczyć zmiany, otwórz program Dreamweaver i otwórz plik, który ma ostatnio dodane rozszerzenie pliku.

    Teraz powinny działać funkcje widoku Projekt, kolorowanie kodu i zachowania serwera (jeśli dotyczy).

    Uwaga:

    Ważna jest kolejność, w jakiej wyświetlone są rozszerzenia. Pierwszym rozszerzeniem na liście rozszerzeń jest domyślne rozszerzenie używane do tego typu pliku.

    Jeśli utworzysz kopię zapasową pliku MMDocumentTypes.xml i zostawisz ją w folderze Konfiguracja/TypyDokumentów, podczas uruchamiania programu Dreamweaver wyświetla się wiele komunikatów ostrzegawczych.

    Widzisz następujące komunikaty o błędzie: „Typ dokumentu „HTML” nie zostanie dodany, gdyż używa rozszerzenia pliku, które jest już powiązane z wcześniejszym Typem dokumentu”.

    Ten komunikat o błędzie wyświetla się także, jeśli w pliku MMDocumentTypes.xml wymieniony jest więcej niż raz ten sam typ pliku.

    Aby wstrzymać wyświetlanie tych komunikatów ostrzegawczych, przenieś kopię zapasową pliku MMDocumentTypes.xml poza folder Konfiguracja/TypyDokumentów.

Edycja w preferencji widoku Kod

Ostatni krok polega na sprawdzeniu ustawień preferencji Typy plików / Edytory (Edytuj > Preferencje) i upewnieniu się, że to rozszerzenie pliku nie jest podane w polu Otwórz w widoku Kod. Domyślnie, na tej liście wyświetlane jest rozszerzenie pliku INC. Jeśli usuniesz „.inc” z listy Otwórz w widoku Kod, możesz wyświetlić pliki z tym rozszerzeniem w widoku Projekt.

Włączanie kolorowania kodu dla niestandardowych typów plików

Po wykonaniu kroków w celu dodania pliku MMDocumentTypes.xml należy wykonać poniższą procedurę, aby włączyć kolorowanie kodu w niestandardowych typach plików.

  1. Zamknij aplikację Dreamweaver.

  2. Otwórz plik brackets.json z następującej lokalizacji w edytorze tekstu:

    • Win: %appdata%\Adobe\Dreamweaver CC xxxx\en_US\Configuration\Brackets\brackets.json
    • macOS: ~/Library/Application Support/Adobe/Dreamweaver CC XXXX/en_US/Configuration/Brackets/brackets.json

    Tutaj xxxx odnosi się do wersji programu Dreamweaver. Na przykład: 2017.

  3. W pliku .json, po ostatniej parze klucz/wartość, wprowadź następujący ogranicznik „,” (przecinek) i wpisz tekst:
    "language.fileExtensions": { ".ext": "php" }

    Zamień .ext na listę rozdzielonych przecinkami rozszerzeń plików, do których należy dodać kolorowanie kodu.

    Zastąp php odpowiednim typem dokumentu. Obsługiwane typy dokumentów to:

    • bash
    • c
    • clojure
    • coffeescript
    • cpp
    • csharp
    • css
    • dart
    • diff
    • ejs
    • erb_html (Embedded Ruby)
    • groovy
    • handlebars
    • haskell
    • html
    • hx (Haxe)
    • java
    • javascript
    • json
    • jsx
    • less
    • lua
    • markdown
    • perl
    • php
    • properties
    • python
    • ruby
    • sass
    • scala
    • scss
    • sql
    • stylus
    • svg
    • turtle (RDF Turtle)
    • vb
    • vbscript
    • xml
    • yaml
  4. Zapisz plik i ponownie uruchom program Dreamweaver.

Dodatkowe informacje

Więcej informacji dotyczących modyfikacji typów plików w programie Dreamweaver znajduje się w temacie Rozszerzanie programu Dreamweaver.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online