Проблема

Значок PDFMaker («Преобразовать в Adobe PDF») и меню Acrobat отсутствуют в приложении Microsoft Office 2003, XP или 2000 (например, Access, Excel, Word).

Решение

Используйте одно или несколько из следующих решений:

Решение 1. Удалите Adobe PDF из списка «Отключенные элементы» в приложении Microsoft Office.

  1. Откройте программу Microsoft Office (Word, Excel, Publisher или Excel).
  2. Перейдите в меню «Справка» > «О программе [имя приложения].
  3. Щелкните «Отключенные элементы».
  4. Выберите Adobe PDF в списке и нажмите «Включить».
  5. Закройте программу Microsoft Office и перезапустите ее.

Примечание. В приложениях Microsoft Office, в качестве защитной меры, надстройки отключаются при преждевременном закрытии приложения (например, если произошло аварийное завершение его работы или если компьютер был выключен ненадлежащим образом).

Решение 2. Убедитесь в том, что на компьютере установлены компоненты PDFMaker.

  1. Выберите «Пуск» > «Выполнить», введите команду appwiz.cpl в текстовом поле «Открыть», а затем нажмите кнопку «ОК», чтобы открыть диалоговое окно «Установка и удаление программ».
  2. Найдите и выберите Adobe Acrobat 7 или Adobe Reader 8 и нажмите «Изменить/удалить».
  3. При появлении мастера нажмите «Далее».
  4. Выберите «Изменить» и затем снова «Далее».
  5. Разверните древовидное меню «Создать Adobe PDF», а затем нажмите стрелку вниз на объекте Acrobat PDFMaker.
  6. Установите флажок «Этот элемент будет установлен на локальный жесткий диск», нажмите кнопку «Далее», а затем щелкните «Обновить».

Решение 3. Включите надстройку COM в приложении Office.

  1. Запустите приложение Office.
  2. Выберите «Справка» > «О программе» [приложение].
  3. Щелкните «Отключенные элементы».
  4. Проверьте, есть ли в списке PDFMakerOfficeAddin:
    • Если да, выделите этот элемент и нажмите «Включить». Закройте все диалоговые окна и перезапустите приложение Office.
    • Если оно отсутствует в списке, убедитесь в том, что библиотека PDFMOfficeAddin.dll находится в папке Acrobat 7.0/PDFMaker/Office (Acrobat 7, Acrobat 3D) или в папке Acrobat 8.0/PDFMaker/Office (Acrobat 8). Если файл отсутствует, переустановите приложение Acrobat.

Решение 4. Переименуйте файл Normal.dot.

Чтобы не допустить воздействие форматирования, автотекста и макросов, которые хранятся в глобальном шаблоне (Normal.dot), на поведение Microsoft Word и других приложений, переименуйте глобальный шаблон (Normal.dot). При этом можно сразу определить, связан ли глобальный шаблон с возникновением проблемы.

Важно! При переименовании шаблона Normal.dot, для нескольких параметров устанавливаются значения по умолчанию. К этим параметрам относятся пользовательские стили, настраиваемые панели инструментов, макросы и автотекст. Поэтому Microsoft настоятельно рекомендует не удалять файл Normal.dot.

В некоторых конфигурациях может быть создано более одного файла Normal.dot. Например, это может произойти, если на компьютере установлено более одной версии Word или если на одном и том же компьютере настроено две или более рабочих станций.

Переименование файла Normal.dot:

Примечание. Следующие инструкции относятся только к Microsoft Word, но также могут быть использованы с небольшими изменениями для других приложений Microsoft Office. Не используйте ключ /a для перезапуска Word или другого приложения после того, как выполните все шаги.

В Windows 2000:

  1. Закройте все сеансы Word, включая Outlook, если Word используется в качестве редактора электронной почты.
  2. Выберите «Пуск» > «Поиск» > «Файлы и папки».
  3. В окне «Искать файлы и папки с именем» введите Normal.dot.
  4. В разделе «Где искать» выберите свой локальный жесткий диск.
  5. Нажмите кнопку «Найти» для поиска файла.
  6. Для каждого вхождения файла Normal.dot в диалоговом окне «Результаты поиска» выполните следующие действия:
    • Щелкните правой кнопкой мыши файл и выберите «Переименовать».
    • Присвойте файлу новое имя (например, OldNormal.dot или Normal-1.dot), а затем нажмите клавишу Enter.
  7. В меню «Файл» выберите пункт «Закрыть», чтобы закончить поиск, а затем перезапустите Word.

В Windows XP:

  1. Закройте все сеансы Word, включая Outlook, если Word используется в качестве редактора электронной почты.
  2. Выберите «Пуск» > «Поиск».
  3. В разделе «Что вы хотите найти» выберите «Все файлы и папки».
  4. В разделе «Полное или часть имени файла» введите Normal.dot.
  5. В разделе «Где искать» выберите свой локальный жесткий диск (или альтернативное местоположение шаблона пользователя, если работа в Word осуществляется посредством сетевого сервера.
  6. Нажмите «Поиск».
  7. Для каждого вхождения файла Normal.dot в диалоговом окне «Результаты поиска» выполните следующие действия:
    • Щелкните правой кнопкой мыши файл и выберите «Переименовать».
    • Присвойте файлу новое имя (например, OldNormal.dot или Normal-1.dot), а затем нажмите клавишу Enter.
  8. В меню «Файл» выберите пункт «Закрыть» и затем перезапустите Word.

Если вы решили свою проблему путем переименования глобального шаблона, то проблема была в поврежденном шаблоне Normal.dot.

Решение 5. Измените уровень безопасности макросов в офисном приложении.

Чтобы файл надстройки COM был загружен в Windows, список на вкладке «Надежные издатели» должен содержать Adobe Inc. В противном случае потребуется изменить параметры защиты.

В приложениях Office 2000 или 2003 XP:

  1. В меню «Инструменты» выберите «Макрос»> «Защита».
  2. Выберите вкладку «Надежные издатели»:
    1. Если Adobe Inc. содержится в списке, изменения не потребуются.

    2. Если Adobe Inc. в списке не содержится, перейдите к шагу 3.

  3. Выберите один из следующих параметров:
    • На вкладке «Защита» установите для уровня защиты значение «Очень высокий». На вкладке «Надежные издатели» выберите «Все установленные надстройки и шаблоны».
    • На вкладке «Защита» установите для уровня защиты значение «Высокий». На вкладке «Надежные издатели» отмените выбор «Все установленные надстройки и шаблоны».
  4. Закройте все диалоговые окна и перезапустите приложение.

Решение 6. Добавьте файл надстройки COM в реестр Windows.

  1. В проводнике Windows найдите файл надстройки COM и запишите его точный путь, который может содержать пробелы.
  2. Выберите «Пуск» > «Выполнить».
  3. Введите regsvr32 с последующим пробелом и заключенным в кавычки путем, указанным на шаге 1. Например:

    regsvr32 "C:\Program Files\Adobe\Acrobat 8.0\PDFMaker\Office"
  4. Нажмите кнопку «ОК» и затем запустите приложение Office.

Решение 7. Запустите команду «Найти и восстановить», убедившись в том, что никакие другие приложения не запущены.

  1. Закройте все приложения и перезагрузите Windows.
  2. Запустите Acrobat.
  3. Выберите «Справка» > «Найти и восстановить» и следуйте инструкциям на экране.
  4. После завершения восстановления, перезагрузите компьютер.

Решение 8. Удалите и повторно установите Acrobat в упрощенном режиме.

Драйверы устройств и программное обеспечение, которые загружаются в Windows автоматически (например, экранные заставки и средства защиты от вирусов) могут конфликтовать с программой установки Acrobat и вызывать проблемы. Для предотвращения конфликта переустановите Acrobat в упрощенном режиме Windows. В упрощенном режиме нестандартные драйверы устройств и программы автозагрузки отключены.

Чтобы удалить Acrobat, выполните следующие действия:

  1. Переместите все личные файлы из папки приложения Acrobat и вложенных в нее папок.
  2. Выберите «Пуск» > «Настройки» > «Панель управления» и дважды щелкните пункт «Установка и удаление программ».
  3. Выберите Adobe [название продукта Acrobat] и нажмите «Удалить». Следуйте инструкциям по удалению программы на экране.
  4. Перезапустите компьютер.

Чтобы переустановить Acrobat в упрощенном режиме, выполните следующие действия:

  1. Закройте все открытые программы.
  2. В проводнике Windows перенесите все значки и ярлыки из следующих папок в другую папку:
    • Documents and Settings/All Users/Start Menu/Programs/Startup
    • Documents and Settings/ [имя пользователя] /Start Menu/Programs/Startup
  3. Перезагрузите Windows.
  4. Щелкните правой кнопкой мыши на панели задач и выберите Диспетчер задач.
  5. Выберите вкладку «Приложения».
  6. Выберите все работающие приложения и нажмите «Снять задачу».
  7. Дважды щелкните файл Setup.exe на установочном носителе и следуйте инструкциям на экране, чтобы завершить установку.
  8. Чтобы повторно включить элементы автозагрузки после завершения установки, переместите значки и ярлыки, которые были перемещены на шаге 2, в соответствующие папки автозагрузки.

Решение 9. Удалите макросы из Word.

  1. Выберите «Инструменты» > «Шаблоны и надстройки».
  2. Выберите каждый из элементов и нажмите кнопку «Удалить».
  3. Закройте и перезапустите Word.



    Примечание.
    Если значок «Преобразовать в PDF» по-прежнему отсутствует, выберите «Инструменты» > «Шаблоны и надстройки» и убедитесь в том, что удаленные элементы не появляются. Если удаленные элементы все же появляются, удалите макрос из Word или удалите приложение, установившее его в Word.

Решение 10. Удалите другие файлы надстройки COM из Word.

  1. Запустите Word.
  2. Выберите «Инструменты» > «Настройки».
  3. Щелкните вкладку «Команды» и выберите «Инструменты» в списке «Категории».
  4. Выберите «Надстройки COM» и перетащите их на панель инструментов в Word.
  5. Щелкните меню «Надстройки COM» на панели инструментов Word.
  6. Выберите и удалите все надстройки, за исключением мастера веб-страниц и инструмента шрифтов Microsoft Word.
  7. Закройте и перезапустите Word.

Решение 11. Восстановите Access. (Только для приложения Access.)

Если вы установили Access 2000 после установки Office XP или Office 2003, то для отображения меню PDFMaker необходимо запустить команду «Восстановить Office».

  1. Выберите «Пуск» > «Настройки» > «Панель управления» > «Установка и удаление программ» (Windows 2000) или «Пуск» > «Панель управления» > «Установка и удаление программ» (Windows XP).
  2. Выберите Microsoft Office и нажмите кнопку «Изменить».
  3. В диалоговом окне «Настройка» выберите «Переустановить (Office 2003) или «Восстановить» (Office XP), а затем нажмите кнопку «Далее».
  4. Выберите «Найти и исправить ошибки в установке Office», а затем нажмите кнопку «Установить».

Решение 12. Настройте панель инструментов. (Только для приложения Access.)

  1. Выберите «Просмотр» > «Панели инструментов» > «Настроить».
  2. На вкладке «Инструменты» выберите параметры «Утилита 1» и «Строка меню».
  3. Нажмите «Свойства».
  4. Выберите параметр «Отображение и скрытие».

Решение 13. Удалите файлы PDFMaker предыдущей версии из системы.

  1. Выберите «Пуск» > «Поиск».
  2. Выберите «Все файлы и папки».
  3. В текстовом поле «Полное или часть имени файла» введите PDFMaker.*.
  4. Нажмите «Поиск».

    Примечание. Поиск может занять несколько минут в зависимости от быстродействия системы.
  5. Удалите все результаты поиска, являющиеся системными файлами (например, PDFMaker.DOT или PDFMaker.XLA). Созданные вами документы, название которых содержит PDFMaker (например, PDFMaker.doc или PDFMaker.pdf), удалять не нужно.

Решение 14. Удалите Microsoft Works.

По результатам проверки в Adobe, при работе Microsoft Works возникает конфликт с Microsoft Word, из-за чего меню «Преобразовать в PDF» не отображается в Word. Компонент Microsoft Works установлен на многих компьютерах.

Чтобы удалить Microsoft Works, выполните следующие действия:

  1. Выберите «Пуск» > «Выполнить», введите команду appwiz.cpl в текстовом поле «Открыть», а затем нажмите кнопку «ОК», чтобы открыть диалоговое окно «Установка и удаление программ».
  2. Найдите и выберите Microsoft Works и нажмите кнопку «Изменить/удалить».
  3. При появлении мастера нажмите «Далее».
  4. Выберите «Удалить», нажмите кнопку «Далее» и следуйте инструкциям на экране.

Дополнительная информация

В рамках установки 7.0-8.0 в папку Acrobat 7.0/PDFMaker/Office или Acrobat 8.0/PDFMaker/Office добавляется файл надстройки COM. Этот файл содержит значки и команды меню PDFMaker для Word, Excel, Powerpoint, Publisher и Project. Файл надстройки COM необходимо занести в реестр Windows, чтобы он отображался в приложениях.

Значки PDFMaker не появляются на панели инструментов при аварийном завершении работы приложения Office и отключении файла надстройки COM.

Другие файлы надстройки COM и макросы иногда конфликтуют с файлом надстройки COM для PDFMaker и могут быть причиной отсутствия значков «Преобразовать в PDF» на панели инструментов.

При работе в Access, если видимость панели инструментов Utility1 отключена, значки PDFMaker не отображаются.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет